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Features and Conventions
You can save time when you use this book by understanding how the Step by Step series 

shows special instructions, keys to press, buttons to click, and so on.

Convention Meaning

1
2

Numbered steps guide you through hands-on exercises in each topic.

This icon at the beginning of a chapter indicates information about 

the practice fi les provided on the companion CD for use in the 

 chapter.

USE This paragraph preceding a step-by-step exercise indicates the 

 practice fi les that you will use when working through the exercise.

BE SURE TO This paragraph preceding a step-by-step exercise indicates any 

 requirements you should attend to before beginning the exercise.

OPEN This paragraph preceding a step-by-step exercise indicates fi les that 

you should open before beginning the exercise.

CLOSE This paragraph following a step-by-step exercise provides instructions 

for closing open fi les or programs before moving on to another topic. 

Tip These paragraphs provide a helpful hint or shortcut that makes 

 working through a task easier.

Important These paragraphs point out information that you need to know to 

complete a procedure.

Troubleshooting These paragraphs explain how to fi x a common problem that might 

prevent you from continuing through an exercise.

See Also These paragraphs direct you to more information in this book about a 

topic.

F In step-by-step exercises, keys you must press appear as they do on 

the keyboard.

J+D A plus sign (+) between two key names means that you must press 

those keys at the same time. For example, “Press J+D” means that 

you hold down the Alt key while you press Tab.
   xi
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Convention Meaning

Program elements In steps, program elements such as buttons, commands, and dialog 

boxes are shown in black bold characters.

Glossary terms Terms that are explained in the glossary at the end of the book are 

shown in blue italic type.

User input Text that you are supposed to type appears in blue and bold in the 

procedures.

Files, folders, 
and URLs

Files, folder paths, URLs, and emphasized words appear in italic type.



Using the Book’s CD
The companion CD included with this book contains practice fi les you can use as you 

work through the book’s exercises. By using practice fi les, you won’t waste time creating 

samples and typing spreadsheet data. Instead, you can jump right in and concentrate on 

learning how to use Microsoft© Offi ce Excel© 2007.

What’s on the CD?
The following table lists the practice fi les supplied on the book’s CD.

Chapter Folder\File

Chapter 1: What’s New in 

Excel 2007

None

Chapter 2: Setting Up a 

Workbook

Creating\Exception Summary.xlsx

Creating\Route Volume.xlsx

Chapter 3: Working with Data 

and Data Tables

Data and Data Tables\Series.xlsx

Data and Data Tables\2007Q1ShipmentsByCategory.xlsx

Data and Data Tables\Average Deliveries.xlsx

Data and Data Tables\Service Levels.xlsx

Data and Data Tables\Driver Sort Times.xlsx

Chapter 4: Performing 

Calculations on Data

Formulas\VehicleMiles.xlsx

Formulas\ITExpenses.xlsx

Formulas\PackagingCosts.xlsx

Formulas\ConveyerBid.xlsx

Chapter 5: Changing 

Document Appearance

Appearance\VehicleMileSummary.xlsx

Appearance\HourlyExceptions.xlsx

Appearance\HourlyTracking.xlsx

Appearance\ExecutiveSearch.xlsx

Appearance\Dashboard.xlsx

Appearance\CallCenter.xlsx

Chapter 6: Focusing on 

Specifi c Data Using Filters

Focusing\PackageExceptions.xlsx

Focusing\ForFollowUp.xlsx

Focusing\Credit.xlsx
   xiii
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Chapter Folder\File

Chapter 7: Reordering and 

Summarizing Data

Sorting\ShippingSummary.xlsx

Sorting\GroupByQuarter.xlsx

Sorting\ShipmentLog.xlsx

Chapter 8: Combining Data 

from Multiple Sources

MultipleFiles\Daily Call Summary.xlsx

MultipleFiles\Operating Expense Dashboard.xlsx

MultipleFiles\Fleeting Operating Costs.xlsx

MultipleFiles\January Calls.xlsx

MultipleFiles\February Calls.xlsx

MultipleFiles\Consolidate.xlsx

Chapter 9: Analyzing 

Alternative Data Sets

Alternatives\2DayScenario.xlsx

Alternatives\Multiple Scenarious.xlsx

Alternatives\Target Values.xlsx

Alternatives\Ad Buy.xlsx

Alternatives\Driver Sort Times.xlsx

Chapter 10: Creating Dynamic 

Lists with PivotTables

PivotTables\Creating.xlsx

PivotTables\Creating.txt

PivotTables\Focusing.xlsx

PivotTables\Editing.xlsx

PivotTables\Formatting.xlsx

Chapter 11: Creating Charts 

and Graphics

Charting\Yearly Package Volume.xlsx

Charting\Volume by Center.xlsx

Charting\Future Volumes.xlsx

Charting\Revenue Analysis.xlsx

Charting\Org Chart.xlsx

Chapter 12: Printing Printing\Revenue by Customer.xlsx

Printing\Pickups by Hour.xlsx

Printing\Summary by Customer.xlsx

Printing\Hourly Pickups.xlsx

Printing\Corporate Revenue.xlsx

Chapter 13: Automating 

Repetitive Tasks with Macros

Macros\VolumeHighlights.xlsm

Macros\Yearly Sales Summary.xlsx

Macros\Performance Dashboard.xlsx

Macros\RunOnOpen.xlsm



 Using the Book’s CD  xv
Chapter Folder\File

Chapter 14: Working with 

Other Microsoft Offi ce 

System Programs

Other Programs\Summary Presentation.xlsx

Other Programs\2007 Yearly Revenue Summary.pptx

Other Programs\RevenueByServiceLevel.xlsx

Other Programs\Hyperlink.xlsx

Other Programs\Level Descriptions.xlsx

Other Programs\Revenue Chart.xlsx

Other Programs\Revenue Summary.pptx

Chapter 15: Collaborating 

with Colleagues

Sharing\Cost Projections.xlsx

Sharing\Projections for Comment.xlsx

Sharing\Projection Change Tracking.xlsx

Sharing\SecureInfo.xlsx

Sharing\Projections Signed.xlsx

Sharing\Shipment Summary.xlsx

Minimum System Requirements
To run Offi ce Excel 2007, your computer needs to meet the following minimum hard-

ware requirements:

 500 megahertz (MHz) 

 256 megabytes (MB) RAM

 1.5 gigabytes (GB) available space

 CD or DVD drive

 1024x768 or higher resolution monitor

Installing the Practice Files
You need to install the practice fi les in the correct location on your hard disk before you 

can use them in the exercises. Follow these steps:

 1. Remove the companion CD from the envelope at the back of the book, and insert 

it into the CD drive of your computer.

The Step By Step Companion CD license terms appear. 

 2. Follow the on-screen directions. To use the practice fi les, you must accept the 

terms of the license agreement. 

After you accept the license agreement and click Next, a menu screen appears.
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Important If the menu screen does not appear, click the Start button and then click 

Computer. Display the Folders list in the Navigation pane, click the icon for your CD drive, 

and then in the right pane, double-click the StartCD executable fi le.

3. Click Install Practice Files.

 4. Click Next on the fi rst screen, and then click Yes to accept the terms of the license 

agreement on the next screen.

 5. If you want to install the practice fi les to a location other than the default folder 

(My Documents\Microsoft Press\Excel SBS), click the Browse button, select the new 

drive and path, and then click OK.

Important If you are using Windows Vista, the default folder will be Documents\Microsoft 
Press\Excel SBS.  

 6. Click Next on the Choose Destination Location screen, and then click Install on 

the Ready to Install the Program screen to install the selected practice fi les.

 7. After the practice fi les have been installed, click Finish.

 8. Close the Step by Step Companion CD window, remove the companion CD from 

the CD drive, and return it to the envelope at the back of the book.

Using the Practice Files
When you install the practice fi les from the companion CD that accompanies this 

book, the fi les are stored on your hard disk in chapter-specifi c subfolders under 

My Documents\Microsoft Press\Excel SBS. Each exercise is preceded by a paragraph that 

lists the fi les needed for that exercise and explains any preparations needed before you 

start working through the exercise. Here are examples:

USE  the ForFollowUp workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Focusing folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the ForFollowUp workbook.

USE thethe ForFollowUpForFollowUp workbook in the practice fi le folder for this topic. This practice fi le is  workbook in the practice fi le folder for this topic. This practice fi le is 

located in thelocated in the My Documents\Microsoft Press\Excel SBS\FocusingMy Documents\Microsoft Press\Excel SBS\Focusing folder. folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe ForFollowUpForFollowUp workbook. workbook.
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You can browse to the practice fi les in Windows Explorer by following these steps:

 1. On the Windows taskbar, click the Start button, and then click My Documents. If 
you are using Windows Vista, click Documents, instead.

 2. In the My Documents or Documents folder, double-click Microsoft Press, 

double-click Excel SBS, and then double-click a specifi c chapter folder. 

You can browse to the practice fi les from a dialog box by following these steps:

 1. In the Favorite Links pane in the dialog box, click My Documents. If you are using 

Windows Vista, click Documents, instead.

 2. In the My Documents or Documents folder, double-click Microsoft Press, 
double-click Excel SBS, and then double-click the specifi ed chapter folder.

Uninstalling the Practice Files
You can free up hard disk space by uninstalling the practice fi les that were installed 

from the companion CD. The uninstall process also deletes any fi les that you created 

in the Microsoft Press\Excel SBS chapter-specifi c folders while working through the 

 exercises. Follow these steps:

 1. On the Windows taskbar, click the Start button, and then click Control Panel.

 2. In Control Panel, click Add or Remove Programs. If you are using Windows Vista, 

in Control Panel, under Programs, click the Uninstall a program task.

 3. In the Add or Remove Programs window, click Microsoft Excel 2007 Step by Step, 
and click Remove. If you are using Windows Vista, in the Programs and Features 
window, click Microsoft Offi ce Excel 2007 Step by Step, and then on the toolbar 

at the top of the window, click the Uninstall button.

 4. If a message box asks you to confi rm the deletion, click Yes.

See Also If you need additional help installing or uninstalling the practice fi les, see “Getting 
Help” later in this book.



Getting Help
Every effort has been made to ensure the accuracy of this book and the contents of its 

companion CD. If you do run into problems, please contact the sources listed below for 

assistance.

Getting Help with This Book and Its Companion CD
If your question or issue concerns the content of this book or its companion CD, 

please fi rst search the online Microsoft Press Knowledge Base, which provides support 

information for known errors in or corrections to this book, at the following Web site:

www.microsoft.com/mspress/support/search.asp

If you do not fi nd your answer at the online Knowledge Base, send your comments or 

questions to Microsoft Press Technical Support at:

mspinput@microsoft.com

Getting Help with Offi ce Excel 2007
If your question is about Microsoft Offi ce Excel 2007, and not about the content of this 

Microsoft Press book, please search the Offi ce 2007 Solution Center or the Microsoft 

Knowledge Base at:

support.microsoft.com

In the United States, Microsoft software product support issues not covered by the 

Microsoft Knowledge Base are addressed by Microsoft Product Support Services. 

Location-specifi c software support options are available from:

support.microsoft.com/gp/selfoverview/
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The Microsoft Business Certifi cation 
Program

Desktop computing profi ciency is becoming increasingly important in today’s business 

world. As a result, when screening, hiring, and training employees, more employers are 

relying on the objectivity and consistency of technology certifi cation to ensure the com-

petence of their workforce. As an employee or job seeker, you can use technology certi-

fi cation to prove that you already have the skills you need to succeed, saving current and 

future employers the trouble and expense of training you. 

The Microsoft Business Certifi cation program is designed to assist employees in 

 validating their Windows Vista and 2007 Microsoft Offi ce program skills. There are two 

paths to certifi cation:

 A Microsoft Certifi ed Application Specialist (MCAS) is an individual who has 

 demonstrated worldwide skill standards for Windows Vista or the 2007 Microsoft 

Offi ce suite through a certifi cation exam in Windows Vista or in one or more of the 

2007 Microsoft Offi ce programs, including Microsoft Offi ce Word 2007, Microsoft 

Offi ce Excel 2007, Microsoft Offi ce PowerPoint 2007, Microsoft Offi ce Outlook 

2007, and Microsoft Offi ce Access 2007. 

 A Microsoft Certifi ed Application Professional (MCAP) is an individual who has 

taken his or her knowledge of the Microsoft 2007 Offi ce suite and of Microsoft 

SharePoint products and technologies to the next level and has demonstrated 

through a certifi cation exam that he or she can use the collaborative power of the 

Offi ce suite to accomplish job functions such as Budget Analysis and Forecasting, 

or Content Management and Collaboration. 

After attaining certifi cation, you can include MCAS or MCAP logo with the appropri-

ate certifi cation designator on your business cards and other personal promotional 

 materials. This logo attests to the fact that you are profi cient in the applications or cross-

 application skills necessary to achieve the certifi cation. 
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Selecting a Certifi cation Path
When selecting a Microsoft Business Certifi cation path that you would like to pursue, 

you should assess the following: 

 The program and program version(s) with which you are familiar with

 The length of time you have used the program

 Whether you have had formal or informal training in the use of that program

Candidates for MCAS-level certifi cation are expected to successfully complete a wide 

range of standard business tasks, such as formatting a document or spreadsheet. 

Successful candidates generally have six or more months of experience with Windows 

Vista or the specifi c Offi ce program, including either formal, instructor-led training, or 

self study using MCAS-approved books, guides, or interactive computer-based materials.

Candidates for MCAP-level certifi cation are expected to successfully complete more 

complex, business-oriented tasks utilizing advance functionality with the combined 

2007 Microsoft Offi ce suite of products. Successful candidates generally have between 

six months and one or more years of experience with the programs, including formal, 

 instructor-led training or self study using MCAP-approved materials.

Becoming a Microsoft Certifi ed Application 
Specialist—Microsoft 2007 Offi ce System

Every MCAS and MCAP certifi cation exam is developed from a set of exam skill 

 standards that are derived from studies of how Windows Vista and the 2007 Offi ce 

 programs are used in the workplace. Because these skill standards dictate the scope of 

each exam, they provide you with critical information on how to prepare for certifi cation. 

To become a Microsoft Certifi ed Application Specialist of 2007 Offi ce programs, you 

must demonstrate the profi ciency in these areas: 

Objective Domain Skill Sets

70-601: Using Microsoft 

Offi ce Word 2007

Creating and Customizing Documents

Formatting Content

Working with Visual Content

Organizing Content

Reviewing Documents

Sharing and Securing Content
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Objective Domain Skill Sets

70-602: Using Microsoft 

Offi ce Excel 2007

Creating and Manipulating Data

Formatting Data and Content

Creating and Modifying Formulas

Presenting Data Visually 

Collaborating and Securing Data

70-603: Using Microsoft 

Offi ce PowerPoint 2007

Creating and Manipulating Data

Formatting Data and Content

Creating and Modifying Formulas

Presenting Data Visually 

Collaborating and Securing Data

70-604: Using Microsoft 

Offi ce Outlook 2007

Managing Messaging

Managing Scheduling

Managing Tasks

Managing Contacts and Personal Contact Information

Organizing Information

70-605: Using Microsoft 

Offi ce Access 2007

Structuring a Database

Creating and Formatting Database Elements

Entering and Modifying Data

Creating and Modifying Queries

Presenting and Sharing

Managing and Maintaining Databases

Becoming a Microsoft Certifi ed Application 
Professional

To become certifi ed as a Microsoft Certifi ed Applications Professional, you must 

 demonstrate the profi ciency in these areas: 

Organizational Support

 Managing a Microsoft Offi ce SharePoint Server 2007 Team Site

 Managing Communication

 Tracking, Maintaining, and Sharing Information

 Presenting Information

 Managing Digital Information

 Organizing and Facilitating Meetings
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Creating and Managing Presentations

 Preparing the Presentation Collaboration Environment

 Creating and Managing Elements for Re-Use in Presentations

 Creating Effective Presentations

 Creating Effective Presentations

 Finalizing, Distributing, and Delivering Presentations

Content Management and Collaboration

 Creating a Collaborative Environment

 Confi guring SharePoint Site Structures and Processes 

 Administering an Offi ce SharePoint Server 2007 Site

Budget Analysis and Forecasting

 Obtaining and Managing Data

 Securing Information

 Managing Collaboration

 Manipulating and Analyzing Data

 Reporting and Presenting Data

Taking a Microsoft Business Certifi cation Exam
The MCAS and MCAP certifi cation exams for Windows Vista and the 2007 Offi ce pro-

grams are performance-based and require you to complete business-related tasks using 

interactive simulation (a digital model) of the Windows Vista operating system or one or 

more programs in the Offi ce suite. 

Test Taking Tips
 Follow all instructions provided in each question completely and accurately

 Enter requested information as it appears in the instructions, but without duplicat-

ing the formatting unless you are specifi cally instructed to do otherwise. 

 Close all dialog boxes before proceeding to the next exam questions unless you are 

specifi cally instructed to do otherwise. 
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 Don’t close task panes proceeding to the next exam questions unless you are spe-

cifi cally instructed to do otherwise.

 If you are asked to print a document, spreadsheet, chart, report, or slide, perform 

the task, but be aware that nothing will actually be printed. 

 Don’t worry about extra keystrokes or mouse clicks. Your work is scored based on 

its result, not on the method you use to achieve that result, and not on the time 

you take to complete the question. 

 If your computer becomes unstable during the exam or if a power outage occurs, 

contact a testing center administrator immediately. The administrator will restart 

the computer and return the exam to the point where the interruption occurred 

with your score intact.

Certifi cation
At the conclusion of the exam, you will receive a score report, which you can print with 

the assistance of the testing center administrator. If your score meets or exceeds that 

passing standard (the minimum score required), you will be mailed a printed certifi cate 

within approximately 14 days.

For More Information
To learn more about the Microsoft Certifi ed Application Specialist exams and 

 courseware, visit

www.microsoft.com/learning/mcp/mcas/

To learn more about the Microsoft Certifi ed Application Professional exams and 

 courseware, visit

www.microsoft.com/learning/mcp/mcap
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Quick Reference
 2 Setting Up a Workbook

Click the Microsoft Offi ce Button and then click Open.

 2. Navigate to the folder that contains the workbook you want to open.

 3. Click the workbook.

 4. Click Open.

To create a new workbook, page 14

 1. Click the Microsoft Offi ce Button.

 2. Click New.

 3. Click Blank Workbook.

To save a workbook, page 15

 1. On the Quick Access Toolbar, click the Save button.

 2. Type a name for the fi le.

 3. Click Save.

To set fi le properties, page 15

 1. Open the fi le for which you want to assign property values.

 2. Click the Microsoft Offi ce Button.

 3. Point to Finish and then click Properties.

 4. Add information describing your fi le.

To defi ne custom properties, page 16

 1. Open the fi le for which you want to assign property values.

 2. Click the Microsoft Offi ce Button.

 3. Point to Finish and then click Properties.

 4. Click the Property Views and Options down arrow.

 5. Click Advanced.

 6. Click the Custom tab.



xxviii  Quick Reference

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Type a property name.

8. Select the type of data contained in the property.

9. Type a value for the property.

10. Click Add.

11. Click OK.

To display a worksheet, page 18

 Click the sheet tab of the worksheet you want to display.

To create a new worksheet, page 18

1. Right-click the sheet tab of the worksheet that follows the location where you want 

to insert a worksheet.

2. Choose Insert from the shortcut menu.

3. Double-click Worksheet.

To rename a worksheet, page 18

1. Double-click the sheet tab of the worksheet you want to rename.

2. Type the new name of the worksheet and press Enter.

To copy a worksheet to another workbook, page 18

1. Open the workbook that will receive the new worksheets.

2. Switch to the workbook that contains the worksheets you want to copy, hold down 

the Ctrl key, and click the sheet tabs of the worksheets you want to copy.

3. Right-click the selection.

4. Choose Move Or Copy from the shortcut menu.

5. Select the Create A Copy check box.

6. Click the To Book down arrow.

7. Click the workbook to which you want the worksheet(s) copied.

8. Click OK.

To change the order of worksheets in a workbook, page 19

 Drag the sheet tab of the worksheet you want to move.



 Quick Reference  xxix

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To hide a worksheet, page 19

1. Hold down the H key and click the sheet tabs of the worksheets you want to hide.

2. Right-click any selected worksheet tab and then choose the Hide command.

To unhide a worksheet, page 19

1. Right-click any worksheet tab.

2. Click Unhide.

3. Click the worksheet you want to unhide.

4. Click OK.

To delete a worksheet, page 19

1. Hold down the H key and click the sheet tabs of the worksheets you want to 

delete.

2. Right-click the selection.

3. Choose Delete from the shortcut menu.

To change a row’s height or column’s width, page 21

1. Select the rows and columns you want to resize.

2. Drag a row or column border until it is the desired size.

To insert a column or row, page 21

1. Right-click the column header to the right of, or the row header below, where you 

want the new column or row to appear.

2. Choose Insert from the shortcut menu.

To delete a column or row, page 22

1. Select the row or column you want to delete.

2. Right-click the selection and choose Delete from the shortcut menu.

To hide a column or row, page 22

1. Select the rows or columns you want to hide.

2. Right-click a row or column header in the selection and choose  Hide from the 

shortcut menu.

To unhide a column or row, page 22

1. Click the row or column header of the row above or the column to the left of the 

rows or columns you want to unhide.
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2. Hold down the G key and click the row or column header of the row or column 

below or to the right of the rows or columns you want to unhide.

3. Right-click the selection and choose Unhide from the shortcut menu.

To insert a cell, page 22

1. Select the cells in the spot where you want to insert new cells.

2. Click the Home tab.

3. In the Cells group, click the Insert button’s down arrow.

4. Click Insert Cells.

5. Select the option button representing how you want to move the existing cells to 

make room for the inserted cells.

6. Click OK.

To delete a cell, page 22

1. Select the cells you want to delete.

2. Click the Home tab.

3. In the Cells group, click the Delete button’s down arrow.

4. Click Delete Cells.

5. Select the option button representing how you want the remaining cells to fi ll in 

the deleted space.

6. Click OK.

To move a group of cells to a new location, page 23

1. Select the cells you want to move.

2. Move the mouse pointer over the outline of the selected cells.

3. Drag the cells to the desired location.

To zoom in or out on a worksheet, page 26

Click the Zoom In control to make your window’s contents 10 percent larger per 

click.

Click the Zoom Out control to make your window’s contents 10 percent smaller per 

click.

Drag the Zoom slider control, shown in the fi gure, to the left to zoom out, or to the 

right to zoom in.
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To zoom in or out to a specifi c zoom level, page 26

1. On the View tab, in the Zoom group, click Zoom.

2. Select the Custom option.

3. Type a new zoom level in the Custom fi eld.

4. Click OK.

To change to another open workbook, page 27

1. On the View tab, in the Window group, click Switch Windows.

2. Click the name of the workbook you want to display.

To arrange all open workbooks in the program window, page 27

1. On the View tab, in the Window group, click Arrange All.

2. Select the desired arrangement.

3. Click OK.

To add a button to the Quick Access Toolbar, page 28

1. Click the Customize Quick Access Toolbar button.

2. Click More Commands.

3. Click the Choose Commands From down arrow.

4. Click the category from which you want to choose the command.

5. Click the command you want to add.

6. Click Add.

7. Click OK.

To move a button on the Quick Access Toolbar, page 28

1. Click the Customize Quick Access Toolbar button.

2. Click More Commands.

3. Click the command you want to move.

4. Click the Move Up button or the Move Down button.

To remove a button from the Quick Access Toolbar, page 28

1. Right-click the button you want to remove.

2. Click Remove from Quick Access Toolbar.
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3 Working with Data and Data Tables

To enter a data series using AutoFill, page 36

1. Type the fi rst label or value for your list.

2. Drag the fi ll handle to the cell containing the last label or value in the series.

To change how dragging the fi ll handle extends a series, page 37

1. Type the fi rst label or value for your list.

2. Hold down the H key, and drag the fi ll handle to the cell containing the last label 

or value in the series.

To enter data by using AutoComplete, page 37

1. Type the beginning of an entry.

2. Press D to accept the AutoComplete value.

To enter data by picking from a list, page 37

1. Right-click a cell in a column with existing values and click Pick from Drop-down 
List from the shortcut menu.

2. Click the item in the list you want to enter.

To copy and paste cells, page 41

1. Select the cell you want to copy.

2. On the Home tab, in the Clipboard group, click Copy.

3. Click the cells into which you want to paste the values.

4. On the Home tab, in the Clipboard group, click Paste.

To copy and paste a row or column, page 41

1. Select the row or column you want to copy.

2. On the Home tab, in the Clipboard group, click Copy.

3. Click the header of the row or column into which you want to paste the values.

4. On the Home tab, in the Clipboard group, click Paste.

To fi nd data within a worksheet, page 44

1. Click the Home tab.

2. In the Editing group, click Find and Select.

3. Click Find.
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4. Type the text you want to fi nd.

5. Click Find Next.

6. Click Close.

To replace a value with another value within a worksheet, page 44

1. Click the Home tab.

2. In the Editing group, click Find and Select.

3. Click Replace.

4. Type the text you want to replace.

5. Type the text you want to take the place of the existing text.

6. Click Find Next. Follow any of these steps:

 Click Replace to replace the text.

 Click Find Next to skip this instance of the text and move to the next time it occurs.

 Click Replace All to replace every instance of the text.

7. Click Close.

To edit a cell’s contents by hand, page 44

1. Click the cell you want to edit.

2. Select the text you want to edit in the Formula Bar.

3. Type the new text and press Enter.

To check spelling, page 48

1. On the Review tab, in the Proofi ng group, click Spelling. If you are asked whether 

you want to save your work, do so.

2. Follow any of these steps:

 Click Ignore Once to ignore the current misspelling.

 Click Ignore All to ignore all instances of the misspelled word.

 Click Add to Dictionary to add the current word to the dictionary.

 Click the correct spelling and then click Change to replace the current mis-

spelling with the correct word.

 Click the correct spelling and then click Change All to replace all instances of 

the current misspelling with the correct word.
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 Click Cancel to stop checking spelling.

3. Click OK to clear the dialog box that appears after the spelling check is complete.

To look up a word in the Thesaurus, page 48

1. Select the word you want to look up.

2. On the Review tab, in the Proofi ng group, click Thesaurus.

To translate a word to another language, page 49

1. Select the word you want to look up.

2. On the Review tab, in the Proofi ng group, click Translate.

To create a data table, page 53

1. Type your table headers in a single row.

2. Type your fi rst data row directly below the header row.

3. Click any cell in the range from which you want to create a table.

4. On the Home tab, in the Styles group, click Format as Table.

5. Click the desired table style.

6. Verify that Excel identifi ed the data range correctly.

7. If your table has headers, select the My table has headers check box.

8. Click OK.

To add rows to a data table, page 53

 Follow either of these steps:

 Click the cell at the bottom right corner of the data table and press D to create a 

new table row.

 Type data into the cell below the bottom left corner of the data table and press D. 

Excel will make the new row part of the data table.

To resize a table, page 53

1. Click any cell in the table.

2. Drag the resize handle to expand or contract the table.

To add a Total row to a column, page 53

1. Click any cell in the table.

2. On the Design tab, in the Table Style Options group, click Total Row.
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To change the Total row summary function, page 54

1. Click any cell in the table’s Total row.

2. Click the down arrow that appears.

3. Click the desired summary function.

To rename a table, page 54

1. Click any cell in the table.

2. On the Design tab, in the Properties group, type a new value in the Table Name 

box.

4 Performing Calculations on Data

To create a named range, page 61

1. Select the cells you want to name.

2. Click the Name Box on the Formula Bar.

3. Type the name you want for the range.

4. Press F.

To create a named range from a selection, page 61

1. Select the cells you want to name as a range. Be sure either the fi rst or last cell 

 contains the name for the range.

2. On the Formulas tab, in the Defi ned Names group, click Create from Selection.

3. Select the check box that represents the cell that contains the range’s desired 

name.

4. Click OK.

To display the Name Manager, page 61

 On the Formulas tab, in the Defi ned Names group, click Name Manager.

To edit a named range, page 62

1. On the Formulas tab, in the Defi ned Names group, click Name Manager.

2. Click the named range you want to edit.

3. Click the Edit button.

4. Click the Collapse Dialog button.
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5. Select the cells you want in the range.

6. Click Close.

To create a formula, page 64

1. Click the cell into which you want to enter a formula.

2. Type =.

3. Type the expression representing the calculation you want to perform. 

4. Press F.

To create a formula using the Insert Function dialog box, page 64

1. On the Formulas tab, in the Function Library group, click Insert Function.

2. Select the function you want to use, and click OK.

3. Fill in the Function Arguments dialog box, and click OK.

To use a named range in a formula, page 66

1. Begin typing the formula.

2. Type the name of the named range as a function’s argument.

To refer to a table column or row in a formula, page 66

1. Click the cell in which you want to create the formula.

2. Type =, followed by the function to include in the formula and a left parenthesis; 

for example, =SUM( would be a valid way to start.

3. Move the mouse pointer over the header of the table column you want to use in 

the formula. When the mouse pointer changes to a black, downward-pointing ar-

row, click the column header.

4. Type a right parenthesis and press F.

To create a formula using Formula AutoComplete, page 67

1. Begin typing the formula.

2. Click the desired function from the list that appears.

To create a formula that doesn’t change when copied between cells, page 68

1. Begin typing the formula.

2. Precede all column and row references with a dollar sign (e.g., $C$4).
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To create a formula that does change when copied between cells, page 68

1. Begin typing the formula.

2. Type all column and row references without a dollar sign (e.g., C4).

To create a conditional formula, page 71

1. Click the cell in which you want to enter an IF function.

2. On the Formulas tab, in the Function Library group, click Logical, and then click IF.

3. Type a conditional statement that evaluates to true or false.

4. Type the text you want to appear if the condition is true.

5. Type the text you want to appear if the condition is false.

6. Click OK.

To display cells that provide values for a formula, page 76

1. Click the cell you want to track.

2. On the Formulas tab, in the Formula Auditing group, click the Trace Precedents 
button.

To display formulas that use a cell’s contents , page 76

1. Click the cell you want to track.

2. On the Formulas tab, in the Formula Auditing group, click the Trace Dependents 
button.

To remove tracer arrows, page 77

1. Click the cell you want to track.

2. On the Formulas tab, in the Formula Auditing group, click the Remove Arrows 
button.

To locate errors in a worksheet, page 77

1. On the Formulas tab, in the Formula Auditing group, click the Error Checking 

button.

2. Click the Edit in Formula Bar button.

3. Edit the formula.

4. Click the Next button to view the next error.
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To step through a formula to locate an error, page 78

1. Click the cell with the formula you want to evaluate.

2. On the Formulas tab, in the Formula Auditing group, click Evaluate Formula.

3. Click Evaluate (one or more times) to move through the formula’s elements.

4. Click Close.

To watch a value in a cell, page 78

1. On the Formulas tab, in the Formula Auditing group, click Watch Window.

2. Click Add Watch.

3. Select the cells you want to watch.

4. Click Add.

5. Click Watch Window.

To delete a watch, page 79

1. On the Formulas tab, in the Formula Auditing group, click Watch Window.

2. Click the watch you want to delete.

3. Click Delete Watch.

4. Click the Close button.

5 Changing Document Appearance

To change a cell’s font, font style, font color, or background color, page 87

1. Select the cells you want to change.

2. On the Home tab, use the controls in the Font group to format the cells.

To add a border to a cell, page 87

1. Select the cells around which you want to draw a border.

2. On the Home tab, in the Font group, click the Border button’s down arrow.

3. Click the type of border you want to apply.

To apply a style to a cell, page 92

1. Select the cells you want to change.

2. On the Home tab, in the Styles group, click Cell Styles.

3. Click a style.
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To create a new style, page 92

1. On the Home tab, in the Styles group, click Cell Styles.

2. Click New Cell Style.

3. Type a new style name.

4. Click Format.

5. Specify the formatting you want this style to contain.

6. Click OK twice.

To delete a style, page 93

1. On the Home tab, in the Styles group, click Cell Styles.

2. Right-click the style you want to delete.

3. Click Delete.

To copy a cell’s formatting onto another cell, page 94

1. Click the cell that contains the format you want to apply to another cell.

2. On the Home tab, in the Clipboard group, click the Format Painter button.

3. Select the cells to which you want to apply the formatting.

To apply a workbook theme, page 97

1. On the Page Layout tab, in the Themes group, click Themes.

2. Click the theme you want to apply.

To change theme fonts, colors, and graphic effects, page 98

 Using the Controls on the Page Layout tab, in the Themes group, follow one of 

these steps:

 Click the Fonts button and select a new font.

 Click the Colors button and select a new color set.

 Click the Effects button and select a new default effect.

To save a workbook’s format as a new theme, page 98

1. Format your worksheet using the colors, fonts, and effects you want to include in 

your theme.

2. On the Page Layout tab, in the Themes group, click Themes.

3. Click Save Current Theme.
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4. Type a name for your theme.

5. Click Save.

To create a new table style, page 98

1. On the Home tab, in the Styles group, click Format as Table and then click New 
Table Style.

2. In the Name fi eld, type a name for the table style.

3. In the Table Element list, click the element you want to format.

4. Click Format, and use the controls in the Format dialog box to format the table 

element.

5. Click OK.

6. Repeat as desired to format other elements, and then click OK.

To format a cell value as a phone number, page 102

1. On the Home tab, click the Number group’s dialog box expander.

2. Click Special.

3. Click Phone Number.

4. Click OK.

To format cell data as a currency value, page 103

 On the Home tab, in the Number group, click the Accounting Number Format 
button.

To select a foreign currency symbol, page 103

1. On the Home tab, in the Number group, click the Accounting Number Format 
button’s down arrow.

2. Click the currency symbol you want to apply.

To add words to a cell’s value, page 103

1. On the Home tab, click the Number group’s dialog box expander.

2. Click Custom.

3. Click the format to serve as the base for your custom format.

4. Type the text to appear in the cell, enclosed in quotes (e.g., “ cases”).

5. Click OK.
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To apply a conditional format to a cell, page 107

1. Select the cells you want to change.

2. On  the Home tab, in the Styles group, click Conditional Formatting.

3. Click New Rule.

4. Click Format Only Cells That Contain.

5. Click the Comparison Phrase down arrow, and then click the comparison phrase 

you want.

6. Type the constant values or formulas you want evaluated.

7. Click Format.

8. Specify the formatting you want and click OK twice.

To edit a conditional formatting rule, page 109

1. Select the cells that contain the rule you want to edit.

2. On the Home tab, in the Styles group, click Conditional Formatting.

3. Click Manage Rules.

4. Click the rule you want to change.

5. Click Edit Rule.

6. Use the controls to make your changes.

7. Click OK twice to save your changes.

To delete a conditional formatting rule, page 109

1. Select the cells that contain the rule you want to edit.

2. On the Home tab, in the Styles group, click Conditional Formatting.

3. Click Manage Rules.

4. Click the rule you want to delete.

5. Click Delete Rule.

6. Click OK.

To display data bars in one or more cells, page 109

1. Select the cells that contain your data.

2. On the Home tab, in the Styles group, click Conditional Formatting.

3. Point to Data Bars.
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4. Click the data bar option you want to apply.

To display a color scale in one or more cells, page 109

1. Select the cells that contain your data.

2. On the Home tab, in the Styles group, click Conditional Formatting.

3. Point to Color Scales.

4. Click the color scale pattern you want to apply.

To display icon sets in one or more cells, page 109

1. Select the cells that contain your data.

2. On the Home tab, in the Styles group, click Conditional Formatting.

3. Point to Icon Sets.

4. Click the icon set you want to apply.

To add a picture to a worksheet, page 113

1. On the Insert tab, in the Illustrations group, click Picture.

2. Double-click the picture you want to insert.

To change a picture’s characteristics, page 113

1. Click the picture.

2. Use the controls on the Format tab to edit the picture.

6 Focusing on Specifi c Data Using Filters

To apply a fi lter to a worksheet, page 122

1. Click any cell in the range you want to fi lter.

2. On the Data tab, in the Sort & Filter group, click Filter.

3. Click the fi lter arrow for the column by which you want to fi lter your worksheet.

4. Select the check boxes next to the values by which you want to fi lter the list.

5. Click OK.

To clear a fi lter, page 122

1. Click any cell in the fi ltered range.

2. On the Data tab, in the Sort & Filter group, click Clear.
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To display the top or bottom values in a column, page 124

1. Click the fi lter arrow at the top of the column by which you want to fi lter the list.

2. Click Number Filters.

3. Click Top 10.

4. Select whether to display the top or bottom values.

5. Select how many values to display.

6. Select whether the value in the middle box represents the number of items to dis-

play, or the percentage of items to display.

To create a custom fi lter, page 124

1. Click any cell in the list you want to fi lter.

2. If necessary, on the Data tab, in the Sort & Filter group, click Filter to display the 

fi lter arrows.

3. Click the fi lter arrow of the column for which you want to create a custom fi lter.

4. Point to Text Filters.

5. Click Custom Filter.

6. Click the Comparison Operator down arrow, and then click the comparison you 

want to use.

7. Type the value by which you want to compare the values in the selected column.

8. Click OK.

To generate a random value, page 127

 Type the formula =RAND().

To generate a random value between two other values, page 127

 Type the formula =RANDBETWEEN(low, high), replacing low and high with the 

lower and upper bound of values you want to generate.

To summarize data quickly using AutoCalculate, page 128

1. Select the cells you want to summarize.

2. View the summary on the status bar, at the bottom right of the Excel program 

window.
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To summarize fi ltered data using a SUBTOTAL formula, page 128

 Type the formula =SUBTOTAL(function, ref), replacing function with the desired 

summary function, and ref with the cell range you want so summarize.

To fi nd list rows that contain unique values, page 130

1. Select the cells in which you want to fi nd unique values.

2. On the Data tab, in the Sort & Filter group, click Advanced.

3. Select the Unique Records Only check box.

4. Click OK.

To create a validation rule, page 132

1. Select the cells you want to validate.

2. On the Data tab, in the Data Tools group, click the Data Validation button’s down 

arrow.

3. Click Data Validation.

4. Click the Allow down arrow, and click what type of data you want to allow.

5. Click the Data down arrow, and click the condition for which you want to validate.

6. Type the appropriate values in the boxes.

7. Click the Input Message tab.

8. Select the Show Input Message When Cell Is Selected check box.

9. Type the message you want to appear when the cell is clicked.

10. Click the Error Alert tab.

11. Select the Show Error Alert After Invalid Data is Entered check box.

12. Click the Style down arrow, and click the icon you want to appear next to your 

message.

13. Type a title for the error message box.

14. Type the error message you want.

15. Click OK.

To identify which cells contain invalid data, page 133

 On the Data tab, in the Data Tools group, click the Data Validation button’s down 

arrow and then click Circle Invalid Data.
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To turn off data validation in a cell, page 134

 On the Data tab, in the Data Tools group, click the Data Validation button’s down 

arrow and then click Clear Invalidation Circles.

 7 Reordering and Summarizing Data

To sort a data list, page 140

 1. Click any cell in the column by which you want to sort your data.

 2. On the Data tab, in the Sort & Filter group, follow either of these steps:

  Click the Sort Ascending button in the Sort & Filter group on the ribbon.

  Click the Sort Descending button in the Sort & Filter group on the ribbon.

To sort a data list by values in multiple columns, page 141

 1. Select a cell in the data list or table you want to sort.

 2. On the Data tab, in the Sort & Filter group, click Sort.

 3. Click the Sort By down arrow and then click the fi rst column by which you want to 

sort.

 4. Click the Sort On down arrow and then click the criteria by which you want to sort.

 5. Click the Order down arrow.

 6. Select the A to Z item or the Z to A item to indicate the order into which the col-

umn’s values should be sorted.

 7. Click Add Level.

 8. If necessary, repeat steps 3–7 to set the columns and order for additional sorting 

rules.

 9. Click OK.

To add a sorting level, page 142

 1. Select a cell in the data list or table you want to sort.

 2. On the Data tab, in the Sort & Filter group, click Sort.

 3. Click Add Level, and defi ne the sort using the tools in the dialog box.

To delete a sorting level, page 142

 1. Select a cell in the sorted data list.

 2. On the Data tab, in the Sort & Filter group, click Sort.
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3. Click the level you want to delete.

4. Click Delete Level.

To create a custom list for sorting, page 142

1. Click the Microsoft Offi ce Button.

2. Click Excel Options.

3. Click Popular.

4. Click Edit Custom Lists.

5. Click New List.

6. Type the custom list you want. Separate each entry by pressing F.

7. Click Add.

8. Click OK twice to close the Custom Lists dialog box and the Excel Options dialog 

box.

To sort worksheet data by a custom list of values, page 143

1. Click any cell in the list you want to sort.

2. On the Data tab, in the Sort & Filter group, click Sort.

3. Click the Sort By down arrow and then click the column you want to sort by.

4. Click the Sort On down arrow and then click the criteria you want to sort by.

5. Click the Order down arrow and then click Custom List.

5. Click a custom list.

7. Click OK to close the Custom Lists dialog box.

8. Click OK to sort the data list.

To organize worksheet data into groups, page 147

1. Click any cell in the range you want to group.

2. On the Data tab, in the Outline group, click Subtotal.

3. Click the At Each Change In down arrow, and then click the value on which you 

want to base the subtotals.

4. Click the Use Function down arrow, and then click the subtotal function you want 

to use.

5. Select which columns should have subtotals calculated.
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 6. Click OK.

To show and hide levels of detail in a grouped data list, page 149

 Follow either of these steps:

 Click the Show Detail control on a hidden grouping level to display that lev-

el’s contents.

 Click the Hide Detail control to hide rows that are currently displayed.

To remove grouping levels from a data list, page 150

 1. Click any cell in the subtotaled range.

 2. On the Data tab, in the Outline group, click Subtotal, and then click Remove All.

To look up data in a data list, page 153

 1. Create a sorted data list or data table that has column headers.

 2. Create a VLOOKUP formula of the form =VLOOKUP(lookup_value, table_array, 

col_index_num, range_lookup). 

 3. Type a value in the cell referred to by the lookup_value argument.

 8 Combining Data from Multiple Sources

To create a workbook template, page 160

 1. Click the Microsoft Offi ce Button, and click Save As.

 2. Click the Save As Type down arrow, and click Excel Template.

 3. Type the name you want for the template.

 4. Click Save.

To create a new workbook that is based on a template, page 161

 1. Click the Microsoft Offi ce Button, and click New.

 2. Click Installed Templates, and double-click the template you want to use to create 

your workbook.

 3. Click the Microsoft Offi ce Button, and click Save As.

 4. Type a name for the fi le.

 5. Click the Save As Type down arrow, and click Excel Workbook.

 6. Click Save.
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To create a worksheet template, page 162

1. Remove all but one worksheet from a workbook, and format the worksheet as you 

want the template to appear.

2. Click the Microsoft Offi ce Button, and click Save As.

3. Click the Save As Type down arrow, and click Excel Template.

4. Type the name you want for the template.

5. Click Save.

To add a template-based worksheet to a workbook, page 162

1. Right-click a sheet tab, and then click Insert.

2. On the Spreadsheet Solutions tab page, click the template you want to use.

3. Click OK.

To create a link between two cells, page 167

1. In the cell you want to be target of the link, type =, but do not press F.

2. On the View tab, in the Window group, click Switch Windows, and then click the 

workbook that contains the data for your target cell.

3. Click the cell that contains the data, and press F.

To open multiple workbooks simultaneously, page 175

1. Open the workbooks you want to open simultaneously.

2. On the View tab, in the Window group, click Save Workspace.

3. Type a name for the workspace.

4. Click Save.

9 Analyzing Alternative Data Sets

Defi ne an alternative data set, page 180

1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Scenario Manager.

2. Click Add.

3. In the Scenario Name fi eld, type a name for the scenario.

4. At the right edge of the Changing cells fi eld, click the Contract Dialog button.

5. Select the cells to change, and then click the Expand Dialog button.
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6. Click OK.

7. Type new values for the cells, and then click OK.

8. Click Close.

To change a worksheet’s values using a scenario, page 183

1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Scenario Manager.

2. Click the scenario you want to display.

3. Click Show.

To summarize the values in multiple scenarios, page 184

1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Scenario Manager.

2. Click Summary.

3. Verify that the Scenario summary option button is selected and that the correct 

cells appear in the Result cells fi eld.

4. Click OK.

To determine the required inputs for a formula to generate a specifi c result, 
page 188

1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Goal Seek.

2. In the Set cell fi eld, type the address of the cell that contains the formula you want 

to generate a target value.

3. In the To value fi eld, type the target value.

4. In the By changing cell fi eld, type the cell that contains the value you want to vary.

5. Click OK.

6. Click Cancel to close the Goal Seek dialog box without saving your changes.

To analyze data by using Descriptive Statistics, page 197

1. On the Data tab, in the Analysis group, click Data Analysis.

2. Click Descriptive Statistics and then click OK.

3. Click in the Input Range fi eld and then select the cells you want to summarize.

4. Select the Summary Statistics check box.
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5. Click OK.

10 Creating Dynamic Lists with PivotTables

To create a PivotTable from a data list, page 204

1. Click any cell in the data table.

2. On the Insert tab, in the Tables group, click PivotTable.

3. Verify that the proper  table name or cell range appears in the Table/Range fi eld 

and that the New Worksheet option button is selected.

4. Click OK.

5. In the PivotTable Field List task pane, drag the available fi elds to the desired spots 

in the PivotTable.

To pivot a PivotTable, page 208

 In the PivotTable Field List task pane, drag a fi eld header to a new position.

To fi lter a PivotTable, page 211

1. On the PivotTable worksheet, click any cell in the PivotTable.

2. In the PivotTable Field List task pane’s Choose fi elds to add to report section, 

click the target fi eld header, and then click the down arrow next to the fi eld header 

and clear the (Select All) check box.

3. Select the check boxes of the values you do want to show, and then click OK.

To show or hide the PivotTable Field List task pane, page 213

1. Click any cell in the PivotTable.

2. On the Options tab, in the Show/Hide group, click the Field List button.

To show or hide levels of detail within a PivotTable, page 214

 In the body of the PivotTable, follow either of these steps:

 Click the Show Detail control to display hidden rows.

 Click the Hide Detail control to hide rows displayed in the PivotTable.

To rename a PivotTable, page 218

1. On the PivotTable worksheet, click any cell in the PivotTable.

2. On the Options contextual tab, in the PivotTable group, in the PivotTable Name 

fi eld, type a new name for the PivotTable.
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To control how and where subtotals and grand totals appear in your PivotTable, 
page 218

1. On the PivotTable worksheet, click any cell in the PivotTable.

2. On the Design contextual tab, in the Layout group, click Subtotals, and then click 

the option representing how you want subtotals to appear in your PivotTable. 

3. On the Design contextual tab, in the Layout group, click Grand Totals, and 

then click the option representing how you want grand totals to appear in your 

PivotTable.

To change the PivotTable summary function, page 219

 Right-click any data cell in the PivotTable, point to Summarize Data By, and then 

click the desired summary function.

To apply a number format to a PivotTable, page 223

1. On the PivotTable worksheet, right-click any data cell and then click Number 
Format.

2. In the Category list, click Number.

3. Use the controls on the Number tab to create your format.

4. Click OK.

To apply a conditional format to a PivotTable, page 224

1. Select the cell ranges you want to format.

2. On the Home tab, in the Styles group, click Conditional Formatting, point to the 

type of conditional format you want to use, and then click the specifi c format you 

want to apply.

To apply a PivotTable Style to a PivotTable, page 225

1. Click any cell in the PivotTable.

2. On the Design tab, in the PivotTable Styles gallery, click the style you want to ap-

ply to the PivotTable.

To create a new PivotTable style, page 225

1. Click any cell in the PivotTable.

2. On the Design contextual tab, in the PivotTable Styles group, click the More but-

ton at the bottom-right corner of the style gallery.

3. Click New PivotTable Style.
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4. In the Name fi eld, type a name for the style.

5. In the Table Element list, click the element you want to change, and then click 

Format.

6. Use the controls in the Format Cells dialog box to format the element.

7. If desired, repeat Step 6 for other elements.

8. Click OK twice.

To import data from an external source, page 231

1. On the Data tab, in the Get External Data group, click From Text.

2. Navigate to the folder that contains the source fi le, and double-click the fi le.

3. Verify that the Delimited option button is selected and then click Next.

4. In the Delimiters section, verify that the correct check box is selected and also 

verify that the data displayed in the Data preview area refl ects the structure you 

expect.

5. Click Finish.

11 Creating Charts and Graphics

To create a chart, page 238

1. Click any cell in the data table.

2. On the Insert tab, in the Charts group, click the desired chart type, and then click 

the desired chart subtype.

To change how Excel plots your data, page 239

1. On the Design tab, in the Data group, click Select Data.

2. In the Legend Entries (Series) area, click the data series you want to change.

3. Click Remove.

4. In the Horizontal (Categories) Axis Labels area, click Edit.

5. Select the cells you want to plot on this axis and then click OK.

To remove a series from an axis, page 240

1. On the Design tab, in the Data group, click Select Data.

2. In the Legend Entries (Series) area, click the data series you want to remove from 

the chart.
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3. Click Remove.

To add a series to an axis, page 240

1. On the Design tab, in the Data group, click Select Data.

2. In the Legend Entries (Series) area, click Add.

3. In the Series name box, type a name for the series.

4. Click in the Series values box, and select the cells to provide values for the series.

5. Click OK.

To move a chart to its own worksheet, page 241

1. Click the chart.

2. On the Design tab, in the Location group, click Move Chart.

3. Select the target sheet for the chart, and click OK.

To apply a Chart Style to a chart, page 244

1. Click the chart.

2. On the Design tab, in the Chart Styles gallery, click the style you want to apply.

To apply a different layout to a chart, page 244

1. Click the chart.

2. On the Design tab, in the Chart Layouts gallery, click the layout you want to apply.

To change the appearance of a chart’s gridlines, page 245

1. Click the chart.

2. On the Layout tab, in the Axes group, click Gridlines, and then click the gridline 

settings you want.

To select a chart element for formatting, page 245

1. Click the chart.

2. On the Layout tab, in the Current Selection group, click the Chart Elements down 

arrow, and then click the element you want to select.

To select a data point in a series, page 245

1. Click the chart.

2. Click any point in the data series.
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3. Click the specifi c data point you want to select.

To format a chart element, page 245

1. Select the chart element you want to format.

2. On the Layout tab, in the Current Selection group, click Format Selection.

3. Use the controls in the Format dialog box to format the chart element. 

To save a chart as a chart template, page 246

1. Click the chart.

2. On the Design tab, in the Type group, click Save As Template.

3. Type a name for the template.

4. Click Save.

To add a trendline to a chart, page 250

1. Select the chart.

2. On the Layout contextual tab, in the Analysis group, click Trendline, and then click 

More Trendline Options.

3. In the Trend/Regression Type area, select the Linear option button.

4. In the Forecast area, in the Forward fi eld, type the number of periods you want to 

project.

5. Click Close.

To create a PivotChart, page 252

1. On the data worksheet, click any cell in the data table.

2. On the Insert tab, in the Tables group, click the PivotTable button down arrow and 

then click PivotChart.

3. Verify that the correct data source appears in the Table/Range fi eld and that the 

New Worksheet option button is selected.

4. Click OK.

To change the chart type of a chart or PivotChart, page 254

1. Click the chart.

2. On the Design contextual tab, in the Type group, click Change Chart Type.

3. Click the desired chart type and subtype.
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4. Click OK.

To create a SmartArt diagram, page 258

1. On the Insert tab, in the Illustrations group, click SmartArt.

2. Click the desired graphic type.

3. Click the desired subtype and then click OK.

To add text to a diagram shape, page 261

 Click the shape and type the text.

To add a shape to a diagram, page 261

1. Click the shape above or to the right of where you want the new shape to appears.

2. On the Design contextual tab, in the Create Graphic group, click the Add Shape 

button down arrow and then click the option representing where you want the 

shape to appear.

To change the format of a diagram shape, page 262

1. Right-click the shape, and then click Format Shape.

2. Use the controls in the Format Shape dialog box to change the shape’s 

appearance.

12 Printing

To display a worksheet in Page Layout View, page 268

 On the View tab, in the Workbook Views group, click Page Layout.

To add a header or footer to a worksheet, page 268

1. On the View tab, in the Workbook Views group, click Page Layout.

2. Follow either of these steps:

 At the top of the worksheet, click the target header section

 At the bottom of the worksheet, click the target footer section.

3. In the active header or footer section, type the text that you want to have appear, 

and press F.
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To create an AutoHeader, page 269

1. On the View tab, in the Workbook Views group, click Page Layout.

2. At the top of the worksheet, click Click to add header.

3. Click in the target header section.

4. On the Design contextual tab, in the Header & Footer Elements group, click the 

auto text you want to add.

To add an image to a header or footer, page 270

1. On the View tab, in the Workbook Views group, click Page Layout.

2. Click the desired header or footer section.

3. On the Design contextual tab, in the Header & Footer Elements group, click 

Picture.

4. Double-click the picture you want to add to the header or footer.

To format an image in a header or footer, page 270

1. Click the image in the footer and then, on the Design contextual tab, click Format 
Picture.

2. Use the controls in the Format Picture dialog box to change the picture’s 

appearance.

3. Click OK.

To change a worksheet’s margins, page 273

 On the Page Layout tab, in the Page Setup group, click Margins and then click the 

desired margins, or click Custom Margins to enter the margins manually.

To change a worksheet’s page orientation, page 274

 On the Page Layout tab, in the Page Setup group, click Orientation and then click 

the desired orientation.

To print a worksheet on a specifi c number of pages, page 275

1. On the Page Layout tab, in the Scale to Fit group, click the Width control down 

arrow and then click the desired number of pages.

2. On the Page Layout tab, in the Scale to Fit group, click the Height control down 

arrow and then click the desired number of pages.
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To preview a worksheet before printing, page 275

 While displaying the worksheet you want to preview, click the Microsoft Offi ce 
Button, point to Print, and then click Print Preview.

To add a page break to a worksheet, page 275

1. Click the row or header below or to the right of where you want the page break to 

appear.

2. On the Page Layout tab, in the Page Setup group, click Breaks and then click 

Insert Page Break.

To remove a page break from a worksheet, page 276

1. Click the row or header below or to the right of the page break.

2. On the Page Layout tab, in the Page Setup group, click Breaks and then click 

Remove Page Break.

To change the order in which worksheets print, page 277

1. On the Page Layout tab, click the Page Setup group’s dialog box launcher.

2. If necessary, click the Sheet tab.

3. In the Page order section, select the desired option button.

4. Click OK.

To print a worksheet, page 281

 Click the Microsoft Offi ce Button, and then click Print.

To print part of a worksheet, page 283

1. On the Page Layout tab, in the Page Setup group, click Print Titles.

2. At the right edge of the Columns to repeat at left fi eld, click the Collapse Dialog 

button.

3. Select the column header of the columns you want to repeat.

4. At the right edge of the Columns to repeat at left fi eld, click the Expand Dialog 

button.

To center material on the printed page, page 284

1. On the Page Layout tab, click the Page Setup group’s dialog box launcher.

2. On the Margins page of the dialog box, select the Horizontally and Vertically 

check boxes.
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3. Click OK.

To print a chart, page 288

1. Select the chart.

2. Click the Microsoft Offi ce Button and then click Print.

3. Verify that the Selected Chart option button is selected and then click OK (or click 

Cancel if you don’t want to print the chart).

13 Automating Repetitive Tasks with Macros

To save a workbook as a macro-enabled workbook, page 292

1. Click the Microsoft Offi ce Button, and then click Save As.

2. Click the Save as type down arrow, and then click Excel Macro-Enabled Workbook 
(*.xlsm).

3. Click Save.

To enable macros to run in a workbook, page 293

1. On the Message Bar, click Options.

2. Select the Enable this content option button.

3. Click OK.

To view a macro, page 295

1. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

2. Click the macro you want to view, and then click Edit.

To step through a macro, page 296

1. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

2. Click the macro you want to view, and then click Step Into.

3. Press ( to execute the fi rst macro step.

To run a macro, page 296

1. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

2. Click the desired macro, and then click Run.
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To record a macro, page 299

1. On the View tab, in the Macros group, click the Macros button’s down arrow, and 

then click Record Macro.

2.  In Record Macro dialog box, in the Macro name box, delete the existing name, 

and then type a new name for the macro.

3. Click OK.

4. Perform the actions you want to record.

5. On the View tab, in the Macros group, click the Macros button down arrow, and 

then click Stop Recording.

To edit a macro, page 300

1. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

2. Click the macro you want to view, and then click Edit.

3. Make any desired changes.

4. Click the Visual Basic Editor Close button.

To run a macro when a Quick Access Toolbar button is clicked, page 303

1. On the Quick Access Toolbar, click the Customize Quick Access Toolbar button 

and then click More Commands.

2. If necessary, click the Choose commands from down arrow and then click the de-

sired category.

3. In the Commands panel, click the desired command.

4. Click Add.

5. Click the Choose commands from box down arrow and then click Macros.

6. In the Commands panel, click the macro you want to run.

7. Click Add.

8. Click OK.

To change the appearance of a Quick Access Toolbar button, page 305

1. On the Quick Access Toolbar, click the Customize Quick Access Toolbar button 

and then click More Commands.

2. In the Customize Quick Access Toolbar command panel, click the command you 

want to change.
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3. Click Modify.

4. Click the desired button design.

5. Click OK twice to close the Modify Button dialog box and the Excel Options dialog 

box.

To run a macro when a shape is clicked, page 305

1. Right-click the shape and then click Assign Macro.

2. Click the desired macro and then click OK.

To run a macro when a workbook is opened, page 308

 Create a macro named Auto_Open.

14 Working with Other Microsoft Offi ce System Programs

To link to another Microsoft Offi ce system document, page 314

1. On the Insert tab, in the Text group, click Object.

2. Click the Create from File tab.

3. Click Browse.

4. Click the fi le to which you want to link, and then click Insert.

5. Select the Link to fi le check box and then click OK.

To embed another document in a workbook, page 317

1. On the Insert tab, in the Text group, click Object.

2. Click the Create from File tab.

3. Click Browse.

4. Click the fi le to which you want to link, and then click Insert.

5. Click OK.

To view a linked or embedded document, page 318

 Double-click the document.

To create a hyperlink, page 320

1. On the Insert tab, in the Links group, click Hyperlink.

2. Click the type of hyperlink you want to create.
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 3. If necessary, use the controls in the Look in box to locate the fi le or location to 

which you want to link.

 4. In the fi le list, click the hyperlink’s target.

 5. In the Text to display box, type the text you want displayed.

 6. Click OK.

To edit a hyperlink, page 323

 1. Right-click the cell that contains the hyperlink, and then click Edit Hyperlink.

 2. Edit the values in the Hyperlink dialog box.

 3. Click OK.

To delete a hyperlink, page 323

 Right-click the cell that contains the hyperlink, and then click Delete Hyperlink.

To paste a chart into another document, page 325

 1. Right-click the chart and then click Copy.

 2. Open the destination document.

 3. Right-click a blank spot in the visible slide and click Paste.

 4. Click the Paste Options button and then click the desired option.

 15 Collaborating with Colleagues

To turn on workbook sharing, page 330

 1. On the Review tab, in the Changes group, click Share Workbook.

 2. Select the Allow changes by more than one use at the same time. This also al-
lows workbook merging. check box.

 3. Click OK.

To add a comment to a cell, page 333

 1. Click the cell where you want the comment to appear.

 2. On the Review tab, in the Comments group, click New Comment. 

 3. Type the comment text, and then click outside the body of the comment.

To edit a comment, page 334

 1. Click the cell that contains the comment.
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2. On the Review tab, in the Comments group, click Edit Comment.

3. Type the new comment text, and then click outside the body of the comment.

To delete a comment, page 334

1. Click the cell that contains the comment.

2. On the Review tab, in the Comments group, click Delete Comment.

To track changes made to a workbook, page 336

1. On the Review tab, in the Changes group, click Track Changes, and then click 

Highlight Changes.

2. Select the Track changes while editing. This also shares your workbook check 

box.

3. Click OK.

To accept and reject changes, page 337

1. On the Review tab, in the Changes group, click Track Changes, and then click 

Accept/Reject Changes.

2. Click OK.

3. Click Accept to accept the change, or click Reject to reject the change. You can also 

click Accept All or Reject All.

To record workbook changes on a History worksheet, page 337

1. On the Review tab, in the Changes group, click Track Changes, and then click 

Highlight Changes.

2. Select the List changes on a new sheet check box, and click OK.

To require a password to open a workbook, page 340

1. Click the Microsoft Offi ce Button, and then click Save As.

2. Click the Tools button, and then click General Options.

3. Type a password in the Password to open box.

4. Type a different password in the Password to modify box.

5. Click OK.

6. In the Reenter password to proceed box, type the fi rst password.

7. Click OK.
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8. In the Reenter password to modify box, type the second password.

9. Click OK.

To password protect a worksheet, page 340

1. On the Review tab, in the Changes group, click Protect Sheet.

2. In the Password to unprotect sheet box, type a password.

3. Clear the Select locked cells and Select unlocked cells check boxes, and then click 

OK.

4. In the Reenter password to proceed box, type the password you entered before, 

and then click OK.

To password protect a cell range, page 341

1. On the Review tab, in the Changes group, click Allow Users to Edit Ranges.

2. Click New.

3. In the Title box, type a title for the range.

4. In the Range password box, type a password, and then click OK.

To sign a workbook using a digital signature, page 345

1. Click the Microsoft Offi ce Button, click Prepare, and then click Add a Digital 
Signature.

2. Click OK to clear the dialog box that appears.

3. In the Purpose for signing this document box, type a reason.

4. Verify that your certifi cate appears in the Signing as area of the dialog box, and 

then click Sign.

5. Click OK.

To publish a workbook to the Web, page 347

1. Click the Microsoft Offi ce Button, and then click Save As.

2. In the File name box, type a name for the fi le.

3. Click the Save as type down arrow, and then click Web Page.

4. Click Save.

5. Click Yes to save the workbook as a web fi le.
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11 What’s New in  What’s New in 
 Excel 2007? Excel 2007?

One of the fi rst things you’ll notice about Microsoft® Offi ce Excel® 2007 is that the user 

interface has changed quite a bit. Earlier versions of Offi ce Excel 2007 housed the pro-

gram’s more than 1,000 commands in a series of menus, toolbars, task panes, and dialog 

boxes. And, as it turns out, there were some functions that didn’t appear by default on 

any of the menus or toolbars. In Excel 2007, there is only one place to look for the tools 

you need to use it: the user interface   Ribbon at the top of the program window. The 

Microsoft Excel 2007 product team took the dozens of menus and toolbars and reor-

ganized their contents onto the Ribbon tabs and galleries. If you’ve used Excel before, 

you’ll need to spend only a little bit of time working with the new user interface to bring 

yourself back up to your usual profi ciency. If you’re new to Excel, you’ll have a much 

easier time learning to use the program than you would have had with the previous user 

interface.

This chapter introduces many of the new features in Excel 2007: the new user interface, 

the improved formatting capabilities provided by galleries and minitoolbars, the new 

 capabilities offered by data tables, the new color management scheme, and the im-

proved charting engine. There are also new ways to manage the data in your workbooks. 

For example, you can create more fl exible rules to have Excel 2007 format your data 

based on its value, summarize your data by using new functions, and save your work-

books as documents in other useful fi le formats. All these improvements combine to 

make Excel 2007 an accessible, powerful program you can use to manage, analyze, and 

present your data effectively.

Note Included in the back of this book is a handy tear-out guide to the 2007 Microsoft 

Offi ce System. This guide will help you fi nd your way around the new interface quickly and 

help you start customizing the interface for the way you work. The guide also provides an 

overview of some of the most-used commands on the Ribbon. Before you know it, you’ll be 

navigating the 2007 Offi ce System with ease.
  1
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Becoming Familiar with the New User Interface
After you enter your data into a worksheet, you can change the data appearance, 

summarize it, or sort it by using the commands on the user interface Ribbon. Unlike in 

previous versions of Excel, which made you hunt through a complex toolbar and menu 

system to fi nd the commands you wanted, you can fi nd everything you need at the 

top of the Excel 2007 program window.

The Excel 2007 user interface divides its commands into seven tabs: Home, Insert, 

Page Layout, Formulas, Data, Review, and View. The Home tab appears when you 

start Excel 2007.

See Also If you work with macros or add-ins, you can add the Developer tab to the user 
interface. For more information about adding the Developer tab, see “Recording a Macro” in 
Chapter 13, “Automating Repetitive Tasks with Macros.”

The Home tab contains a series of groups: Clipboard, Font, Alignment, Number, Styles, 

Cells, and Editing. Each group, in turn, hosts a series of controls that enable you to 

perform tasks related to that group (formatting fonts, setting cell alignment, creating 

number formats, and so on). Clicking a control with a drop-down arrow displays a menu 

that contains further options; if an option has an ellipsis (…) after the item name, click-

ing the item displays a dialog box. If a group has a dialog box associated with it, such as 

the Number group shown in the preceding graphic, you can display that dialog box by 

clicking the Dialog Box Launcher at the lower-right corner of the group. (The Dialog Box 

Launcher looks like a small box with an arrow pointing down and to the right.)

Managing Larger Data Collections
Many Excel users take advantage of the program’s data summary and calculation 

 capabilities to process large data collections. In Excel 2003 and earlier versions, you were 

limited to 65,536 rows and 256 columns of data in a worksheet. You could always spread 

larger data collections across multiple worksheets, but it took a lot of effort to make ev-

erything work correctly. You don’t have that problem in Excel 2007. The Microsoft Excel 

2007 product team expanded worksheets to include 16,384 columns and 1,048,576 rows 

of data, which should be suffi cient for most of the projects you want to do in Excel 2007.
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Excel 2007 also comes with more powerful and fl exible techniques you can use to 

process your worksheet data. In Excel 2003, you could assign up to three conditional 

formats (rules that govern how Excel displays a value) to a cell. In Excel 2007, the only 

limit on the number of conditional formats you can create is your computer’s memory. 

The table below summarizes the expanded data storage and other capabilities found in 

Excel 2007.

Limit Excel 2003 Excel 2007

Columns in a worksheet 256 16,384

Rows in a worksheet 65,536 1,048,576

Number of different colors allowed in a 

workbook

56 4.3 billion

Number of conditional format conditions 

applied to a cell

3 Limited by 

available 

memory

Number of sorting levels of a range or 

table

3 64

Number of items displayed in an 

AutoFilter list

1,024 32,768

Total number of characters displayed in 

a cell

1,024 32,768

Total number of characters per cell that 

Excel can print

1,024 32,768

Total number of unique cell styles in 

a workbook

4,000 65,536

Maximum length of a formula, in 

characters

1,024 8,192

Number of nested levels allowed in a 

formula

7 64

Maximum number of arguments in a 

formula

30 255

Number of characters that can be 

stored and displayed in a cell with a 

text format

255 32,768

Number of columns allowed in a 

PivotTable

255 16,384

Number of fi elds displayed in the 

PivotTable Field List task pane

255 16,384
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Using the New Microsoft Offi ce File Format
Starting with the 1997 release, all Microsoft Offi ce programs have used a binary fi le 

 format that computers (but not humans) can read. Excel 2007, Microsoft Offi ce Word 

2007, and Microsoft Offi ce PowerPoint® 2007 have a new and improved fi le format 

that, in addition to being somewhat readable, creates much smaller fi les than the older 

binary format.

The new Microsoft Offi ce Open XML Formats combine the XML and the Zip fi le com-

pression format to create robust fi les that (on average) are about half the size of similar 

Excel 97–2003 fi les. You can open and save Excel 97–2003 fi les in Excel 2007, of course. 

If you want to open Excel 2007 fi les in Excel 2000, Excel 2002, or Excel 2003, you can in-

stall the Microsoft Offi ce Compatibility Pack for Offi ce Word 2007, Excel 2007, and Offi ce 

PowerPoint 2007 fi le formats from this book’s companion CD.

Besides smaller fi le sizes, the 2007 Microsoft Offi ce system fi le formats offer several 

other advantages:

Improved interoperability. Because the new fi le formats use XML as their base, it 

is much easier for organizations to share and exchange data between the Microsoft 

Offi ce system programs and other applications. The older binary fi le format was 

diffi cult to read and wasn’t standards-based.

Enhanced customization. The letter “X” in XML stands for “extensible,” which 

means that information professionals and developers can create custom document 

structures, or schema, that meet their organization’s needs. 

Improved automation. The Excel 2007 fi le format is based on open standards, 

which means that any program written to process data based on those standards 

will work with Excel 2007. In other words, you don’t need to write special routines 

or use another program in the Microsoft Offi ce system to handle your Excel 2007 

data programmatically. 

Compartmentalizing information. The new Microsoft Offi ce system fi le format 

separates document data, macro code, and header information into separate con-

tainers, which Excel 2007 then combines into the fi le you see when you open your 

workbook. Separating macro code (automated program instructions) from your 

worksheet data improves security by identifying that a workbook contains a macro 

and enables you to prevent Excel 2007 from executing code that could harm your 

computer or steal valuable personal or business information.
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Formatting Cells and Worksheets
Excel has always been a great program for analyzing numerical data, but even Excel 

2003 came up a bit short in the presentation department. In Excel 2003 and earlier 

 versions of the program, you could have a maximum of 56 different colors in your work-

book. In addition, there was no easy way to ensure that your colors complemented the 

other colors in your workbook (unless you were a graphic designer and knew what you 

wanted going in).

Excel 2007 offers vast improvements over the color management and formatting options 

found in previous versions of the program. You can have as many different colors in a 

workbook as you like, for example, and you can assign a design theme to a workbook. 

Assigning a theme to a workbook offers you color choices that are part of a complemen-

tary whole, not just a dialog box with no guidance about which colors to choose. You 

can, of course, still select any color you want when you format your worksheet, defi ne 

custom cell styles, and create your own themes. The preinstalled themes are there as 

guides, not prescriptions.

Managing Data Tables More Effectively
You’ll often discover that it makes sense to arrange your Excel 2007 data as a table, in 

which each column contains a specifi c data element (such as an order number or the 

hours you worked on a given day), and each row contains data about a specifi c business 

object (such as the details of delivery number 1403). 
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In Excel 2007, tables enable you to enter and summarize your data effi ciently. If you 

want to enter data in a new table row, all you have to do is type the data in the row 

below the table. After you press TAB or ENTER after typing in the last cell’s values, Excel 

2007  expands the table to include your new data. You can also have Excel 2007 display a 

Totals row, which summarizes your table’s data using a function you specify.

See Also For more information on how to change the appearance and summary operations of 
a data table, see “Defi ning a Table” in Chapter 3, “Working with Data and Data Tables.”

Creating Formulas More Easily by Using Formula 
AutoComplete

Excel 2003 and earlier versions of the program provided two methods to fi nd the name 

of a function to add to a formula: the help system and the Insert Function dialog box. 

Excel 2007 adds a new tool to your arsenal: Formula AutoComplete. Here’s how it works: 

When you begin typing a formula into a cell, Excel 2007 examines what you’re typing 

and then displays a list of functions and function arguments, such as named cell ranges 

or table columns that could be used in the formula. 

Formula AutoComplete offers lists of the following items as you create a formula:

Excel 2007 functions. Typing the characters =SUB into a cell causes Excel 2007 

to display a list with the functions SUBSTITUTE and SUBTOTAL. Clicking the desired 

function name adds that function to your formula without requiring you to fi nish 

typing the function’s name.
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User-defi ned functions. User-defi ned functions are custom procedures created 

by a programmer and are included in your workbook as macro code. 

Formula arguments. Some formulas accept a limited set of values for a function 

argument; Formula AutoComplete enables Excel 2007 to select from the list of 

acceptable values. 

Defi ned names. Defi ned names are user-defi ned nicknames for specifi c cell 

ranges (for example, cells A2:A29 on the Sales worksheet could be named 

February Sales).

Table structure references. A table structure reference denotes a table or part of 

a table. For example, if you create a table named Package Volume that contains a 

column named Northwest, typing the letter P in a formula prompts Excel 2007 to 

display the table name Package Volume as a possible entry into the formula.

Summarizing Data Using New Functions
The Microsoft Excel 2007 programming team encourages users to suggest new 

 capabilities that might be included in the future versions of the program. One of the 

most common requests from corporations using Excel was to fi nd the average value of 

cells where the value met certain criteria. For example, in a table summarizing daily sales 

by department, a formula could summarize sales in the Housewares department for days 

in which the sales total was more than $10,000.
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The Excel 2007 team responded to those requests by creating fi ve new formulas that 

enable you to summarize worksheet data that meets a given condition. Here are quick 

descriptions of the new functions and any existing functions to which they’re related:

AVERAGEIF enables you to fi nd the average value of cells in a range for cells that 

meet a single criterion.

AVERAGEIFS enables you to fi nd the average value of cells in a range for cells that 

meet multiple criteria. 

SUMIFS, an extension of the SUMIF function, enables you to fi nd the average value 

of cells in a range for cells that meet multiple criteria.

COUNTIFS, an extension of the COUNTIF function, enables you to count the 

 number of cells in a range that meet multiple criteria.

IFERROR, an extension of the IF function, enables you to tell Excel 2007 what to 

do in case a cell’s formula generates an error (as well as what to do if the formula 

works the way it’s supposed to).

Creating Powerful Conditional Formats
Businesses often use Excel to track corporate spending and revenue. The actual fi gures 

are very important, of course, but it’s also useful for managers to be able to glance at 

their data and determine whether the data exceeds expectations, falls within an accept-

able range, or requires attention because the value falls below expectations. In versions 

prior to Excel 2007, you could create three conditions and defi ne a format for each one. 

For example, you could create the following rules:

If monthly sales are more than 10 percent ahead of sales during the same month in 

the previous year, display the value in green.

If monthly sales are greater than or equal to sales during the same month in the 

previous year, display the value in yellow.

If monthly sales are fewer than sales during the same month in the previous year, 

display the value in red.

In Excel 2007, you can have as many rules as you like, apply several rules to a single 

data value, choose to stop evaluating rules after a particular rule has been applied, and 

change the order in which the rules are evaluated without having to delete and re-create 

the rules you change. You can also apply several new types of conditional data formats: 

data bars, which create a horizontal bar across a cell to indicate how large the value is; 

color gradients, which change a cell’s fi ll color to indicate how large the value is; and icon 

sets, which display one of three icons depending on the guidelines you establish.
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Creating More Attractive Charts
Excel 2007 enables you to manage large amounts of numerical data effectively, but 

 humans generally have a hard time determining patterns from that data if all they have 

to look at are the raw numbers. That’s where charts come in. Charts summarize your 

data visually, which means that you and other decision-makers can quickly detect trends, 

determine high and low data points, and forecast future prospects using mathematical 

tools. The Excel charting engine and color palette haven’t changed signifi cantly since 

Excel 97, but Excel 2007 marks a tremendous step forward with more ways to create 

 attractive and informative charts quickly. 



10  Chapter 1 What’s New in Excel 2007?
See Also For more information on the new charting capabilities in Excel 2007, see Chapter 11, 
“Creating Charts and Graphics.”

Controlling Printouts More Carefully
One of the Microsoft Excel 2007 product group’s goals for Excel 2007 was to enable you 

to create great-looking documents. Of course, to create these documents, you must 

know what your documents will look like when you print them. The Microsoft Excel team 

introduced the Page Break Preview view in Excel 97, which enabled you to see where 

one printed page ended and the next page began. Page Break Preview is somewhat 

limited from a printing control and layout perspective in that it displays your workbook’s 

contents at an extremely small size. When you display a workbook in Page Layout view, 

you see exactly what your work will look like on the printed page. Page Layout view also 

enables you to change your workbook’s margins, add and edit headers and footers, and 

edit your data.
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Key Points
Excel 2007 features a new Ribbon user interface that enables you to discover the 

program’s capabilities more easily.

Excel 2007 greatly expands the size of the data collections you can manage in Excel 

and enables you to organize your data into tables.

Excel 2007 offers new graphics, formatting, and charting capabilities, enabling you 

to create great-looking documents quickly.

Excel 2007 offers powerful new functions to summarize your data and streamlines 

formula creation with Formula AutoComplete.

Excel 2007 greatly enhances your ability to create conditional formats, which 

change the appearance of a cell’s contents based on its value. 
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 2 2 Setting Up a Setting Up a
  Workbook  Workbook

In this chapter, you will learn how to:

  Create a workbook.

  Modify a workbook.

  Modify a worksheet.

  Customize the Excel 2007 program window.

When you start Microsoft® Offi ce Excel® 2007, the program presents a blank workbook 

that contains three worksheets. You can add or delete worksheets, hide worksheets with-

in the workbook without deleting them, and change the order of your worksheets within 

the workbook. You can also copy a worksheet to another workbook or move the work-

sheet without leaving a copy of the worksheet in the fi rst workbook. If you and your 

colleagues work with a large number of documents, you can defi ne property values to 

make your workbooks easier to fi nd when you and your colleagues attempt to locate 

them by using the Microsoft Windows® search facility. 

Another way to make Offi ce Excel 2007 easier to use is by customizing the Excel 2007 

program window to fi t your work style. If you have several workbooks open at the same 

time, you can move between the workbook windows by using the new user interface. 

However, if you switch between workbooks frequently, you might fi nd it easier to resize 

the workbooks so they don’t take up the entire Excel 2007 window. In that case, you just 

need to click the title bar of the workbook you want to display.

The 2007 Microsoft Offi ce system design team created the new user interface to reduce 

the number of places you have to look for commands; if you fi nd that you use a com-

mand frequently, you can add it to the Quick Access Toolbar so it’s never more than one 

click away.

In this chapter, you learn how to create and modify workbooks, create and modify 

worksheets, make your workbooks easier to fi nd, and customize the Excel 2007 

program window.



14  Chapter 2 Setting Up a Workbook
See Also Remember, you can get a quick refresher on the topics in this chapter. See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice fi les in this chapter, you need to install them 

from the book’s companion CD to their default location. See “Using the Book’s CD” on 

page xiii for more information.

Creating Workbooks
Every time you want to gather and store data that isn’t closely related to any of your 

other existing data, you should create a new workbook. The default new workbook 

in Excel 2007 has three worksheets, although you can add more worksheets or 

delete existing worksheets if you want. Creating a new workbook is a straightforward 

process—you just click the Microsoft Offi ce Button, click New, and identify the type of 

workbook you want to create.

When you start Excel 2007, the program displays a new, blank workbook; you can be-

gin to enter data in the worksheet’s cells or open an existing workbook. In the exercises 

that follow, you’ll work with some of the workbooks that have already been created 

for Consolidated Messenger. After you make any desired changes to a workbook, you 

should save the workbook to avoid losing your work.
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When you save a fi le, you overwrite the previous copy of the fi le. If you have made 

changes that you want to save, but you want to keep a copy of the fi le as it was 

 previously, you can use the Save As command to specify a name for the new fi le. 

Tip Readers frequently ask, “How often should I save my fi les?” It is good practice to save 

your changes every half hour or even every fi ve minutes, but the best time to save a fi le is 

whenever you make a change that you would hate to have to make again. 

You also can use the controls in the Save As dialog box to specify a different format 

for the new fi le and a different location in which to save the new version of the fi le. For 

example, Jenny Lysaker, the chief operating offi cer of Consolidated Messenger, might 

want to save an Excel fi le that tracks consulting expenses as an Excel 2003 fi le if she 

needs to share the fi le with a consulting fi rm that uses Excel 2003. 

After you create a fi le, you can add additional information to make the fi le easier to 

fi nd when you search for it using the Windows search facility. Each category of informa-

tion, or property, stores specifi c information about your fi le. In Windows, you can search 

for fi les based on the fi le’s author or title, or by keywords associated with the fi le. A fi le 

tracking the postal code destinations of all packages sent from a collection might have 

the keywords postal, destination, and origin associated with it.

To set values for your workbook’s properties, click the Microsoft Offi ce Button, point 

to Prepare, and click Properties to display the Document Properties panel on the user 

interface. The Standard version of the Document Properties panel has fi elds for the fi le’s 

author, title, subject, keywords, category, and status, and any comments about the fi le. 

You can also create custom properties by clicking the Property Views and Options 

button, located just to the right of the Document Properties label, and then clicking 

Advanced Properties.

On the Custom tab of the advanced Properties dialog box, you can click one of the 

existing custom categories or create your own by typing a new property name in the 

Name fi eld, clicking the Type arrow and selecting a data type (for example, Text, Date, 
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Number, Yes/No), selecting or typing a value in the Value fi eld, and then clicking Add. If 

you want to delete an existing custom property, move your mouse pointer down to the 

Properties list, click the property you want to get rid of, and click Delete. After you fi nish 

making your changes, click the OK button. To hide the Document Properties panel on 

the user interface, click the Close button in the upper-right corner of the panel.

In this exercise, you will create a new workbook, save the workbook under a new name, 

assign values to the workbook’s standard properties, and create a custom property.

USE the Exception Summary workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Creating folder.

BE SURE TO start Excel 2007 before beginning these exercises.

OPEN the Exception Summary workbook.

1. Click the Microsoft Offi ce Button and then click Close.

The Exception Summary workbook disappears.

2. Click the Microsoft Offi ce Button and then click New.

The New Workbook dialog box appears.

3. Click Blank Workbook and then click Create.

A new, blank workbook appears.

4. Click the Microsoft Offi ce Button and then click Save As.

The Save As dialog box appears.

USE thethe Exception SummaryException Summary workbook in the practice fi le folder for this topic. This practice  workbook in the practice fi le folder for this topic. This practice yy
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\CreatingMy Documents\Microsoft Press\Excel SBS\Creating folder.folder.

BE SURE TO start Excel 2007 before beginning these exercises.start Excel 2007 before beginning these exercises.

OPEN thethe Exception SummaryException Summary workbook.workbook.yy
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Creating Workbooks
5. Use the navigation controls to display the My Documents\Microsoft Press\Excel SBS 
\Setting Up\Creating folder. In the File name fi eld, type Exceptions 2006.

6. Click the Save button.

Excel 2007 saves your work, and the Save As dialog box disappears.

7. Click the Microsoft Offi ce Button, click Prepare, and then click Properties.

The Document Properties pane appears.

8. In the Keywords fi eld, type exceptions, regional, percentage.

9. In the Category fi eld, type performance.

10. Click the Property View and Options button and then click Advanced Properties.

The Exceptions 2006 Properties dialog box appears.

11. Click Custom.

The Custom tab appears.

12. In the Name fi eld, type Performance.

13. In the Value fi eld, type Exceptions.

 

14. Click the Add button and then click OK.

The Exceptions 2006 Properties dialog box disappears.

15. On the Quick Access Toolbar, click the Save button to save your work.

CLOSE the Exceptions 2006 workbook.CLOSE the Exceptions 2006 workbook.6



18  Chapter 2 Setting Up a Workbook
Modifying Workbooks
Most of the time, you create a workbook to record information about a particular 

business activity, such as the number of packages that a regional distribution center 

handles or the average time of the last delivery on a route. Each worksheet within that 

workbook should thus represent a subdivision of that activity. To display a particular 

worksheet, just click the worksheet’s tab on the tab bar ( just below the grid of cells).

In the case of Consolidated Messenger, the workbook used to track daily package 

volumes could have a separate worksheet for each regional distribution center. New 

Excel 2007 workbooks contain three worksheets; because Consolidated Messenger uses 

nine regional distribution centers, you need to create six new ones. To create a new 

worksheet, click the Insert Worksheet button at the right edge of the tab bar. 

When you create a worksheet, Excel 2007 assigns it a generic name such as Sheet4, 

Sheet5, or Sheet6. After you decide what type of data you want to store on a worksheet, 

you should change the default worksheet names to something more descriptive. For ex-

ample, you could change the name of Sheet1 in the regional distribution center tracking 

workbook to Northeast. When you want to change a worksheet’s name, double-click 

the worksheet’s tab on the tab bar to highlight the worksheet name, type the new name, 

and press F.

Another way to work with more than one workbook is to copy a worksheet from another 

workbook to the current workbook. One circumstance in which you might consider 

copying worksheets to the current workbook is if you have a list of your current employ-

ees in another workbook. You can copy worksheets from another workbook by right-

clicking the tab of the sheet you want to copy and, from the shortcut menu that appears, 

clicking Move or Copy to display the Move Or Copy dialog box.
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Tip Selecting the Create a copy check box leaves the copied worksheet in its original 

workbook, whereas clearing the check box causes Excel 2007 to delete the worksheet from 

its original workbook.

After the worksheets are in the target workbook, you can change their order to make 

the data easier to locate within the workbook. To change a worksheet’s location in the 

workbook, you drag its sheet tab to the desired location on the tab bar. If you want 

a worksheet to stand out in a workbook, you can right-click its sheet tab and use the 

menu that appears to change the tab’s color. At the other end of the spectrum, you can 

hide the active worksheet by right-clicking the worksheet’s tab on the tab bar and click-

ing Hide on the context menu that appears. When you want Excel 2007 to redisplay the 

worksheet, right-click any visible sheet tab and click Unhide. In the Unhide dialog box, 

click the sheet you want to display and click OK.

Note If you copy a worksheet to another workbook, and the destination workbook has the 

same theme applied as the active workbook, the worksheet retains its tab color. If the des-

tination workbook has another theme applied, the worksheet’s tab color changes to refl ect 

that theme.

If you determine that you no longer need a particular worksheet, such as one you 

created to store some fi gures temporarily, you can delete the worksheet quickly. To do 

so, right-click its sheet tab and then click Delete. 

In this exercise, you will insert and rename a worksheet, change a worksheet’s position 

in a workbook, hide and unhide a worksheet, copy a worksheet to another workbook, 

change a worksheet’s tab color, and delete a worksheet.

USE the Exception Summary workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Creating folder.

OPEN the Exception Summary workbook.

 1. On the tab bar, click the Insert Worksheet button.

A new worksheet appears.

 2. Right-click the new worksheet’s sheet tab and click Rename.

Excel 2007 highlights the new worksheet’s name.

 3. Type 2007 and press F.

 4. On the tab bar, right-click the Sheet1 sheet tab and click Rename.

USE thethe Exception SummaryException Summary workbook in the practice fi le folder for this topic. This practice  workbook in the practice fi le folder for this topic. This practice yy
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\CreatingMy Documents\Microsoft Press\Excel SBS\Creating folder.folder.

OPEN thethe Exception SummaryException Summary workbook.workbook.yy
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5. Type 2006 and press F.

6. Right-click the 2006 sheet tab, point to Tab Color, and then, in the Standard Colors
section of the color palette, click a green square.

Excel 2007 changes the 2006 sheet’s tab to green.

7. On the tab bar, drag the 2007 sheet tab to the left of the Scratch Pad sheet tab.

8. Right-click the 2007 sheet tab and then click Hide.

Excel 2007 hides the 2007 worksheet.

9. Right-click the 2006 sheet tab and then click Move or Copy.

The Move or Copy dialog box appears.

10. Click the To Book down arrow and click New Book.

11. Select the Create a copy check box.

12. Click OK.

A new workbook appears; it contains only the worksheet you copied into it.

13. On the Quick Access Toolbar, click the Save button.

The Save As dialog box appears.

14. In the File name fi eld, type 2006 Archive and press F.

Excel 2007 saves the workbook, and the Save As dialog box disappears.

15. On the View tab, click the Switch Windows button, and then click Exception 
Summary.

The Exception Summary workbook appears.

16. On the tab bar, right-click the Scratch Pad sheet tab and click Delete.

The Scratch Pad worksheet disappears.



   21Modifying Worksheets
 17. Right-click the 2006 sheet tab and then click Unhide.

The Unhide dialog box appears.

 18. Click 2007 and then click OK.

The Unhide dialog box disappears, and the 2007 worksheet appears in 

the workbook.

CLOSE the Exception Summary workbook.

Modifying Worksheets
After you put up the signposts that make your data easy to fi nd, you can take other steps 

to make the data in your workbooks easier to work with. For instance, you can change 

the width of a column or the height of a row in a worksheet by dragging the column or 

row’s border to the desired position. Increasing a column’s width or a row’s height in-

creases the space between cell contents, making it easier to select a cell’s data without 

inadvertently selecting data from other cells as well.

Tip You can apply the same change to more than one row or column by selecting the rows 

or columns you want to change and then dragging the border of one of the selected rows 

or columns to the desired location. When you release the mouse button, all the selected 

rows or columns change to the new height or width.

Modifying column width and row height can make a workbook’s contents easier to work 

with, but you can also insert a row or column between the edge of a worksheet and the 

cells that contain the data to accomplish this. Adding space between the edge of a work-

sheet and cells, or perhaps between a label and the data to which it refers, makes the 

workbook’s contents less crowded and easier to work with. You insert rows by clicking a 

cell and clicking the Home tab. Then, in the Cells group, click the Insert button’s down 

arrow and click Insert Sheet Rows. Excel 2007 inserts a row above the row that contains 

CLOSE the Exception Summary workbook.y
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the active cell. You insert a column in much the same way by choosing Insert Sheet 

Columns from the Insert button’s drop-down list. When you do this, Excel 2007 inserts a 

column to the left of the active cell.

When you insert a row, column, or cell in a worksheet with existing format-

ting, the Insert Options button appears. Clicking the Insert Options but-

ton displays a list of choices you can make about how the inserted row or 

column should be formatted. The following table summarizes your options. 

Option Action

Format Same as Above Applies the format of the row above the inserted row 

to the new row.

Format Same as Below Applies the format of the row below the inserted row 

to the new row.

Format Same as Left Applies the format of the column to the left of the in-

serted column to the new column.

Format Same as Right Applies the format of the column to the right of the 

inserted column to the new column.

Clear Formatting Applies the default format to the new row or column.

If you want to delete a row or column, right-click the row or column head and then, 

from the shortcut menu that appears, click Delete. You can temporarily hide a number 

of rows or columns by selecting those rows or columns and then, on the Home tab, in 

the Cells group, clicking the Format button, pointing to Hide & Unhide, and then  clicking 

either Hide Rows or Hide Columns. The rows or columns you selected disappear, but 

they aren’t gone for good, as they would be if you’d used Delete. Instead, they have 

just been removed from the display until you call them back. To return the hidden rows 

to the display, on the Home tab, in the Cells group, click the Format button, point to 

Hide & Unhide, and then click either Unhide Rows or Unhide Columns.

Likewise, you can insert individual cells into a worksheet. To insert a cell, click the cell 

that is currently in the position where you want the new cell to appear. On the Home 

tab, in the Cells group, click the Insert button down arrow and then click Insert Cells to 

display the Insert dialog box. In the Insert dialog box, you can choose whether to shift 

the cells surrounding the inserted cell down (if your data is arranged as a column) or to 

the right (if your data is arranged as a row). When you click OK, the new cell appears, 

and the contents of affected cells shift down or to the right, as appropriate. In a similar 

vein, if you want to delete a block of cells, select the cells, and on the Home tab of the 

user interface, in the Cells group, click the Delete button down arrow and then click 
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Delete Cells to display the Delete dialog box—complete with option buttons that enable 

you to choose how to shift the position of the cells around the deleted cells.

Tip The Insert dialog box also includes option buttons you can select to insert a new row 

or column; the Delete dialog box has similar buttons that enable you to delete an entire 

row or column.

If you want to move the data in a group of cells to another location in your worksheet, 

select the cells you want to move and position the mouse pointer on the selection’s bor-

der. When the mouse pointer changes to a four-way arrow, you can drag the selected 

cells to the desired location on the worksheet. If the destination cells contain data, Excel 

2007 displays a dialog box asking if you want to overwrite the destination cells’ contents. 

If you want to replace the existing values, click the OK button. If you don’t want to over-

write the existing values, click the Cancel button and insert the required number of cells 

to accommodate the data you want to move.

In this exercise, you will insert a column and row into a worksheet, specify insert options, 

hide a column, insert a cell into a worksheet, delete a cell from a worksheet, and move a 

group of cells within the worksheet.

USE the Route Volume workbook from the My Documents\Microsoft Press\Excel SBS\
Setting Up\Creating folder.

OPEN the Route Volume workbook.

 1. On the May 12 worksheet, select cell A1.

 2. On the Home tab, in the Cells group, click the Insert button down arrow and then 

click Insert Sheet Columns.

A new column A appears.

 3. On the Home tab, in the Cells group, click the Insert button down arrow and then 

click Insert Sheet Rows.

A new row 1 appears.

 4. Click the Insert Options button and click Clear Formatting.

Excel 2007 removes the formatting from the new row 1.

 5. Right-click the column header of column E and click Hide.

Column E disappears.

USE thethe Route VolumeRoute Volume workbook from theworkbook from the My Documents\Microsoft Press\Excel SBS\My Documents\Microsoft Press\Excel SBS\
Setting Up\CreatingSetting Up\Creating folder. folder.

OPEN thethe Route VolumeRoute Volume workbook. workbook.



24  Chapter 2 Setting Up a Workbook

 

 

 

 

 

6. On the tab bar, click the May 13 sheet tab.

The worksheet named May 13 appears.

7. Click cell B6.

8. On the Home tab, in the Cells group, click the Delete button down arrow and then 

click Delete Cells.

The Delete dialog box appears.

9. If necessary, select the Shift cells up option button and then click OK.

The Delete dialog box disappears and Excel 2007 deletes cell B6, moving the cells 

below it up to fi ll in the gap.

10. Click cell C6.
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 11. On the Home tab, in the Cells group, click the Insert button down arrow and then 

click Insert Cells.

The Insert dialog box appears.

 12. If necessary, select the Shift cells down option button and then click OK.

The Insert dialog box disappears, and Excel 2007 creates a new cell C6, moving 

cells C6:C11 down to accommodate the inserted cell.

 13. In cell C6, type 4499 and press F.

 14. Select cells E13:F13.

 15. Point to the border of the selected cells. When your mouse pointer changes to a 

four-pointed arrow, drag the selected cells to cells B13:C13.

The dragged cells replace cells C13:D13.

CLOSE the Route Volume workbook.CLOSE the Route Volume workbook.
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Customizing the Excel 2007 Program Window
How you use Excel 2007 depends on your personal working style and the type of data 

collections you manage. The Excel 2007 product team interviews customers, observes 

how differing organizations use the program, and sets up the user interface so that 

you don’t need to change it to work effectively. If you do fi nd yourself wishing that you 

could change the Excel 2007 program window, including the user interface, you can. You 

can change how Excel 2007 displays your worksheets, zoom in on worksheet data, and 

add frequently used commands to the Quick Access Toolbar.

Zooming In on a Worksheet
One way to make Excel 2007 easier to work with is to change the program’s zoom 

level. Just as you can “zoom in” with a camera to increase the size of an object in 

the camera’s viewer, you can use the Excel 2007 zoom setting to change the size of 

objects within the Excel 2007 program window. For example, if Peter Villadsen, the 

Consolidated Messenger European Distribution Center Manager, displayed a worksheet 

that  summarized his distribution center’s package volume by month, he could click the 

user interface’s View tab and then, in the Zoom group, click the Zoom button to display 

the Zoom dialog box. The Zoom dialog box contains controls that enable him to select a 

preset magnifi cation level or to type in a custom magnifi cation level. He could also use 

the Zoom control at the lower-right corner of the Excel 2007 window. 

Zoom out Zoom in

Clicking the Zoom In control increases the size of items in the program window by 10 

percent, whereas clicking the Zoom Out control decreases the size of items in the pro-

gram window by 10 percent. If you want more fi ne-grained control of your zoom level, 

you can use the slider control to select a specifi c zoom level.

The View tab’s Zoom group also contains the Zoom to Selection button, which fi lls the 

program window with the contents of any selected cells, up to the program’s maximum 

zoom level of 400 percent.

Note The mimimum zoom level in Excel 2007 is 10 percent.
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Arranging Multiple Workbook Windows
As you work with Excel 2007, you will probably need to have more than one workbook 

open at a time. For example, you could open a workbook that contains customer contact 

information and copy it into another workbook to be used as the source data for a mass 

mailing you create in Microsoft Offi ce Word 2007. When you have multiple workbooks 

open simultaneously, you can switch between them by clicking the user interface’s View 

tab and then, in the Window group, clicking the Switch Windows button and clicking the 

name of the workbook you want to view. 

You can arrange your workbooks within the Excel 2007 window so that most of the 

 active workbook is shown, but the others are easily accessible by clicking the View tab 

and then, in the Window group, clicking the Arrange All button. Then, in the Arrange 

Windows dialog box, select the Cascade option. 

Many Excel 2007 workbooks contain formulas on one worksheet that derive their value 

from data on another worksheet, which means you need to change between two work-

sheets every time you want to see how modifying your data changes the formula’s 

result. However, you can display two copies of the same workbook, displaying the 

worksheet that contains the data in the original window and displaying the worksheet 

with the formula in the new window. When you change the data in the original copy of 

the workbook, Excel 2007 updates the formula result in a new window. To display two 

copies of the same workbook, open the desired workbook and then, on the View tab’s 

Window group, click New Window. Excel 2007 will open a second copy of the workbook. 

If the original workbook’s name was ExceptionSummary, Excel 2007 displays the name 

ExceptionSummary:1 on the original workbook’s title bar and ExceptionSummary:2 on 

the second workbook’s title bar.
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Adding Buttons to the Quick Access Toolbar
As you continue to work with Excel 2007, you might discover that you use certain com-

mands much more frequently than others. If your workbooks draw data from external 

sources, you might fi nd yourself displaying the Data tab and then, in the Connections 

group, clicking the Refresh All button much more often than the program’s design-

ers might have expected. You can make any button accessible with one click by adding 

the button to the Quick Access Toolbar, located just to the right of the Microsoft Offi ce 

Button at the upper-left corner of the Excel 2007 program window. 

To add a button to the Quick Access Toolbar, click the Microsoft Offi ce Button and then 

click Excel Options. In the Excel Options dialog box, click the Customize name, click the 

Choose Commands From down arrow, and then click the category from which you want 

to select the control to add. Excel 2007 displays the available commands in the list box 

below the Choose Commands From fi eld. Click the control you want and then click the 

Add button. You can change a button’s position on the Quick Access Toolbar by clicking 

its name in the lower-right pane and then clicking either the Move Up or Move Down 

button. To remove a button from the Quick Access Toolbar, click the button’s name 

and then click the Remove button. When you’re done making your changes, click the 

OK button.
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Customizing the Excel 2007 Program Window
You can also choose whether your Quick Access Toolbar change affects all your work-

books or just the active workbook. To control how Excel 2007 applies your change, click 

the Customize Quick Access Toolbar fi eld down arrow. Then either click For all docu-

ments (default) to apply the change to all of your workbooks or choose For workbook-

name.xlsx to apply the change to the active workbook only.

In this exercise, you will change your worksheet’s zoom level, zoom in to emphasize a 

selected cell range, switch between multiple open workbooks, cascade multiple open 

workbooks within the Excel 2007 program window, and add a button to the Quick 

Access Toolbar.

USE the Route Volume workbook and the Exception Summary workbook from the My 

Documents\Microsoft Press\Excel SBS\Setting Up\Creating folder.

OPEN the Route Volume workbook and the Exception Summary workbook.

1. In the Exception Summary workbook, display the 2006 worksheet.

2. In the lower-right corner of the Excel 2007 window, click the Zoom In control fi ve 

times.

The worksheet’s zoom level changes to 150%.

3. Select cells B2:C11.

USE thethe Route VolumeRoute Volume workbook and the workbook and the Exception SummaryException Summary workbook from the Myworkbook from the Myyy
Documents\Microsoft Press\Excel SBS\Setting Up\Creating folder.Documents\Microsoft Press\Excel SBS\Setting Up\Creating folder.

OPEN thethe Route VolumeRoute Volume workbook and the workbook and the Exception Summary Exception Summary workbook.workbook.
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4. On the View tab, in the Zoom group, click the Zoom to Selection button.

Excel 2007 displays the selected cells so they fi ll the program window.

5. On the View tab, in the Zoom group, click the Zoom button.

The Zoom dialog box appears.

6. Select the 100% option button and then click OK.

The worksheet returns to its default zoom level.

7. On the View tab, in the Window group, click the Switch Windows button and then 

click Route Volume.

The Route Volume workbook appears.
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 8. On the View tab, in the Window group, click the Arrange All button.

The Arrange Windows dialog box appears.

 9. Select the Cascade option button and then click OK.

Excel 2007 cascades the open workbook windows within the Excel 2007 

program window.

 10. Click the Microsoft Offi ce Button and then click Excel Options.

The Excel Options dialog box appears.

 11. Click Customize.

The Customize tab appears.

 12. Click the Choose commands from fi eld down arrow and then click Review Tab.

The commands in the Review Tab category appear in the command list.

 13. Click the Spelling command, and then click Add.
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14. Click OK. 

Excel 2007 adds the Spelling command to the Quick Access Toolbar.

CLOSE Excel.

ey Points
Save your work whenever you do something you’d hate to have to do again.

Assigning values to a workbook’s properties makes it easier to fi nd your workbook 

using the Windows search facility.

Be sure to give your worksheets descriptive names.

If you want to use a worksheet’s data in another workbook, you can send a copy of 

the worksheet to that other workbook without deleting the original worksheet.

You can delete a worksheet you no longer need, but you can also hide a worksheet 

in the workbook. When you need the data on the worksheet, you can unhide it.

CLOSE Excel.



   33Key Points
You can save yourself a lot of bothersome cutting and pasting by inserting and 

deleting worksheet cells, columns, and rows.

Customize your Excel 2007 program window by changing how it displays your 

workbooks, zooming in on data, and adding frequently used buttons to the Quick 

Access Toolbar.
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 3 3 Working with DataWorking with Data
  and Data Tables  and Data Tables

In this chapter, you will learn to:

  Enter data quickly.

  Move data within a workbook.

  Find and replace workbook data.

  Verify and extend workbook data using proofi ng and reference tools.

  Organize your data using tables.

Microsoft® Offi ce Excel® 2007 enables you to visualize and present information 

 effectively using charts, graphics, and formatting, but the data is the most important 

part of any workbook. By learning to enter data effi ciently, you will make fewer data 

 entry errors and give yourself more time to analyze your data so you can make decisions 

about your organization’s performance and direction.

Offi ce Excel 2007 provides a wide variety of tools you can use to enter and  manage 

worksheet data effectively. For example, Excel 2007 enables you to organize your 

data into tables, which enables you to analyze and store your data quickly and easily. 

Excel 2007 also enables you to enter a data series quickly; repeat one or more values; 

or control how Excel 2007 formats cells, columns, and rows moved from one part of 

a worksheet to another. And you can do so with a minimum of effort. Excel 2007 also 

 enables you to check the spelling of worksheet text, look up alternative words using the 

Thesaurus, and translate words to foreign languages.

In this chapter, you will learn how to enter and revise Excel 2007 data, move data within 

a workbook, fi nd and replace existing data, use proofi ng and reference tools to enhance 

your data, and organize your data by using Excel 2007 data tables.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.
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Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Entering and Revising Data
After you create a workbook, you can begin entering data. The simplest way to enter 

data is to click a cell and type a value, which is a method that works very well when 

you’re entering a few pieces of data, but it is less than ideal when you’re entering 

long sequences or series of values. For example, Craig Dewar, the VP of Marketing for 

Consolidated Messenger, might want to create a worksheet listing the monthly program 

savings that large customers can enjoy if they sign exclusive delivery contracts with 

Consolidated Messenger. To record those numbers, he would need to create a worksheet 

with the following layout.

Entering the sequence January, February, March, and so on repeatedly can be handled 

by copying and pasting the fi rst occurrence of the sequence, but there’s an easier way to 

do it: use AutoFill. With AutoFill, you enter the fi rst element in a recognized series, grab 

the fi ll handle at the lower-right corner of the cell, and drag the fi ll handle until the series 

extends far enough to accommodate your data. A similar tool, FillSeries, enables you to 

enter two values in a series and use the fi ll handle to extend the series in your worksheet. 

For example, if you want to create a series starting at 2 and increasing by 2, you can put 
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2 in the fi rst cell and 4 in the second cell, select both cells, and then use the fi ll handle to 

extend the series to your desired end value.

You do have some control over how Excel 2007 extends the values in a series when you 

drag the fi ll handle. For example, if you drag the fi ll handle up (or to the left), Excel 2007 

extends the series to include previous values. If you type January in a cell and then 

drag that cell’s fi ll handle up (or to the left), Excel 2007 places December in the fi rst cell, 

November in the second cell, and so on.

Another way to control how Excel 2007 extends a data series is by holding down the H 

key while you drag the fi ll handle. For example, if you select a cell that contains the value 

January and then drag the fi ll handle down, Excel 2007 extends the series by placing 

February in the next cell, March in the cell after that, and so on. If you hold down the H 

key, however, Excel 2007 repeats the value January in each cell you add to the series. 

Tip Be sure to experiment with how the fi ll handle extends your series and how pressing 

the H key changes that behavior. Using the fi ll handle can save you a lot of time entering 

data.

Other data entry techniques you’ll use in this section are AutoComplete, which detects 

when a value you’re entering is similar to previously entered values; Pick from Drop-
down List, which enables you to choose a value from existing values in a column; and 

H+F, which enables you to enter a value in multiple cells simultaneously.

The following table summarizes these data entry techniques.

Method Action

AutoFill Enter the fi rst value in a recognized series and use the fi ll handle to 

extend the series. 

FillSeries Enter the fi rst two values in a series and use the fi ll handle to extend 

the series.

AutoComplete Type the fi rst few letters in a cell, and if a similar value exists in the 

same column, Excel 2007 suggests the existing value.

Pick from Drop-

down List

Right-click a cell, and from the shortcut menu that appears, choose 

Pick From Drop-down List. A list of existing values in the cell’s 

column appears. Click the value you want to enter into the cell.

H+F Select a range of cells to contain the same data, type the data in the 

active cell, and press H+F.
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Troubleshooting If an AutoComplete suggestion doesn’t appear as you begin typing 

a cell value, the option might be turned off. To turn on AutoComplete, click the Microsoft 

Offi ce Button and click Excel Options. In the Excel Options dialog box, click the Advanced 

category. In the Editing Options section of the dialog box, select the Enable AutoComplete 

for cell values check box and click OK.

Another handy feature in the current version of Excel 2007 is the Auto Fill Options 

button that appears next to data you add to a worksheet using AutoFill.

Clicking the Auto Fill Options button displays a list of actions Excel 2007 can take 

regarding the cells affected by your fi ll operation. The options in the list are summarized 

in the following table.

Option Action

Copy Cells Copies the contents of the selected cells to the cells indicated by the 

Fill operation.

Fill Series Fills the cells indicated by the Fill operation with the next items in 

the series.

Fill Formatting Only Copies the format of the selected cell to the cells indicated by the 

Fill operation, but does not place any values in the target cells.

Fill Without 

Formatting

Fills the cells indicated by the Fill operation with the next items in 

the series, but ignores any formatting applied to the source cells.
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Option Action

Fill Days, 

Weekdays, etc.
Changes according to the series you extend. For example, if you 

extend the cells Wed, Thu, and Fri, Excel 2007 presents two options, 

Fill Days and Fill Weekdays, and enables you to select which one 

you intended. If you do not use a recognized sequence, the option 

does not appear.

In this exercise, you will enter a data series by dragging the fi ll handle, enter data by 

 accepting AutoComplete values, enter cell data by using Pick From Drop-down List, and 

control how Excel 2007 formats an extended data series by setting the program’s Auto 

Fill Options.

USE the Series workbook from the My Documents\Microsoft Press\Excel SBS\Data and Data 
Tables folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the Series workbook.

1. On the Monthly worksheet, select cell B3 and then drag the fi ll handle down until 

it covers cells B3:B7.

Excel 2007 repeats the value Fabrikam in cells B4:B7.

2. Select cell C3, hold down the H key, and drag the fi ll handle down until it covers 

cells C3:C7.

Excel 2007 repeats the value January in cells C4:C7.

3. Select cell B8 and type the letter F.

Excel 2007 displays the characters abrikam in reverse video.

USE thethe SeriesSeries workbook from the workbook from the My Documents\Microsoft Press\Excel SBS\Data and DataMy Documents\Microsoft Press\Excel SBS\Data and Data
TablesTables folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe SeriesSeries workbook.workbook.
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 4. Press D to accept the value Fabrikam for the cell.

 5. In cell C8, type February.

 6. Right-click cell D8 and then click Pick From Drop-down List.

A list of values in column D appears below cell D8.

 7. From the list that appeared, click 2Day.

The value 2Day appears in cell D8.

 8. In cell E8, type 11802.14.

The value $11,802.14 appears in cell E8.

 9. Select cell B2 and then drag the fi ll handle so that it covers cells C2:E2.

Excel 2007 replaces the values in cells C2:E2 with the value Customer.

 10. Click the Auto Fill Options button and then click Fill Formatting Only.

Excel 2007 restores the original values in cells C2:E2 but applies the formatting of 

cell B2 to those cells.

CLOSE the Series workbook.

Moving Data Within a Workbook
You can move to a specifi c cell in lots of ways, but the most direct method is to 

click the cell to which you want to move. The cell you click will be outlined in black, 

and its contents, if any, will appear in the formula bar. When a cell is outlined, it is the 

CLOSE the Series workbook.
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active cell, meaning that you can modify its contents. You use a similar method to select 

multiple cells (referred to as a cell range)—just click the fi rst cell in the range and drag 

the mouse pointer over the remaining cells you want to select. After you select the cell 

or cells you want to work with, you can cut, copy, delete, or change the format of the 

contents of the cell or cells. For instance, Gregory Weber, the Northwestern Distribution 

Center Manager, might want to copy the cells that contain a set of column labels to a 

new page that summarizes similar data.

Important If you select a group of cells, the fi rst cell you click is designated the active cell.

You’re not limited to selecting cells individually or as part of a range. For example, you 

might need to move a column of price data one column to the right to make room for a 

column of headings that indicate to which service category (ground, three-day express, 

two-day express, overnight, or priority overnight) a set of numbers belongs. To move an 

entire column (or entire columns) of data at a time, you click the column’s header, locat-

ed at the top of the worksheet. Clicking a column header highlights every cell in that col-

umn and enables you to copy or cut the column and paste it elsewhere in the workbook.

The Paste Options button appears next to data you copy from a cell and paste into 

another cell. Clicking the Paste Options button displays a list of actions that Excel 2007 

can take regarding the pasted cells.
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The options in the list are summarized in the following table.

Option Action 

Use Destination 

Theme

Pastes the contents of the Clipboard (which holds the last informa-

tion selected via Cut or Copy) into the target cells and formats the 

data using the theme applied to the target workbook.

Match Destination 

Formatting

Pastes the contents of the Clipboard into the target cells and 

 formats the data using the existing format in the target cells, 

 regardless of the workbook’s theme.

Keep Source 

Formatting

Pastes a column of cells into the target column; applies the format 

of the copied column to the new column.

Values Only Pastes the values from the copied column into the destination 

 column without applying any formatting.

Values and Number 

Formatting

Pastes the contents of the Clipboard into the target cells, keeping 

any numeric formats.

Values and Source 

Formatting

Pastes the contents of the Clipboard into the target cells, retaining 

all the source cells’ formatting.

Keep Source 

Column Widths

Pastes the contents of the Clipboard into the target cells and resizes 

the columns of the target cells to match the widths of the columns 

of the source cells.

Formatting Only Applies the format of the source cells to the target cells, but does 

not copy the contents of the source cells.

Troubleshooting If the Paste Options button doesn’t appear, you can turn the feature on 

by clicking the Microsoft Offi ce Button and then clicking Excel Options to display the Excel 

Options dialog box. In the Excel Options dialog box, click the Advanced category and then, 

in the Cut, copy, and paste section, select the Show Paste Options buttons check box. Click 

OK to close the dialog box and save your setting.

In this exercise, you will copy a set of column headers to another worksheet, move a 

column of data within a worksheet, and select paste options for copied data.

USE the 2007Q1ShipmentsByCategory workbook from the My Documents\Microsoft Press\
Excel SBS\Data and Data Tables folder.

OPEN the 2007Q1ShipmentsByCategory workbook.

1. On the Count worksheet, select cells B2:D2.

USE thethe 2007Q1ShipmentsByCategory2007Q1ShipmentsByCategory workbook from the workbook from theyy My Documents\Microsoft Press\My Documents\Microsoft Press\
Excel SBS\Data and Data TablesExcel SBS\Data and Data Tables folder. folder.

OPEN thethe 2007Q1ShipmentsByCategory2007Q1ShipmentsByCategory workbook.workbook.yy
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Moving Data Within a Workbook
2. On the Home tab, in the Clipboard group, click the Copy button.

Excel 2007 copies the contents of cells B2:D2 to the Clipboard.

3. On the tab bar, click the Sales sheet tab.

The Sales worksheet appears.

4. Select cell B2.

5. On the Home tab, in the Clipboard group, click Paste.

Excel 2007 pastes the header values into cells B2:D2.

6. Click the Paste Options smart tag and then click Keep Source Formatting.

Excel 2007 retains the cells’ original formatting.

7. Right-click the column header of column I and then click Cut.

Excel 2007 outlines column I with a marquee.

8. Right-click the header of column E and then click Paste.

Excel 2007 pastes the contents of column I into column E.

CLOSE the 2007Q1ShipmentsByCategory workbook.CLOSE the 2007Q1ShipmentsByCategory workbook.y
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Finding and Replacing Data
Excel 2007 worksheets can contain more than one million rows of data, so it’s unlikely 

that you would have the time to move through a worksheet a row at a time to locate 

the data you want to fi nd. You can locate specifi c data on an Excel 2007 worksheet by 

using the Find and Replace dialog box, which has two tabs (one named Find; the other 

named Replace) that enable you to search for cells that contain particular values. Using 

the controls on the Find tab fi nds the data you specify; using the controls on the Replace 

tab enables you to substitute one value for another. As an example, one of Consolidated 

Messenger’s customers might change the company name. If that’s the case, you can 

change every instance of the old name to the new name.

When you need more control over the data that you fi nd and replace, such as if you 

want to fi nd cells in which the entire cell value matches the value you’re searching for, 

you can click the Options button to expand the Find and Replace dialog box.

One way you can use the extra options in the Find and Replace dialog box is to iden-

tify data that requires review using a specifi c format. As an example, Consolidated 

Messenger VP of Marketing Craig Dewar could make corporate sales plans based on a 

projected budget for the next year. After the executive board fi nalizes the numbers, he 

could use Find Format in the Find and Replace dialog box to locate the old prices and 

then change them by hand. 

To change a value by hand, select the cell and then either type a new value in the cell or, 

on the Formula Bar, select the value you want to replace and type the new value.

The following table summarizes the Find and Replace dialog box controls’ functions.

Control Function

Find what fi eld Contains the value you want to fi nd or replace.

Find All button Selects every cell that contains the value in the Find what fi eld.

Find Next button Selects the next cell that contains the value in the Find what fi eld.

Replace with fi eld Contains the value to overwrite the value in the Find what fi eld.
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Control Function

Replace All button Replaces every instance of the value in the Find what fi eld with the 

value in the Replace with fi eld.

Replace button Replaces the next occurrence of the value in the Find what fi eld and 

highlights the next cell that contains that value.

Options button Expands the Find and Replace dialog box to display additional 

 capabilities.

Format button Displays the Find Format dialog box, which you can use to specify 

the format of values to be found or to replace found values.

Within list box Enables you to select whether to search the active worksheet or the 

entire workbook.

Search list box Enables you to select whether to search by rows or by columns.

Look in list box Enables you to select whether to search cell formulas or values.

Match case check 

box

When checked, requires that all matches have the same 

 capitalization as the text in the Find what fi eld (for example, cat 

doesn’t match Cat).

Match entire cell 

contents check box

Requires that the cell contain exactly the same value as in the Find 

what fi eld (for example, Cat doesn’t match Catherine).

Close button Closes the Find and Replace dialog box.

In this exercise, you will fi nd a specifi c value in a worksheet, replace every occurrence of 

a company name in a worksheet, and fi nd a cell with a particular formatting.

USE the Average Deliveries workbook from the My Documents\Microsoft Press\Excel SBS\
Data and Data Tables folder.

OPEN the Average Deliveries workbook.

 1. If necessary, click the Time Summary sheet tab.

The Time Summary worksheet appears.

 2. On the Home tab, in the Editing group, click Find & Select and then click Find.

The Find and Replace dialog box appears with the Find tab displayed.

 3. In the Find what fi eld, type 114.

 4. Click Find Next.

Excel 2007 highlights cell B16, which contains the value 114.

USE thethe Average DeliveriesAverage Deliveries workbook from the  workbook from the My Documents\Microsoft Press\Excel SBS\My Documents\Microsoft Press\Excel SBS\
Data and Data TablesData and Data Tables folder.folder.

OPEN thethe Average DeliveriesAverage Deliveries workbook.workbook.
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5. Delete the value in the Find What fi eld and then click the Options button.

The Find and Replace dialog box expands to display additional search options.

6. Click Format.

The Find Format dialog box appears.

7. Click the Font tab.

The Font tab appears.

8. In the Font Style list, click Italic.
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Finding and Replacing Data
9. Click OK.

The Find Format dialog box disappears.

10. Click Find Next.

Excel 2007 highlights cell D25.

11. Click Close.

The Find and Replace dialog box disappears.

12. On the tab bar, click the Customer Summary sheet tab.

The Customer Summary worksheet appears.

13. On the Home tab, in the Editing group, click Find & Select and then click Replace.

The Find and Replace dialog box appears with the Replace tab displayed.

14. On the Format button to the right of the Find what fi eld, click the Format button 

down arrow and then click Clear Find Format.

The format displayed next to the Find what fi eld disappears.

15. In the Find what fi eld, type Contoso.

16. In the Replace with fi eld, type Northwind Traders.

17. Click Replace All.

18. Click OK to clear the message box that appears, indicating that Excel 2007 made 

three replacements.

19. Click Close.

The Find and Replace dialog box disappears.

CLOSE the Average Deliveries workbook.CLOSE the Average Deliveries workbook.
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Correcting and Expanding Upon Worksheet Data
After you enter your data, you should take the time to check and correct it. You do need 

to verify visually that each piece of numeric data is correct, but you can make sure that 

the text is spelled correctly by using the Excel 2007 spelling checker. When the spelling 

checker encounters a word it doesn’t recognize, it highlights the word and offers sug-

gestions representing its best guess of the correct word. You can then edit the word 

directly, pick the proper word from the list of suggestions, or have the spelling checker 

ignore the misspelling. You can also use the spelling checker to add new words to a 

custom dictionary so that Excel 2007 will recognize them later, saving you time by not 

requiring you to identify the words as correct every time they occur in your worksheets. 

After you make a change, you can remove the change as long as you haven’t closed 

the workbook in which you made the change. To undo a change, click the Undo button 

on the Quick Access Toolbar. If you decide you want to keep a change, you can use the 

Redo  command to restore it.

If you’re not sure of your word choice or if you use a word that is almost but not quite 

right for your meaning, you can check for alternative words by using the Thesaurus. A 

number of other research tools are also available, such as the Microsoft Encarta ency-

clopedia, which you can refer to as you create your workbook. To display those tools, on 

the Review tab of the user interface, in the Proofi ng group, click Research to display the 

Research task pane.
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Finally, if you want to translate a word from one language to another, you can do so by 

selecting the cell that contains the value you want to translate, by displaying the Review 

tab, and then, in the Proofi ng group, by clicking Translate. The Research task pane ap-

pears (or changes if it’s already open) and displays controls you can use to select the 

original and destination languages.

Caution Excel 2007 translates a sentence by using word substitutions, which means that 

the translation routine doesn’t always pick the best word for a given context. The translated 

sentence might not capture your exact meaning.

In this exercise, you will check a worksheet’s spelling, add two new terms to a dictionary, 

undo a change, search for an alternative word using the Thesaurus, and translate a word 

to French.

USE the Service Levels workbook from the My Documents\Microsoft Press\Excel SBS\Data 
and Data Tables folder.

OPEN the Service Levels workbook.

 1. On the Review tab, in the Proofi ng group, click Spelling.

The Spelling dialog box appears with the misspelled word displayed in the Not in 
Dictionary fi eld.

USE thethe Service LevelsService Levels workbook from the workbook from the My Documents\Microsoft Press\Excel SBS\Data My Documents\Microsoft Press\Excel SBS\Data 
and Data Tablesand Data Tables folder.folder.

OPEN thethe Service LevelsService Levels workbook.workbook.
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2. Verify that the word shipped is highlighted in the Suggestions pane and then click 

Change.

Excel 2007 corrects the word and displays the next questioned word: TwoDay.

3. Click Add to Dictionary.

Excel 2007 adds the word to the dictionary and displays the next 

questioned word: ThreeDay.

4. Click Add to Dictionary.

Excel 2007 adds the word to the dictionary.

5. Click Close.

The Spelling dialog box disappears, and a message box appears, indicating that 

the spell check is complete for the selected items.

6. Click OK to close the message box.

7. Click cell B6.

8. On the Review tab, in the Proofi ng group, click Thesaurus.

The Research task pane appears and displays a list of synonyms and antonyms for 

the word overnight.
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Correcting and Expanding Upon Worksheet Data
9. On the Review tab, in the Proofi ng group, click Translate.

The Research task pane displays the translation tools.

10. If necessary, click the From list box down arrow and then click English (United 
States).

11. Click the To list box down arrow and then click French (France).

The Research task pane displays French words that mean overnight.
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CLOSE the Service Levels workbook.

Defi ning a Table
Excel has always enabled you to manage lists of data effectively, enabling you to sort 

your worksheet data based on the values in one or more columns, limit the data dis-

played by using criteria (for example, show only those routes with fewer than 100 

stops), and create formulas that summarize the values in visible (that is, unfi ltered) cells. 

Customer feedback indicated that many Excel 2007 users wanted a more robust struc-

ture within Excel 2007 that enabled users to perform those operations and more. Excel 

2003 included a structure called a data list that has evolved into the table in Excel 2007.

CLOSE the Service Levels workbook.
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Caution For more information about how data tables facilitate creating and managing 

PivotTables, see “Creating a PivotTable” in Chapter 10.

To create a data table, type a series of column headers in adjacent cells and then type 

a row of data below the headers. Select the headers and data; on the Home tab, in the 

Styles group, click Format as Table; and then, from the gallery that appears, click the 

style you to apply to the table. When the Format as Table dialog box appears, verify that 

the cells in the Where is the data for your table? fi eld refl ect your current selection and 

that the My table has headers check box is selected, and then click OK.

Excel 2007 can also create a table from an existing data list as long as your data has a 

differently formatted header row, the list has no blank rows or columns within the data, 

and there is no extraneous data in cells immediately below or next to the list.

When you want to add data to a table, select a cell in the row immediately below the last 

row in the table or a cell in the column immediately to the right of the table; then type 

a value into the cell. After you enter the value and move out of the cell, the AutoCorrect 

Options smart tag appears. If you didn’t mean to include the data in the table, you can 

click Undo Table AutoExpansion to exclude the cells from the table. If you never want 

Excel 2007 to include adjacent data in a table, click the Stop Automatically Expanding 

Tables option.

Tip To stop Table AutoExpansion before it starts, click the Microsoft Offi ce Button and 

then click Excel Options. In the Excel Options dialog box, click Proofi ng and then click the 

AutoCorrect Options button to display the AutoCorrect dialog box. Click the AutoFormat As 

You Type tab, clear the Include new rows and columns in table check box, and then click OK 

twice.

You can add rows and columns to a table, or remove them from a table, by dragging 

the resize handle at the table’s lower-right corner. If your table’s headers contain a 

 recognizable series of values (such as Region1, Region2, and Region3), and you drag the 

resize handle to create a fourth column, Excel 2007 creates the column with the label 

Region4—the next value in the series. 

Tables often contain data you can summarize by calculating a sum or average, or by 

fi nding the maximum or minimum value in a column. To summarize one or more 

 columns of data, you can add a Total row to your table. 
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When you add the Total row, Excel 2007 creates a formula that calculates the sum of the 

values in the rightmost table column. To change that summary operation or to add a 

summary operation to any other cell in the Total row, click the cell, click the down  arrow 

that appears, and then click the summary operation you want to apply. Clicking the 

More Functions item displays the Insert Function dialog box, from which you can select 

any of the functions in Excel 2007.

See Also For more information about using the Insert Function dialog box, see “Creating 
Formulas to Calculate Values” in Chapter 4.

Much as it does when you create a new worksheet, Excel 2007 gives your tables generic 

names such as Table1 and Table2. You can change a table name to something easier to 

recognize by clicking any cell in the table, clicking the Design contextual tab, and then, 

in the Properties group, editing the value in the Table Name fi eld. Changing a table 

name might not seem important, but it helps make formulas that summarize table data 

much easier to understand. You should make a habit of renaming your tables so you can 

recognize the data they contain.

See Also For more information on referring to tables in formulas, see “Creating Formulas to 
Calculate Values” in Chapter 4.

If for any reason you want to convert your table back to a normal range of cells, click 

any cell in the table and then, on the Table Tools contextual tab, in the Tools group, click 

Convert to Range. When Excel 2007 displays a message box asking if you’re sure you 

want to convert the table to a range, click OK.

In this exercise, you will create a data table from existing data, add data to a table, add a 

Total row, change the Total row’s summary operation, and rename the table.

USE the Driver Sort Times workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Data and Data Tables folder.

OPEN the Driver Sort Times workbook.

1. Select cell B2.

2. On the Home tab, in the Styles group, click Format as Table and then select a 

table style.

The Format As Table dialog box appears.

USE thethe Driver Sort TimesDriver Sort Times workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice 

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\Data and Data TablesMy Documents\Microsoft Press\Excel SBS\Data and Data Tables folder.folder.

OPEN thethe Driver Sort TimesDriver Sort Times workbook. workbook.
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Defi ning a Table
3. Verify that the range =$B$2:$C$17 appears in the Where is the data for your 
table? fi eld and that the My table has headers check box is selected, and then click 

OK.

Excel 2007 creates a table from your data and displays the Design contextual tab.

4. In cell B18, type D116, press D, type 100 in cell C18, and press F.

Excel 2007 includes the data in your table.

5. Select a cell in the table and on the Design contextual tab, in the Table Style 
Options group, select the Total Row check box.

A Total row appears in your table.

6. Select cell C19, click the down arrow that appears at the right edge of the cell, and 

then click Average.

Excel 2007 changes the summary operation to Average.

7. On the Design contextual tab, in the Properties group, type the value 

SortingSample01 in the Table Name fi eld, and press F.

Excel 2007 renames your table.

8. On the Quick Access Toolbar, click the Save button to save your work.

CLOSE the Driver Sort Times workbook.

CLOSE Excel 2007.

CLOSE the Driver Sort Times workbook.

CLOSE Excel 2007.
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Key Points
  You can enter a series of data quickly by entering one or more values in adjacent 

cells, selecting the cells, and then dragging the fi ll handle. To change how dragging 

the fi ll handle extends a data series, hold down the H key.

  Dragging a fi ll handle displays the Auto Fill Options button, which enables you to 

specify whether to copy the selected cells’ values, extend a recognized series, or 

apply the selected cells’ formatting to the new cells.

  Excel 2007 enables you to enter data by using a drop-down list, AutoComplete, 

and H+F. You should experiment with these techniques and use the one that 

best fi ts your circumstances.

  When you copy (or cut) and paste cells, columns, or rows, Excel 2007 displays the 

Paste Options smart tag. You can use its controls to determine which elements of 

the cut or copied elements Excel 2007 applies when they are pasted back into the 

worksheet.

  You can fi nd and replace data within a worksheet by searching for specifi c values or 

by searching for cells that have a particular format applied.

  Excel 2007 provides a variety of powerful proofi ng and research tools, enabling you 

to check your workbook’s spelling, fi nd alternative words using the Thesaurus, and 

translate words between languages.

  Data tables, which are new in Excel 2007, enable you to organize and summarize 

your data effectively.
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 4 4 PerformingPerforming
  Calculations   Calculations 
  on Data  on Data

In this chapter, you will learn to:

  Name groups of data.

  Create formulas to calculate values.

  Summarize data that meets specifi c conditions.

  Find and correct errors in calculations.

Microsoft® Offi ce Excel® 2007 workbooks give you a handy place to store and or-

ganize your data, but you can also do a lot more with your data in Offi ce Excel 2007. 

One important task you can perform is to calculate totals for the values in a series of 

related cells. You can also use Excel 2007 to fi nd out other information about the data 

you select, such as the maximum or minimum value in a group of cells. By fi nding the 

maximum or minimum value in a group, you can identify your best salesperson, product 

categories you might need to pay more attention to, or suppliers that consistently give 

you the best deal. Regardless of your bookkeeping needs, Excel 2007 gives you the abil-

ity to fi nd the information you want. And if you should make an error, you can fi nd the 

cause and correct it quickly.

Many times you can’t access the information you want without referencing more than 

one cell, and it’s also often true that you’ll use the data in the same group of cells for 

more than one calculation. Excel 2007 makes it easy to reference a number of cells at 

once, enabling you to defi ne your calculations quickly.

In this chapter, you’ll learn how to streamline references to groups of data on your 

worksheets and how to create and correct formulas that summarize Consolidated 

Messenger’s business operations.
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See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Naming Groups of Data
When you work with large amounts of data, it’s often useful to identify groups of cells 

that contain related data. For example, you can create a worksheet in which cells C4:I4 

hold the number of packages Consolidated Messenger’s Northeast processing facility 

handled from 5:00 PM to 12:00 AM on the previous day.

Instead of specifying the cells individually every time you want to use the data they con-

tain, you can defi ne those cells as a range (also called a named range). For instance, you 

can group the items from the preceding graphic into a range named NortheastLastDay. 
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Whenever you want to use the contents of that range in a calculation, you can simply 

use the name of the range instead of specifying each cell individually.

Note Yes, you could just name the range Northeast, but if you use the range’s values 

in a formula in another worksheet, the more descriptive range name tells you and your 

colleagues exactly what data is used in the calculation.

To create a named range, select the cells you want to include in your range, click the 

Formulas tab on the user interface, and then, in the Defi ned Names group, click Defi ne 

Name to display the New Name dialog box. In the New Name dialog box, type a name 

in the Name fi eld, verify that the cells you selected appear in the Refers to fi eld, and 

then click OK. You can also add a comment about the fi eld in the Comment fi eld and 

select whether you want to make the name available for formulas in the entire workbook 

or just on an individual worksheet.

If the cells you want to defi ne as a named range have a label you want to use as the 

range’s name, you can display the Formulas tab and then, in the Defi ned Names group, 

click Create from Selection to display the Create Names from Selection dialog box. In the 

Create Names from Selection dialog box, select the check box that represents the label’s 

position in relation to the data cells and then click OK. 

A fi nal way to create a named range is to select the cells you want in the range, click in 

the Name box next to the formula bar, and then type the name for the range. You can 

display the ranges available in a workbook by clicking the Name box down arrow.

To manage the named ranges in a workbook, display the Formulas tab on the rib-

bon and then, in the Defi ned Names group, click Name Manager to display the Name 

Manager dialog box.
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When you click a named range, Excel 2007 displays the cells it encompasses in the Refers 

to fi eld. Clicking the Edit button displays the Edit Name dialog box, which is a version of 

the New Name dialog box, enabling you to change a named range’s defi nition. You can 

also get rid of a name by clicking it, clicking the Delete button, and then clicking OK in 

the confi rmation dialog box that appears.

Important If your workbook contains a lot of named ranges, you can click the Filter 

button in the Name Manager dialog box and select a criterion to limit the names displayed 

in the Name Manager dialog box.

In this exercise, you will create named ranges to streamline references to groups of cells.

USE the VehicleMiles workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Formulas folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the VehicleMiles workbook from the My Documents\Microsoft Press\Excel SBS\
Formulas folder.

1. Select cells C4:G4.

2. In the Name box on the left of the formula bar, type V101LastWeek and press F.

Excel 2007 creates a named range named V101LastWeek.

3. On the Formulas tab of the user interface, in the Defi ned Names group, click 

Name Manager.

The Name Manager dialog box appears.

USE thethe VehicleMilesVehicleMiles workbook in the practice fi le folder for this topic. This practice fi le is workbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\FormulasMy Documents\Microsoft Press\Excel SBS\Formulas folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe VehicleMilesVehicleMiles workbook from the workbook from the My Documents\Microsoft Press\Excel SBS\My Documents\Microsoft Press\Excel SBS\
FormulasFormulas folder.folder.
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Naming Groups of Data
4. Click the V101LastWeek name.

The cell range to which the V101LastWeek name refers appears in the 

Refers to fi eld.

5. Edit the cell range in the Refers to fi eld to =LastWeekMiles!$C$4:$H$4, click OK, 

and then click the check button next to the Refers to fi eld.

Excel 2007 changes the named range’s defi nition.

6. Click Close.

The Name Manager dialog box disappears.

7. Select the cell range C5:H5.

8. On the Formulas tab, in the Defi ned Names group, click Defi ne Name.

The New Name dialog box appears.

9. In the Name fi eld, type V102LastWeek.

10. Verify that the defi nition in the Refers to fi eld is =LastWeekMiles!$C$5:$H$5.

11. Click OK.

Excel 2007 creates the name and closes the New Name dialog box.

CLOSE the VehicleMiles workbook.CLOSE the VehicleMiles workbook.
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Creating Formulas to Calculate Values
After you add your data to a worksheet and defi ne ranges to simplify data references, 

you can create a formula, or an expression that performs calculations on your data. For 

example, you can calculate the total cost of a customer’s shipments, fi gure the average 

number of packages for all Wednesdays in the month of January, or fi nd the highest and 

lowest daily package volumes for a week, month, or year.

To write an Excel 2007 formula, you begin the cell’s contents with an equal sign; when 

Excel 2007 sees it, it knows that the expression following it should be interpreted as a 

calculation, not text. After the equal sign, type the formula. For example, you can fi nd 

the sum of the numbers in cells C2 and C3 using the formula =C2+C3. After you have 

entered a formula into a cell, you can revise it by clicking the cell and then editing the 

formula in the formula bar. For example, you can change the preceding formula to =C3-
C2, which calculates the difference between the contents of cells C2 and C3.

Troubleshooting If Excel 2007 treats your formula as text, make sure that you haven’t 

accidentally put a space before the equal sign. Remember, the equal sign must be the fi rst 

character!

Typing the cell references for 15 or 20 cells in a calculation would be tedious, but Excel 

2007 makes it easy to handle complex calculations. To create a new calculation, click the 

Formulas tab on the ribbon and then, in the Function Library group, click Insert Function. 

The Insert Function dialog box appears, with a list of functions, or predefi ned formulas, 

from which you can choose.

The following table describes some of the most useful functions in the list.
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Function Description

SUM Finds the sum of the numbers in the specifi ed cells

AVERAGE Finds the average of the numbers in the specifi ed cells

COUNT Finds the number of entries in the specifi ed cells

MAX Finds the largest value in the specifi ed cells

MIN Finds the smallest value in the specifi ed cells

Two other functions you might use are the NOW() and PMT() functions. The NOW() 
function returns the time the workbook was last opened, so the value will change every 

time the workbook is opened. The proper form for this function is =NOW(). To update 

the value to the current date and time, just save your work, close the workbook, and 

then reopen it. 

The PMT() function is a bit more complex. It calculates payments due on a loan, as-

suming a constant interest rate and constant payments. To perform its calculations, the 

PMT() function requires an interest rate, the number of months of payments, and the 

starting balance. The elements to be entered into the function are called arguments and 

must be entered in a certain order. That order is written PMT(rate, nper, pv, fv, type). The 

following table summarizes the arguments in the PMT() function.

Argument Description

rate The interest rate, to be divided by 12 for a loan with monthly 

payments

nper The total number of payments for the loan

pv The amount loaned (pv is short for present value, or principal)

fv The amount to be left over at the end of the payment cycle (usually 

left blank, which indicates 0)

type 0 or 1, indicating whether payments are made at the beginning or 

at the end of the month (usually left blank, which indicates 0, or the 

end of the month)

If Consolidated Messenger wanted to borrow $2,000,000 at a 6 percent interest rate 

and pay the loan back over 24 months, you could use the PMT() function to fi gure out 

the monthly payments. In this case, the function would be written =PMT(6%/12, 24, 

2000000), which calculates a monthly payment of $88,641.22.
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You can also use the names of any ranges you defi ned to supply values for a formula. 

For example, if the named range NortheastLastDay refers to cells C4:I4, you can 

calculate the average of cells C4:I4 with the formula =AVERAGE(NortheastLastDay). 
In previous versions of Excel, you had to type the name into your formula by hand. 

Excel 2007 enables you to add functions, named ranges, and table references to your 

formulas more effi ciently by using the new Formula AutoComplete capability. Just as 

AutoComplete offers to fi ll in a cell’s text value when Excel 2007 recognizes that the 

value you’re typing matches a previous entry, Formula AutoComplete offers to fi ll in a 

function, named range, or table reference while you create a formula.

As an example, consider a worksheet that contains a two-column table named 

Exceptions. The fi rst column is labeled Route; the second is labeled Count. 

You refer to a table by typing the table name, followed by the column or row name in 

square brackets. For example, the table reference Exceptions[Count] would refer to the 

Exceptions table’s Count column.

To create a formula that fi nds the total number of exceptions by using the SUM function, 

you begin by typing =SU. When you type the letter S, Formula AutoComplete lists func-

tions that begin with the letter S; when you type the letter U, Excel 2007 narrows the list 

down to the functions that start with the letters SU.
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To add the SUM function (followed by an opening parenthesis) to the formula, click SUM
and then press D. To begin adding the table column reference, type the letter E. Excel 

2007 displays a list of available functions, tables, and named ranges that start with the 

letter E. Click Exceptions and press D to add the table reference to the formula. Then, 

because you want to summarize the values in the table’s Count column, type [Count] to 

create the formula =SUM(Exceptions[Count]).

If you want to include a series of contiguous cells in a formula, but you haven’t defi ned 

the cells as a named range, you can click the fi rst cell in the range and drag to the last 

cell. If the cells aren’t contiguous, hold down the H key and click the cells to be included. 

In both cases, when you release the mouse button, the references of the cells you se-

lected appear in the formula.
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After you create a formula, you can copy it and paste it into another cell. When you do, 

Excel 2007 tries to change the formula so that it works in the new cells. For instance, 

suppose that you have a worksheet in which cell D8 contains the formula =SUM(C2:C6). 
Clicking cell D8, copying the cell’s contents, and then pasting the result into cell D16 

writes =SUM(C10:C14) into cell D16. Excel 2007 has reinterpreted the formula so that it 

fi ts the surrounding cells! Excel 2007 knows it can reinterpret the cells used in the for-

mula because the formula uses a relative reference, or a reference that can change if the 

formula is copied to another cell. Relative references are written with just the cell row 

and column (for example, C14). If you want a cell reference to remain constant when 

the formula using it is copied to another cell, you can use an absolute reference. To 

write a cell reference as an absolute reference, type $ before the row name and the col-

umn number. If you want the formula in cell D16 to show the sum of values in cells C10 

through C14 regardless of the cell into which it is pasted, you can write the formula as 

=SUM($C$10:$C$14). 

Tip If you copy a formula from the formula bar, use absolute references or use only named 

ranges in your formula. Excel 2007 doesn’t change the cell references when you copy your 

formula to another cell.
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Creating Formulas to Calculate Values
One quick way to change a cell reference from relative to absolute is to select the 

cell reference on the formula bar and then press $. Pressing $ cycles a cell reference 

through the four possible types of references:

  Relative columns and rows (for example, C4)

  Absolute columns and rows (for example, $C$4)

  Relative columns and absolute rows (for example, C$4)

  Absolute columns and relative rows (for example, $C4)

In this exercise, you will create a formula manually, revise it to include additional cells, 

create a formula that contains a table reference, create a formula with relative refer-

ences, and change the formula so it contains absolute references.

USE the ITExpenses workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Formulas folder.

OPEN the ITExpenses workbook.

1. If necessary, display the Summary worksheet. Then, in cell F9, type =C4 and 

press F.

The value $385,671.00 appears in cell F9.

2. Select cell F9 and then, on the formula bar, erase the existing formula and 

type =SU.

Formula AutoComplete displays a list of possible functions to use in the formula.

3. In the Formula AutoComplete list, click SUM and then press D.

Excel 2007 changes the contents of the formula bar to =SUM(.

4. Select the cell range C3:C8, type a right parenthesis (the ) character) to make the 

formula bar’s contents =SUM(C3:C8) and then press F.

The value $2,562,966.00 appears in cell F9.

5. In cell F10, type =SUM(C4:C5) and press F.

6. Select cell F10 and then, on the formula bar, select the cell reference C4 and 

press $.

Excel 2007 changes the cell reference to $C$4.

7. On the formula bar, select the cell reference C5, press $, and then press F.

Excel 2007 changes the cell reference to $C$5.

USE thethe ITExpensesITExpenses workbook in the practice fi le folder for this topic. This practice fi le is  workbook in the practice fi le folder for this topic. This practice fi le is 

located in thelocated in the My Documents\Microsoft Press\Excel SBS\FormulasMy Documents\Microsoft Press\Excel SBS\Formulas folder.folder.

OPEN thethe ITExpensesITExpenses workbook. workbook.
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8. On the tab bar, click the JuneLabor sheet tab.

The JuneLabor worksheet appears.

9. In cell F13, type =SUM(J.

Excel 2007 displays JuneSummary, the name of the table in the JuneLabor 
worksheet.

10. Press D.

Excel 2007 extends the formula to read =SUM(JuneSummary.

11. Type [, and then, in the Formula AutoComplete list, click [Labor Expense] and 

press D.

Excel 2007 extends the formula to read =SUM(JuneLabor[Labor Expense.

12. Type ]) to complete the formula and then press F.

The value $637,051.00 appears in cell F13.

CLOSE the ITExpenses workbook.CLOSE the ITExpenses workbook.
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Summarizing Data That Meets Specifi c Conditions
Another use for formulas is to display messages when certain conditions are met. For 

instance, Consolidated Messenger’s VP of Marketing, Craig Dewar, might have agreed 

to examine the rates charged to corporate customers who were billed for more than 

$100,000 during a calendar year. This kind of formula is called a conditional formula, and 

it uses the IF function. To create a conditional formula, you click the cell to hold the for-

mula and open the Insert Function dialog box. From within the dialog box, select IF from 

the list of available functions and then click OK. The Function Arguments dialog box 

appears.

When you work with an IF function, the Function Arguments dialog box has three boxes: 

Logical_test, Value_if_true, and Value_if_false. The Logical_test box holds the condition 

you want to check. If the customer’s year-to-date shipping bill appears in cell G8, the ex-

pression would be G8>100000.

Now you need to have Excel 2007 display messages that indicate whether Craig Dewar 

should evaluate the account for a possible rate adjustment. To have Excel 2007 print a 

message from an IF function, you enclose the message in quotes in the Value_if_true 

or Value_if_false box. In this case, you would type “High-volume shipper—evaluate 
for rate decrease.” in the Value_if_true box and “Does not qualify at this time.” in the 

Value_if_false box.

Excel 2007 also includes fi ve new conditional functions with which you can summarize 

your data:

 IFERROR, which displays one value if a formula results in an error; another if it 

doesn’t

 AVERAGEIF, which fi nds the average of values within a cell range that meet a given 

criterion
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 AVERAGEIFS, which fi nds the average of values within a cell range that meet 

multiple criteria

 SUMIFS, which fi nds the sum of values in a range that meet multiple criteria

 COUNTIFS, which counts the number of cells in a range that meet multiple criteria

The IFERROR function enables you to display a custom error message instead of relying 

on the default Excel 2007 error messages to explain what happened. One example of 

an IFERROR formula is if you want to look up the CustomerID value from cell G8 in the 

Customers table by using the VLOOKUP function. One way to create such a formula is 

=IFERROR(VLOOKUP(G8,Customers,2,false),”Customer not found”). If the function fi nds a 

match for the CustomerID in cell G8, it displays the customer’s name; if it doesn’t 

fi nd a match, it displays the text Customer not found.

See Also For more information about the VLOOKUP function, see “Looking Up Information in 
a Data List” in Chapter 15.

The AVERAGEIF function is a variation on the existing COUNTIF and SUMIF functions. To 

create a formula using the AVERAGEIF function, you defi ne the range to be examined, 

the criteria, and, if required, the range from which to draw the values. As an example, 

consider the following worksheet, which lists each customer’s name, state, and total 

monthly shipping bill.



   73Summarizing Data That Meets Specifi c Conditions
If you want to fi nd the average order of customers from Washington State (abbreviated 

in the worksheet as WA), you can create the formula =AVERAGEIF(D3:D6,”=WA”, E3:E6). 

The AVERAGEIFS, SUMIFS, and COUNTIFS functions extend the capabilities of the 

AVERAGEIF, SUMIF, and COUNTIF functions to allow for multiple criteria. If you want to 

fi nd the sum of all orders of at least $100,000 placed by companies in Washington, you 

can create the formula =SUMIFS(E3:E6, D3:D6, “=WA”, E3:E6, “>=100000”).

The AVERAGEIFS and SUMIFS functions start with a data range that contains values 

that the formula summarizes; you then list the data ranges and the criteria to apply to 

that range. In generic terms, the syntax runs =AVERAGEIFS(data_range, criteria_range1, 
criteria1[,criteria_range2, criteria2…]). The part of the syntax in square brackets is op-

tional, so an AVERAGEIFS or SUMIFS formula that contains a single criterion works. 

The COUNTIFS function, which doesn’t perform any calculations, doesn’t need a data 

range—you just provide the criteria ranges and criteria. For example, you could fi nd the 

number of customers from Washington billed at least $100,000 by using the formula 

=COUNTIFS(D3:D6, “=WA”, E3:E6, “>=100000”).

In this exercise, you will create a conditional formula that displays a message if a condi-

tion is true, fi nd the average of worksheet values that meet one criterion, and fi nd the 

sum of worksheet values that meet two criteria.

USE the PackagingCosts workbook in the practice fi le folder for this topic. This practice fi le 

is located in the My Documents\Microsoft Press\Excel SBS\Formulas folder.

OPEN the PackagingCosts workbook.

 1. In cell G3, type the formula =IF(F3>=35000,”Request discount”,”No discount 
available”) and press F.

Excel 2007 accepts the formula, which displays Request discount if the value in cell 

F3 is at least 35,000 and displays No discount available if not. The value Request 
discount appears in cell G3.

 2. Click cell G3 and drag the fi ll handle down until it covers cell G14.

Excel 2007 copies the formula in cell G3 to cells G4:G14, adjusting the formula 

to refl ect the cells’ addresses. The results of the copied formulas appear in 

cells G4:G14.

USE thethe PackagingCostsPackagingCosts workbook in the practice fi le folder for this topic. This practice fi le  workbook in the practice fi le folder for this topic. This practice fi le 

is located in theis located in the My Documents\Microsoft Press\Excel SBS\Formulas folderMy Documents\Microsoft Press\Excel SBS\Formulas folder..rrrr

OPEN thethe PackagingCostsPackagingCosts workbook. workbook.
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3. In cell I3, type the formula =AVERAGEIF(C3:C14, “=Box”, F3:F14) and press F.

The value $46,102.50, which represents the average cost per category of boxes, ap-

pears in cell I3.

4. In cell I6, type  =SUMIFS(F3:F14, C3:C14, “=Envelope”, E3:E14, “=International”).

The value $45,753.00, which represents the total cost of all envelopes used for in-

ternational shipments, appears in cell I6.

CLOSE the PackagingCosts workbook.CLOSE the PackagingCosts workbook.
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Finding and Correcting Errors in Calculations
Including calculations in a worksheet gives you valuable answers to questions about your 

data. As is always true, however, it is possible for errors to creep into your formulas. Excel 

2007 makes it easy to fi nd the source of errors in your formulas by identifying the cells 

used in a given calculation and describing any errors that have occurred. The process of 

examining a worksheet for errors in formulas is referred to as auditing.

Excel 2007 identifi es errors in several ways. The fi rst way is to fi ll the cell holding the for-

mula generating the error with an error code. In the following graphic, cell F13 has the 

error code #NAME?.
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When a cell with an erroneous formula is the active cell, an Error button appears next 

to it. You can click the button down arrow to display a menu with options that provide 

information about the error and offer to help you fi x it. The following table lists the most 

common error codes and what they mean. 

Error Code Description

##### The column isn’t wide enough to display the value.

#VALUE! The formula has the wrong type of argument (such as text in which 

a TRUE or FALSE value is required).

#NAME? The formula contains text that Excel 2007 doesn’t recognize (such 

as an unknown named range).

#REF! The formula refers to a cell that doesn’t exist (which can happen 

whenever cells are deleted).

#DIV/0! The formula attempts to divide by zero.

Another technique you can use to fi nd the source of formula errors is to ensure that the 

appropriate cells are providing values for the formula. For example, you might want to 

calculate the total number of deliveries for a service level, but you could accidentally cre-

ate a formula referring to the service levels’ names instead of their quantities. You can 

identify what kind of error has appeared by having Excel 2007 trace a cell’s precedents, 
which are the cells with values used in the active cell’s formula. Excel 2007 identifi es a 

cell’s precedents by drawing a blue tracer arrow from the precedent to the active cell.

You can also audit your worksheet by identifying cells with formulas that use a value 

from a given cell. For example, you might use one region’s daily package total in a for-

mula that calculates the average number of packages delivered per region on a given 

day. Cells that use another cell’s value in their calculations are known as dependents, 
meaning that they depend on the value in the other cell to derive their own value. As 

with tracing precedents, you can click the Formulas tab on the user interface and then, 

in the Formula Auditing group, click Trace Dependents to have Excel 2007 draw blue ar-

rows from the active cell to those cells that have calculations based on that value.
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If the cells identifi ed by the tracer arrows aren’t the correct cells, you can hide the arrows 

and correct the formula. To hide the tracer arrows on a worksheet, display the Formulas 

tab and then, in the Formula Auditing group, click Remove Arrows.

If you prefer to have the elements of a formula error presented as text in a dialog box, 

you can use the Error Checking dialog box (which you can display by displaying the 

Formulas tab and then, in the Formula Auditing group, clicking the Error Checking but-

ton) to view the error and the formula in the cell in which the error occurs. You can also 

use the controls in the Error Checking dialog box to move through the formula one step 

at a time, to choose to ignore the error, or to move to the next or the previous error. If 

you click the Options button in the dialog box, you can also use the controls in the Excel 

Options dialog box to change how Excel 2007 determines what is an error and what isn’t.



78  Chapter 4 Performing Calculations on Data
Tip You can have the Error Checking tool ignore formulas that don’t use every cell in a 

region (such as a row or column). If you clear the Formulas that omit cells in a region check 

box, you can create formulas that don’t add up every value in a row or column (or rect-

angle) without Excel 2007 marking them as an error.

For times when you just want to display the results of each step of a formula and don’t 

need the full power of the Error Checking tool, you can use the Evaluate Formula dia-

log box to move through each element of the formula. To display the Evaluate Formula 

dialog box, you display the Formulas tab and then, in the Formula Auditing group, click 

the Evaluate Formula button. The Evaluate Formula dialog box is much more useful for 

examining formulas that don’t produce an error but aren’t generating the result you 

expect.

Finally, you can monitor the value in a cell regardless of where in your workbook you are 

by opening a Watch Window that displays the value in the cell. For example, if one of 

your formulas uses values from cells in other worksheets or even other workbooks, you 

can set a watch on the cell that contains the formula and then change the values in the 

other cells. To set a watch, click the cell you want to monitor and then, on the Formulas 

tab, in the Formula Auditing group, click Watch Window. Click Add Watch to have Excel 

2007 monitor the selected cell. 
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As soon as you type in the new value, the Watch Window displays the new result of the 

formula. When you’re done watching the formula, select the watch, click Delete Watch, 

and close the Watch Window.

In this exercise, you use the formula-auditing capabilities in Excel 2007 to identify and 

correct errors in a formula.

USE the ConveyerBid workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Formulas folder.

OPEN the ConveyerBid workbook.

 1. Click cell D20.

 2. On the Formulas tab, in the Formula Auditing group, click Watch Window.

The Watch Window appears.

 3. Click Add Watch and then, in the Add Watch dialog box, click Add.

Cell D20 appears in the Watch Window.

 4. Click cell D8.

=SUM(C3:C7) appears in the formula bar.

 5. On the Formulas tab, in the Formula Auditing group, click Trace Precedents.

USE thethe ConveyerBidConveyerBid workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le isdd
located in thelocated in the My Documents\Microsoft Press\Excel SBS\FormulasMy Documents\Microsoft Press\Excel SBS\Formulas folder.folder.

OPEN thethe ConveyerBidConveyerBid workbook.workbook.dd
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A blue arrow appears between cell D8 and the cell range C3:C7, indicating that the 

cells in the range C3:C7 are precedents of the value in cell D8.

6. On the Formulas tab, in the Formula Auditing group, click Remove Arrows.

The arrow disappears.

7. Click cell A1.

8. On the Formulas tab, in the Formula Auditing group, click the Error Checking 

button.

The Error Checking dialog box appears.

9. Click Next.

Excel 2007 displays a message box indicating that there are no more errors in the 

worksheet.

10. Click OK.
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Finding and Correcting Errors in Calculations
The message box and the Error Checking dialog box disappear.

11. On the Formulas tab, in the Formula Auditing group, click the Error Checking but-

ton down arrow, and then click Trace Error.

Blue arrows appear, pointing to cell D21 from cells C12 and D19. These arrows indi-

cate that using the values (or lack of values, in this case) in the indicated cells gen-

erates the error in cell D21.

12. On the Formulas tab, in the Formula Auditing group, click Remove Arrows.

The arrows disappear.

13. In the formula bar, delete the existing formula, type =C12/D20, and press F.

The value 14% appears in cell D21.

14. Click cell D21.

15. On the Formulas tab, in the Formula Auditing group, click the Evaluate Formula 

button.

The Evaluate Formula dialog box appears, with the formula from cell D21 

displayed.

16. Click Evaluate three times to step through the formula’s elements and then click 

Close.

The Evaluate Formula dialog box disappears.

17. In the Watch Window, click the watch in the list.

18. Click Delete Watch.

The watch disappears.

19. On the Formulas tab, in the Formula Auditing group, click Watch Window.

The Watch Window disappears.

CLOSE the ConveyerBid workbook.

CLOSE Excel.

CLOSE the ConveyerBid workbook.d

CLOSE Excel.
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Key Points
  You can add a group of cells to a formula by typing the formula and then, at the 

spot in the formula in which you want to name the cells, selecting the cells using 

the mouse.

  Creating named ranges enables you to refer to entire blocks of cells with a single 

term, saving you lots of time and effort. You can use a similar technique with table 

data, referring to an entire table or one or more table columns.

  When you write a formula, be sure you use absolute referencing ($A$1) if you want 

the formula to remain the same when it’s copied from one cell to another or use 

relative referencing (A1) if you want the formula to change to refl ect its new posi-

tion in the worksheet.

  Instead of typing a formula from scratch, you can use the Insert Function dialog 

box to help you on your way.

  You can monitor how the value in a cell changes by adding a watch to the Watch 
Window.

  To see which formulas refer to the values in the selected cell, use Trace Dependents; 
if you want to see which cells provide values for the formula in the active cell, use 

Trace Precedents.

  You can step through the calculations of a formula in the Evaluate Formula dia-

log box or go through a more rigorous error-checking procedure using the Error 
Checking tool.
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In this chapter, you will learn to:
  Format a cell.

  Defi ne styles.

  Apply a workbook theme.

  Make numbers easier to read.

  Change data’s appearance based on its value.

  Add an image to a document.

Entering data into a workbook effi ciently saves you time, but you must also ensure that 

your data is easy to read. Microsoft® Offi ce Excel® 2007 gives you a wide variety of 

ways to make your data easier to understand; for example, you can change the font, 

character size, or color used to present a cell’s contents. Changing how data appears on 

a worksheet helps set the contents of a cell apart from the contents of surrounding cells. 

The simplest example of that concept is a data label. If a column on your worksheet has 

a list of days, you can set a label (for example, Day) apart easily by presenting it in bold 

type that’s noticeably larger than the type used to present the data to which it refers. To 

save time, you can defi ne a number of custom formats and then apply them quickly to 

the desired cells.

You might also want to specially format a cell’s contents to refl ect the value in that cell. 

For instance, Jenny Lysaker, the chief operating offi cer of Consolidated Messenger, might 

want to create a worksheet that displays the percentage of improperly delivered pack-

ages from each regional distribution center. If that percentage exceeds a threshold, she 

could have Offi ce Excel 2007 display a red traffi c light icon, indicating that the center’s 

performance is out of tolerance and requires attention. 
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In addition to changing how data appears in the cells of your worksheet, you can also 

use headers and footers to add page numbers, current data, or graphics to the top and 

bottom of every printed page.

In this chapter, you’ll learn how to change the appearance of data, apply existing formats 

to data, make numbers easier to read, change data’s appearance based on its value, 

make printouts easier to follow, and position your data on the printed page.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Formatting Cells
Offi ce Excel 2007 spreadsheets can hold and process lots of data, but when you  manage 

numerous spreadsheets it can be hard to remember from a worksheet’s title exactly 

what data is kept in that worksheet. Data labels give you and your colleagues informa-

tion about data in a worksheet, but it’s important to format the labels so that they stand 

out visually. To make your data labels or any other data stand out, you can change the 

format of the cells in which the data is stored.

Most of the tools you need to change a cell’s format can be found on the user interface’s 

Home tab. You can apply the formatting represented on a button by selecting the cells 

you want to apply the style to and then clicking the appropriate button. If you want to 

set your data labels apart by making them appear bold, click the Bold button. If you 
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have already made a cell’s contents bold, selecting the cell and clicking the Bold button 

will remove the formatting.

Tip Deleting a cell’s contents doesn’t delete the cell’s formatting. To delete a cell’s format-

ting, select the cell and then, on the Home tab, in the Editing group, click the Clear button 

and then click Clear Formats.

Items in the Home tab’s Font group that give you choices, such as the Font Color control, 

have a down arrow at the right edge of the control. Clicking the down arrow displays a 

list of options accessible for that control, such as the fonts available on your system or 

the colors you can assign to a cell.

Another way you can make a cell stand apart from its neighbors is to add a border 

around the cell. To place a border around one or more cells, select the cells and then 

choose the border type you want by clicking the down arrow in the Font group’s Border 

control and selecting the type of border to apply. Excel 2007 does provide more op-

tions—to display the full range of border types and styles, open the Border control’s 

drop-down list and then click More Borders. The Border tab of the Format Cells dialog 

box contains the full range of tools you can use to defi ne your cells’ borders.
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Another way you can make a group of cells stand apart from its neighbors is to change 

its shading, or the color that fi lls the cells. On a worksheet that tracks total package vol-

ume for the past month, Jenny Lysaker could change the fi ll color of the cells holding her 

data labels to make the labels stand out even more than by changing the formatting of 

the text used to display the labels.

Tip You can display the most commonly used formatting controls by right- clicking 

a  selected range. When you do, a minitoolbar containing a subset of the Home tab 

 formatting tools appears at the top of the shortcut menu.

If you want to change the attributes of every cell in a row or column, you can click the 

header of the row or column you want to format and then select your desired format.

One task you can’t perform using the tools on the Home tab of the user interface is to 

change the standard font for a workbook, which is used in the Name box and on the 

formula bar. The standard font when you install Excel 2007 is Calibri, a simple font that 

is easy to read on a computer screen and on the printed page. If you want to choose an-

other font, click the Microsoft Offi ce Button and then click Excel Options. On the Popular 

page of the Excel Options dialog box, set the values in the Use this font and Font size list 

boxes to pick your new display font.

Important The new standard font doesn’t take effect until you quit Excel 2007 and restart 

the program.
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Formatting Cells
In this exercise, you emphasize a worksheet’s title by changing the format of cell data, 

adding a border to a cell range, and then changing a cell range’s fi ll color. After those 

tasks are complete, you change the default font for the workbook.

USE the VehicleMileSummary workbook in the practice fi le folder for this topic. This 

 practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Appearance folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the VehicleMileSummary workbook.

1. Click cell D2.

2. On the Home tab of the user interface, in the Font group, click the Bold button.

Excel 2007 displays the cell’s contents in bold type.

3. In the Font group, click the Font Size control down arrow and then click 18.

Excel 2007 increases the size of the text in cell D2.

4. Select cells B5 and C4.

5. On the Home tab, in the Font group, click the Bold button.

Excel 2007 displays the cells’ contents in bold type.

6. Select the cell ranges B6:B15 and C5:H5.

USE thethe VehicleMileSummaryVehicleMileSummary workbook in the practice fi le folder for this topic. This  workbook in the practice fi le folder for this topic. This yy
practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\AppearanceMy Documents\Microsoft Press\Excel SBS\Appearance folder. folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe VehicleMileSummaryVehicleMileSummary workbook.workbook.yy
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7. On the Home tab, in the Font group, click the Italic button.

Excel 2007 displays the cells’ contents in italic type.

8. Select the cell range C6:H15.

9. On the Home tab, in the Font group, click the Border control down arrow and then 

click Outside Borders.

Excel 2007 places a border around the outside edge of the selected cells.

10. Select the cell range B4:H15.

11. On the Home tab, in the Font group, click the Border control down arrow and then 

click Thick Box Border.

Excel 2007 places a thick border around the outside edge of the selected cells.

12. Select the cell ranges B4:B15 and C4:H5.

13. On the Home tab, in the Font group, click the Fill Color control down arrow and 

then, in the Standard Colors section of the color palette, click the yellow button.

Excel 2007 changes the selected cells’ background color to yellow.
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Formatting Cells
14. Click the Microsoft Offi ce Button and then click Excel Options.

The Excel Options dialog box appears.

15. If necessary, click Popular to display the Popular tab.

16. In the When creating new workbooks section, click the Use this font fi eld down 

arrow and then click Verdana.

Verdana appears in the Use this font fi eld.

17. Click Cancel.

The Excel Options dialog box disappears without saving your change.

CLOSE the VehicleMileSummary workbook.CLOSE the VehicleMileSummary workbook.y
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Defi ning Styles
As you work with Excel 2007, you will probably develop preferred formats for data labels, 

titles, and other worksheet elements. Instead of adding the format’s characteristics one 

element at a time to the target cells, you can have Excel 2007 store the format and re-

call it as needed. You can fi nd the predefi ned formats available to you by displaying the 

Home tab of the user interface and then, in the Styles group, clicking Cell Styles.

Clicking a style from the Cell Styles gallery applies the style to the selected cells, but 

Excel 2007 goes a step beyond previous versions of the program by displaying a live 

 preview of a format when you hover your mouse pointer on it. If none of the exist-

ing styles is what you want, you can create your own style by displaying the Cell Styles 

 gallery and, at the bottom of the gallery, clicking New Cell Style to display the Style 

 dialog box. In the Style dialog box, type the name of your new style in the Style name 

fi eld and then click Format. The Format Cells dialog box appears.
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After you set the characteristics of your new style, click OK to make your style available 

in the Cell Styles gallery. If you ever want to delete a style, display the Cell Styles gallery, 

right-click the style, and then click Delete.

The Style dialog box is quite versatile, but it’s overkill if all you want to do is apply 

 formatting changes you made to a cell to the contents of another cell. To do so, use the 

Format Painter button, found in the Home tab’s Clipboard group. Just click the cell that 

has the format you want to copy, click the Format Painter button, and select the target 

cells to have Excel 2007 apply the copied format to the target range.

In this exercise, you create a style, apply the new style to a data label, and then use the 

Format Painter to apply the style to the contents of another cell. 

USE the HourlyExceptions workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Appearance folder.

OPEN the HourlyExceptions workbook.

 1. On the Home tab, in the Styles group, click Cell Styles and then click New Cell 
Style.

The Style dialog box appears.

USE thethe HourlyExceptionsHourlyExceptions workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\AppearanceMy Documents\Microsoft Press\Excel SBS\Appearance folder. folder.

OPEN thethe HourlyExceptionsHourlyExceptions workbook. workbook.
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2. In the Style name fi eld, type Crosstab Column Heading.

3. Click the Format button.

The Format Cells dialog box appears.

4. Click the Alignment tab.

The Alignment tab of the Format Cells dialog box appears.

5. Click the Horizontal fi eld down arrow and then click Center.

Center appears in the Horizontal fi eld.

6. Click the Font tab.

The Font tab of the Format Cells dialog box appears.



   95

 

 

 

 

 

 

 

 

Defi ning Styles
7. In the Font style list, click Italic.

The text in the Preview pane appears in italicized text.

8. Click the Number tab.

The Number tab of the Format Cells dialog box appears.

9. In the Category list, click Time.

The available time formats appear.

10. In the Type pane, click 1:30 PM.

11. Click OK to accept the default time format.

The Format Cells dialog box disappears, and your new style’s defi nition appears in 

the Style dialog box.

12. Click OK.

The Style dialog box disappears.

13. Select cells C4:N4.

14. On the Home tab, in the Styles group, click Cell Styles.

Your new style appears at the top of the gallery, in the Custom group.
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 15. Click the Crosstab Column Heading style.

Excel 2007 applies your new style to the selected cells.

CLOSE the HourlyExceptions workbook.

Applying Workbook Themes and Table Styles
The 2007 Microsoft Offi ce system includes powerful new design tools that enable you to 

create attractive, professional documents quickly. The Excel 2007 product team imple-

mented the new design capabilities by defi ning workbook themes and table styles. A 

theme is a way to specify the fonts, colors, and graphic effects that appear in a work-

book. Excel 2007 comes with many themes installed.

CLOSE the HourlyExceptions workbook.
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To apply an existing workbook theme, display the Page Layout tab of the user interface. 

Then, in the Themes group, click Themes and then click the theme you want to apply to 

your workbook. By default, Excel 2007 applies the Offi ce theme to your workbooks. 

The theme colors appear in the top segment of the color palette—the standard colors 

and the More Colors link, which displays the Colors dialog box, appear at the bottom of 

the palette. If you format workbook elements using colors from the theme colors por-

tion of the color palette, applying a different theme changes that object’s colors.
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You can change a theme’s colors, fonts, and graphic effects by displaying the Page 

Layout tab on the user interface and then, in the Themes group, selecting new values by 

using the Colors, Fonts, and Effects buttons’ drop-down lists. To save your changes as a 

new theme, display the Page Layout tab of the user interface, and then, in the Themes 

group, click Themes and then click Save Current Theme. Use the controls in the dialog 

box that appears to record your theme for later use. Later, when you click the Themes 

button, your custom theme will appear at the top of the gallery.

Note When you save a theme, you save it as an Offi ce Theme fi le. You can apply the 

theme to Microsoft Offi ce Word 2007 and Microsoft Offi ce PowerPoint® 2007 fi les as well.

Just as you can defi ne themes and apply them to entire workbooks, you can apply and 

defi ne table styles. You select a table’s initial style when you create it; to create a new 

table style, display the Home tab of the user interface and then, in the Styles group, click 

Format as Table. In the Format as Table gallery, click New Table Style to display the New 

Table Quick Style dialog box.

Type a name for the new style, select the fi rst table element you want to format, and 

then click Format to display the Format Cells dialog box. Defi ne the element’s formatting 

and then click OK. When the New Table Quick Style dialog box reappears, its Preview 

pane displays the overall table style and the Element Formatting section displays the 

selected element’s appearance. Also, in the Table Element list, Excel 2007 displays the 

element’s name in bold to indicate it has been changed.

If you want to make your new style the default for any new tables created in the current 

workbook, select the Set as default table quick style for this document check box. When 

you click OK, Excel 2007 saves your custom table style.

See Also For more information on creating Excel 2007 tables, see “Defi ning a Table” in Chapter 3.
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Applying Workbook Themes and Table Styles
In this exercise, you will create a new workbook theme, change a workbook’s theme, 

 create a new table style, and apply the new style to a table.

USE the HourlyTracking workbook in the practice fi le folder for this topic. This practice fi le 

is located in the My Documents\Microsoft Press\Excel SBS\Appearance folder.

OPEN the HourlyTracking workbook.

1. If necessary, click any cell in the table.

2. On the Home tab of the ribbon, in the Styles group, click Format as Table and 

then click the style at the upper-left corner of the Table Styles gallery.

Excel 2007 applies the style to the table.

3. On the Home tab of the user interface, in the Styles group, click Format as Table 

and then click New Table Style.

The New Table Quick Style dialog box appears.

4. In the Name fi eld, type Exception Default.

5. In the Table Element list, click Header Row.

6. Click Format.

The Format Cells dialog box appears.

7. Click the Fill tab.

The Fill tab appears.

USE thethe HourlyTrackingHourlyTracking workbook in the practice fi le folder for this topic. This practice fi le  workbook in the practice fi le folder for this topic. This practice fi le 

is located in theis located in the My Documents\Microsoft Press\Excel SBS\AppearanceMy Documents\Microsoft Press\Excel SBS\Appearance folder.folder.

OPEN thethe HourlyTrackingHourlyTracking workbook. workbook.
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8. In the fi rst row of color squares, just below the No Color button, click the third 

square from the left.

The new background color appears in the Sample pane of the dialog box.

9. Click OK.

The Format Cells dialog box disappears. When the New Table Quick Style dialog 

box reappears, the Header Row table element appears in bold, and the Preview 

pane’s header row is shaded.

10. In the Table Element list, click Second Row Stripe and then click Format.

The Format Cells dialog box appears.

11. Click the No Color button and click the third square from the left again.

The new background color appears in the Sample pane of the dialog box.

12. Click OK.

The Format Cells dialog box disappears. When the New Table Quick Style dialog 

box reappears, the Second Row Stripe table element appears in bold, and every 

second row is shaded in the Preview pane.

13. Click OK.

The New Table Quick Style dialog box disappears.

14. On the Home tab, in the Styles group, click Format as Table. In the gallery that 

 appears, in the Custom section, click the new format.

Excel 2007 applies the new format.

15. On the Page Layout tab, in the Themes group, click the Fonts control down arrow 

and then click Verdana.

Excel 2007 changes the theme’s font to Verdana.
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Applying Workbook Themes and Table Styles
16. In the Themes group, click the Themes button and then click Save Current Theme.

The Save Current Theme dialog box appears.

17. In the File name fi eld, type Verdana Offi ce and then click Save.

Excel 2007 saves your theme.
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 18. In the Themes group, click the Themes button and then click Origin.

Excel 2007 applies the new theme to your workbook.

CLOSE the HourlyTracking workbook.

Making Numbers Easier to Read
Changing the format of the cells in your worksheet can make your data much easier to 

read, both by setting data labels apart from the actual data and by adding borders to 

defi ne the boundaries between labels and data even more clearly. Of course, using for-

matting options to change the font and appearance of a cell’s contents doesn’t help with 

idiosyncratic data types such as dates, phone numbers, or currency.

For example, consider U.S. phone numbers. These numbers are 10 digits long and have 

a 3-digit area code, a 3-digit exchange, and a 4-digit line number written in the form 

(###) ###-####. Although you can certainly type a phone number with the expected 

formatting in a cell, it’s much simpler to simply type the 10 digits and have Excel 2007 

change the data’s appearance. You can tell Excel 2007 to expect a phone number in 

a cell by opening the Format Cells dialog box to the Number tab and displaying the 

 formats under the Special category.

Clicking Phone Number from the Type list tells Excel 2007 to format 10-digit numbers 

in the standard phone number format. As you can see by comparing the contents of the 

active cell and the contents of the formula bar in the next graphic, the underlying data 

isn’t changed, just its appearance in the cell.

CLOSE the HourlyTracking workbook.
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Troubleshooting If you type a nine-digit number in a fi eld that expects a phone num-

ber, you won’t see an error message; instead, you’ll see a two-digit area code. For example, 

the number 425555012 would be displayed as (42) 555-5012. An 11-digit number would be 

displayed with a 4-digit area code.

Just as you can instruct Excel 2007 to expect a phone number in a cell, you can also have 

it expect a date or a currency amount. You can make those changes from the Format 

Cells dialog box by choosing either the Date category or the Currency category. The 

Date category enables you to pick the format for the date (and determine whether the 

date’s appearance changes due to the Locale setting of the operating system on the 

computer viewing the workbook). In a similar vein, selecting the Currency category dis-

plays controls to set the number of places after the decimal point, the currency symbol 

to use, and the way in which Excel 2007 should display negative numbers.

Tip The new Excel 2007 user interface enables you to set the most common format 

 changes by using the controls in the Home tab’s Number group.

You can also create a custom numeric format to add a word or phrase to a number in a 

cell. For example, you can add the phrase per month to a cell with a formula that calcu-

lates average monthly sales for a year to ensure that you and your colleagues will recog-

nize the fi gure as a monthly average. To create a custom number format, click the Home 

tab and then click the Number group’s dialog expander to display the Format Cells dia-

log box. Then, if necessary, click the Number tab.

In the Category list, click Custom to display the available custom number formats in the 

Type list. You can then click the base format you want and modify it in the Type box. For 

example, clicking the 0.00 format causes Excel 2007 to format any number in a cell with 

two digits to the right of the decimal point.

Tip The zeros in the format indicate that the position in the format can accept any number 

as a valid value.



104  Chapter 5 Changing Document Appearance

 

 

 

 

To customize the format, click in the Type box and add any symbols or text you want to 

the format. For example, typing a dollar sign to the left of the existing format and then 

typing “per month” to the right of the existing format causes the number 1500 to be 

displayed as $1500.00 per month.

Important You need to enclose any text in quotes so that Excel 2007 recognizes the text 

as a string to be displayed in the cell.

In this exercise, you assign date, phone number, and currency formats to ranges of cells 

in your worksheet. After you assign the formats, you test them by entering customer 

data.

USE the ExecutiveSearch workbook in the practice fi le folder for this topic. This practice fi le 

is located in the My Documents\Microsoft Press\Excel SBS\Appearance folder.

OPEN the ExecutiveSearch workbook.

1. Click cell A3.

2. On the Home tab, in the Font group, click the dialog expander.

The Format Cells dialog box appears.

3. If necessary, click the Number tab.

4. In the Category list, click Date.

The Type list appears with a list of date formats.

USE thethe ExecutiveSearchExecutiveSearch workbook in the practice fi le folder for this topic. This practice fi le  workbook in the practice fi le folder for this topic. This practice fi le 

is located in theis located in the My Documents\Microsoft Press\Excel SBS\AppearanceMy Documents\Microsoft Press\Excel SBS\Appearance folder.folder.

OPEN thethe ExecutiveSearchExecutiveSearch workbook. workbook.
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Making Numbers Easier to Read
5. In the Type list, click 3/14/01.

Caution Be sure to click the format without the asterisk in front of the sample date.

6. Click OK.

Excel 2007 assigns the chosen format to the cell.

7. Click cell G3.

8. On the Home tab, in the Font group, click the dialog expander.

The Format Cells dialog box appears.

9. If necessary, click the Number tab.

The Number tab of the dialog box appears.

10. In the Category list, click Special.

The Type list appears with a list of special formats.

11. In the Type list, click Phone Number and then click OK.

The contents of the cell change to (425) 555-0102, matching the format you chose 

earlier, and the Format Cells dialog box disappears.

12. Click cell H3.

13. On the Home tab, in the Font group, click the dialog expander.

The Format Cells dialog box appears.

14. If necessary, click the Number tab.

The Number tab of the dialog box appears.

15. In the Category list, click Custom.

The contents of the Type list are updated to refl ect your choice.
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16. In the Type list, click the #,##0 item.

#,##0 appears in the Type box.

17. In the Type box, click to the left of the existing format and type $ and then click 

the right of the format and type “before bonuses”.

18. Click OK.

The Format Cells dialog box disappears.
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CLOSE the ExecutiveSearch workbook.

Changing the Appearance of Data Based on 
Its Value

Recording package volumes, vehicle miles, and other business data in a worksheet 

 enables you to make important decisions about your operations. And as you saw earlier 

in this chapter, you can change the appearance of data labels and the worksheet itself to 

make interpreting your data easier.

Another way you can make your data easier to interpret is to have Excel 2007 change 

the appearance of your data based on its value. These formats are called conditional for-
mats because the data must meet certain conditions to have a format applied to it. For 

instance, if chief operating offi cer Jenny Lysaker wanted to highlight any Thursdays with 

higher-than-average weekday package volumes, she could defi ne a conditional  format 

that tests the value in the cell recording total sales, and that will change the  format of 

the cell’s contents when the condition is met.

In previous versions of Excel, you could have a maximum of three conditional formats. 

There’s no such limit in Excel 2007; you may have as many conditional formats as you 

like. The other major limitation of conditional formats in Excel 2003 and earlier versions 

was that Excel stopped evaluating conditional formats as soon as it found one that ap-

plied to a cell. In other words, you couldn’t have multiple conditions be true for the same 

cell! In Excel 2007, you can control whether Excel 2007 stops or continues after it discov-

ers that a specifi c condition applies to a cell.

To create a conditional format, you select the cells to which you want to apply the 

 format, display the Home tab of the user interface, and then, in the Styles group, click 

Conditional Formatting to display a menu of possible conditional formats. Excel 2007 

enables you to create all the conditional formats available in previous versions of the 

program and offers many more conditional formats than were previously available. Prior 

to Excel 2007, you could create conditional formats to highlight cells that contained val-

ues meeting a certain condition. For example, you could highlight all cells that contain a 

value over 100, contain a date before 1/28/2007, or contain an order amount between 

$100 and $500. In Excel 2007, you can defi ne conditional formats that change how the 

program displays data in cells that contain values above or below the average values of 

CLOSE the ExecutiveSearch workbook.
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the related cells, that contain values near the top or bottom of the value range, or that 

contain values duplicated elsewhere in the selected range.

When you select which kind of condition to create, Excel 2007 displays a dialog box that 

contains fi elds and controls you can use to defi ne your rule. To display all your rules, 

display the Home tab and then, in the Styles group, click Conditional Formatting. From 

the menu that appears, click Manage Rules to display the Conditional Formatting Rules 

Manager.

The Conditional Formatting Rules Manager, which is new in Excel 2007, enables you to 

control your conditional formats in the following ways:

  Creates a new rule by clicking the New Rule button

  Changes a rule by clicking the rule and then clicking the Edit Rule button

  Removes a rule by clicking the rule and then clicking the Delete Rule button

  Moves a rule up or down in the order by clicking the Move Up or Move Down 

button

  Controls whether Excel 2007 continues evaluating conditional formats after it fi nds 

a rule to apply by selecting or clearing a rule’s Stop If True check box

  Saves any new rules and closes the Conditional Formatting Rules Manager by 

 clicking OK

  Saves any new rules without closing the Conditional Formatting Rules Manager by 

clicking Apply

  Discards any unsaved changes by clicking Cancel

Note Clicking the New Rule button in the Conditional Formatting Rules Manager 

 displays the New Formatting Rule dialog box. The commands in the New Formatting Rule 

dialog box duplicate the options displayed when you click the Home tab’s Conditional 

Formatting button.
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After you create a rule, you can change the format applied if the rule is true by clicking 

the rule and then clicking the Edit Rule button to display the Edit Formatting Rule dialog 

box. In that dialog box, click the Format button to display the Format Cells dialog box. 

After you defi ne your format, click OK.

Important Excel 2007 doesn’t check to make sure that your conditions are logically 

 consistent, so you need to be sure that you enter your conditions correctly.

Excel 2007 also enables you to create three new types of conditional formats: data bars, 

color scales, and icon sets. Data bars summarize the relative magnitude of values in a cell 

range by extending a band of color across the cell.

Color scales compare the relative magnitude of values in a cell range by applying colors 

from a two- or three-color set to your cells. The intensity of a cell’s color refl ects the 

value’s tendency toward the top or bottom of the values in the range.
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Icon sets are collections of three, four, or fi ve images that Excel 2007 displays when 

 certain rules are met. 

When you click a color scale or icon set in the Conditional Formatting Rule Manager and 

then click the Edit Rule button, you can control when Excel 2007 applies a color or icon 

to your data.

Caution Be sure to not include cells that contain summary formulas in your conditionally 

formatted ranges. The values, which could be much higher or lower than your regular cell 

data, could throw off your formatting comparisons.

In this exercise, you create a series of conditional formats to change the appearance of 

data in worksheet cells displaying the package volume and delivery exception rates of a 

regional distribution center.

USE the Dashboard workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Appearance folder.

OPEN the Dashboard workbook.

1. Select cells C4:C12.

2. On the Home tab, in the Styles group, click Conditional Formatting. From the 

menu that appears, point to Color Scales, and then, in the top row of the palette 

that appears, click the second pattern from the left.

Excel 2007 formats the selected range.

USE thethe DashboardDashboard workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le isdd
located in thelocated in the My Documents\Microsoft Press\Excel SBS\AppearanceMy Documents\Microsoft Press\Excel SBS\Appearance folder.folder.

OPEN thethe DashboardDashboard workbook.workbook.dd
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Changing the Appearance of Data Based on Its Value
3. Select cells F4:F12.

4. On the Home tab, in the Styles group, click Conditional Formatting. From the 

menu that appears, point to Data Bars, and then click the light blue data bar 

format.

Excel 2007 formats the selected range.

5. Select cells I4:I12.

6. On the Home tab, in the Styles group, click Conditional Formatting. From the 

menu that appears, point to Icon Sets, and then, in the left-hand column of the list 

of formats that appears, click the three traffi c lights.

Excel 2007 formats the selected cells.
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7. With the range I4:I12 still selected, on the Home tab, in the Styles group, click 

Conditional Formatting, and then click Manage Rules.

The Conditional Formatting Rules Manager appears.

8. Click the icon set rule and then click Edit Rule.

The Edit Formatting Rule dialog box appears.
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Adding Images to a Document
9. Select the Reverse Icon Order check box.

Excel 2007 reconfi gures the rules so the red light icon is at the top and the green 

light icon is at the bottom.

10. In the red light icon’s row, click the Type fi eld down arrow and then click Percent.

11. In the red light icon’s Value fi eld, type 80.

12. In the yellow light icon’s row, click the Type fi eld down arrow and then click 

Percent.

13. In the yellow light icon Value fi eld, type 67.

14. Click OK twice to clear the Edit Formatting Rule dialog box and the Conditional 
Formatting Rules Manager.

Excel 2007 formats the selected cell range.

15. Click cell C15.

16. On the Home tab, in the Styles group, click Conditional Formatting. From the 

menu that appears, point to Highlight Cells Rules and then click Less Than.

The Less Than dialog box appears.

17. In the left fi eld, type 96%.

18. Click the With fi eld down arrow and then click Red text.

19. Click OK.

The Less Than dialog box disappears, and Excel 2007 displays the text in cell C15 

in red.
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CLOSE the Dashboard workbook.

Adding Images to a Document
Establishing a strong corporate identity helps customers remember your  organization 

and the products and services you offer. Setting aside the obvious need for sound 

management, two important physical attributes of a strong retail business are a well-

conceived shop space and an eye-catching, easy-to-remember logo. After you or 

your graphic artist has created a logo, you should add the logo to all your documents, 

 especially any that might be seen by your customers. Not only does the logo mark 

the documents as coming from your company but it also serves as an advertisement, 

 encouraging anyone who sees your worksheets to call or visit your company.

One way to add a picture to a worksheet is to display the Insert tab of the user inter-

face and then, in the Illustrations group, click Picture. Clicking Picture displays the Insert 

Picture dialog box, which enables you to locate the picture you want to add from your 

hard disk. When you insert a picture, the Picture Tools contextual tab appears with the 

CLOSE the Dashboard workbook.d
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Format contextual tab right below it. You can use the tools on the Format contextual tab 

to change the picture’s contrast, brightness, and so on. The controls in the Picture Styles 

group enable you to place a border around the picture, change the picture’s shape, or 

change a picture’s effects (such as shadow, refl ection, or rotation in three dimensions). 

Other tools, found in the Arrange and Size groups, enable you to rotate, reposition, and 

resize the picture. 

You can also resize a picture by clicking it and then dragging one of the handles that 

 appear on the graphic. If you accidentally resize a graphic by dragging a handle, just 

click the Undo button to remove your change. If you want to generate a repeating  image 

in the background of a worksheet, forming a tiled pattern behind your worksheet’s data, 

you can display the Page Layout tab of the user interface and then, in the Page Setup 

group, click Background. In the Sheet Background dialog box, click the image that you 

want to serve as the background pattern for your worksheet and click OK.

Tip To remove a background image from a worksheet, display the Page Layout tab of the 

user interface and then, in the Page Setup group, click Delete Background.
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In this exercise, you add an image to an existing worksheet, change the graphic’s 

 location on the worksheet, reduce the size of the graphic, change the image’s brightness 

and contrast, rotate and crop the image, delete the image, and then set the image as a 

repeating background for the worksheet.

USE the CallCenter workbook and the callcenter.jpg image fi le in the practice fi le folder 

for this topic. This practice fi le is located in the My Documents\Microsoft Press\Excel SBS\
Appearance folder.

OPEN the CallCenter workbook.

1. On the Insert tab, click Picture.

The Insert Picture dialog box appears.

2. Browse to the My Documents\Microsoft Press\Excel SBS\Appearance folder and 

then double-click callcenter.jpg.

The image appears on your worksheet.

3. Move the image to the upper-left corner of the worksheet, grab the handle at the 

lower-right corner of the image, and drag it up and to the left until it no longer 

 obscures the Call Volume label.

USE thethe CallCenterCallCenter workbook and the  workbook and the rr callcenter.jpgcallcenter.jpg image fi le in the practice fi le folder  image fi le in the practice fi le folder 

for this topic. This practice fi le is located in the for this topic. This practice fi le is located in the My Documents\Microsoft Press\Excel SBS\My Documents\Microsoft Press\Excel SBS\
AppearanceAppearance folder.folder.

OPEN thethe CallCenterCallCenter workbook. workbook.rr
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Adding Images to a Document
4. On the Page Layout tab, in the Page Setup group, click Background.

The Sheet Background dialog box appears.

5. Browse to the My Documents\Microsoft Press\Excel SBS\Appearance folder and 

then double-click acbluprt.jpg.

Excel 2007 repeats the image to form a background pattern.

6. On the Page Layout tab, in the Page Setup group, click Delete Background.

Excel 2007 removes the background image.

CLOSE the CallCenter workbook.

CLOSE Excel.

CLOSE the CallCenter workbook.r

CLOSE Excel.
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Key Points
  If you don’t like the default font in which Excel 2007 displays your data, you can 

change it.

  You can use cell formatting, including borders, alignment, and fi ll colors, to 

 emphasize certain cells in your worksheets. This emphasis is particularly useful for 

making column and row labels stand out from the data.

  Excel 2007 comes with a number of existing styles that enable you to change the 

appearance of individual cells. You can also create new styles to make formatting 

your workbooks easier.

  If you want to apply the formatting from one cell to another cell, use the Format 

Painter to copy the format quickly.

  There are quite a few built-in document themes and table formats you can apply 

to groups of cells. If you see one you like, use it and save yourself lots of formatting 

time.

  Conditional formats enable you to set rules so that Excel 2007 changes the 

 appearance of a cell’s contents based on its value.

  Adding images can make your worksheets more visually appealing and make your 

data easier to understand.
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66 Focusing on Specifi c Focusing on Specifi c
 Data Using Filters Data Using Filters

In this chapter, you will learn to:

  Limit the data that appears on your screen.

  Manipulate list data.

  Defi ne a valid set of values for a range of cells.

Microsoft® Offi ce Excel® 2007 enables you to manage huge data collections, but 

 storing more than 1,000,000 rows of data doesn’t help you make business decisions 

 unless you have the ability to zero in on the most important data in a worksheet 

 (whether that data represents the 10 busiest days in a month or low revenue that 

you might need to reevaluate). Offi ce Excel 2007 offers a number of powerful and 

fl exible tools with which you can limit the data displayed in your worksheet. After your 

worksheet displays the subset of the data you need to make a decision, you can perform 

calculations on that data. You can discover what percentage of monthly sales were made 

up by the 10 best days in the month, fi nd your total sales for particular days of the week, 

or locate the slowest business day of the month.

Just as you can limit the data displayed by your worksheets, you can limit the data 

 entered into them as well. Setting rules for data entered into cells enables you to catch 

many of the most common data entry errors, such as entering values that are too small 

or too large, or attempting to enter a word in a cell that requires a number. If you add a 

validation rule to worksheet cells after data has been entered into them, you can circle 

any invalid data so that you know what to correct.

In this chapter, you’ll learn how to limit the data that appears on your screen, manipulate 

list data, and create validation rules that limit data entry to appropriate values.
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See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Limiting Data That Appears on Your Screen
Excel 2007 spreadsheets can hold as much data as you need them to, but you might not 

want to work with all the data in a worksheet at the same time. For example, you might 

want to see the sales fi gures for your company during the fi rst third, second third, and 

fi nal third of a month. You can limit the data shown on a worksheet by creating a fi lter, 
which is a rule that selects rows to be shown in a worksheet.

To create a fi lter, you click the cell in the group you want to fi lter and then, on the Home 

tab, in the Editing group, click Sort & Filter and then click Filter. When you do, Excel 2007 

displays a fi lter arrow at the right edge of the top cell in each column of the selected 

range. The arrow indicates that the Excel 2007 AutoFilter capability is active. 

Important When you turn on fi ltering, Excel 2007 treats the cells in the active cell’s 

 column as a range. To ensure that the fi ltering works properly, you should always add a 

 label to the column you want to fi lter.

Clicking the down arrow displays a list of fi ltering options (greatly expanded over Excel 

2003) and a list of the unique values in the column. The fi rst few items in the list are sort-

ing options, followed by the Clear Filter item. The next option that appears on the list 

depends on the type of data in the column. For example, if the column contains a set of 

dates, the item will be Date Filters. Clicking the item displays a list of options specifi c to 

that data type.



   123Limiting Data That Appears on Your Screen
Note When a column contains several types of data, the fi lter option becomes Number 

Filters.

When you click a fi ltering option, Excel 2007 displays a dialog box that enables you to 

defi ne the fi lter’s criteria. As an example, you could create a fi lter that displays only dates 

after 3/31/2007.
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If you want to see the highest or lowest values in a data column, you can create a Top 10 

fi lter. Choosing the Top 10 option from the list doesn’t just limit the display to the top 10 

values. Instead, it opens the Top 10 AutoFilter dialog box. From within this dialog box, 

you can choose whether to show values from the top or bottom of the list, defi ne the 

number of items you want to see, and choose whether the number in the middle box 

indicates the number of items or the percentage of items to be shown when the fi lter is 

applied. Using the Top 10 AutoFilter dialog box, you can fi nd your top 10 salespeople or 

identify the top 5 percent of your customers.

When you choose Custom Filter from the AutoFilter list, you can defi ne a rule that Excel 

2007 uses to decide which rows to show after the fi lter is applied. For instance, you can 

create a rule that determines only days with package volumes of greater than 100,000 

should be shown in your worksheet. With those results in front of you, you might be able 

to determine whether the weather or another factor resulted in slower business on those 

days.

Excel 2007 indicates that a column has a fi lter applied by changing the column’s fi lter 

arrow to include an icon that looks like a funnel. After you fi nish examining your data 

by using a fi lter, you can remove the fi lter by clicking the column’s fi lter arrow and then 

clicking Clear Filter. To turn off fi ltering, display the Data tab of the user interface and 

then, in the Sort & Filter group, click Filter.

In this exercise, you will fi lter a data list using a series of AutoFilter items, create a fi lter 

showing the fi ve days with the highest delivery exception counts in a month, and create 

a custom fi lter.

USE the PackageExceptions workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Focusing folder. 

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the PackageExceptions workbook.

 1. On the ByRoute worksheet, click any cell in the cell range B2:F27.

 2. On the Home tab, in the Editing group, click Sort & Filter and then click Filter.

A fi lter arrow appears in each column’s header cell.

 3. Click the Date column fi lter arrow and then, from the list of options that appears, 

clear the March check box.

USE thethe PackageExceptionsPackageExceptions workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice 

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\FocusingMy Documents\Microsoft Press\Excel SBS\Focusing folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe PackageExceptionsPackageExceptions workbook. workbook.
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Limiting Data That Appears on Your Screen
4. Click OK.

Excel 2007 hides all rows that contain a date from the month of March.

5. Click the Center column fi lter arrow and then, from the list of options that appears, 

clear the Select All check box.

Excel 2007 clears all the check boxes in the list.

6. Select the Midwest check box and then click OK.

Excel 2007 displays only those exceptions that occurred in the Midwest distribution 

center during the month of April.

7. On the Home tab, in the Editing group, click Sort & Filter and then click Clear.

Excel 2007 clears all active fi lters but leaves the fi lter arrows in place.
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8. Click the MarchDailyCount sheet tab.

The MarchDailyCount worksheet appears.

9. Click any cell in the data table.

10. Click the Exceptions column fi lter arrow, point to Number Filters, and then click 

Top 10.

The Top 10 AutoFilter dialog box appears.

11. In the middle fi eld, type 5.

12. Click OK.

Excel 2007 displays the table rows that contain the fi ve highest values in the 

Exceptions column.

13. Click the Exceptions column fi lter arrow, and then click Clear Filter from 
“Exceptions”.

Excel 2007 removes the fi lter.

14. Click the Date column fi lter arrow, point to Date Filters, and then click Custom 
Filter.

The Custom AutoFilter dialog box appears.

15. Click the upper-left fi eld down arrow and then click is after or equal to.

16. Click the upper-right fi eld down arrow and then click 3/8/2007.

17. Click the lower-left fi eld down arrow and then click is before or equal to.

18. Click the upper-right fi eld down arrow and then click 3/14/2007.

19. Click OK.

Because you left the And option button selected, Excel 2007 displays all table rows 

that contain a date from 3/8/2007 to 3/14/2007, inclusive.
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 20. On the Quick Access Toolbar, click the Undo button to remove your fi lter.

Excel 2007 restores the table to its unfi ltered state.

CLOSE the PackageExceptions workbook.

Manipulating List Data
Related tasks you can do in Excel 2007 include choosing rows at random from a list and 

displaying the unique values in a column in the worksheet (not in the down arrow list, 

which you can’t normally work with). Generating a list of unique values in a column can 

give you important information, such as from which states you have customers or which 

categories of products sold in an hour.

Selecting rows randomly is useful for selecting customers to receive a special offer, 

 deciding which days of the month to audit, or picking prize winners at an employee 

 party. To choose rows, you can use the RAND function, which generates a random value 

between 0 and 1 and compares it with a test value included in the statement. A state-

ment that returns a TRUE value 30 percent of the time would be RAND()<=30%; that is, 

whenever the random value was between 0 and .3, the result would be TRUE. You could 

use this statement to select each row in a list with a probability of 30 percent. A for-

mula that displayed True when the value was equal to or less than 30 percent, and False
 otherwise, would be =IF(RAND()<=0.3,”True”,”False”).

Tip Because the RAND function is a volatile function (it recalculates its results every time 

you update the worksheet), you should copy the cells that contain the RAND function in a 

formula. Then, on the Home tab of the user interface, in the Clipboard group, click the Paste 

button down arrow and select Paste Values to replace the formula with its current result.

CLOSE the PackageExceptions workbook.
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Excel 2007 has a new function, RANDBETWEEN, which enables you to generate a 

 random value within a defi ned range. For example, the formula =RANDBETWEEN(1,100) 

would generate a random value from 1 to 100, inclusive.

The ability to focus on the data that’s most vital to your current needs is important, but 

there are a few limitations. One limitation is that any formulas you create using the SUM 

and AVERAGE functions don’t change their calculations if some of the rows used in the 

formula are hidden by the fi lter. 

Excel 2007 provides two ways to fi nd the total of a group of fi ltered cells. The fi rst meth-

od is to use AutoCalculate. To use AutoCalculate, you select the cells you want to fi nd the 

total for. When you do, Excel 2007 displays the average of values in the cells, the sum of 

the values in the cells, and the number of visible cells (count) in the selection. You’ll fi nd 

the display on the status bar at the lower edge of the Excel 2007 window.

When you use AutoCalculate, you aren’t limited to fi nding the sum of the selected cells. 

To display the other functions you can use, right-click the AutoCalculate pane and select 

the function you want from the shortcut menu that appears.

AutoCalculate is great for fi nding a quick total or average for fi ltered cells, but it doesn’t 

make the result available in the worksheet. Formulas such as =SUM(C3:C26) always 

consider every cell in the range, regardless of whether a cell’s row is hidden by a fi lter, 

so you need to create a formula using the SUBTOTAL function. The SUBTOTAL func-

tion, which enables you to summarize only the visible cells in a range, has this syntax: 

SUBTOTAL(function_num, ref1, ref2, ...). The function_num argument holds the number of 

the operation you want to use to summarize your data. The ref1, ref2, and further argu-

ments represent up to 29 ranges to include in the calculation. For example, the formula 

=SUBTOTAL(9, C3:C26, E3:E26, G3:G26) would fi nd the sum of all values in the ranges 

C3:C26, E3:E26, and G3:G26. 

Caution Be sure to place your SUBTOTAL formula on a row that is even with or above the 

headers in the range you’re fi ltering. If you don’t, your fi lter might hide the formula’s result!

The following table lists the summary operations available to you in a SUBTOTAL 

 formula. The function numbers in the fi rst column include all values in the summary; the 

function numbers in the second column summarize only those values that are visible 

within the worksheet.
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Number 
(includes 
hidden 
values)

Number 
(ignores 
hidden 
values)

Function Description

1 101 AVERAGE Returns the average of the values in the 

range

2 102 COUNT Counts the cells in the selected range that 

contain a number

3 103 COUNTA Counts the nonblank cells in the selected 

range

4 104 MAX Returns the largest (maximum) value in 

the selected range

5 105 MIN Returns the smallest (minimum) value in 

the selected range

6 106 PRODUCT Returns the result of multiplying all 

 numbers in the selected range

7 107 STDEV Calculates the standard deviation of  values 

in the selected range by examining a 

 sample of the values

8 108 STDEVP Calculates the standard deviation of the 

values in the range by using all the values

9 109 SUM Returns the result of adding all numbers in 

the range together

10 110 VAR Calculates the variance of values in the 

selected range by examining a sample of 

the values

11 111 VARP Calculates the variance of the values in the 

range by using all of the values

Note Excel 2007 displays the available summary operations as part of the Formula 

AutoComplete functionality, so you don’t need to remember the operation codes or look 

them up in the Help system.

If you want to fi nd a list of the unique values in a data list row, click any cell in the data 

list, display the Data tab of the user interface, and then in the Sort & Filter group, click 

Advanced to display the Advanced Filter dialog box. 
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In the List Range fi eld, type the reference of the cell range you want to examine for 

unique values, select the Unique records only check box, and then click OK to have Excel 

2007 display the fi rst occurrence of each value in the column. 

Important Excel 2007 treats the fi rst cell in the data range as a header cell, so it doesn’t 

consider the cell as it builds the list of unique values. Be sure to include the header cell in 

your data range!

In this exercise, you will select random rows from a list of exceptions to identify package 

delivery misadventures to investigate, create a SUBTOTAL formula to summarize the vis-

ible cells in a fi ltered data list, and fi nd the unique values in one column of a data list.

USE the ForFollowUp workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Focusing folder.

OPEN the ForFollowUp workbook.

1. Select cells G3:G27.

The average of the values in the selected cells, the number of cells selected, and 

the total of the values in the selected cells appear in the AutoCalculate section of 

the status bar.

2. In cell K2, enter the formula =SUBTOTAL(101,G3:G27).

The value $15.76 appears in cell K2.

3. On the Data tab, in the Sort & Filter group, click Advanced.

The Advanced AutoFilter dialog box appears.

4. In the List range fi eld, type E2:E27.

USE thethe ForFollowUpForFollowUp workbook in the practice fi le folder for this topic. This practice fi le is  workbook in the practice fi le folder for this topic. This practice fi le is 

located in thelocated in the My Documents\Microsoft Press\Excel SBS\FocusingMy Documents\Microsoft Press\Excel SBS\Focusing folder. folder.

OPEN thethe ForFollowUpForFollowUp workbook. workbook.
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Manipulating List Data
5. Select the Unique records only check box, and then click OK.

Excel 2007 displays the rows that contain the fi rst occurrence of each different 

value in the selected range.

Note Remember that you must include cell E2, the header cell, in the List range fi eld range 

so that the fi lter doesn’t display two occurrences of Northeast in the unique values list. To 

see what happens when you don’t include the header cell, try changing the range in the List 

range fi eld to E3:E27, selecting the Unique records only check box, and clicking OK.

6. On the Data tab, in the Sort & Filter group, click Clear.

Excel 2007 removes the fi lter.

7. In cell H3, type the formula =IF(RAND()<0.15,”Yes”,”No”) and press F.

A value of Yes or No appears in cell H3, depending on the RAND function result.

8. Select cell H3 and then drag the fi ll handle down until it covers cell H27.

Excel 2007 copies the formula into every cell in the range H3:H27.

9. With the range H3:H27 still selected, on the Home tab of the user interface, in the 

Clipboard group, click the Copy button.

Excel 2007 copies the cell range’s contents to the Clipboard.

10. Click the Paste button down arrow and then click Paste Values.

Excel 2007 replaces the cells’ formulas with the formulas’ current results. 
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CLOSE the ForFollowUp workbook.

Defi ning Valid Sets of Values for Ranges of Cells
Part of creating effi cient and easy-to-use worksheets is to do what you can to ensure 

that the data entered into your worksheets is as accurate as possible. Although it isn’t 

possible to catch every typographical or transcription error, you can set up a validation 
rule to make sure that the data entered into a cell meets certain standards.

To create a validation rule, open the Data Validation dialog box. You can use the Data 

Validation dialog box to defi ne the type of data that Excel 2007 should allow in the cell 

and then, depending on the data type you choose, to set the conditions data must meet 

to be accepted in the cell. In the following graphic, Excel 2007 knows to look for a whole 

number value between 1000 and 2000.

CLOSE the ForFollowUp workbook.
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Setting accurate validation rules can help you and your colleagues avoid entering a 

customer’s name in the cell designated to hold their phone number or setting a credit 

limit above a certain level. To require a user to enter a numeric value in a cell, display 

the Settings page of the Data Validation dialog box, click the Allow down arrow, and, 

depending on your needs, choose either Whole Number or Decimal from the list that 

appears.

If you want to set the same validation rule for a group of cells, you can do so by select-

ing the cells to which you want to apply the rule (such as a column in which you enter 

the credit limit of customers of Consolidated Messenger) and setting the rule using the 

Data Validation dialog box. One important fact you should keep in mind is that Excel 

2007 enables you to create validation rules for cells in which you have already entered 

data. Excel 2007 doesn’t tell you whether any cells have data that violate your rule, but 

you can fi nd out by having Excel 2007 circle any worksheet cells containing data that 

violates the cell’s validation rule. To do so, display the Data tab of the user interface and 

then, in the Data Tools group, click the Data Validation button down arrow. On the menu 

that appears, click the Circle Invalid Data button to circle cells with invalid data.
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When you’re ready to hide the circles, click the Data Validation button down arrow and 

click Clear Validation Circles. 

Of course, it’s frustrating if you want to enter data into a cell and, when a message box 

appears that tells you the data you tried to enter isn’t acceptable, you aren’t given the 

rules you need to follow. Excel 2007 enables you to create messages that tell the user 

which values are expected before the data is entered and then, if the conditions aren’t 

met, reiterate the conditions in a custom error message.

You can turn off data validation in a cell by displaying the Settings page of the Data 

Validation dialog box and clicking the Clear All button in the lower-left corner of the 

 dialog box.

In this exercise, you create a data validation rule limiting the credit line of Consolidated 

Messenger customers to $25,000, add an input message mentioning the limitation, and 

then create an error message if someone enters a value greater than $25,000. After you 

create your rule and messages, you test them.

USE the Credit workbook in the practice fi le folder for this topic. This practice fi le is located 

in the My Documents\Microsoft Press\Excel SBS\Focusing folder.

OPEN the Credit workbook.

USE thethe CreditCredit workbook in the practice fi le folder for this topic. This practice fi le is located workbook in the practice fi le folder for this topic. This practice fi le is located tt
in the in the My Documents\Microsoft Press\Excel SBS\FocusingMy Documents\Microsoft Press\Excel SBS\Focusing folder. folder.

OPEN thethe CreditCredit workbook.workbook.tt
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Defi ning Valid Sets of Values for Ranges of Cells
1. Select the cell range J4:J7.

2. On the Data tab of the user interface, in the Data Tools group, click Data 
Validation.

The Data Validation dialog box appears with the Settings tab page in front.

3. In the Allow box, click the down arrow and, from the list that appears, click Whole 
Number.

Boxes labeled Minimum and Maximum appear below the Data box.

4. In the Data box, click the down arrow and, from the list that appears, click less than 
or equal to.

The Minimum box disappears.

5. In the Maximum box, type 25000.

6. Clear the Ignore blank check box.

7. Click the Input Message tab.

The Input Message tab page appears.

8. In the Title box, type Enter Limit.
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9. In the Input Message box, type Please enter the customer’s credit limit, omitting 
the dollar sign.

10. Click the Error Alert tab page.

The Error Alert tab page appears.

11. In the Style box, click the down arrow and, from the list that appears, choose Stop.

The icon that appears on your message box changes to the Stop icon.

12. In the Title box, type Error and then click OK.

13. Click cell J7.

A ScreenTip with the title Enter Limit and the text Please enter the customer’s credit 
limit, omitting the dollar sign appears near cell J7.

14. Type 25001 and press F.

A stop box with the title Error and default text appears.

Tip Leaving the Error message box blank causes Excel 2007 to use its default message: The 
value you entered is not valid. A user has restricted values that can be entered into this cell.

15. Click Cancel.

The error box disappears.

Important Clicking Retry enables you to edit the bad value, whereas clicking Cancel 

 deletes the entry.
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 16. Click cell J7.

Cell J7 becomes the active cell, and the ScreenTip reappears.

 17. Type 25000, and press F.

Excel 2007 accepts your input.

 18. On the Data tab, in the Data Tools group, click the Data Validation button down 

arrow and then click Circle Invalid Data.

A red circle appears around the value in cell J4.

 19. On the Data tab, in the Data Tools group, click the Data Validation button down 

arrow and then click Clear Validation Circles.

The red circle around the value in cell K4 disappears.

CLOSE the Credit workbook.

CLOSE Excel 2007.

Key Points
  A number of fi lters are defi ned in Excel 2007 (you might fi nd the one you want 

 already in place).

  Filtering an Excel 2007 worksheet based on values in a single column is easy to do, 

but you can create a custom fi lter to limit your data based on the values in more 

than one column as well.

  Don’t forget that you can get a running total (or an average, or any one of several 

other summary operations) for the values in a group of cells. Just select the cells 

and look on the status bar: the result will be there.

  Use data-validation techniques to improve the accuracy of data entered into your 

worksheets and to identify data that doesn’t meet the guidelines you set.

CLOSE the Credit workbook.

CLOSE Excel 2007.
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77 Reordering and Reordering and
 Summarizing Data Summarizing Data

In this chapter, you will learn to:

  Sort a data list.

  Organize data into levels.

  Look up information in a data list.

Most of the time, when you enter data in a Microsoft® Offi ce Excel® 2007 worksheet, 

you will enter it in chronological order. For instance, you could enter hourly shipment 

data in a worksheet, starting with the fi rst hour of the day and ending with the last 

hour. The data would naturally be displayed in the order in which you entered it, but 

that might not always be the best order to answer your questions. For instance, you 

might want to sort your data so that the top row in your worksheet shows the day of the 

month with the highest package volume, with subsequent rows displaying the remaining 

days in decreasing order of package volumes handled. You can also sort based on the 

contents of more than one column. A good example is sorting package handling data by 

week, day, and then hour of the day.

After you have sorted your data into the desired order, Offi ce Excel 2007 enables you to 

fi nd partial totals, or subtotals, for groups of cells within a given range. Yes, you can cre-

ate formulas to fi nd the sum, average, or standard deviation of data in a cell range, but 

you can do the same thing much more quickly by having Excel 2007 calculate the total 

for cells with the same value in a column. If your worksheet holds sales data for a list of 

services, you can calculate subtotals for each product category.

When you calculate subtotals in a worksheet, Excel 2007 creates an outline that marks 

the cell ranges used in each subtotal. For example, if the fi rst 10 rows of a worksheet 

have overnight shipping data, and the second 10 rows have second-day shipping data, 

Excel 2007 divides the rows into two units. You can use the markers on the worksheet 

to hide or display the rows used to calculate a subtotal; in this case, you can hide all the 

rows that contain overnight shipping data, hide all the rows that contain second-day 

shipping data, hide both, or show both.
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Excel 2007 does have a capability you might expect to fi nd only in a database 

 program—the capability to have a user type a value in a cell and have Excel 2007 look in 

a named range to fi nd a corresponding value. For instance, you can have a two- column 

named range with one column displaying the International Standard Book Number 

(ISBN) of a book and the second column displaying the title of the same book. By using 

a VLOOKUP formula that references the named range, you can let colleagues using your 

workbook type an ISBN in a cell and have the name of the book with that ISBN appear in 

the cell with the formula.

In this chapter, you’ll learn how to sort your data using one or more criteria, calculate 

subtotals, organize your data into levels, and look up information in a data list.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Sorting Data Lists
Although Excel 2007 makes it easy to enter your business data and to manage it after 

you’ve saved it in a worksheet, your data will rarely answer every question you want to 

ask it. For example, you might want to discover which of your services generates the 

most profi ts, which service costs the most for you to provide, and so on. You can fi nd out 

that information by sorting your data.

When you sort data in a worksheet, you rearrange the worksheet rows based on the 

contents of cells in a particular column. Sorting a worksheet to fi nd your highest-revenue 

services might show the results displayed in the following graphic.

You can sort a group of rows in a worksheet in a number of ways, but the fi rst step is to 

identify the column that will provide the values by which the rows should be sorted. In 

the preceding graphic, you could fi nd the highest revenue totals by selecting the cells 
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in the Revenue column and displaying the Home tab of the user interface. Then, in the 

Editing group, click Sort & Filter and click Sort Descending. Clicking Sort Descending 

makes Excel 2007 put the row with the highest value in the Revenue column at the top 

of the worksheet and continue down to the lowest value.

If you want to sort the rows in the opposite order, from the lowest revenue to the 

 highest, select the cells in the Revenue column and then, from the Editing group 

Sort & Filter button list, click Sort Ascending.

The Sort Ascending and Sort Descending buttons enable you to sort rows in a worksheet 

quickly, but you can use them only to sort the worksheet based on the contents of one 

column, even though you might want to sort by two columns. For example, you might 

want to order the worksheet rows by service category and then by total so that you can 

see the customers that use each service category most frequently. You can sort rows in 

a worksheet by the contents of more than one column through the Sort dialog box, in 

which you can pick any number of columns to use as sort criteria and choose whether to 

sort the rows in ascending or descending order.

To display the Sort dialog box, display the Home tab and then, in the Editing group, click 

Sort & Filter and then click Custom Sort.

If your data list has a header row, select the My data has headers check box so the 

 column headers will appear when you click the Column down arrow next to the Sort by 

fi eld. After you set the column by which you want to sort, clicking the Sort On fi eld down 

arrow enables you to select whether you want to sort by a cell’s value (the default), a 

cell’s fi ll color, a cell’s font color, or an icon displayed in the cell.

See Also For more information on creating conditional formats that change a cell’s formatting or 
display icon sets to refl ect the cell’s value, refer to “Changing the Appearance of Data Based on Its 
Value” in Chapter 5.
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Finally, you can click the Order fi eld down arrow to select how you want Excel 2007 to 

sort the column values. The exact list changes to refl ect the data in your column. If your 

column contains numerical values, you’ll see the options Largest to Smallest, Smallest 

to Largest, and Custom List. If your column contains text values, the options will be A 

to Z (ascending order), Z to A (descending order), and Custom List. And if your column 

 contains dates, you’ll see Newest to Oldest, Oldest to Newest, and Custom List.

Adding, moving, copying, and deleting sorting levels are a matter of clicking the 

 appropriate button in the Sort dialog box. To manage a data range’s sorting levels, click 

the Add Level button. 

Note In previous versions of Excel, you could create a maximum of three sorting levels. 

You may create up to 64 sorting levels in Excel 2007.

The Sort dialog box appears with fi elds to create one sorting level. To create a new level, 

click Add Level. To delete a level, click the level in the list and then click Delete Level. 

Clicking Copy Level enables you to put all the settings from one rule into another, saving 

you some work if you need to change only one item. The Move Up and Move Down 

buttons, which display an upward-pointing arrow and a downward-pointing arrow, 

respectively, enable you to change a sorting level’s position in the order. Finally, clicking 

the Options button displays the Sort Options dialog box, which you can use to make a 

sorting level case sensitive.

The default setting for Excel 2007 is to sort numbers according to their values and to 

sort words in alphabetical order, but that pattern doesn’t work for some sets of values. 

One example in which sorting a list of values in alphabetical order would yield incor-

rect results is with the months of the year. In an “alphabetical” calendar, April is the fi rst 

month, and September is the last! Fortunately, Excel 2007 recognizes a number of spe-

cial lists, such as days of the week and months of the year. You can have Excel 2007 sort 

the contents of a worksheet based on values in a known list; if needed, you can create 

your own list of values. For example, the default lists of weekdays in Excel 2007 start with 

Sunday. If you keep your business records based on a Monday–Sunday week, you can 

create a new list with Monday as the fi rst day and Sunday as the last. 

To create a new list, type the list of values you want to use as your list into a contiguous 

cell range, select the cells, click the Microsoft Offi ce Button, and then click Excel Options. 

On the Popular page of the dialog box, click the Edit Custom Lists button to display the 

Custom Lists dialog box.
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Sorting Data Lists
The selected cell range’s reference appears in the Import list from cells fi eld. To record 

your list, click the Import button. 

Note Another benefi t of creating a custom list is that dragging the fi ll handle of a list cell 

that contains a value causes Excel 2007 to extend the series for you. For example, if you 

 create the list Spring, Summer, Fall, Winter, type Summer in a cell, and then drag the cell’s 

fi ll handle; Excel 2007 extends the series as Fall, Winter, Spring, Summer, Fall, and so on.

To use a custom list as a sorting criterion, display the Sort dialog box, click the rule’s 

Order fi eld down arrow, click Custom List, and select your list from the dialog box that 

appears.

Important In previous versions of Excel, your custom list had to be the primary sorting 

criterion. In Excel 2007, you can use your custom list as any criterion.

In this exercise, you will sort a data list, sort a list by multiple criteria, change the order in 

which sorting criteria are applied, sort data by using a custom list, and sort data by color.

USE the ShippingSummary workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Sorting folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the ShippingSummary workbook.

1. Click cell C3.

2. On the Home tab, in the Editing group, click Sort & Filter and then click Sort A to Z.

Excel 2007 sorts the data by season.

USE thethe ShippingSummaryShippingSummary workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practiceyy
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\SortingMy Documents\Microsoft Press\Excel SBS\Sorting folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe ShippingSummaryShippingSummary workbook.workbook.yy
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3. On the Home tab, in the Editing group, click Sort & Filter and then click 

Custom Sort.

The Sort dialog box appears.

4. Select the My data has headers check box.

5. Click the Column fi eld down arrow and then click Customer. If necessary, click th

Sort On fi eld down arrow and click Values; then click the Order fi eld down arrow

and click A to Z.

6. Click Add Level.

A new Then by sorting level appears.

7. Click the new Column fi eld down arrow and then click Revenue.

8. Click the new Order fi eld down arrow and then click Largest to Smallest.

9. Click OK.

Excel 2007 closes the Sort dialog box and sorts the data list.

10. On the Home tab, in the Editing group, click Sort & Filter and then click 

Custom Sort.

The Sort dialog box appears.



   145

 

 

 

 

 

 

 

Sorting Data Lists
11. Click Then by.

Excel 2007 highlights the second sorting rule.

12. Click the Move Up button.

Excel 2007 moves the second sorting rule above the fi rst.

13. Click OK.

Excel 2007 closes the Sort dialog box and sorts the data list.

14. Select cells G4:G7, click the Microsoft Offi ce Button and then click Excel Options.

The Excel Options dialog box appears.

15. On the Popular tab, click Edit Custom Lists.

The Custom Lists dialog box appears.

16. Verify that the cell range $G$4:$G$7 appears in the Import list from cells fi eld and 

then click Import.

The new list appears in the Custom lists pane.

17. Click OK twice to close the Custom Lists dialog box and the Excel Options 
dialog box.
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18. Click cell C3.

19. On the Home tab, in the Editing group, click Sort & Filter and then click 

Custom Sort.

The Sort dialog box appears.

20. Click the rule in the Sort by row and then click Delete Level.

The sorting rule disappears.

21. In the Sort by row, click the Column fi eld down arrow and then click Season.

22. In the same row, click the Order fi eld down arrow and then click Custom List.

The Custom Lists dialog box appears.

23. In the Custom lists pane, click the sequence Spring, Summer, Fall, Winter.

24. Click OK twice to close the Custom Lists dialog box and the Sort dialog box.

Excel 2007 sorts the data list.

25. Click cell C3 and then, on the Home tab, in the Editing group, click Sort & Filter 
and then click Custom Sort.

The Sort dialog box appears.

26. In the Sort by row, click the Sort by fi eld down arrow and then click Revenue.

27. Click the Sort on fi eld down arrow and then click Cell Color.

28. Click the fi nal fi eld in the Sort by row and then click On Bottom to have Excel 2007 

put the Revenue cells that have no cell color on the bottom.
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 29. Click OK.

Excel 2007 sorts the data list.

CLOSE the ShippingSummary workbook.

Organizing Data into Levels
After you have sorted the rows in an Excel 2007 worksheet or entered the data so that 

it doesn’t need to be sorted, you can have Excel 2007 calculate subtotals or totals for a 

portion of the data. In a worksheet with sales data for three different product categories, 

for example, you can sort the products by category, select all the cells that contain data, 

and then open the Subtotal dialog box. To open the Subtotal dialog box, display the 

Data tab and then, in the Outline group, click Subtotal.

In the Subtotal dialog box, you can choose the column on which to base your subtotals 

(such as every change of value in the Week column), the summary calculation you want 

to perform, and the column or columns with values to be summarized. In the work-

sheet in the preceding graphic, for example, you could also calculate subtotals for the 

 number of units sold in each category. After you defi ne your subtotals, they appear in 

your worksheet.

CLOSE the ShippingSummary workbook.y
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As the graphic shows, when you add subtotals to a worksheet, Excel 2007 also defi nes 

groups based on the rows used to calculate a subtotal. The groupings form an outline 

of your worksheet based on the criteria you used to create the subtotals. In the preced-

ing example, all the rows representing months in the year 2006 are in one group, rows 

representing months in 2007 are in another, and so on. The outline section at the left 

of your worksheet holds controls you can use to hide or display groups of rows in your 

worksheet.

There are three types of controls in the outline section: Hide Detail buttons, Show Detail 

buttons, and level buttons.
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The Hide Detail button beside a group can be clicked to hide the rows in that group. 

In the previous graphic, clicking the Hide Detail button next to row 27 would hide rows 

15 through 26 but leave the row holding the subtotal for that group, row 27, visible.

When you hide a group of rows, the button next to the group changes to a Show Detail 

button. Clicking a group’s Show Detail button restores the rows in the group to the 

worksheet.

The level buttons comprise the other set of buttons in the outline section of a worksheet 

with subtotals. Each button represents a level of organization in a worksheet; clicking a 

level button hides all levels of detail below that of the button you clicked. The following 

table identifi es the three levels of organization shown in the preceding graphic.

Level Description

1 Grand total

2 Subtotals for each group

3 Individual rows in the worksheet

Clicking the Level 2 button in the worksheet shown in the preceding illustration would 

hide the rows with data on each month’s revenue but would leave the row that contains 

the grand total (Level 1) and all rows that contain the subtotal for each year (Level 2) 

 visible in the worksheet.

If you like, you can add levels of detail to the outline that Excel 2007 creates. For 

 instance, you might want to be able to hide revenues from January and February, 

which you know are traditionally strong months. To create a new outline group within an 

existing group, select the rows you want to group; on the Data tab, in the Outline group, 

point to Group and Outline, and then click Group. 
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You can remove a group by selecting the rows in the group and clicking Ungroup from 

the Data tab Outline group.

Tip If you want to remove all subtotals from a worksheet, open the Subtotal dialog box 

and click the Remove All button.

In this exercise, you will add subtotals to a worksheet and then use the outline that 

 appears to show and hide different groups of data in your worksheet.

USE the GroupByQuarter workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Sorting folder.

OPEN the GroupByQuarter workbook.

1. Click any cell in the data list.

2. On the Data tab, in the Outline group, click Subtotal.

The Subtotal dialog box appears with the default options to add a subtotal at 

 every change in the Year column, to return the sum of the values in the subtotaled 

rows, and to add a row with the subtotal of values in the Package Volume column 

below the fi nal selected row.

USE thethe GroupByQuarterGroupByQuarter workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice rr
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\SortingMy Documents\Microsoft Press\Excel SBS\Sorting folder.folder.

OPEN thethe GroupByQuarterGroupByQuarter workbook.workbook.rr



   151

 

 

 

 

Organizing Data into Levels
3. Click OK.

The Subtotal dialog box disappears. New rows appear with subtotals for package 

volume during each year represented in the worksheet. The new rows are num-

bered 14 and 27. A row with the grand total of all rows also appears; that row is 

row 28. A new section with outline bars and group-level indicators appears to the 

left of column A.

4. Click the row head button of row 5 and drag to the row head button of row 7.

Rows 5 through 7 are highlighted.

5. On the Data tab, in the Outline group, click Group.

Rows 5 through 7 are made into a new group. An outline bar appears on a new 

level in the outline section, and a corresponding Level 4 button appears at the top 

of the outline section.

6. In the outline section, click the Hide Detail button next to row 8.

Rows 5 through 7 are hidden, and the Hide Detail button you clicked changes to a 

Show Detail button.
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7. In the outline section, click the Show Detail button next to row 8.

Rows 5 through 7 reappear.

8. In the outline section, click the Level 1 button.

All rows except row 1 with the column headings and row 28 with the grand total 

are hidden.

9. In the outline section, click the Level 2 button.

The rows with the subtotal for each week appear.

10. In the outline section, click the Level 3 button.

All rows except rows 5 through 7 appear.

11. In the outline section, click the Level 4 button.

Rows 5 through 7 reappear.

CLOSE the GroupByQuarter workbook.CLOSE the GroupByQuarter workbook.r
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Looking Up Information in a Data List
Whenever you create a worksheet that holds information about a list of distinct items, 

such as products offered for sale by a company, you should ensure that at least one 

 column in the list contains a unique value that distinguishes that row (and the item the 

row represents) from every other row in the list. Assigning each row a column with a 

unique value means that you can associate data in one worksheet with data in another 

worksheet. For example, if every customer is assigned a unique identifi cation number, 

you can store a customer’s contact information in one worksheet and all orders for that 

customer in another worksheet. You can then associate the customer’s orders and con-

tact information without writing the contact information in a worksheet every time the 

customer places an order.

In the case of shipments handled by Consolidated Messenger, the column that contains 

those unique values, or the primary key column, is the ShipmentID column.

If you know a shipment’s ShipmentID, it’s no trouble to look through a list of 20 or 30 

items to fi nd a particular shipment. If, however, you have a list of many thousands of 

shipments, looking through the list to fi nd one would take quite a bit of time. Instead, 

you can use the VLOOKUP function to let your colleagues type a ShipmentID in a cell 

and have the corresponding details appear in another cell.
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The VLOOKUP function fi nds a value in the leftmost column of a named range, such as 

a table, and then returns the value from the specifi ed cell to the right of the cell with 

the found value. A properly formed VLOOKUP function has four arguments (data that is 

passed to the function), as shown in the following defi nition: =VLOOKUP(lookup_value, 
table_array, col_index_num, range_lookup). 

The following table summarizes the values Excel 2007 expects for each of these 

arguments.

Argument Expected Value

lookup_value The value to be found in the fi rst column of the named range  specifi ed 

by the table_array argument. The lookup_value argument can be a 

value, a cell reference, or a text string.

table_array The multicolumn range or name of the range or data table to be 

searched.

col_index_num The number of the column in the named range with the value to be 

returned.

range_lookup A TRUE or FALSE value, indicating whether the function should fi nd 

an approximate match (TRUE) or an exact match (FALSE) for the 

lookup_value. If left blank, the default value for this argument is TRUE.

Important When range_lookup is left blank or set to TRUE, for VLOOKUP to work 

 properly the rows in the named range specifi ed in the table_array argument must be sorted 

in ascending order based on the values in the leftmost column of the named range.

The VLOOKUP function works a bit differently depending on whether the range_lookup 

argument is set to TRUE or FALSE. The following list summarizes how the function works 

based on the value of range_lookup:

  If the range_lookup argument is left blank or set to TRUE, and VLOOKUP doesn’t 

fi nd an exact match for lookup_value, the function returns the largest value that is 

less than lookup_value.

  If the range_lookup argument is left blank or set to TRUE, and lookup_value is 

smaller than the smallest value in the named range, an #N/A error is returned.

  If the range_lookup argument is left blank or set to TRUE, and lookup_value is 

larger than all values in the named range, the largest value in the named range is 

returned.

  If the range_lookup argument is set to FALSE, and VLOOKUP doesn’t fi nd an exact 

match for lookup_value, the function returns an #N/A error.
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As an example of a VLOOKUP function, consider the following worksheet and the 

 accompanying VLOOKUP formula.

Tip The related HLOOKUP function matches a value in a column of the fi rst row of a table 

and returns the value in the specifi ed row number of the same column. For more informa-

tion on using the HLOOKUP function, click the Excel 2007 Help button, type HLOOKUP in 

the search terms box, and then click Search.

When you type CI02 in cell E3 and press F, the VLOOKUP function searches the fi rst 

column of the table, fi nds an exact match, and returns the value Northwind Traders to 

cell C3.

Caution Be sure to give the cell in which you type the VLOOKUP formula the same format 

as the data you want the formula to display. For example, if you create a VLOOKUP formula 

in cell G14 that fi nds a date, you must apply a date cell format to cell G14 for the formula’s 

result to display properly.

In this exercise, you create a VLOOKUP function to return the destination postal code of 

deliveries with ShipmentIDs typed in a specifi c cell.
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USE the ShipmentLog workbook in the practice file folder for this topic. This practice 

file is located in the My Documents\Microsoft Press\Excel SBS\Database folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the ShipmentLog workbook.

1. In cell C3, type the formula =VLOOKUP(B3,Shipments,5,FALSE).

Cell B3, which the formula uses to look up values in the Shipments table, is blank, 

so the #N/A error code appears in cell C3.

2. In cell B3, type SI3049224, and press F.

The value 51102 appears in cell C3.

3. In cell C3, edit the formula so that it reads =VLOOKUP(B3,Shipments,2,FALSE).

The formula now fi nds its target value in table column 2 (the CustomerID column), 

so the value CI512191 appears in cell C3.

4. In cell C3, edit the formula so that it reads =VLOOKUP(B3,Shipments,4,TRUE). 

Changing the last argument to TRUE enables the VLOOKUP formula to fi nd an ap-

proximate match for the ShipmentID in cell B3, whereas changing the column to 4 

means the formula gets its result from the OriginationPostalCode column. The value 

14020 appears in cell C3.

USE thethe ShipmentLogShipmentLog workbook in the practice file folder for this topic. This practice  workbook in the practice file folder for this topic. This practice 

file is located in thefile is located in the My Documents\Microsoft Press\Excel SBS\DatabaseMy Documents\Microsoft Press\Excel SBS\Database folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe ShipmentLogShipmentLog workbook. workbook.
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 5. In cell B3, type SI3049209.

The value in cell B3 is smaller than the smallest value in the Shipments table’s fi rst 

column, so the VLOOKUP formula displays the #N/A error code in cell C3.

 6. In cell B3, type SI3049245.

The ShipmentID typed into cell B3 is greater than the last value in the table’s fi rst 

column, so the VLOOKUP formula displays the last value in the target column (in 

this case, the fourth column). Therefore, the value 44493 appears in cell C3.

CLOSE the ShipmentLog workbook.

CLOSE Excel 2007

Key Points
  You can rearrange the data in a worksheet quickly by clicking either the Sort 

Ascending or Sort Descending toolbar button.

  Don’t forget that you can sort the rows in a worksheet by using orders other than 

alphabetical or numerical. For example, you can sort a series of days based on their 

order in the week or by cell color.

  If none of the existing custom sort orders (days, weekdays, and so on) meets your 

needs, you can create your own custom sort order.

  You can divide the data in your worksheet into levels and fi nd a subtotal for each 

level.

  Creating subtotals enables you to show or hide groups of data in your worksheets.

  Use the VLOOKUP function to look up a value in one column of a data list and 

 return a value from another column in the same row.

CLOSE the ShipmentLog workbook.

CLOSE Excel 2007
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In this chapter, you will learn to:

  Use an existing data list as a template for other lists.

  Link to data in other workbooks.

  Summarize multiple sets of data.

  Group multiple data lists.

Microsoft® Offi ce Excel® 2007 gives you a wide range of tools with which to format, 

summarize, and present your data. After you have created a workbook to hold data 

about a particular subject, you can create as many worksheets as you need to make 

that data easier to fi nd within the workbook. For instance, you can create a workbook 

to store sales data for a year, with each worksheet representing a month in that year. 

To ensure that the workbook for every year has a similar appearance, you can create a 

workbook with the desired characteristics (such as more than the standard number of 

worksheets, custom worksheet formatting, or a particular color for the workbook’s sheet 

tabs) and save it as a pattern for similar workbooks you create in the future. The benefi t 

of ensuring that all your sales data worksheets have the same layout is that you and your 

colleagues immediately know where to look for specifi c totals. Also, when you create a 

summary worksheet, you know in advance which cells to include in your calculations.

If you work with the same workbooks repeatedly, you can group those workbooks in a 

special fi le, called a workspace. When you open the workspace, Offi ce Excel 2007 knows 

to open the fi les you included in that workspace.

A consequence of organizing your data into different workbooks and worksheets is that 

you need ways to manage, combine, and summarize data from more than one Excel 

2007 document. You can always copy data from one worksheet to another, but if the 

original value were to change, that change would not be refl ected in the cell range to 
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which you copied the data. Rather than remember which cells you need to update when 

a value changes, you can create a link to the original cell. That way, Excel 2007 will up-

date the value for you whenever you open the workbook. If multiple worksheets hold 

related values, you can use links to summarize those values in a single worksheet.

In this chapter, you’ll learn how to use a data list as a template for other lists, work with 

more than one set of data, link to data in other workbooks, summarize multiple sets of 

data, and group multiple data lists.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Using Data Lists as Templates for Other Lists
After you decide on the type of data you want to store in a workbook and what that 

workbook should look like, you probably want to be able to create similar workbooks 

without adding all the formatting and formulas again. For example, you might have 

settled on a design for your monthly sales tracking workbook.

When you have settled on a design for your workbooks, you can save one of the work-

books as a template, or pattern, for similar workbooks you create in the future. You 

can leave any labels to aid data entry, but you should remove any existing data from a 

workbook that you save as a template, both to avoid data entry errors and to remove 

any confusion as to whether the workbook is a template. You can also remove any work-

sheets you and your colleagues won’t need by right-clicking the tab of an unneeded 

worksheet and, from the shortcut menu that appears, clicking Delete.

If you want your template workbook to have more than the standard number of work-

sheets (such as 12 worksheets to track shipments for a year, by month), you can add 

worksheets by clicking the Insert Worksheet button on the tab bar at the bottom-left 

corner of the Excel 2007 window.

To create a template from an existing workbook, save the model workbook under the 

Offi ce Excel Template fi le type (a fi le with an .xltx extension), which you can choose 

from the Save as type drop-down list in the Save As dialog box. If you ever want to 

change the template, you can open it like a standard workbook (that is, an Excel 2007 
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fi le with the .xlsx extension) and make your changes. When you have completed your 

work,  resave the fi le normally—it will still be a template.

See Also You can also save your Excel 2007 workbook either as an Excel 97–2003 template (.xlt) 
or as a macro-enabled Excel 2007 workbook template (.xltm). For more information on using 
macros in Excel 2007 workbooks, see “Introducing Macros” in Chapter 13.

After you save a workbook as a template, you can use it as a model for new workbooks. 

To create a workbook from a template in Excel 2007, click the Microsoft Offi ce Button 

and then click New to display the New Workbook dialog box.

The leftmost pane of the New Workbook dialog box displays featured templates, 

which appear by default when you open the New Workbook dialog box, templates 

that are installed on your computer, and a list of template categories available through 

the Microsoft Offi ce Online Web site. The middle pane of the dialog box displays the 

Recently Used Templates section, which contains a list of any previously used templates. 

Tip You can also fi nd templates and other tools related to your job functions at 

the  Microsoft Work Essentials Web site, which you can fi nd online by visiting 

http://offi ce. microsoft.com and clicking Work Essentials in the left pane.

From the Templates dialog box, you can double-click the template you want to use as 

the model for your workbook. Excel 2007 creates a new workbook with the template’s 

formatting and contents in place.
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Tip The default fi le type for fi les created with a template is workbook (.xlsx), not 

template (.xltx).

In addition to creating a workbook template, it’s possible to create a template you can 

add as a worksheet within an existing workbook. To create a worksheet template, design 

the worksheet you want to use as a template, delete all the other worksheets in that 

workbook, and save the single-sheet workbook as a template. You can then add a work-

sheet based on that template to your workbook by right-clicking a sheet tab and then 

clicking Insert to display the Insert dialog box.

The Insert dialog box splits its contents into two panes. The General pane contains 

buttons you can click to insert a blank worksheet (the equivalent of clicking the Insert 

Worksheet button on the tab bar), a chart sheet, and any worksheet templates you cre-

ated. The Spreadsheet Solutions tab contains a set of useful templates for a variety of 

fi nancial and personal tasks. 
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To add a spreadsheet from the Insert dialog box to your workbook, click the desired 

template and then click OK.

Note The other two options on the General tab, MS Excel 4.0 Macro and MS Excel 5.0 

Dialog are there to help users integrate older (much older) Offi ce Excel spreadsheet 

 solutions into Excel 2007. You’ll know if you need to use them; odds are, you won’t.

In this exercise, you’ll create a workbook from an existing template, save a template 

to track hourly call volumes to each regional center, save another version of the fi le 

as a worksheet template, and insert a worksheet based on that template into a new 

workbook.

USE the Daily Call Summary workbook from the My Documents\Microsoft Press\Excel SBS
\MultipleFiles folder.

BE SURE TO start Excel 2007 before starting this exercise.

OPEN the Daily Call Summary workbook.

 1. Click the Microsoft Offi ce Button and then click Save As.

The Save As dialog box appears.

 2. Click the Save as type fi eld down arrow and then click Excel Template.

Excel 2007 displays the 2007 Microsoft Offi ce system default template folder.

 3. Click Save.

Excel 2007 saves the workbook as a template and closes the Save As dialog box.

USE thethe Daily Call SummaryDaily Call Summary workbook from the workbook from theyy My Documents\Microsoft Press\Excel SBSMy Documents\Microsoft Press\Excel SBS
\MultipleFiles\MultipleFiles folder.folder.

BE SURE TO start Excel 2007 before starting this exercise.start Excel 2007 before starting this exercise.

OPEN thethe Daily Call SummaryDaily Call Summary workbook.workbook.yy
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4. Click the Microsoft Offi ce Button and then click Close.

Excel 2007 closes the Daily Call Summary workbook.

5. Click the Microsoft Offi ce Button and then click New.

The New Workbook dialog box appears.

6. In the Template Categories list, click Installed Templates.

The Installed Templates list appears.

7. Click Project To Do List and then click Create.

Excel 2007 creates a workbook based on the selected template.

8. On the Quick Access Toolbar, click the Save button.

The Save dialog box appears.

9. In the File name fi eld, type ToDoList, use the dialog box controls to browse to the 

My Documents\Microsoft Press\Excel SBS\MultipleFiles folder, and then click Save.

Excel 2007 saves your workbook.

10. Click the Microsoft Offi ce Button and then, in the Recent Files list, click the Daily 
Call Summary.xlsx fi le.

The Daily Call Summary fi le appears.
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11. Right-click the Sheet2 sheet tab and then click Delete.

Excel 2007 deletes the worksheet, leaving one worksheet in the workbook.

12. Click the Microsoft Offi ce Button and then click Save As.

The Save As dialog box appears.

13. In the File name fi eld, type Daily Call Worksheet.

14. If necessary, click the Save as type fi eld down arrow and then click Excel Template.

15. Click Save.

Excel 2007 saves your template.

16. Click the Microsoft Offi ce Button and then click Close.

Excel 2007 closes the workbook.

17. Click the Microsoft Offi ce Button and then click New.

The New Workbook dialog box appears.

18. Click Blank Workbook and then click Create.

A blank workbook appears.

19. Right-click any sheet tab and then click Insert.

The Insert dialog box appears.
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 20. On the General tab, click Daily Call Worksheet and then click OK.

Excel 2007 creates a new worksheet based on the template.

 21. On the Quick Access Toolbar, click the Save button.

The Save As dialog box appears.

 22. In the File name fi eld, type Current Call Summary, use the dialog box controls to 

browse to the My Documents\Microsoft Press\Excel SBS\MultipleFiles folder, and 

then click Save.

Excel 2007 saves your workbook.

CLOSE the Current Call Summary workbook.

Linking to Data in Other Worksheets 
and Workbooks

Cutting and pasting data from one workbook to another is a quick and easy way to 

gather related data in one place, but there is a substantial limitation: if the data from the 

original cell changes, the change is not refl ected in the cell to which the data was copied. 

In other words, cutting and pasting a cell’s contents doesn’t create a relationship be-

tween the original cell and the target cell.

You can ensure that the data in the target cell refl ects any changes in the original cell 

by creating a link between the two cells. Instead of entering a value into the target cell 

by typing or pasting, you create a type of formula that identifi es the source from which 

Excel 2007 will derive the target cell’s value.

CLOSE the Current Call Summary workbook.y
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To create a link between cells, open both the workbook with the cell from which you 

want to pull the value and the workbook with the target cell. Then click the target cell 

and type an equal sign, signifying that you want to create a formula. After you type the 

equal sign, activate the workbook with the cell from which you want to derive the value 

and then click that cell.

When you switch back to the workbook with the target cell, you see that Excel 2007 has 

fi lled in the formula with a reference to the cell you clicked.

The reference from the example =’[Fleet Operating Costs.xlsx]Truck Fuel’!$C$15 gives 

three pieces of information: the workbook, the worksheet, and the cell you clicked in the 

worksheet. The fi rst element of the reference, the name of the workbook, is enclosed 

in square brackets; the end of the second element is marked with an exclamation point; 

and the third element, the cell reference, has a dollar sign before both the row and the 

column identifi er. This type of reference is known as a 3-D reference, refl ecting the 

three dimensions (workbook, worksheet, and cell) that you need to point to a cell in an-

other workbook.

Note For references to cells in the same workbook, the workbook information is omitted. 

Likewise, references to cells in the same worksheet don’t use a worksheet identifi er.



168  Chapter 8 Combining Data from Multiple Sources

 

 

You can also link to cells in an Excel 2007 data table. Such links include the work-

book name, worksheet name, name of the table, and row and column references of 

the cell to which you’ve linked. Creating a link to the Cost column’s cell in a table’s 

Totals row, for example, results in a reference such as =’FleetOperatingCosts.xlsx’!Truck 
Maintenance[[#Totals],[Cost]]. 

Caution Hiding or displaying a table’s Totals row affects a link to a cell in that row. Hiding 

a table Totals row causes any references to that row to display a #REF! error message.

Whenever you open a workbook with a link to another document, Excel 2007 tries to 

update the information in linked cells. If the program can’t fi nd the source, such as when 

a workbook or worksheet is deleted or renamed, an alert box appears to indicate that 

there is a broken link. At that point, you can click the Update button and then the Edit 

Links button to open the Edit Links dialog box and fi nd which link is broken. After you 

identify the broken link, you can close the Edit Links dialog box, click the cell containing 

the broken link, and create a new link to the desired data.

If you type a link yourself and you make an error, a #REF! error message appears in the 

cell with the link. To fi x the link, click the cell, delete its contents, and then either retype 

the link or create it with the point-and-click method described earlier in this section.

Note Excel 2007 is much better at tracking workbook changes, such as new worksheet 

names, than earlier versions of the program. Unless you delete a worksheet or workbook, 

or move a workbook to a new folder, odds are good that Excel 2007 can update your link 

references to refl ect the change.

In this exercise, you’ll create a link to another workbook, make the link’s reference inval-

id, use the Edit Links dialog box to break the link, and then re-create the link correctly.

USE the Operating Expense Dashboard and Fleet Operating Costs workbooks from the My 
Documents\Microsoft Press\Excel SBS\MultipleFiles folder.

OPEN the Operating Expense Dashboard and Fleet Operating Costs workbooks.

1. In the Operating Expense Dashboard workbook, in cell I6, type =, but do not 

press F.

2. On the View tab, in the Window group, click Switch Windows and then click Fleet 
Operating Costs.

The Fleet Operating Costs workbook appears.

USE thethe Operating Expense DashboardOperating Expense Dashboard andanddd Fleet Operating CostsFleet Operating Costs workbooks from the workbooks from the My My 
Documents\Microsoft Press\Excel SBS\MultipleFilesDocuments\Microsoft Press\Excel SBS\MultipleFiles folder.folder.

OPEN thethe Operating Expense DashboardOperating Expense Dashboard andanddd Fleet Operating CostsFleet Operating Costs workbooks.workbooks.
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3. If necessary, click the Plane Repairs sheet tab to display the Plane Repairs 
 worksheet and then click cell C15.

Excel 2007 sets the cell’s formula to =’[Fleet Operating Costs.xlsx]Plane 
Repairs’!$C$15.

4. Press F.

Excel 2007 displays the Operating Expense Dashboard workbook; the value 

$2,410,871.00 appears in cell I6.

Note Yes, cell C15 on the Plane Repairs worksheet contains the wrong total for the 

Airplane Fuel category; that’s why you replace it later in this exercise.

5. On the View tab, in the Window group, click Switch Windows and then click Fleet 
Operating Costs.

The Fleet Operating Costs workbook appears.

6. Right-click the Plane Repairs sheet tab and then click Delete. In the message box 

that appears, click Delete to confi rm that you want to delete the worksheet.

Excel 2007 deletes the Plane Repairs worksheet.
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7. On the View tab, in the Window group, click Switch Windows and then click 

Operating Expense Dashboard.

The Operating Expense Dashboard workbook appears.

8. On the Data tab, in the Connections group, click Edit Links.

The Edit Links dialog box appears.

9. Click Break Link.

Excel 2007 displays a warning box asking if you’re sure you want to break the link.

10. Click Break Links.

The warning box disappears, and Excel 2007 removes the link from the workbook.

11. Click Close.
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The Edit Links dialog box disappears and the error code #REF! appears in cell I6.

12. In cell I6, type =, but do not press Enter.

13. On the View tab, in the Window group, click Switch Windows and then click Fleet 
Operating Costs.

The Fleet Operating Costs workbook appears.

14. Click the Plane Fuel sheet tab.

The Plane Fuel worksheet appears.

15. Click cell C15 and then press F.

Excel 2007 displays the Operating Expense Dashboard workbook with the value 

$52,466,303.00 in cell I6.

CLOSE the Operating Expense Dashboard and Fleet Operating Costs workbooks.CLOSE the Operating Expense Dashboard andd Fleet Operating Costs workbooks.
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Consolidating Multiple Sets of Data into 
a Single Workbook

When you create a series of worksheets that contain similar data, perhaps by using a 

template, you build a consistent set of workbooks in which data is stored in a predict-

able place. For example, the workbook template in the following graphic uses cell C5 to 

record the number of calls received from 9:00 a.m. to 10:00 a.m. regarding phone calls 

handled by the Northeast distribution center.

Using links to bring data from one worksheet to another gives you a great deal of power 

to combine data from several sources in a single spot. For example, you can create a 

worksheet that lists the total revenue just for certain months of a year, use links to draw 

the values from the worksheets in which the sales were recorded, and then create a for-

mula to perform calculations on the data. However, for large worksheets with hundreds 

of cells fi lled with data, creating links from every cell to cells on another worksheet is 

time-consuming. Also, to calculate a sum or an average for the data, you would need to 

include links to cells in every workbook.

Fortunately, there is an easier way to combine data from multiple worksheets in a single 

worksheet. This process, called data consolidation, enables you to defi ne ranges of cells 

from multiple worksheets and have Excel 2007 summarize the data. You defi ne these 

ranges in the Consolidate dialog box.
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After you open the dialog box, you move to the worksheet with the cells in the fi rst 

range you want to include in your summary. When you select the cells, the 3-D reference 

for the cell range appears in the Consolidate dialog box.

Clicking Add stores the reference, whereas clicking Delete removes a range from the 

calculation. You can then choose the other cell ranges with data to include in the sum-

mary. Cells that are in the same relative position in the ranges have their contents sum-

marized together. So the cell in the upper-left corner of one range is added to the cell in 

the upper-left corner of another range, even if those ranges are in different areas of the 

worksheet. After you choose the ranges to be used in your summary, you can choose the 

calculation to perform on the data (sum, average, and so on). When you’re done select-

ing ranges to use in the calculation, click OK to have Excel 2007 summarize the data on 

your target worksheet.

Important You can defi ne only one data consolidation summary per workbook.

In this exercise, you’ll defi ne a series of ranges from two workbooks to be included in a 

data consolidation calculation. You then add the contents of the ranges and show the 

results in a worksheet.

USE the Consolidate, January Calls, and February Calls workbooks from the My Documents\
Microsoft Press\Excel SBS\MultipleFiles folder.

OPEN the Consolidate, January Calls, and February Calls workbooks.

1. In the Consolidate workbook, on the Data tab, in the Data Tools group, click 

Consolidate.

The Consolidate dialog box appears.

2. Click the Contract Dialog button at the right edge of the Reference fi eld.

The Consolidate dialog box contracts.

USE thethe ConsolidateConsolidate,, January CallsJanuary Calls, and, and February CallsFebruary Calls workbooks from the  workbooks from the My Documents\My Documents\
Microsoft Press\Excel SBS\MultipleFilesMicrosoft Press\Excel SBS\MultipleFiles folder.folder.

OPEN thethe ConsolidateConsolidate,, January CallsJanuary Calls, and , and February CallsFebruary Calls workbooks. workbooks.
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3. On the View tab, in the Window group, click Switch Windows and then click 

January Calls.

The January Calls workbook appears.

4. Select the cell range C5:O13 and then click the Expand Dialog control.

The Consolidate dialog box reappears.

5. Click Add.

The range ‘[January Calls.xlsx]January’!$C$5:$O$13 appears in the All references
pane.

6. Click the Contract Dialog button at the right edge of the Reference fi eld.

The Consolidate dialog box contracts.

7. On the View tab, in the Window group, click Switch Windows and then click 

February Calls.

The February Calls workbook appears.

8. Select the cell range C5:O13 and then click the Expand Dialog control.

The Consolidate dialog box reappears.

9. Click Add.

The range ‘[February Calls.xlsx]February’!$C$5:$O$13 appears in the All references
pane.

10. Click OK.

Offi ce Excel 2007 consolidates the January Calls and February Calls workbook 

data into the range C5:O13 in the Consolidate workbook.
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CLOSE the Consolidate, January Calls, and February Calls workbooks.

Grouping Multiple Sets of Data
When you work with Excel 2007 for awhile, you’ll fi nd that you often work with a number 

of the same workbooks at a time. For instance, Jenny Lysaker, the chief operating offi cer 

of Consolidated Messenger, might always pull up a workbook that tracks labor costs at 

the same time she opens the package volume summary workbook. She can open the 

workbooks individually through the Open dialog box, but she can also group the fi les so 

that she has the option of opening them all simultaneously.

If you want to open a set of fi les simultaneously, you can defi ne them as part of a work-

space, which uses a single Excel 2007 fi le name to reference several workbooks instead 

of one. To defi ne a workspace, you open the fi les you want to include and then open the 

Save Workspace dialog box.

When the Save Workspace dialog box is open, clicking Save saves references to the Excel 

2007 fi les that are currently open. Whenever you open the workspace you create, all the 

fi les that were open when you defi ned the workspace appear. Including a fi le in a work-

space doesn’t remove it from general circulation; you can still open it by itself.

CLOSE the Consolidate, January Calls, and February Calls workbooks.
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In this exercise, you save a workspace that consists of two workbooks, close the included 

fi les, and then test the workspace by opening it from the Open dialog box.

USE the Operating Expense Dashboard and Fleet Operating Costs workbooks from the 

My Documents\Microsoft Press\Excel SBS\MultipleFiles folder.

OPEN the Operating Expense Dashboard and Fleet Operating Costs workbooks.

1. On the View tab, in the Window group, click Save Workspace.

The Save Workspace dialog box appears.

2. In the File name fi eld, type Expenses.

3. Click Save.

Excel 2007 saves your workspace and closes the Save Workspace dialog box.

4. Click the Microsoft Offi ce Button and then click Close.

Excel 2007 closes the active workbook.

5. Click the Microsoft Offi ce Button and then click Close.

Excel 2007 closes the active workbook.

6. Click the Microsoft Offi ce Button and then click Open.

The Open dialog box appears.

7. Click Expenses and then click Open.

Excel 2007 opens the Operating Expense Dashboard and Fleet Operating Costs 
workbooks.

USE thethe Operating Expense DashboardOperating Expense Dashboard andanddd Fleet Operating CostsFleet Operating Costs workbooks from the workbooks from the

My Documents\Microsoft Press\Excel SBS\MultipleFilesMy Documents\Microsoft Press\Excel SBS\MultipleFiles folder. folder.

OPEN thethe Operating Expense DashboardOperating Expense Dashboard andanddd Fleet Operating CostsFleet Operating Costs workbooks.workbooks.
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CLOSE the Operating Expense Dashboard and Fleet Operating Costs workbooks.

CLOSE Excel 2007.

Key Points
  If you create a lot of workbooks with the same layout and design, saving a work-

book with the common elements (and no data) takes much less time.

  You can use data in other worksheets or workbooks in your formulas. You make the 

link by clicking the cell, which creates a 3-D reference to that cell.

  When you create a link to a cell in a table’s Totals row, hiding the row doesn’t make 

the link invalid.

  If you always work on a group of workbooks at the same time, create a workspace 

so that you can open them all at once.

CLOSE the Operating Expense Dashboard andd Fleet Operating Costs workbooks.

CLOSE Excel 2007.



Chapter at a GlanceChapter at a GlanceChapter at a Glance

Varying your data to
get a desired result
using Goal Seek,
page 187

Define and edit
alternative data sets,

page 180

Define multiple
alternative data
sets,page 183

Finding optimal
solutions with Solver,
page 190

Analyze data with
descriptive statistics,

page 196



Chapter at a GlanceChapter at a Glance
   179

 9 9 Analyzing Analyzing
   Alternative   Alternative
  Data Sets  Data Sets

In this chapter, you will learn to:

  Defi ne and edit alternative data sets.

  Defi ne multiple alternative data sets.

  Vary your data to get a desired result using Goal Seek.

  Find optimal solutions with Solver.

  Analyze data with descriptive statistics.

When you store data in a Microsoft® Offi ce Excel® 2007 workbook, you can use that 

data, either by itself or as part of a calculation, to discover important information about 

your business. When you track total sales on a time basis, you can fi nd your best and 

worst sales periods and correlate them with outside events. For businesses such as 

Consolidated Messenger, package volume increases dramatically during the holidays as 

customers ship gifts to friends and family members.

The data in your worksheets is great for asking this question: “What happened?” The 

data is less useful for asking “what-if” questions such as this: “How much money would 

we save if we reduced our labor to 20 percent of our total costs?” You can always save an 

alternative version of a workbook and create formulas that calculate the effects of your 

changes, but you can do the same thing in your workbook by defi ning one or more al-

ternative data sets and switching between the original data and the new sets you create.

Offi ce Excel 2007 also provides the tools to determine the inputs that would be required 

for a formula to produce a given result. For example, the chief operating offi cer of 

Consolidated Messenger, Jenny Lysaker, could fi nd out to what level three-day shipping 

would need to rise for that category to account for 25 percent of total revenue.
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In this chapter, you’ll learn how to defi ne alternative data sets and determine the 

 necessary inputs to make a calculation produce a particular result.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Defi ning and Editing Alternative Data Sets
When you save data in an Excel 2007 worksheet, you create a record that refl ects the 

characteristics of an event or object. That data could represent an hour of sales on a 

particular day, the price of an item you just began offering for sale, or the percentage of 

total sales accounted for by a category of products. After the data is in place, you can 

create formulas to generate totals, fi nd averages, and sort the rows in a worksheet based 

on the contents of one or more columns. However, if you want to perform a what-if 
analysis or explore the impact that changes in your data would have on any of the 

 calculations in your workbooks, you need to change your data.

The problem of working with data that refl ects an event or item is that changing any 

data to affect a calculation runs the risk of destroying the original data if you acciden-

tally save your changes. You can avoid ruining your original data by creating a duplicate 

workbook and making your changes to it, but you can also create alternative data sets, 

or scenarios, within an existing workbook.

When you create a scenario, you give Excel 2007 alternative values for a list of cells in a 

worksheet. You can use the Scenario Manager to add, delete, and edit scenarios.
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Clicking the Add button causes the Add Scenario dialog box to appear.

From within this dialog box, you can name the scenario and identify the cells that will 

hold alternative values. After you click OK, a new dialog box appears with spaces for you 

to enter the new values.

Clicking OK returns you to the Scenario Manager dialog box. From there, clicking the 

Show button replaces the values in the original worksheet with the alternative values 

you just defi ned in a scenario. Any formulas using cells with changed values recalculate 

their results. You can then remove the scenario by clicking the Undo button on the Quick 

Access Toolbar.

Warning If you save and close a workbook while a scenario is in effect, those values 

 become the default values for the cells changed by the scenario! You should strongly 

 consider creating a scenario that contains the original values of the cells you change or 

 creating a scenario summary worksheet (a topic covered later in this chapter).
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In this exercise, you’ll create a scenario to measure the projected impact on total revenue 

of a rate increase on two-day shipping.

USE the 2DayScenario workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Alternatives folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the 2DayScenario workbook.

1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Scenario Manager.

The Scenario Manager dialog box appears.

2. Click Add.

The Add Scenario dialog box appears.

3. In the Scenario Name fi eld, type 2DayIncrease.

4. At the right edge of the Changing cells fi eld, click the Contract Dialog button.

The Add Scenario dialog box contracts.

5. Click cell C5 and then click the Expand Dialog button.

C5 appears in the Changing cells fi eld.

6. Click OK.

The Scenario Values dialog box appears.

7. In the value fi eld, type 13.2 and then click OK.

The Scenario Values dialog box disappears.

8. If necessary, drag the Scenario Manager dialog box so you can view the entire 

table.

USE thethe 2DayScenario2DayScenario workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\AlternativesMy Documents\Microsoft Press\Excel SBS\Alternatives folder. folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe 2DayScenario2DayScenario workbook.workbook.
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 9. Click Show.

Excel 2007 applies the scenario, changing the value in cell C5 to $13.20, which in 

turn increases the value in cell E8 to $747,450,000.00.

 10. Click Close.

The Scenario Manager dialog box disappears.

 11. On the Quick Access Toolbar, click the Undo button.

Excel 2007 removes the scenario.

CLOSE the 2DayScenario workbook.

Defi ning Multiple Alternative Data Sets
One great feature of Excel 2007 scenarios is that you’re not limited to creating one 

 alternative data set—you can create as many as you like and apply them at will by using 

the Scenario Manager. To apply more than one scenario by using the Scenario Manager, 

click the name of the fi rst scenario you want to display, click the Show button, and then 

do the same for the second scenario. The values you defi ned as part of those scenarios 

CLOSE the 2DayScenario workbook.
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will appear in your worksheet, and Excel 2007 will update any calculations involving the 

changed cells.

Tip If you apply a scenario to a worksheet and then apply another scenario to the same 

worksheet, both sets of changes appear. If the second scenario changes a cell changed by 

the fi rst scenario, the cell refl ects the value in the second scenario.

Applying multiple scenarios gives you an overview of how the scenarios affect your 

 calculations, but Excel 2007 also gives you a way to view the results of all your scenarios 

in a single worksheet. To create a worksheet in your current workbook that summarizes 

the changes caused by your scenarios, open the Scenario Manager and then click the 

Summary button. When you do, the Scenario Summary dialog box appears.

From within the dialog box, you can choose the type of summary worksheet you want 

to create and the cells you want to appear in the summary worksheet. To choose the 

cells to appear in the summary, click the button in the box, select the cells you want 

to appear, and then expand the dialog box. After you verify that the range in the box 

represents the cells you want included on the summary sheet, click to create the new 

worksheet.

It’s a good idea to create an “undo” scenario named Normal with the original val-

ues of every cell before they’re changed in other scenarios. For example, if you cre-

ate a  scenario named High Fuel Costs that changes the sales fi gures in three cells, 

your Normal scenario restores those cells to their original values. That way, even if you 

 accidentally modify your worksheet, you can apply the Normal scenario and not have to 

reconstruct the worksheet from scratch.

Tip Each scenario can change a maximum of 32 cells, so you might need to create more 

than one scenario to restore a worksheet.
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In this exercise, you create scenarios to represent projected revenue increases from 

two rate changes, view the scenarios, and then summarize the scenario results in a new 

worksheet.

USE the Multiple Scenarios workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Alternatives folder.

OPEN the Multiple Scenarios workbook.

 1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Scenario Manager.

The Scenario Manager dialog box appears.

 2. Click Add.

The Add Scenario dialog box appears.

 3. In the Scenario name fi eld, type 3DayIncrease.

 4. At the right edge of the Changing cells fi eld, click the Collapse Dialog button.

The Edit Scenario dialog box collapses.

 5. Click cell C4 and then click the Expand Dialog button.

Excel 2007 restores the Edit Scenario dialog box.

 6. Click OK.

The Scenario Values dialog box appears.

 7. In the value fi eld, type 11.50.

 8. Click OK.

The Edit Scenario dialog box disappears, and the Scenario Manager reappears.

 9. Click Add.

The Add Scenario dialog box appears.

 10. In the Scenario name fi eld, type Ground and Overnight Increase.

 11. At the right edge of the Changing cells fi eld, click the Collapse Dialog button.

The Edit Scenario dialog box collapses.

 12. Ctrl+click cells C3 and C6 and then click the Expand Dialog button.

Excel 2007 restores the Edit Scenario dialog box.

USE thethe Multiple ScenariosMultiple Scenarios workbook in the practice fi le folder for this topic. This practiceworkbook in the practice fi le folder for this topic. This practice

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\AlternativesMy Documents\Microsoft Press\Excel SBS\Alternatives folder.folder.

OPEN thethe Multiple ScenariosMultiple Scenarios workbook. workbook.



186  Chapter 9 Analyzing Alternative Data Sets
 13. Click OK.

The Scenario Values dialog box appears.

 14. In the $C$3 value fi eld, type 10.15.

 15. In the $C$6 fi eld, type 18.5.

 16. Click OK.

The Scenario Values dialog box disappears, and the Scenario Manager dialog box 

reappears.

 17. Click the 3DayIncrease scenario and then click Show.

Excel 2007 applies the scenario to your worksheet.

 18. Click the Ground and Overnight Increase scenario and then click Show.

Excel 2007 applies the scenario to your worksheet.

 19. Click Summary.

The Scenario Summary dialog box appears.

 20. Verify that the Scenario summary option button is selected and that cell E8 ap-

pears in the Result cells fi eld.
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 21. Click OK.

Excel 2007 creates a Scenario Summary worksheet.

CLOSE the Multiple Scenarios workbook.

Varying Your Data to Get a Desired Result Using 
Goal Seek

When you run a business, you must know how every department and  product is 

 performing, both in absolute terms and in relation to other departments or products in 

the company. Just as you might want to reward your employees for maintaining a per-

fect safety record and keeping down your insurance rates, you might also want to stop 

carrying products you cannot sell.

When you plan how you want to grow your business, you should have specifi c goals 

in mind for each department or product category. For example, Jenny Lysaker of 

Consolidated Messenger might have the goal of reducing the fi rm’s labor cost by 20 

 percent over the previous year. Finding the labor amount that represents a 20 percent 

decrease is simple, but expressing goals in other ways can make fi nding the solution 

CLOSE the Multiple Scenarios workbook.
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more challenging. Instead of decreasing labor costs 20 percent over the previous year, 

Jenny might want to decrease labor costs so they represent no more than 20 percent of 

the company’s total outlays.

As an example, consider the following worksheet, which holds cost fi gures for 

Consolidated Messenger’s operations and uses those fi gures to calculate both total costs 

and the share each category has of that total.

Important In this worksheet, the values in the Share row are displayed as percentages, 

but the underlying values are decimals. For example, Excel 2007 represents 0.3064 as 

30.64%.

Although it would certainly be possible to fi gure the target number that would make 

labor costs represent 20 percent of the total, there is an easier way to do it in Excel 2007: 

Goal Seek. To use Goal Seek, you display the Data tab and then, in the Data Tools group, 

click What-If Analysis. From the menu that appears, click Goal Seek to open the Goal 

Seek dialog box.

In the dialog box, you identify the cell with the target value; in this case, it is cell C4, 

which has the percentage of costs accounted for by the Labor category. The box has the 

target value (.2, which is equivalent to 20%), and the box identifi es the cell with the value 

Excel 2007 should change to generate the target value of 20% in cell C4. In this example, 

the cell to be changed is C3.

Clicking OK tells Excel 2007 to fi nd a solution for the goal you set. When Excel 2007 

 fi nishes its work, the new values appear in the designated cells, and the Goal Seek Status 

dialog box appears.
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Tip Goal Seek fi nds the closest solution it can without exceeding the target value. In this 

case, the closest percentage it could fi nd was 19.97%.

In this exercise, you’ll use Goal Seek to determine how much you need to decrease 

transportation costs so those costs comprise no more than 40 percent of Consolidated 

Messenger’s operating costs.

USE the Target Values workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Alternatives folder.

OPEN the Target Values workbook.

 1. On the Data tab, in the Data Tools group, click What-If Analysis and then click 

Goal Seek.

The Goal Seek dialog box appears.

USE thethe Target ValuesTarget Values workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\AlternativesMy Documents\Microsoft Press\Excel SBS\Alternatives folder. folder.

OPEN thethe Target ValuesTarget Values workbook.workbook.
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 2. In the Set cell fi eld, type D4.

 3. In the To value fi eld, type .4.

 4. In the By changing cell fi eld, type D3.

 5. Click OK.

Excel 2007 displays the solution in both the worksheet and the Goal Seek Status 
dialog box. 

 6. Click Cancel.

Excel 2007 closes the Goal Seek Status dialog box without saving the new 

 worksheet values.

CLOSE the Target Values workbook.

Finding Optimal Solutions with Solver
Goal Seek is a great tool for fi nding out how much you need to change a single input to 

generate a desired result from a formula, but it’s of no help if you want to fi nd the best 

mix of several inputs. For example, marketing vice president Craig Dewar might want to 

advertise in four national magazines to drive customers to Consolidated Messenger’s 

CLOSE the Target Values workbook.
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Web site, but he might not know the best mix of ads to place among the publications. 

He asked the publishers for ad pricing and readership numbers, which are refl ected in 

the spreadsheet shown as follows, along with the minimum number of ads per publica-

tion (3) and the minimum number of times he wants the ad to be seen (10,000,000). 

Because one of the magazines has a high percentage of corporate executive readers, 

Craig does want to take out at least four ads in that publication despite its relatively 

low readership. The goal of the ad campaign is for the ads to be seen as many times as 

 possible without spending more than the $3,000,000 budget.

Tip It helps to spell out every aspect of your problem so that you can identify the cells you 

want Solver to use in its calculations.

If you performed a complete installation when you installed Excel 2007 on your system, 

you see the Solver item on the Data tab in the Analysis group. If not, you need to in-

stall the Solver Add-In. To do so, click the Microsoft Offi ce Button and then click Excel 

Options. In the Excel Options dialog box, click Add-Ins to display the Add-Ins page. At 

the bottom of the dialog box, click the Manage fi eld down arrow, click Excel Add-Ins, 



192  Chapter 9 Analyzing Alternative Data Sets
and then click Go to display the Add-Ins dialog box. Select the Solver Add-in check box 

and click OK to install Solver.

Note You might be prompted for the Microsoft Offi ce system installation CD-ROM. If so, 

put the CD-ROM in your CD-ROM drive and click OK.

After the installation is complete, Solver appears on the Add-Ins tab in the Menu 

Commands group. Click Solver to display the Solver Parameters dialog box.

The fi rst step of setting up your Solver problem is to identify the cell that refl ects the 

results of changing the other cells in the worksheet. To identify that cell, click in the Set 

Target Cell box, click the target cell, and then select the option button representing 

whether you want to minimize the cell’s value, maximize the cell’s value, or make the cell 

take on a specifi c value. Next you click in the By Changing Cells box and select the cells 

Solver should vary to change the value in the target cell. Finally, you set the limits for the 

values Solver can use by clicking Add to display the Add Constraint dialog box.

You add constraints to the Solver problem by selecting the cells to which you want to 

apply the constraint, selecting the comparison operation (less than or equal to, greater 

than or equal to, requiring the value to be an integer, and so on) by clicking the down 

arrow in the middle box, clicking in the Constraint box, and selecting the cell with the 

value of the constraint. You could also type a value in the Constraint box, but referring to 

a cell makes it possible for you to change the constraint without opening Solver.

Note After you run Solver, you can use the controls in the Solver Results, save the results 

as changes to your worksheet, or create a scenario based on the changed data.
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In this exercise, you use Solver to determine the best mix of ads given the following 

constraints:

  You want to maximize the number of people who see the ads.

  You must buy at least eight ads in three magazines and at least ten in the fourth.

  You can’t buy part of an ad (that is, all numbers must be integers).

  You can buy no more than 20 ads in any one magazine.

  You must reach at least 10,000,000 people.

  Your ad budget is $3,000,000.

USE the Ad Buy workbook in the practice fi le folder for this topic. This practice fi le is lo-

cated in the My Documents\Microsoft Press\Excel SBS\Alternatives folder.

OPEN the Ad Buy workbook.

 1. If Solver doesn’t appear on the Add-Ins tab, in the Menu Commands group, click 

the Microsoft Offi ce Button and then click Excel Options.

The Excel Options dialog box appears.

 2. Click Add-Ins.

The Add-Ins page of the dialog box appears.

 3. Click the Manage fi eld down arrow and then click Excel Add-Ins.

 4. Click Go.

The Add-Ins tab appears.

 5. Select the Solver Add-In check box and then click OK.

 6. On the Add-Ins tab, in the Menu Commands group, click Solver.

The Solver Parameters dialog box appears.

 7. Click in the Set Target Cell box and then click cell G9.

$G$9 appears in the Set Target Cell fi eld.

 8. Select the Max option button.

 9. Click in the By Changing Cells fi eld and select cells E5:E8.

$E$5:$E$8 appears in the By Changing Cells fi eld.

USE thethe Ad BuyAd Buy workbook in the practice fi le folder for this topic. This practice fi le is lo-workbook in the practice fi le folder for this topic. This practice fi le is lo-yy
cated in thecated in the My Documents\Microsoft Press\Excel SBS\AlternativesMy Documents\Microsoft Press\Excel SBS\Alternatives folder.folder.

OPEN thethe Ad BuyAd Buy workbook.workbook.yy
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 10. Click Add.

The Add Constraint dialog box appears.

 11. Select cells E5:E8.

$E$5:$E$8 appears in the Cell Reference fi eld.

 12. Click the down arrow in the middle fi eld and select int.

 13. Click Add.

Excel 2007 adds the constraint to the Solver problem, and the Add Constraint 
 dialog box clears to accept the next constraint.

 14. Click cell F9.

$F$9 appears in the Cell Reference fi eld.

 15. Click in the Constraint fi eld and then click cell G11.

$G$11 appears in the Constraint fi eld.

 16. Click Add.

Excel 2007 adds the constraint to the Solver problem, and the Add Constraint 
 dialog box clears to accept the next constraint.

 17. Click cell G9.

$G$9 appears in the Cell Reference fi eld.

 18. Click the down arrow in the middle fi eld and select =.

 19. Click in the Constraint fi eld and then click cell G12.

$G$12 appears in the Constraint fi eld.



   195Finding Optimal Solutions with Solver
 20. Click Add.

Excel 2007 adds the constraint to the Solver problem, and the Add Constraint 
 dialog box clears to accept the next constraint.

 21. Select cells E5:E7.

$E$5:$E$7 appears in the Cell Reference fi eld.

 22. Click the down arrow in the middle fi eld and select =.

 23. Click in the Constraint fi eld and then click cell G13.

$G$13 appears in the Constraint fi eld.

 24. Click Add.

Excel 2007 adds the constraint to the Solver problem, and the Add Constraint 
 dialog box clears to accept the next constraint.

 25. Click cell E8.

$E$8 appears in the Cell Reference fi eld.

 26. Click the down arrow in the middle fi eld and select =.

 27. Click in the Constraint fi eld and then click cell G14.

$G$14 appears in the Constraint fi eld.

 28. Click Add.

Excel 2007 adds the constraint to the Solver problem, and the Add Constraint 
 dialog box clears to accept the next constraint.

 29. Select cells E5:E8.

$E$5:$E$8 appears in the Cell Reference fi eld.

 30. Click in the Constraint fi eld and then click cell G15.

$G$15 appears in the Constraint fi eld.

 31. Click OK.

Excel 2007 adds the constraint to the Solver problem, and the Solver Parameters 
dialog box reappears.
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 32. Click Solve.

The Solver Results dialog box appears, indicating that Solver found a solution. The 

result is displayed in the body of the worksheet.

 33. Click Cancel.

The Solver Results dialog box disappears.

 34. Click Close. If you are asked if you want to save your changes, click No.

The Solver dialog box disappears.

CLOSE the Ad Buy workbook.

Analyzing Data with Descriptive Statistics
Experienced businesspeople can tell a lot about numbers just by looking at them to see 

if they “look right” (that is, the sales fi gures are about where they’re supposed to be for a 

particular hour, day, or month; the average seems about right; and sales have increased 

CLOSE the Ad Buy workbook.y
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from year to year). When you need more than an off-the-cuff assessment, however, you 

can use the tools in the Analysis ToolPak. 

If you don’t see the Data Analysis item in the Data tab’s Analysis group, you can install 

it. To do so, click the Microsoft Offi ce Button and then click Excel Options. In the Excel 

Options dialog box, click Add-Ins to display the Add-Ins page. At the bottom of the 

 dialog box, click the Manage fi eld down arrow, click Excel Add-Ins, and then click Go to 

display the Add-Ins dialog box. Select the Analysis ToolPak check box and click OK.

Note You might be prompted for the Microsoft Offi ce system installation CD-ROM. If so, 

put the CD-ROM in your CD-ROM drive and click OK.

After the installation is complete, the Data Analysis item appears in the Analysis group 

on the Data tab.

You then click the item representing the type of data analysis you want to perform, click 

OK, and use the controls in the resulting dialog box to analyze your data.

In this exercise, you’ll use the Analysis ToolPak to generate descriptive statistics of driver 

sorting time data.

USE the Driver Sort Times workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Alternatives folder.

OPEN the Driver Sort Times workbook.

 1. On the Data tab, in the Analysis group, click Data Analysis.

The Data Analysis dialog box appears.

 2. Click Descriptive Statistics and then click OK.

The Descriptive Statistics dialog box appears.

Note You might be prompted for the Microsoft Offi ce system installation CD-ROM. If so, You might be prompted for the Microsoft Offi ce system installation CD-ROM. If so, 

put the CD-ROM in your CD-ROM drive and click OK.put the CD-ROM in your CD-ROM drive and click OK.

USE thethe Driver Sort TimesDriver Sort Times workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice 

fi le is located in thefi le is located in the My Documents\Microsoft Press\Excel SBS\AlternativesMy Documents\Microsoft Press\Excel SBS\Alternatives folder.folder.

OPEN thethe Driver Sort TimesDriver Sort Times workbook. workbook.
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3. Click in the Input Range fi eld and position the mouse pointer near the top of 

the Sorting Minutes column header. When the pointer changes to a downward-

 pointing black arrow, click the header.

$C$3:$C$17 appears in the Input Range fi eld.

4. Select the Summary Statistics check box.

5. Click OK.

A new worksheet that contains summary statistics about the selected data appears.
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CLOSE the Driver Sort Times workbook.

CLOSE Excel 2007.

Key Points
  Scenarios enable you to describe many potential business cases within a single 

workbook.

  It’s usually a good idea to create a “normal” scenario that enables you to reset your 

worksheet.

  Remember that you can change up to 32 cells in a scenario, but no more.

  You can summarize your scenarios on a new worksheet to compare how each 

 scenario approaches the data.

  Use Goal Seek to determine what value you need in a single cell to generate the 

desired result from a formula.

  If you want to vary the values in more than one cell to fi nd the optimal mix of 

 inputs for a calculation, use the Solver Add-In.

  Advanced statistical tools are available in the Analysis ToolPak—use them to go 

over your data thoroughly.

CLOSE the Driver Sort Times workbook.

CLOSE Excel 2007.
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In this chapter, you will learn to:

  Create dynamic lists with PivotTables.

  Filter, show, and hide PivotTable data.

  Edit PivotTables.

  Format PivotTables.

  Create PivotTables from external data.

When you create Microsoft® Offi ce Excel® 2007 worksheets, you must consider how 

you want the data to appear when you show it to your colleagues. You can change the 

formatting of your data to emphasize the contents of specifi c cells, sort and fi lter your 

worksheets based on the contents of specifi c columns, or hide rows containing data that 

isn’t relevant to the point you’re trying to make.

One limitation of the standard Offi ce Excel worksheet is that you can’t change how the 

data is organized on the page. For example, in a worksheet in which each column rep-

resents an hour in the day, each row represents a day in a month, and the body of the 

worksheet contains the total sales for every hourly period of the month, you can’t easily 

change the worksheet so that it displays only sales on Tuesdays during the afternoon.

An Offi ce Excel 2007 tool enables you to create worksheets that can be sorted, fi ltered, 

and rearranged dynamically to emphasize different aspects of your data. That tool is the 

PivotTable.

In this chapter, you’ll learn how to create and edit PivotTables from an existing worksheet 

and how to create a PivotTable with data imported from a text fi le.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.
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Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Analyzing Data Dynamically with PivotTables
Excel 2007 worksheets enable you to gather and present important data, but the 

 standard worksheet can’t be changed from its original confi guration easily. As an 

 example, consider the worksheet in the following graphic.

This worksheet records monthly package volumes for each of nine distribution centers 

in the United States. The data in the worksheet is organized so that each row represents 

a distribution center, whereas the columns in the body of the worksheet represent a 

month of the year. When presented in this arrangement, the monthly totals for all cen-

ters and the yearly total for each distribution center are given equal billing: neither set of 

totals stands out.
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Such a neutral presentation of your data is versatile, but it has limitations. First, although 

you can use sorting and fi ltering to restrict the rows or columns shown, it’s diffi cult to 

change the worksheet’s organization. For example, in a standard worksheet you can’t 

reorganize the contents of your worksheet so that the hours are assigned to the rows 

and the distribution centers are assigned to the columns.

The Excel 2007 tool to reorganize and redisplay your data dynamically is the PivotTable. 

You can create a PivotTable, or dynamic worksheet, that enables you to reorganize and 

fi lter your data on the fl y. For instance, you can create a PivotTable with the same layout 

as the worksheet shown previously, which emphasizes totals by month, and then change 

the PivotTable layout to have the rows represent the months of the year and the col-

umns represent a distribution center. The new layout emphasizes the totals by regional 

 distribution center, as shown in the following graphic.

To create a PivotTable, you must have your data collected in a list. The new Excel 2007 

data tables mesh perfectly with PivotTable® dynamic views; not only do the data tables 

have a well- defi ned column and row structure but the ability to refer to a data table by 

its name also greatly simplifi es PivotTable creation and management.
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The following graphic shows the fi rst few lines of the data table used to create the 

PivotTable just shown.

Notice that each line of the table contains a value representing the Distribution Center, 

Date, Month, Week, Weekday, Day, and Volume for every day of the years 2006 and 

2007. Excel 2007 needs that data when it creates the PivotTable so that it can maintain 

relationships among the data. If you want to fi lter your PivotTable so that it shows all 

package volumes on Thursdays in January, for example, Excel 2007 must be able to 

 identify January 11 as a Thursday.

After you create a data table, you can click any cell in that list, display the Insert tab of 

the user interface, and then, in the Tables group, click PivotTable to display the Create 

PivotTable dialog box.



   205Analyzing Data Dynamically with PivotTables
In this dialog box, you verify the data source for your PivotTable and whether you want 

to create a PivotTable on a new worksheet. After you click OK, Excel 2007 creates a new 

worksheet and displays the PivotTable Field List task pane.

Tip You should always place your PivotTable on its own worksheet to avoid unwanted edits 

and reduce the number of cells Excel 2007 must track when you rearrange your data. You 

might not notice a difference with a small data set, but it’s noticeable when your table runs 

more than a few hundred rows.
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To assign a fi eld, or column in a data list, to an area of the PivotTable, drag the fi eld head 

from the Choose Fields To Add To Report area at the top of the PivotTable Field List task 

pane to the Drag Fields Between Areas Below area at the bottom of the task pane. For 

example, if you drag the Volume fi eld header to the Values area, the PivotTable displays 

the total of all entries in the Volume column. 

If the PivotTable Field List task pane isn’t visible, click any cell in the PivotTable to display 

it. If you accidentally click the Close button at the upper-right corner of the PivotTable 

Field List task pane, you can redisplay the task pane by clicking any cell in the PivotTable 

to display the PivotTable Tools context tabs on the user interface. On the Options 

 contextual tab, in the Show/Hide group, click Field List.

It’s important to note that the order in which you enter the fi elds in the Row Labels and 

Column Labels areas affects how Excel 2007 organizes the data in your PivotTable. As an 

example, the following graphic shows a PivotTable that groups the PivotTable rows by 

distribution center and then by month.
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And here is the same PivotTable data, but this time it’s organized by month and then by 

distribution center.
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In the preceding examples, all the fi eld headers are in the Row Labels area. If you drag 

the Center header from the Row Labels area to the Column Labels area, the PivotTable 

reorganizes its data (pivots) to form this confi guration.

To pivot a PivotTable, you drag a fi eld header to a new position in the PivotTable Field 

List task pane. As you drag the task pane, Excel 2007 displays a blue line in the interior of 

the target area so you know where the fi eld will appear when you release the left mouse 

button. If your data set is large or if you based your PivotTable on a data collection on 

another computer, it might take some time for Excel 2007 to reorganize the PivotTable 

after a pivot. You can have Excel 2007 delay redrawing the PivotTable by selecting the 

Defer Layout Update button at the lower-left corner of the PivotTable Field List task 

pane. When you’re ready for Excel 2007 to display the reorganized PivotTable, click 

Update.

If you expect your PivotTable source data to change, such as when you link to an 

 external database that records shipments or labor hours, ensure that your PivotTable 

summarizes all the available data. To do that, you can refresh the PivotTable connec-

tion to its data source. If Excel 2007 detects new data in the source table, it updates 

the PivotTable contents accordingly. To refresh your PivotTable, click any cell in the 

PivotTable and then, in the Data group, on the Options contextual tab, click Refresh.
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Analyzing Data Dynamically with PivotTables
In this exercise, you create a PivotTable using data from a table, add fi elds to the 

PivotTable, and then pivot the PivotTable.

USE the Creating workbook in the practice fi le folder for this topic. This practice fi le is 

 located in the My Documents\Microsoft Press\Excel SBS\PivotTables folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the Creating workbook.

1. Click any cell in the data table.

2. On the Insert tab, in the Tables group, click PivotTable.

The Create PivotTable dialog box appears.

3. Verify that the DailyVolumes table name appears in the Table/Range fi eld and that 

the New Worksheet option button is selected.

4. Click OK.

Excel 2007 creates a PivotTable on a new worksheet.

5. In the PivotTable Field List task pane, drag the Center fi eld header to the Row 
Labels area.

Excel 2007 adds the Center fi eld values to the PivotTable row area.

USE thethe CreatingCreating workbook in the practice fi le folder for this topic. This practice fi le is workbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\PivotTablesMy Documents\Microsoft Press\Excel SBS\PivotTables folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe CreatingCreating workbook.workbook.
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6. In the PivotTable Field List task pane, drag the Year fi eld header to the Column 
Labels area.

Excel 2007 adds the Year fi eld values to the PivotTable column area.

7. In the PivotTable Field List task pane, drag the Volume fi eld header to the Values 
area.

Excel 2007 fi lls in the body of the PivotTable with the Volume fi eld values.

8. In the PivotTable Field List task pane, in the Column Labels area, drag the Year 
fi eld header to the Row Labels area and drop it beneath the Center fi eld header.

Excel 2007 changes the PivotTable to refl ect the new organization.

CLOSE the Creating workbook.CLOSE the Creating workbook.
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Filtering, Showing, and Hiding PivotTable Data
PivotTables often summarize huge data sets in a relatively small worksheet. The more 

details you can capture and write to a table, the more fl exibility you have in analyzing 

the data. As an example, consider all the details captured in the following data table.

Each line of the table contains a value representing the Distribution Center, Date, Month, 

Week, Weekday, Day, and Volume for every day of the year. Each column, in turn, con-

tains numerous values: there are nine distribution centers, data from two years, twelve 

months in a year, seven weekdays, and as many as fi ve weeks and 31 days in a month. 

Just as you can fi lter the data that appears in a table, you can fi lter the data displayed in 

a PivotTable by selecting which values you want the PivotTable to include. 

See Also For more information on fi ltering an Excel 2007 data table, see “Limiting Data That 
Appears on Your Screen” in Chapter 6.

To fi lter a PivotTable based on a fi eld’s contents, click the fi eld’s header in the PivotTable 

Field List task pane’s Choose Fields To Add To Report a rea to display a menu of sorting 

and fi ltering options.



212  Chapter 10 Creating Dynamic Lists with PivotTables

. 
The PivotTable displays data that’s related to the values with a checked box next to them

Clicking the Select All check box clears it, which enables you to select the check boxes 

of the values you want to display. Selecting only the Northwest check box, for example, 

leads to the following PivotTable confi guration.
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If you’d rather display as much PivotTable data as possible, you can hide the PivotTable 

Field List task pane and fi lter the PivotTable by using the fi lter arrows on the Row Labels 

and Column Labels headers within the body of the PivotTable. Clicking either of those 

headers enables you to select a fi eld by which you want to fi lter; you can then defi ne 

the fi lter using the same controls you see when you click a fi eld header in the PivotTable 

Field List task pane.

Excel 2007 indicates that the PivotTable has fi lters applied by placing a fi lter indicator 

next to the Column Labels or Row Labels header, as appropriate, and the fi ltered fi eld 

name in the PivotTable Field List task pane.

So far, all the fi elds by which you’ve fi ltered your PivotTable have changed the 

 organization of the data in the PivotTable. Adding some fi elds to a PivotTable, however, 

might create unwanted complexity. For example, you might want to fi lter a PivotTable by 

weekday, but adding the Weekday fi eld to the body of the PivotTable expands the table 

unnecessarily.

Instead of adding the Weekday fi eld to the Row Labels or Column Labels area, you can 

drag the fi eld to the Report Filter area near the bottom of the PivotTable Field List task 

pane. Doing so leaves the body of the PivotTable in the same position, but adds a new 

area above the PivotTable in its worksheet.
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Note In Excel 2003 and earlier versions, this area was called the Page Field area.

When you click the down arrow of a fi eld in the Report Filter area, Excel 2007 displays 

a list of the values in the fi eld. In previous versions of Excel 2007, you could select only 

one Report Filter value by which to fi lter a PivotTable; in Excel 2007, selecting the Select 

Multiple Items check box enables you to fi lter by more than one value.

Finally, you can fi lter values in a PivotTable by hiding and collapsing levels of detail 

within the report. To do that, you click the Hide Detail control (which looks like a box 

with a minus sign in it) or the Show Detail control (which looks like a box with a plus sign 

in it) next to a header. For example, you might have your data divided by year; clicking 

the Show Detail control next to the 2006 year header would display that year’s details. 

Conversely, clicking the 2007 year header Hide Detail control would hide the individual 

months’ values and display only the year’s total.
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Filtering, Showing, and Hiding PivotTable Data
In this exercise, you will focus the data displayed in a PivotTable by creating a fi lter, by 

fi ltering a PivotTable based on the contents of a fi eld in the Report Filters area, and 

by showing and hiding levels of detail within the body of the PivotTable.

USE the Focusing workbook in the practice fi le folder for this topic. This practice fi le is 

 located in the My Documents\Microsoft Press\Excel SBS\PivotTables folder.

OPEN the Focusing workbook.

1. On the PivotTable worksheet, click any cell in the PivotTable.

2. In the PivotTable Field List task pane’s Choose fi elds to add to report section, 

click the Center fi eld header, click the down arrow next to the Center fi eld header, 

and then clear the (Select All) check box.

Excel 2007 clears all the check boxes in the fi lter menu.

3. Select the Northwest check box and then click OK.

Excel 2007 fi lters the PivotTable.

USE thethe FocusingFocusing workbook in the practice fi le folder for this topic. This practice fi le is workbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\PivotTablesMy Documents\Microsoft Press\Excel SBS\PivotTables folder.folder.

OPEN thethe FocusingFocusing workbook.workbook.
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4. On the Quick Access Toolbar, click the Undo button.

Excel 2007 removes the fi lter.

5. In the PivotTable Field List task pane, drag the Weekday fi eld header from the 

Choose fi elds to add to report section to the Report Filter area in the Drag fi elds 
between areas below section.

6. In the PivotTable Field List task pane, click the Close button.

The PivotTable Field List task pane disappears.

7. In the body of the worksheet, click the Weekday header fi lter arrow and then  select 

the Select Multiple Items check box.

Excel 2007 adds check boxes beside the items in the Weekday fi eld fi lter list.

8. Clear the All check box.

Excel 2007 removes the check from each check box in the list.
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 9. Select the Tuesday and Thursday check boxes, and then click OK.

Excel 2007 fi lters the PivotTable, summarizing only those values from Tuesdays and 

Thursdays.

 10. In cell A5, click the Hide Detail button.

Excel 2007 collapses rows that contain data from the year 2006, leaving only the 

subtotal row that summarizes that year’s data.

CLOSE the Focusing workbook.CLOSE the Focusing workbook.
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Editing PivotTables
After you create a PivotTable, you can rename it, edit it to control how it summarizes 

your data, and use the PivotTable cell data in a formula. As an example, consider the 

 following PivotTable.

Excel 2007 displays the PivotTable name on the Options contextual tab, in the PivotTable 

Options group. The name PivotTable5 doesn’t help you or your colleagues understand 

the data the PivotTable contains, particularly if you use the PivotTable data in a formula 

on another worksheet. To give your PivotTable a more descriptive name, click any cell in 

the PivotTable and then, on the Options contextual tab, in the PivotTable Options group, 

type the new name in the PivotTable Name fi eld.

When you create a PivotTable with at least one fi eld in the Row Labels area and one 

fi eld in the Column Labels area of the PivotTable Field List task pane, Excel 2007 adds a 

grand total row and column to summarize your data. You can control how and where 

these summary rows and columns appear by clicking any PivotTable cell and then, in the 

Design contextual tab, in the Layout group, clicking either the Subtotals or Grand Totals 

button and selecting the desired layout.
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After you create a PivotTable, Excel 2007 determines the best way to summarize the data 

in the column you assign to the Values area. For numeric data, for example, Excel 2007 

uses the Sum function. If you want to change a PivotTable summary function, right-click 

any data cell in the PivotTable values area, point to Summarize Data By, and then click 

the desired operation. If you want to use a function other than those listed, click More 

Options to display the Value Field Settings dialog box.

On the Summarize By tab of the dialog box, click the summary operation you want to 

use and then click OK. 

The Value Field Settings dialog box also enables you to change how the PivotTable 

 displays the data in the Values area. If you click the Show Values As tab of the Value Field 

Settings dialog box, you can use the Show Values As list box to select whether to display 

each cell’s percentage contribution to its column’s total, its row’s total, or its contribution 

to the total of all values displayed in the PivotTable.

In versions prior to Offi ce Excel 2002, you couldn’t create a link to a cell in a PivotTable. 

Now you can create a link from a cell in another workbook to a cell in your PivotTable. 

To create a link, you click the cell you want to link to your PivotTable, type an equal 

sign, and then click the cell in the PivotTable with the data you want linked. When you 
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click the PivotTable cell, a GETPIVOTDATA formula appears in the formula bar of the 

 worksheet with the PivotTable. When you press Enter, the contents of the PivotTable cell 

will appear in the linked cell.

In this exercise, you’ll rename a PivotTable, specify whether subtotal and grand total rows 

will appear, change the PivotTable summary function, display each cell’s contribution to 

its row’s total, and create a link to a PivotTable cell.

USE the Editing workbook in the practice fi le folder for this topic. This practice fi le is 

 located in the My Documents\Microsoft Press\Excel SBS\PivotTables folder.

OPEN the Editing workbook.

1. On the PivotTable worksheet, click any cell in the PivotTable.

2. On the Options contextual tab, in the PivotTable group, in the PivotTable Name 

fi eld, type VolumeSummary.

Excel 2007 renames the PivotTable to VolumeSummary.

3. On the Design contextual tab, in the Layout group, click Subtotals and then click 

Do Not Show Subtotals.

Excel 2007 removes the subtotal rows from the PivotTable.

4. On the Design contextual tab, in the Layout group, click Grand Totals and then 

click On for columns only.

Excel 2007 removes the cells that calculate each row’s grand total.

USE thethe EditingEditing workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\PivotTablesMy Documents\Microsoft Press\Excel SBS\PivotTables folder.folder.

OPEN thethe EditingEditing workbook.workbook.
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Editing PivotTables
5. On the Quick Access Toolbar, click the Undo button.

Excel 2007 reverses the last change.

6. Right-click any data cell in the PivotTable, point to Summarize Data By, and then 

click Average.

Excel 2007 changes the Value fi eld summary operation.

7. On the Quick Access Toolbar, click the Undo button.

Excel 2007 reverses the last change.

8. Right-click any data cell in the PivotTable and then click Value Field Settings.

The Value Field Settings dialog box appears.

9. Click the Show values as tab.

The Show values as tab appears.

10. Click the Show values as fi eld down arrow and then click % of row.

11. Click OK.

Excel 2007 changes how it calculates the values in the PivotTable.
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12. On the Quick Access Toolbar, click the Undo button.

Excel 2007 reverses the last change.

13. On the Design tab, in the Layout group, click Subtotals and then click Show All 
Subtotals at Bottom of Group.

Excel 2007 displays subtotals in the workbook.

14. On the tab bar, click the Package Summary sheet tab.

The Package Summary worksheet appears.

15. In cell C4, type =, but do not press F.

16. On the tab bar, click the PivotTable sheet tab.

The PivotTable worksheet appears.

17. Click cell K32 and then press F.

Excel 2007 creates the formula =GETPIVOTDATA(“Volume”,PivotTable!$A$3,”Year”,

2007) in cell C4.
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CLOSE the Focusing workbook.

Formatting PivotTables
PivotTables are the ideal tools for summarizing and examining large data tables, even 

those containing in excess of 10 or even 100,000 rows. Even though PivotTables often 

end up as compact summaries, you should do everything you can to make your data 

more comprehensible. One way to improve your data’s readability is to apply a number 

format to the PivotTable Values fi eld. To apply a number format to a fi eld, right-click any 

cell in the fi eld and then click Number Format to display the Format Cells dialog box. 

Select or defi ne the format you want to apply and then click OK to enact the change.

See Also For more information on selecting and defi ning cell formats by using the Format 
Cells dialog box, see “Formatting Cells” in Chapter 5.

Analysts often use PivotTables to summarize and examine organizational data with an 

eye to making important decisions about the company. For example, chief operating 

 offi cer Jenny Lysaker might examine monthly package volumes handled by Consolidated 

Messenger and notice that there’s a surge in package volume during the winter months 

in the United States.

CLOSE the Focusing workbook.
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Excel 2007 extends the capabilities of your PivotTables by enabling you to apply a 

 conditional format to the PivotTable cells. What’s more, you can select whether to apply 

the conditional format to every cell in the Values area, to every cell at the same level as 

the selected cell (that is, a regular data cell, a subtotal cell, or a grand total cell) or to ev-

ery cell that contains or draws its values from the selected cell’s fi eld (such as the Volume 

fi eld in the previous example).

To apply a conditional format to a PivotTable fi eld, click a cell in the Values area. On the 

Home tab, in the Styles group, click Conditional Formatting and then create the desired 

conditional format. After you do, Excel 2007 displays a Formatting Options smart tag, 

which offers three options on how to apply the conditional format:

  Selected cells, which applies the conditional format to the selected cells only

  All cells showing “Sum of fi eld_name” values, which applies the conditional format 

to every cell in the data area, regardless of whether the cell is in the data area, a 

subtotal row or column, or a grand total row or column

  All cells showing “Sum of fi eld_name” values for fi elds, which applies the 

 conditional format to every cell at the same level (for example, data cell, subtotal, 

or grand total) as the selected cells

See Also For more information on creating conditional formats, see “Changing the 
Appearance of Data Based on Its Value” in Chapter 5.
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In Excel 2003 and earlier versions of the program, you were limited to a small number 

of formatting styles, called autoformats, which you could apply to a PivotTable. In Excel 

2007, you can take full advantage of the Microsoft Offi ce system enhanced format-

ting capabilities to apply existing formats to your PivotTables. Just as you can create 

data table formats, you can also create your own PivotTable formats to match your 

 organization’s desired color scheme.

To apply a PivotTable style, click any cell in the PivotTable and then, on the Design 

 contextual tab, in the PivotTable Styles group, click the gallery item representing the 

style you want to apply. If you want to create your own PivotTable style, click the More 

button in the PivotTable Styles gallery (in the lower-right corner of the gallery) and then 

click New PivotTable Style to display the New PivotTable QuickStyle dialog box.

Type a name for the style in the Name fi eld, click the fi rst table element you want to 

 customize, and then click Format. Use the controls in the Format Cells dialog box to 

change the element’s appearance. After you click OK to close the Format Cells dia-

log box, the New PivotTable Quick Style dialog box Preview pane displays the style’s 

 appearance. If you want Excel 2007 to use the style by default, select the Set as default 

PivotTable quick style for this document check box. After you fi nish creating your for-

mats, click OK to close the New PivotTable Quick Style dialog box and save your style.

The Design contextual tab contains many other tools you can use to format your 

PivotTable, but one of the most useful is the Banded Columns check box, which you can 

fi nd on the Design contextual tab, in the PivotTable Style Options group. If you select 

a PivotTable Style that offers banded rows as an option, selecting the Banded Rows 

check box turns banding on. If you prefer not to have Excel 2007 band the rows in your 

PivotTable, clearing the check box turns banding off.
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In this exercise, you’ll apply a number format to a PivotTable values fi eld, apply a 

PivotTable style, create your own PivotTable style, give your PivotTable banded rows, and 

apply a conditional format to a PivotTable.

USE the Formatting workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\PivotTables folder.

OPEN the Formatting workbook.

1. On the PivotTable worksheet, right-click any data cell and then click Number 
Format.

The Format Cells dialog box appears.

2. In the Category list, click Number.

The Number tab page appears.

3. In the Decimal places fi eld, type 0.

4. Select the Use 1000 Separator (,) check box.

5. Click OK.

Excel 2007 reformats your PivotTable data.

USE thethe FormattingFormatting workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\PivotTablesMy Documents\Microsoft Press\Excel SBS\PivotTables folder.folder.

OPEN thethe FormattingFormatting workbook.workbook.
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Formatting PivotTables
6. If necessary, on the Design contextual tab, in the PivotTable Style Options group, 

select the Banded Rows check box.

7. On the Design contextual tab, in the PivotTable Styles group, click the third style 

from the left (when you point your mouse pointer to it, Excel 2007 displays a 

ScreenTip that reads Pivot Style Light 2).

Excel 2007 applies the PivotTable style.
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8. On the Design contextual tab, in the PivotTable Styles group, click the More 

 button in the lower-right corner of the style gallery.

The gallery expands.

9. Click New PivotTable Style.

The New PivotTable Quick Style dialog box appears.

10. In the Name fi eld, type Custom Style 1.

11. In the Table Element list, click Header Row and then click Format.

The Format Cells dialog box appears.

12. On the Font tab, click the Color fi eld down arrow and then click the white square.

13. On the Border tab, in the Presets area, click Outline.

14. On the Fill tab, in the Background Color area, click the purple square at the lower-

right corner of the color palette.

15. Click OK.

The Format Cells dialog box disappears, and the style change appears in the 

Preview pane of the New PivotTable Quick Style dialog box.

16. In the Table Element list, click Second Row Stripe and then click Format.

The Format Cells dialog box appears.

17. On the Fill tab, in the middle part of the Background Color section, click the eighth 

square in the second row (it’s a light, dusty purple).

18. Click OK twice.

The Format Cells dialog box disappears, and your format appears in the PivotTable 
Styles gallery.
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Formatting PivotTables
19. Click the new style.

Excel 2007 formats your PivotTable using your custom PivotTable style.

20. On the Design contextual tab, in the PivotTable Style Options group, clear the 

Banded Rows check box.

Excel 2007 removes the banding from your PivotTable.
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 21. Select the cell ranges K6:K17 and K20:K31.

 22. On the Home tab, in the Styles group, click Conditional Formatting, point to Color 
Scales, and then click the second color scale in the top row (it’s a three-color scale 

with red at the top).

Excel 2007 applies the conditional format to the selected cells.

CLOSE the Formatting workbook.

Creating PivotTables from External Data
Although most of the time you will create PivotTables from data stored in Excel 2007 

worksheets, you can also bring data from outside sources into Excel 2007. For example, 

you might need to work with data created in another spreadsheet program with a fi le 

format that Excel 2007 can’t read directly. Fortunately, you can transfer worksheets from 

one program to another by exporting the data from the original program into a text fi le, 

which Excel 2007 then translates into a worksheet.

Spreadsheet programs store data in cells, so the goal of representing spreadsheet data 

in a text fi le is to indicate where the contents of one cell end and those of the next cell 

CLOSE the Formatting workbook.
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begin. The character that marks the end of a cell is a delimiter, in that it marks the end 

(or “limit”) of a cell. The most common cell delimiter is the comma, so the delimited 

sequence 15, 18, 24, 28 represents data in four cells. The problem with using commas 

to delimit fi nancial data is that larger values—such as 52,802—can be written by using 

commas as thousands markers. To avoid confusion when importing a text fi le, the most 

commonly used delimiter for fi nancial data is the Tab character.

To import data from a text fi le, on the Data tab, in the Get External Data group, click 

From Text to display the Import Text File dialog box.

From within the Import Text File dialog box, you browse to the directory that  contains 

the text fi le you want to import. Double-clicking the fi le launches the Text Import 

Wizard.
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The fi rst page of the Text Import Wizard enables you to indicate whether the data fi le 

you are importing is Delimited or Fixed Width; Fixed Width means that each cell value 

will fall within a specifi c position in the fi le. Clicking Next to accept the default choice, 

Delimited (which Excel 2007 assigns after examining the data source you selected), 

 advances you to the next wizard screen.

This screen enables you to choose the delimiter for the fi le (in this case, Excel 2007 

 detected tabs in the fi le and selected the Tab check box for you) and gives you a preview 

of what the text fi le will look like when imported. Clicking Next advances you to the fi nal 

wizard screen.

This screen enables you to change the data type and formatting of the columns in your 

data list. Because you’ll assign number styles and PivotTable Quick Styles after you cre-

ate the PivotTable, you can click Finish to import the data into your worksheet. After the 

data is in Excel 2007, you can work with it normally.
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In this exercise, you’ll import a data list into Excel 2007 from a text fi le and then create a 

PivotTable based on that list.

BE SURE to start Excel 2007 before beginning this exercise.

 1. On the Data tab, in the Get External Data group, click From Text.

The Import Text File dialog box appears.

 2. Navigate to the My Documents\Microsoft Press\Excel SBS\PivotTables folder and 

then double-click Creating.txt.

The Text Import Wizard appears.

 3. Verify that the Delimited option button is selected and then click Next.

The next Text Import Wizard page appears.

 4. In the Delimiters section, verify that the Tab check box is selected and also verify 

that the data displayed in the Data preview area refl ects the structure you expect.

 5. Click Finish.

The Import Data dialog box appears.

 6. Verify that the Existing worksheet option button is selected and then click OK.

Excel 2007 imports the data into your workbook.

 7. On the Insert tab, in the Tables group, click PivotTable.

The Create PivotTable dialog box appears.

 8. Verify that the Select a table or range option button is selected, that the range 

Sheet1$A$1:$H$6571 appears in the Table/Range fi eld, and that the New 
Worksheet option button is selected.

 9. Click OK.

Excel 2007 creates a new worksheet.

 10. In the PivotTable Field List task pane, drag the Volume fi eld header to the Values 
area.

 11. In the PivotTable Field List task pane, drag the Weekday fi eld header to the 

Column Labels area.

BE SURE to start Excel 2007 before beginning this exercise.to start Excel 2007 before beginning this exercise.



234  Chapter 10 Creating Dynamic Lists with PivotTables
 12. In the PivotTable Field List task pane, drag the Center fi eld header to the Row 
Labels data area.

 13. On the Quick Access Toolbar, click the Save button.

The Save As dialog box appears.

 14. Browse to the My Documents\Microsoft Press\Excel SBS\PivotTables folder.

 15. In the File name fi eld, type Imported Data.

 16. Click OK.

Excel 2007 saves your fi le.

CLOSE the Imported Data workbook.

Key Points
  A PivotTable is a versatile tool you can use to rearrange your data dynamically, 

enabling you to emphasize different aspects of your data without creating new 

worksheets.

CLOSE the Imported Data workbook.
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  PivotTable data must be formatted as a list. Using a data table as the PivotTable 

data source enables you to streamline the creation process by referring to the table 

name instead of being required to select the entire range that contains the data 

you want to summarize.

  Excel 2007 comes with many attractive styles for PivotTables; you’ll probably fi nd 

one you like.

  The PivotTable Field List task pane enables you to create your PivotTable by using a 

straightforward, compact tool.

  Just as you can limit the data shown in a static worksheet, you can use fi lters to 

limit the data shown in a PivotTable.

  If you have data in a compatible format, such as a text fi le, you can import that 

data into Excel 2007 and create a PivotTable from it.
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 11 11 Creating Charts Creating Charts
  and Graphics  and Graphics

In this chapter, you will learn to:

  Create charts.

  Customize the appearance of charts.

  Find trends in your data.

  Create dynamic charts using PivotCharts.

  Create diagrams by using SmartArt.

When you enter data into a Microsoft® Offi ce Excel® 2007 worksheet, you create a 

 record of important events, whether they are individual sales, sales for an hour of a day, 

or the price of a product. What a list of values in cells can’t communicate easily, however, 

is the overall trends in the data. The best way to communicate trends in a large collec-

tion of data is by creating a chart, which summarizes data visually.

You have a great deal of control over your charts’ appearance—you can change the 

color of any chart element, choose a different chart type to better summarize the under-

lying data, and change the display properties of text and numbers in a chart. If the data 

in the worksheet used to create a chart represents a progression through time, such as 

sales over a number of months, you can have Offi ce Excel 2007 extrapolate future sales 

and add a trend line to the graph representing that prediction.

Just as you can create PivotTable® dynamic views to reorganize a data list dynamically, 

you can create a PivotChart® dynamic view that refl ects the contents and organization 

of the associated PivotTable. You can also create diagrams, such as organizational charts, 

that are useful in many organizations.

In this chapter, you’ll learn how to create a chart and customize its elements, fi nd trends 

in your overall data, create dynamic charts, and create and format diagrams.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.
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Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Creating Charts
To create a chart, select the data you want to summarize visually and then, on the Insert 

tab, in the Charts group, click the type of chart you want to create to have Excel 2007 

display the available chart subtypes. 

When you click your desired chart subtype, Excel 2007 creates the chart using the 

 default layout and color scheme defi ned in your workbook’s theme. The following 

graphic shows a column chart and the data used to create it.
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If Excel 2007 doesn’t plot your data the way you want, you can change the axis on which 

Excel 2007 plots a data column. The most common situation in which Excel 2007 plots 

data incorrectly is when the column you want to provide values for the horizontal axis 

contains numerical data. For example, if your data list contains a Year column and a 

Volume column, Excel 2007 plots both of those columns in the body of the chart and 

creates a sequential series to provide values for the horizontal axis. If your data set con-

tains one column of text values and another column of numerical values, the Excel 2007 

chart engine plots the data correctly.

You can change which data it applies to the vertical axis (also known as the y-axis) and 

the horizontal axis (also known as the x-axis). To make that change, select the chart and 

then, on the Design tab, in the Data group, click Select Data to display the Select Source 

Data dialog box.
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The Year column doesn’t belong in the Legend Entries (Series) pane, which corresponds 

to a column chart’s vertical axis. To remove a column from an axis, select the column’s 

name and then click Remove. To add the column to the Horizontal (Category) Axis 

Labels pane, click that pane’s Edit button to display the Axis Labels dialog box.

In the Axis Labels dialog box, click the Contract Dialog button at the right edge of the 

Axis Label Range fi eld, select the cells to provide the values for the horizontal axis (not 

including the column header, if any), click the Expand Dialog button, and then click OK. 

Click OK again to close the Select Data Source dialog box and revise your chart.

After you create your chart, you can change its size to refl ect whether you want the 

chart to dominate its worksheet or take on a role as another informative element on 

the worksheet. For example, Gary Schare, the chief executive offi cer of Consolidated 

Messenger, could create a dashboard to summarize the performance of each of his 

company’s business units. In that case, he would display multiple measures on the same 

worksheet, so he would want to make his charts as small as possible without sacrifi cing 

comprehensibility.
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Creating Charts
To resize a chart, select the chart and then drag one of the handles on the chart’s edges. 

Handles in the middle of the edges enable you to resize the chart in one direction. 

Dragging a handle on the left or right edge enables you to make the chart narrower or 

wider, whereas dragging the handles on the chart’s upper and lower edges enable you 

to make the chart shorter or taller. Dragging a corner handle enables you to change the 

chart’s height and width at the same time; holding down the Shift key as you drag the 

corner handle changes the chart’s size proportionally.

Just as you can control a chart’s size, you can also control its location. To move a chart 

within a worksheet, drag the chart to the desired location. If you want to move the 

chart to a new worksheet, click the chart and then, on the Design contextual tab, in the 

Location group, click Move Chart to display the Move Chart dialog box.

To move the chart to a new chart sheet, select the New sheet option button and type 

the new sheet’s name in the accompanying fi eld. Selecting the New sheet option creates 

a chart sheet, which contains only your chart. You can still resize the chart on that sheet, 

but when Excel 2007 creates the new chart sheet, the chart takes up the full sheet. 

To move the chart to an existing worksheet, select the Object In option button, click 

the accompanying fi eld down arrow, and then click the worksheet to which you want to 

move the chart.

In this exercise, you’ll create a chart, change how the chart plots your data, resize your 

chart, move your chart within a worksheet, and move your chart to its own chart sheet.

USE the Yearly Package Volume workbook in the practice fi le folder for this topic. This 

practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Charting folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the Yearly Package Volume workbook.

1. On the Data worksheet, click any cell in the data table.

USE thethe Yearly Package VolumeYearly Package Volume workbook in the practice fi le folder for this topic. This  workbook in the practice fi le folder for this topic. This 

practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\ChartingMy Documents\Microsoft Press\Excel SBS\Charting folder. folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe Yearly Package VolumeYearly Package Volume workbook.workbook.
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2. On the Insert tab, in the Charts group, click Bar, and then, in the 2D Bar group, 

click the fi rst chart subtype (the chart subtype is named Clustered Bar).

Excel 2007 creates the chart, with both the Year and Volume data series plotted in 

the body of the chart.

3. On the Design tab, in the Data group, click Select Data.

The Select Data Source dialog box appears.

4. In the Legend Entries (Series) area, click Year.

5. Click Remove.

The Year series disappears.

6. In the Horizontal (Category) Axis Labels area, click Edit.

The Axis Labels dialog box appears.

7. Select cells B3:B9 and then click OK.

The Axis Labels dialog box disappears, and the Select Data Source dialog box 

 reappears with the years in the Horizontal (Category) Axis Labels area.



   243

 

 

 

 

 

Creating Charts
8. Click OK.

Excel 2007 redraws your chart, using the years as the values for the horizontal axis.

9. Position the mouse pointer on an edge of the chart.

The mouse pointer changes to a four-headed arrow.

10. Drag the chart up and to the left so that it covers the data table.

11. On the Design tab, in the Location group, click Move Chart.

The Move Chart dialog box appears.

12. Select the New sheet option button and then click OK.

Your chart appears on its own chart sheet.
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CLOSE the Yearly Package Volume workbook.

Customizing the Appearance of Charts
If you want to change a chart’s appearance, select the chart and then, on the Design tab, 

click a style in the Chart Styles gallery. The gallery contains far more chart styles than are 

shown in the ribbon—to select a new look for your chart, click the More button at the 

gallery’s lower-right corner and then click the design you want.

Important The styles in the Chart Styles gallery are tied to your workbook’s theme. If you 

change your workbook’s theme, Excel 2007 changes your chart’s appearance to refl ect the 

new theme’s colors.

When you create a chart by using the tools in the Insert tab’s Charts group, Excel 2007 

creates an attractive chart that focuses on the data. In most cases, the chart has a title, 

legend (list of data series displayed in the chart), horizontal lines in the body of the 

chart to make it easier to discern individual values, and axis labels. If you want to cre-

ate a chart that has more or different elements, such as by adding data labels to each 

data point plotted on your chart, you can do so by selecting the chart and then, on the 

Design tab, in the Chart Layouts group, clicking the layout you want.

If you don’t fi nd the exact chart layout you like, you can use the tools on the Layout 

 contextual tab to control each element’s appearance and placement.

CLOSE the Yearly Package Volume workbook.
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In the Axes group, clicking Gridlines enables you to determine whether the chart  displays 

horizontal and vertical gridlines and, if it does, at what value intervals they should 

appear. 

In addition to changing your chart’s layout, you can control the appearance of each 

element within the chart. To select a chart element to format, click that element. For 

example, if you want to change the formatting of the data series named Volume in the 

column chart shown in the previous graphic, clicking any column in the series selects the 

entire series. Any formatting changes you make now apply to every point in the entire 

series. If you want to change a single data point, select the entire series and then click 

the chart element (for example, a column) that represents the data point you want to 

change. For example, you can highlight the column representing the year 2005 in the 

chart shown in the previous graphic.

You can display a list of the selectable chart elements by selecting the chart and then, on 

the Format tab, in the Current Selection group, clicking the Chart Elements control down 

arrow. Just click the desired chart element to select it.

After you select the chart element, you can drag one of the elements’ handles to resize 

the chart or drag the element to another location within the chart. To change the chart 

element’s format, use the tools and dialog expanders in the Shape Styles, Word Art 

Styles, Arrange, and Size groups to change the element’s appearance. You can also  select 

the chart element and then, on the Format tab, in the Current Selection group, click 

Format Selection to display a Format dialog box that enables you to change the chart 

element’s fi ll, line, line style, shadow, 3-D format, and alignment.
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If you think you want to apply the same set of changes to charts you’ll create in the 

 future, you can save your chart as a chart template. When you select the data you want 

to summarize visually and apply the chart template, you’ll create consistently format-

ted charts in a minimum of steps. To save a chart as a chart template, select the chart 

you want to use as a template and then, on the Design tab, in the Type group, click Save 

Template. Use the controls in the dialog box that appears to name and save your tem-

plate. Then, to create a chart based on that template, select the data you want to sum-

marize and then, on the Insert tab, in the Charts group, click any chart type, and then 

click All Chart Types to display the Create Charts dialog box. Under Choose a Chart Type, 

click Templates, and then click the template you want to use.

Tip You can apply a template to an existing chart by selecting the chart and then, on the 

Design tab, in the Type group, clicking Change Chart Type to display the Change Chart Type 

dialog box. Click Templates and then click the template you want to use.

In this exercise, you’ll change a chart’s layout, apply a new Chart Style, reposition the 

chart’s legend, change the number format of the values on the vertical axis, and save the 

chart as a chart template.

USE the Volume by Center workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Charting folder.

OPEN the Volume by Center workbook.

USE thethe Volume by CenterVolume by Center workbook in the practice fi le folder for this topic. This practiceworkbook in the practice fi le folder for this topic. This practicerr
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\ChartinMy Documents\Microsoft Press\Excel SBS\Charting folder.g folder.

OPEN thethe Volume by CenterVolume by Center workbook.workbook.rr
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Customizing the Appearance of Charts
1. On the Presentation worksheet, select the chart.

2. On the Design tab, in the Chart Layouts group, click the fi rst chart layout (its 

screen tip says the layout name is Layout 1).

Excel 2007 changes the chart’s layout.

3. On the Design contextual tab, in the Chart Styles group, click the More button.

The Chart Styles gallery expands.

4. Click Style 7 (it’s the next-to-last style on the top row of the gallery).

Excel 2007 changes the chart’s style.

5. Right-click the values on the vertical axis and then click Format Axis.

The Format Axis dialog box appears.

6. In the left pane, click Number.

The Format Axis dialog box displays the Number tab.

7. In the Category list, click Number.

The Format Axis dialog box displays the Number style’s controls.
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8. In the Decimal places fi eld, type 0.

9. Select the Use 1000 Separator (,) check box.

10. Click Close.

Excel 2007 changes the format of the values on the vertical axis.
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Customizing the Appearance of Charts
11. On the Design contextual tab, in the Type group, click Save As Template.

The Save Chart Template dialog box appears.

12. In the File name fi eld, type Cool Blue.

13. Click Save.

Excel 2007 saves your template.

14. On the tab bar, click the Yearly Summary sheet tab.

The Yearly Summary worksheet appears.

15. Select the chart and then, on the Design tab, in the Type group, click Change 
Chart Type.

The Change Chart Type dialog box appears.

16. Click Templates.

The My Templates list appears.

17. Click the Cool Blue custom template and then click OK.

Excel 2007 applies the template to your chart.

CLOSE the Volume by Center workbook.CLOSE the Volume by Center workbook.r
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Finding Trends in Your Data
You can use the data in Excel 2007 workbooks to discover how your business has 

 performed in the past, but you can also have Excel 2007 make its best guess as to future 

shipping revenues if the current trend continues. As an example, consider the following 

graph for Consolidated Messenger.

This graph shows the fl eet maintenance costs for the years 2001 through 2006. The total 

has increased from 2001 to 2006, but the growth hasn’t been uniform, so guessing how 

much maintenance costs would increase if the overall trend continued would require 

 diffi cult mathematical computations. Fortunately, Excel 2007 knows that math. To have 

Excel 2007 project future values in the maintenance costs data series, click the chart 

and then, on the Layout tab, in the Analysis group, click Trendline. Click More Trendline 

Options to display the Format Trendline  dialog box.
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Finding Trends in Your Data
The Trendline Options tab page of the Format Trendline dialog box enables you to 

choose the data distribution that Excel 2007 should expect when it makes its projec-

tion. The right choice for most business data is Linear—the other distributions (such as 

Exponential, Logarithmic, and Polynomial) are used for scientifi c and operations research 

applications.

Tip If you don’t know which distribution to choose, try Linear fi rst.

After you pick the distribution type, you need to tell Excel 2007 how far ahead to project 

the data trend. The horizontal axis of the chart used in this example shows revenues by 

year from 2001 to 2006. To tell Excel 2007 how far in the future to look, type a number 

in the Forecast section’s Forward box. In this case, to look ahead one year, type 1 in the 

Forward box and then click OK to add the trend line to the chart.

Tip When you click the Trendline button in the Analysis group, one of the options 

Excel 2007 displays is Linear Forecast Trendline, which adds a trend line with a two-period 

forecast.

As with other chart elements, you can double-click the trend line to open a formatting 

dialog box and change the line’s appearance.

In this exercise, you’ll add a trend line to a chart.

USE the Future Volumes workbook in the practice fi le folder for this topic. This practice fi le 

is located in the My Documents\Microsoft Press\Excel SBS\Charting folder.

OPEN the Future Volumes workbook.

1. Select the chart.

2. On the Layout contextual tab, in the Analysis group, click Trendline and then click 

More Trendline Options.

The Format Trendline dialog box appears.

3. In the Trend/Regression Type area, select the Linear option button.

4. In the Forecast area, in the Forward fi eld, type 3.

5. Click Close.

Excel 2007 adds the trend line to the chart.

USE thethe Future VolumesFuture Volumes workbook in the practice fi le folder for this topic. This practice fi le  workbook in the practice fi le folder for this topic. This practice fi le 

is located in theis located in the My Documents\Microsoft Press\Excel SBS\ChartingMy Documents\Microsoft Press\Excel SBS\Charting folder. folder.

OPEN thethe Future VolumesFuture Volumes workbook. workbook.
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CLOSE the Future Volumes workbook.

Creating Dynamic Charts Using PivotCharts
Just as you can create tables that you can reorganize on the fl y to emphasize different 

aspects of the data in a list, you can also create dynamic charts, or PivotCharts, to refl ect 

the contents and organization of a PivotTable.

Creating a PivotChart is fairly straightforward. Just click any cell in a list or data table 

you would use to create a PivotTable, and then click the Insert tab. In the Tables group, 

click the PivotTable button down arrow and then click PivotChart. In a worksheet with an 

existing PivotTable, click a cell in the PivotTable, display the Insert tab, and then, in the 

Charts group, click the type of chart you want to create.

CLOSE the Future Volumes workbook.
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Any changes to the PivotTable on which the PivotChart is based are refl ected in the 

PivotChart. For example, if the data in an underlying data list changes, clicking the 

Refresh Data button on the Options contextual tab, in the Data group, will change the 

PivotChart to refl ect the new data. Also, you can fi lter the contents of the PivotTable 

shown here by clicking the Year down arrow, clicking 2003 from the list that appears, 

and then clicking OK. The PivotTable then shows revenues from 2003. The PivotChart 

also refl ects the fi lter.
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See Also For more information on manipulating PivotTables, see “Creating Dynamic Lists with 
PivotTables” in Chapter 10.

The PivotChart has controls with which you can fi lter the data in the PivotChart and 

PivotTable. Clicking the Weekday down arrow, clicking (All) from the list that appears, 

and then clicking OK will restore the PivotChart to its original confi guration.

If you ever want to change the chart type of an existing chart, you can do so by selecting 

the chart and then, on the Design tab, in the Type group, clicking Change Chart Type to 

display the Change Chart Type dialog box. When you select the desired type and click 

OK, Excel 2007 re-creates your chart.

Important If your data is the wrong type to be represented by the chart type you select, 

Excel 2007 displays an error message.

In this exercise, you create a PivotTable and associated PivotChart, change the 

 underlying data and update the PivotChart to refl ect that change, and then change 

the PivotChart’s type.
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Creating Dynamic Charts Using PivotCharts
USE the Revenue Analysis workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Charting folder.

OPEN the Revenue Analysis workbook.

1. On the Through 2006 worksheet, click any cell in the data table.

2. On the Insert tab, in the Tables group, click the PivotTable button down arrow and 

then click PivotChart.

The Create PivotTable with PivotChart dialog box appears.

3. Verify that the QuarterlyRevenue table appears in the Table/Range fi eld and that 

the New Worksheet option button is selected.

4. Click OK.

Excel 2007 creates the PivotTable and associated PivotChart.

5. In the PivotTable Field List task pane, drag the Center fi eld header from the 

Choose fi elds to add to report area to the Legend Fields area.

6. In the PivotTable Field List task pane, drag the Year fi eld header from the Choose 
fi elds to add to report pane to the Axis Fields area.

7. In the PivotTable Field List task pane, drag the Quarter fi eld header from the 

Choose fi elds to add to report area to the Axis Fields area, positioning it below 

the Year fi eld header.

8. In the PivotTable Field List task pane, drag the Revenue fi eld header from the 

Choose fi elds to add to report area to the Values area.

Excel 2007 updates the PivotChart to refl ect the fi eld placements.

USE thethe Revenue AnalysisRevenue Analysis workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\ChartingMy Documents\Microsoft Press\Excel SBS\Charting folder.folder.

OPEN thethe Revenue AnalysisRevenue Analysis workbook. workbook.



256  Chapter 11 Creating Charts and Graphics 

 

 

 

 

 

 

9. On the tab bar, click the 2007 sheet tab.

The 2007 worksheet appears.

10. Select the data in cells B2:E10 and then press H+c.

Excel 2007 copies the data to the Clipboard.

11. On the tab bar, click the Through 2006 sheet tab.

The Through 2006 sheet tab appears.

12. Select cell B147 and then press H+v.

Excel 2007 pastes the data into the worksheet and includes it in the table.

13. On the tab bar, click the tab of the worksheet that contains the PivotChart.

The PivotChart appears.

14. Select the PivotChart and then, on the Analyze contextual tab, in the Data group, 

click Refresh.

Excel 2007 adds the new table data to your PivotChart.
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Creating Dynamic Charts Using PivotCharts
15. On the Design contextual tab, in the Type group, click Change Chart Type.

The Change Chart Type dialog box appears.

16. Click Line and then click the second Line chart subtype.

17. Click OK.

Excel 2007 changes your PivotChart to a line chart.

18. In the PivotTable Field List, in the Choose fi elds to add to report area, click the 

Center fi eld header.

19. Click the down arrow that appears and then, in the menu that appears, clear the 

Select All check box.

Excel 2007 removes the check boxes from the fi lter list items.

20. Select the Northeast check box and then click OK.

Excel 2007 fi lters the PivotChart.
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C

CLOSE the Revenue Analysis workbook.

reating Diagrams by Using SmartArt
As an international delivery company, Consolidated Messenger’s business processes 

are quite complex. Many times, chief operating offi cer Jenny Lysaker summarizes the 

company’s processes for the board of directors by creating diagrams. Excel 2007 has just 

the tool she needs to create those diagrams: SmartArt. To create a SmartArt graphic, on 

the Insert tab, in the Illustrations group, click SmartArt to display the Choose a SmartArt 

Graphic dialog box.

CLOSE the Revenue Analysis workbook.
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See Also For more information on adding pictures from existing fi les to your worksheets, see 
“Adding Images to a Document” in Chapter 5.

Clicking one of the buttons in the Choose a SmartArt Graphic dialog box selects the 

type of diagram the button represents and causes a description of the diagram type 

to appear in the rightmost pane of the dialog box. Clicking All displays every available 

SmartArt graphic type. The following table lists the seven types of diagrams you can 

 create by using the Choose a SmartArt Graphic dialog box.

Tip Some of the diagram types can be used to illustrate several types of relationships. Be 

sure to examine all your options when you decide on the type of diagram to use to illustrate 

your point.

Diagram Description

List Shows a series of items that typically require a large 

amount of text to explain.

Process Shows a progression of sequential steps through a 

task, process, or workfl ow.

Hierarchy Shows hierarchical relationships, such as those within a 

company.

Cycle Shows a process with a continuous cycle or to show 

relationships of a core element.

Relationship Shows the relationships between two or more items.

Pyramid diagram Shows proportional, foundation-based, or hierarchical 

relationships such as a series of skills.

Matrix diagram Shows the relationship of components to a whole by 
using quadrants.
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After you click the button representing the type of diagram you want to create, clicking 

OK adds the diagram to your worksheet. 

While the diagram is selected, Excel 2007 displays the SmartArt Tools contextual tabs 

named Design and Format. You can use the tools on the Design contextual tab to 

change the graphic’s layout, style, or color scheme. The Design contextual tab also con-

tains the Create Graphic group, which is home to tools you can use to add a shape to 

the SmartArt graphic, add text to the graphic, and promote or demote shapes within the 

graphic.

As an example, consider a process diagram that describes how Consolidated Messenger 

handles a package within one of the company’s regional distribution centers.
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The Text Pane, located to the left of the SmartArt graphic, enables you to add text to a 

shape without having to click and type within the shape. If you enter the process steps 

in the wrong order, you can move a shape by right-clicking the shape you want to move 

and then clicking Cut from the shortcut menu that appears. To paste the shape back into 

the graphic, right-click the shape to the left of where you want the pasted shape to ap-

pear and then click Paste. For example, if you have a fi ve-step process and accidentally 

switch the second and third steps, you can move the third step to the second position 

by right-clicking the third step and then clicking Cut. Then right-click the fi rst shape and 

click Paste.

If you want to add a shape to a SmartArt graphic, such as add a step to a process, click 

a shape next to the position you want the new shape to occupy and then, on the Design 

contextual tab, in the Create Graphic group, click Add Shape, and then click the option 

that represents where you want the new shape to appear in relation to the selected 

shape.

Note The options that appear when you click Add Shape depend on the type of SmartArt 

graphic you created and which graphic element is selected. For an organizational chart, the 

options are Add Shape After, Add Shape Before, Add Shape Above, Add Shape Below, and 

Add Assistant.



262  Chapter 11 Creating Charts and Graphics 

 

 

 

 

You can edit the graphic’s elements by using the controls on the Formatting contextual 

tab as well as by right-clicking the shape and then clicking Format Shape to display the 

Format Shape dialog box. If you have selected the text in a shape, you can use the tools 

in the Home tab’s Font group to change the text’s appearance.

Tip The controls in the Format Shape dialog box enable you to change the shape’s fi ll 

color, borders, shadow, 3-D appearance, and text box properties.

In this exercise, you create an organization chart, fi ll in the shapes, delete a shape, add a 

shape, change the layout of the diagram without changing the information it embodies, 

and change the formatting of one of the diagram elements.

USE the Org Chart workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Charting folder.

OPEN the Org Chart workbook.

1. On the Insert tab, in the Illustrations group, click SmartArt.

The Choose a SmartArt Graphic dialog box appears.

2. Click Hierarchy.

The Hierarchy graphic subtypes appear.

3. Click the fi rst subtype (Organization Chart) and then click OK.

Excel 2007 creates the organization chart graphic.

4. In the Type your text here pane, in the fi rst text box, type CEO and then press the 

down arrow key.

The value CEO appears in the shape at the top level of the organization chart.

USE thethe Org ChartOrg Chart workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le istt
located in thelocated in the My Documents\Microsoft Press\Excel SBS\ChartingMy Documents\Microsoft Press\Excel SBS\Charting folder. folder.

OPEN thethe Org ChartOrg Chart workbook.workbook.tt
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Creating Diagrams by Using SmartArt
5. In the SmartArt diagram, right-click the assistant box, located below the CEO 

shape, and then click Cut.

Excel 2007 removes the shape and moves the shapes on the third level of the orga-

nization chart to the second level.

6. Click the leftmost shape on the second level of the organization chart and then 

type COO.

7. Click the middle shape on the second level of the organization chart and then type 

CIO.

8. Click the rightmost shape on the second level of the organization chart and then 

type CFO.

9. Click the CFO shape, and then, on the Design contextual tab, in the Create Graphic 

group, click the Add Shape button down arrow and then click Add Shape Below.

A new shape appears below the CFO shape.

10. In the new shape, type Comptroller.

11. On the Design contextual tab, in the Layouts group, click the second layout.

Excel 2007 applies the new layout to your organization chart.
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12. Right-click the Comptroller shape and then click Format Shape.

The Format Shape dialog box appears.

13. If necessary, click the Fill category.

Excel 2007 displays the fi ll controls.

14. Verify that the Solid fi ll option button is selected, click the Color control, and then, 

in the Standard color area of the color picker, click the red square.

15. Click Close.

Excel 2007 changes the shape’s fi ll to red.
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CLOSE the Org Chart workbook.

CLOSE Excel 2007.

Key Points
  You can use charts to summarize large sets of data in an easy-to-follow visual 

format.

  You’re not stuck with the chart you create; if you want to change it, you can.

  If you format a lot of your charts the same way, creating a chart template can save 

you a lot of work in the future.

  Adding chart labels and a legend makes your chart much easier to follow.

  If your chart data represents a series of events over time (such as monthly or yearly 

sales), you can use trend line analysis to extrapolate future events based on the 

past data.

  A PivotChart enables you to rearrange your chart on the fl y, emphasizing different 

aspects of the same data without having to create a new chart for each view.

  Excel 2007 enables you to quickly create and modify common business and 

 organizational diagrams, such as organization charts and process diagrams.

CLOSE the Org Chart workbook.t

CLOSE Excel 2007.
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 12 12 PrintingPrinting

In this chapter, you will learn to:

  Add headers and footers to printed pages.

  Prepare worksheets for printing.

  Print data lists.

  Print parts of data lists.

  Print charts.

Microsoft® Offi ce Excel® 2007 gives you a wide range of tools to create and manipulate 

your data lists. By using fi lters, by sorting, and by creating PivotTables and charts, you 

can change your worksheets so that they convey the greatest possible amount of infor-

mation. After you confi gure your worksheet so that it shows your data to best advan-

tage, you can print your Offi ce Excel 2007 documents to use in a presentation or include 

in a report. You can choose to print all or part of any of your worksheets, change how 

your data and charts appear on the printed page, and even suppress any error messages 

that might appear in your worksheets.

In this chapter, you’ll learn how to print all or part of a data list, how to print charts, and 

how to add headers and footers to your worksheets.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need 

to install them from the book’s companion CD to their default location. See “Using the 

Book’s CD” on page xiii for more information.
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Adding Headers and Footers to Printed Pages
Changing how your data appears in the body of your worksheets can make your infor-

mation much easier to understand, but it doesn’t communicate when the worksheet was 

last opened or to whom it belongs. You could always add that information to the top 

of every printed page, but you would need to change the current date every time you 

opened the document. And if you wanted the same information to appear at the top of 

every printed page, any changes to the body of your worksheets could mean that you 

would need to edit your workbook so that the information appeared in the proper place.

If you want to ensure that the same information appears at the top or bottom of every 

printed page, you can do so by using headers or footers. (A header is a section that ap-

pears at the top of every printed page; a footer is a section that appears at the bottom 

of every printed page.) To create a header or footer in Excel 2007, you display the Insert 

tab and then, in the Text group, click Header & Footer to display the Header & Footer 

Tools Design contextual tab.

When you display your workbook’s headers and footers, Excel 2007 displays the work-

book in Page Layout view, which is new in Excel 2007. The Excel 2007 product team’s 

goal in creating Page Layout view was to show you exactly how your workbook will look 

when printed while still enabling you to edit your fi le, a capability not provided by Print 
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Preview. You can also switch to Page Layout view quickly by displaying the View tab and 

then, in the Workbook Views group, clicking Page Layout.

See Also For more information on editing your workbook in Print Preview mode, see the 
section titled “Previewing Worksheets Before Printing” later in this chapter.

Excel 2007 divides its headers and footers into left, middle, and right sections. When you 

move your mouse pointer over an editable header or footer section, Excel 2007 high-

lights the section to indicate that clicking the left mouse button will open that header or 

footer section for editing.

Important If you have a chart selected when you click the Header & Footer button on the 

Insert tab, Excel 2007 displays the Header/Footer page of the Page Setup dialog box instead 

of opening a header or footer section for editing.

When you click a header or footer section, Excel 2007 adds the Design contextual tab 

to the ribbon. The Design contextual tab holds a number of standard headers and foot-

ers, such as page numbers by themselves or followed by the name of the workbook. To 

add an Auto Header to your workbook, display the Design contextual tab and then, in 

the Auto Header & Footer group, click Auto Header and then click the Auto Header you 

want to apply. 
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You can also create custom headers by typing your own text or by using the controls in 

the Header & Footer Elements group to insert a date, time, worksheet name, or page 

number. Beginning with Excel 2002, you have had the option of adding a graphic to a 

header or footer. Adding a graphic such as a company logo to a worksheet enables you 

to identify the worksheet as referring to your company and helps reinforce your com-

pany’s identity if you include the worksheet in a printed report distributed outside your 

company. After you insert a graphic into a header or footer, the Format Picture button in 

the Header & Footer Elements group will become available. Clicking that button opens a 

dialog box with tools to edit your graphic. 

In this exercise, you will create a custom header for a workbook. You will add a graphic 

to the footer and then edit the graphic using the Format Picture dialog box.

USE the Revenue by Customer workbook in the practice fi le folder for this topic.  This 

 practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Printing folder.

BE SURE TO  start Excel 2007 before starting this exercise.

OPEN the Revenue by Customer workbook.

1. On the View tab, in the Workbook Views group, click Page Layout.

Excel 2007 displays your workbook in Page Layout view.

2. At the top of the worksheet, click Click to add header.

Excel 2007 opens the middle header section for editing.

USE thethe Revenue by CustomerRevenue by Customer workbook in the practice fi le folder for this topic.  Thisworkbook in the practice fi le folder for this topic.  Thisrr
practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\PrintingMy Documents\Microsoft Press\Excel SBS\Printing folder. folder.

BE SURE TO start Excel 2007 before starting this exercise.start Excel 2007 before starting this exercise.

OPEN thethe Revenue by CustomerRevenue by Customer workbook.workbook.rr
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Adding Headers and Footers to Printed Pages
3. In the middle header section, type Q1 2006 and then press F.

4. On the Design contextual tab, in the Header & Footer Elements group, click File 
Name.

Excel 2007 adds the &[File] code to the header.

5. To the right of the &[File] code, type a comma and then press S.

6. On the Design contextual tab, in the Header & Footer Elements group, click 

Current Date.

Excel 2007 changes the contents of the middle header section to &[File], &[Date].

7. Press D.

Excel 2007 highlights the right header section; the workbook name and current 

date appear in the middle header section.

8. On the Design contextual tab, in the Navigation group, click Go to Footer.

Excel 2007 highlights the right footer section.

9. Click the middle footer section.

10. On the Design contextual tab, in the Header & Footer Elements group, click 

Picture.

The Insert Picture dialog box appears.
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 11. Browse to the My Documents\Microsoft Press\Excel SBS\Printing folder and then 

double-click ConsolidatedMessenger.png.

The code &[Picture] appears in the middle footer section.

 12. Click any worksheet cell above the footer.

Excel 2007 displays the worksheet as it will be printed.

 13. Click the image in the footer and then, on the Design contextual tab, click Format 
Picture.

The Format Picture dialog box appears.

 14. If necessary, click the Size tab to display the Size tab page.

 15. In the Height fi eld, type 80% and then press F.

The Format Picture dialog box disappears.

 16. Click any worksheet cell above the footer. 

Excel 2007 displays the newly formatted picture.

CLOSE the Revenue by Customer workbook.

Preparing Worksheets for Printing
After you have your data and any headers or footers in your workbook, you can change 

your workbook properties to ensure that your worksheets display all your information 

and that printing is centered on the page.

CLOSE the Revenue by Customer workbook.r
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One of the workbook properties you can change is its margins, or the boundaries 

 between different sections of the printed page. You can view a document’s margins and 

where the contents of the header, footer, and body appear in relation to those margins 

in the Print Preview window.

You can drag each margin line to change the corresponding margin’s position, increasing 

or decreasing the amount of space allocated to each worksheet section. Do bear in mind 

that increasing the size of the header or footer reduces the size of the worksheet body, 

meaning that fewer rows can be printed on a page.

Excel 2007 comes with three margin settings: Normal, Wide, and Narrow. Excel 2007 

applies the Normal setting by default, but you can select any of the three options by 

displaying the Page Layout tab and then, in the Page Setup group, by clicking Margins. 

If you want fi ner control over your margins, click Custom Margins to display the 

Margins tab of the Page Setup dialog box.



274  Chapter 12 Printing
Another issue with printing worksheets is that the data in worksheets tends to be wider 

horizontally than a standard sheet of paper. For example, the data in the worksheet in 

the previous graphic is several columns wider than a standard piece of paper. You can 

use the controls on the Page Layout tab to change the alignment of the rows and col-

umns on the page. When the columns follow the long edge of a piece of paper, the page 

is laid out in portrait mode; when the columns follow the short edge of a piece of paper, 

it is in landscape mode. The following graphic displays the contents of the previous work-

sheet laid out in landscape mode.
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This arrangement is a better fi t, but not all the data fi ts on the printed page. This is 

where the tools in the Scale to Fit group on the Page Layout tab come to the rescue. You 

can use the tools in that group to have Excel 2007 reduce the size of the worksheet’s 

contents until the entire worksheet can be printed on a single page. You can make the 

same changes (and more) by using the controls in the Page Setup dialog box. To dis-

play the Page Setup dialog box, click the Page Layout tab and then click the Page Setup 

group dialog box launcher.

Previewing Worksheets Before Printing
You can view your Excel 2007 worksheet as it will be printed by clicking the Microsoft 

Offi ce Button, pointing to Print, and then clicking Print Preview. When you do, Excel 

2007 displays the active worksheet in the Print Preview window.

When the Print Preview window opens, it shows the active worksheet as it will be printed 

with its current settings. In the lower-left corner of the Print Preview window, Excel 2007 

indicates how many pages the worksheet will require when printed and the number of 

the page you are viewing.

Tip You can view the next printed page by pressing the C key; to move to the previous 

page, press the < key.

Changing Page Breaks in a Worksheet
Another way to change how your worksheet will appear on the printed page is to 

change where Excel 2007 assigns its page breaks or the point where Excel 2007 prints 

all subsequent data on a new sheet of paper. You can do that indirectly by changing a 

worksheet’s margins, but you can do it directly by displaying your document in Page 

Break Preview mode. To display your worksheet in Page Break Preview mode, on the 

View tab, in the Workbook Views group, click Page Break Preview.
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The blue lines in the window represent the page breaks. If you want to set a page break 

manually, you can do so by displaying your worksheet in Page Break Preview mode and 

then right-clicking the row header of the row below where you want the new page to 

start. In other words, if you right-click the row header of row 15 and click Insert Page 

Break, row 14 will be the last row on the fi rst printed page, and row 15 will be the fi rst 

row on the second printed page. The same technique applies to columns: if you right-

click the column H column header and click Insert Page Break, column G will be the last 

column on the fi rst printed page, and column H will be the fi rst column on the second 

printed page.

You can also add page breaks without displaying your workbook in Page Break Preview 

mode. To add a page break while your workbook is open in Normal view, click a row or 

column header and then, on the Page Layout tab, in the Page Setup area, click Breaks 

and then click Insert Page Break. The Breaks button menu also enables you to delete a 

page break or to reset all of your worksheet’s page breaks.

Important Be sure to right-click a row header or column header when you want to  insert 

a single page break. If you view a workbook in Page Break Preview mode, right-click a cell 

within the body of a worksheet, and then choose Insert Page Break, Excel 2007 creates 

both a vertical page break above the selected cell and a horizontal page break below the 

selected cell.
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To move a page break, drag the line representing the break to its new position. 

Excel 2007 will change the worksheet’s properties so that the area you defi ned will be 

printed on a single page.

Tip If you prefer not to display your workbook in Page Break Preview mode, you can insert 

a page break by clicking a cell, row header, or column header. Then, on the Page Layout 

tab, in the Page Setup group, click Breaks and click Insert Page Break.

Changing the Page Printing Order for Worksheets
When you view a document in Page Break Preview mode, Excel 2007 indicates the order 

in which the pages will be printed with light gray words on the worksheet pages. (These 

indicators appear only in Page Break Preview mode; they don’t show up when the docu-

ment is printed.) You can change the order in which the pages are printed by displaying 

the Page Layout tab, clicking the Page Setup group’s dialog box launcher to display the 

Page Setup dialog box, and displaying the dialog box’s Sheet tab.

On the Sheet tab, selecting the Over, Then Down option changes the order in which the 

worksheets will be printed from the default Down, Then Over. You might want to change 

the printing order to keep certain information together on consecutive printed pages. 

For example, suppose you have a worksheet that holds hourly package pickup informa-

tion; the columns represent hours of the day, and the rows represent days of the month. 

If you want to print out consecutive days for each hour, you use Down, Then Over, as 

shown in the following graphic. Pages 1 and 2 enable you to see the 5:00 a.m. to 11:00 

a.m. pickups for the months of January and February, pages 3 and 4 enable you to see 

the 12:00 p.m. to 5:00 p.m. pickups for the months, and so on.
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As the next graphic shows, changing the print order to Over, Then Down prints consecu-

tive hours for each day. Pages 1 and 2 enable you to see the 5:00 a.m. to 5:00 p.m. pick-

ups for January, and pages 3 and 4 enable you to see the same pickups for February.
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In this exercise, you will preview a worksheet before printing, change a worksheet’s 

 margins, change a worksheet’s orientation, reduce a worksheet’s size, add a page break, 

and change the page printing order.

USE the Pickups by Hour workbook in the practice fi le folder for this topic. This practice fi le 

is located in the My Documents\Microsoft Press\Excel SBS\Printing folder.

OPEN the Pickups by Hour workbook.

 1. While displaying the JanFeb worksheet, click the Microsoft Offi ce Button, point to 

Print, and then click Print Preview.

The workbook appears in Print Preview mode.

 2. On the Print Preview tab, in the Preview group, click Close Print Preview.

The workbook appears in Normal view.

 3. On the Page Layout tab, in the Page Setup group, click Orientation and then click 

Landscape.

Excel 2007 reorients the worksheet.

 4. On the Page Layout tab, in the Scale to Fit group, in the Scale fi eld, type 80% and 

then press F.

Excel 2007 resizes your worksheet.

 5. Click the row header for row 38.

Excel 2007 highlights row 38.

 6. On the Page Layout tab, in the Page Setup group, click Breaks and then click 

Insert Page Break.

Excel 2007 sets a horizontal page break above row 38.

USE thethe Pickups by Hour Pickups by Hour workbook in the practice fi le folder for this topic. This practice fi le workbook in the practice fi le folder for this topic. This practice fi le 

is located in theis located in the My Documents\Microsoft Press\Excel SBS\PrintingMy Documents\Microsoft Press\Excel SBS\Printing folder. folder.

OPEN thethe Pickups by Hour Pickups by Hour workbook.workbook.
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7. On the tab bar, click the MarJun sheet tab.

The MarJun worksheet appears.

8. On the Page Layout tab, in the Page Setup group, click Margins and then click 

Wide.

Excel 2007 applies wide margins to the worksheet.

9. On the Page Layout tab, click the Page Setup group’s dialog box launcher.

The Page Setup dialog box appears.

10. If necessary, click the Sheet tab.

The Sheet tab page appears.

11. In the Page order section, select the Over, then down option button.

12. Click OK.

13. If desired, click the Microsoft Offi ce Button and then click Print.

Excel 2007 prints your worksheet.

CLOSE the Pickups by Hour workbook.CLOSE the Pickups by Hour workbook.r
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Printing Data Lists
When you’re ready to print a worksheet, all you have to do is click the Microsoft Offi ce 

Button, point to Print, and then click Quick Print. If you want a little more say in how 

Excel 2007 prints your worksheet, you can use the controls in the Print dialog box to 

 determine how Excel 2007 prints your worksheet. For example, you can choose the 

printer to which you want to send this job, print multiple copies of the worksheet, 

and select whether the copies are collated (all pages of a document together) or not 

( multiple copies of the same page are printed together).

Important The exact version of the Print dialog box that Excel 2007 presents depends 

on the printer you select, so your Print dialog box might differ from the one shown in the 

 preceding graphic.

If you want to print more than one worksheet from the active workbook, but not every 

worksheet in the workbook, you can select the worksheets to print from the tab bar. To 

select the worksheets to print, hold down the H key while you click the sheet tabs of the 

worksheets you want to print. Then click the Microsoft Offi ce Button, point to Print, and 

click Quick Print.

Note The worksheets you select for printing do not need to be next to one another in the 

workbook.

A helpful option on the Sheet tab page of the Page Setup dialog box is the Cell Errors As 

box, which enables you to select how Excel 2007 will print any errors in your worksheet. 

You can print an error as it normally appears in the worksheet, print a blank cell in place 

of the error, or choose one of two other indicators that are not standard error messages.
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After you prepare your worksheet for printing, you can print it by opening the Print 

 dialog box. To print every page in the worksheet, select the All option button in the Print 

range section and then click OK. To print every worksheet in the active workbook, select 

the Entire Workbook option button in the Print What section.

In this exercise, you’ll print nonadjacent worksheets in your workbook and suppress 

 errors in the printed worksheet.

USE the Summary by Customer workbook in the practice fi le folder for this topic. This 

practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Printing folder.

OPEN the Summary by Customer workbook.

1. If necessary, display the Summary worksheet.

2. On the Page Layout tab, in the Page Setup group, click the group’s dialog box 

launcher.

The Page Setup dialog box appears.

3. Click the Sheet tab.

The Sheet tab appears.

4. Click the Cell errors as fi eld down arrow and then click <blank>.

5. Click OK.

6. Hold down the H key and then, on the tab bar, click the Northwind sheet tab.

Excel 2007 selects the Summary and Northwind worksheets.

7. Click the Microsoft Offi ce Button and then click Print.

USE thethe Summary by CustomerSummary by Customer workbook in the practice fi le folder for this topic. Thisworkbook in the practice fi le folder for this topic. Thisrr
practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\PrintingMy Documents\Microsoft Press\Excel SBS\Printing folder. folder.

OPEN thethe Summary by CustomerSummary by Customer workbook.workbook.rr
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The Print dialog box appears.

 8. In the Print what area, verify that the Active sheet(s) option button is selected.

 9. Click Cancel (you can click OK if you want to print the worksheets).

CLOSE the Summary by Customer workbook.

Printing Parts of Data Lists
Excel 2007 gives you a great deal of control over what your worksheets look like when 

you print them, but you also have a lot of control over which parts of your worksheets 

will be printed. For example, you can use the Print dialog box to choose which pages of a 

multipage worksheet you want to print.

Selecting the Page(s) option button in the Print Range section of the dialog box enables 

you to fi ll in the page numbers you want to print in the From and To boxes.

Tip You can use the Page Break Preview window to determine which pages you want to 

print, and if the pages aren’t in an order you like, you can use the controls on the Sheet tab 

page of the Page Setup dialog box to change the order in which they will be printed.

Another way you can modify how a worksheet will be printed is to have Excel 2007 fi t 

the entire worksheet on a specifi ed number of pages. For example, you can have Excel 

2007 resize a worksheet so that it will fi t on a single printed page. Fitting a worksheet 

onto a single page is a handy tool when you need to add a sales or other summary to a 

report and don’t want to spread important information across more than one page.

CLOSE the Summary by Customer workbook.r
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To have Excel 2007 fi t a worksheet on a set number of pages, display the Page Layout 

tab and use the controls in the Scale to Fit group. When you click the Width and Height 

control down arrows, you can select how many pages wide or tall you want your print-

out to be.

If you want to print a portion of a worksheet instead of the entire worksheet, you can 

defi ne the area or areas you want to have printed. To identify the area of the worksheet 

you want to print, select the cells with the data you want to print, and on the Page 

Layout tab, in the Page Setup group, click Print Area and then click Set Print Area. Excel 

2007 marks the area with a dotted line around the border of the selected cells and prints 

only the cells you selected. To remove the selection, click Print Area and then click Clear 

Print Area.

Tip You can include noncontiguous groups of cells in the area to be printed by holding 

down the H key as you select the cells.

After you defi ne a print area, you can use the Page Setup dialog box to position the print 

area on the page. Specifi cally, you can have Excel 2007 center the print area on the page 

by selecting the Horizontally and Vertically check boxes on the Margins tab page.
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Printing Parts of Data Lists
If the contents of a worksheet will take up more than one printed page, you can have 

Excel 2007 repeat one or more rows at the top of the page or columns at the left of the 

page. For example, if you want to print a lengthy data list containing the mailing ad-

dresses of customers signed up to receive your company’s monthly newsletter, you could 

repeat the column headings Name, Address, City, and so forth at the top of the page. To 

repeat rows at the top of each printed page, on the Page Layout tab, in the Page Setup 

group, click Print Titles. Excel 2007 will display the Page Setup dialog box Sheet tab page. 

On the Sheet tab of the Page Setup dialog box, you can use the controls in the Print 

Titles section of the dialog box to select the rows or columns to repeat. To choose rows 

to repeat at the top of the page, click the Collapse Dialog button next to the Rows To 

Repeat At Top box, select the rows, and then click the Expand Dialog button. The rows 

you selected appear in the Rows To Repeat At Top box.

Similarly, to have a set of columns appear at the left of every printed page, click the 

Collapse Dialog button next to the Columns To Repeat At Left box, select the columns, 

and then click the Expand Dialog button. When you’re done, click OK to accept the 

settings.

A fi nal feature that comes in handy when you print Excel 2007 worksheets is Intelliprint, 

which was introduced in Excel 2003. Intelliprint prevents Excel 2007 from printing any 

blank pages at the end of a document. The end result is that you don’t need to set a 

print area manually unless you want to print a subset of the data in your worksheet or if 

you do want to print blank pages after the rest of your data. 

In this exercise, you will select certain pages of a worksheet to print, have Excel 2007 fi t 

your printed worksheet on a set number of pages, defi ne a multiregion print area, center 

the printed material on the page, and repeat columns at the left edge of each printed 

page.

USE the HourlyPickups workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Printing folder.

OPEN the Hourly Pickups workbook.

1. On the Page Layout tab, in the Page Setup group, click Print Titles.

The Page Setup dialog box appears, opened to the Sheet tab.

2. At the right edge of the Columns to repeat at left fi eld, click the Collapse Dialog 

button.

The dialog box collapses.

USE thethe HourlyPickups HourlyPickups workbook in the practice fi le folder for this topic. This practice fi le is workbook in the practice fi le folder for this topic. This practice fi le is 

located in thelocated in the My Documents\Microsoft Press\Excel SBS\PrintingMy Documents\Microsoft Press\Excel SBS\Printing folder. folder.

OPEN thethe Hourly PickupsHourly Pickups workbook.workbook.
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3. Select the column header of column A and drag to select the column header of 

column B, too.

The reference $A:$B appears in the Columns to repeat at left fi eld.

4. At the right edge of the Columns to repeat at left fi eld, click the Expand Dialog 

button.

The dialog box expands.

5. Click Print Preview.

Excel 2007 displays your worksheet as it will appear when printed.

6. Click Close Print Preview.

Excel 2007 displays your worksheet in Normal view.

7. Click the Microsoft Offi ce Button and then click Print.

The Print dialog box appears.

8. Select the Page(s) option button.

9. In the From fi eld, type 1; in the To fi eld, type 2.

10. Click Cancel (or click OK to print the selected pages).

The Print dialog box disappears.



   287

 

 

 

 

 

 

 

 

Printing Parts of Data Lists
11. On the Page Layout tab, in the Scale to Fit group, click the Width control down 

arrow and then click 1 page.

12. On the Page Layout tab, in the Scale to Fit group, click the Height control down 

arrow and then click 2 pages.

Excel 2007 resizes your worksheet so that it will fi t on two printed pages. The new 

scaling and size values appear in the Scale to Fit group on the Page Layout tab.

13. Select the cell range A1:E8, hold down the H key, and then select the cell range 

A38:E45.

14. On the Page Layout tab, in the Page Setup group, click Print Area and then click 

Set Print Area.

15. On the Page Layout tab, click the Page Setup group’s dialog box launcher.

The Page Setup dialog box appears.

16. On the Margins page of the dialog box, select the Horizontally and Vertically 

check boxes.

17. Click Print Preview.

Excel 2007 displays your worksheet as it will appear when printed.

18. Click Close Print Preview.

Excel 2007 displays your worksheet in Normal view.
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 19. On the Page Layout tab, in the Page Setup group, click Print Area and then click 

Clear Print Area.

Excel 2007 removes the print areas defi ned for the JanFeb worksheet.

CLOSE the Hourly Pickups workbook.

Printing Charts
Charts, which are graphic representations of your Excel 2007 data, enable you to com-

municate lots of information with a picture. Depending on your data and the type of 

chart you make, you can show trends across time, indicate the revenue share for various 

departments in a company for a month, or project future sales using trend line analysis. 

After you create a chart, you can print it to include in a report or use in a presentation.

If you embed a chart in a worksheet, however, the chart will probably obscure some of 

your data unless you move the chart to a second page in the worksheet. That’s one way 

to handle printing a chart or the underlying worksheet, but there are other ways that 

don’t involve changing the layout of your worksheets.

To print a chart, click the chart, click the Microsoft Offi ce Button, point to Print, and then 

click Print to display the Print dialog box. In the Print What section, the Selected Chart 

option button is the only one available. If you click anywhere on the worksheet outside 

the chart, the Print What section appears with the Active Sheet(s) option button selected, 

meaning that the chart and underlying worksheet are printed as they appear on the 

screen.

In this exercise, you will print a chart.

USE the Corporate Revenue workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Printing folder.

OPEN the Corporate Revenue workbook.

 1. Select the chart.

 2. Click the Microsoft Offi ce Button and then click Print.

The Print dialog box appears.

CLOSE the Hourly Pickups workbook.

USE thethe Corporate RevenueCorporate Revenue workbook in the practice fi le folder for this topic. This practice  workbook in the practice fi le folder for this topic. This practice 

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\PrintingMy Documents\Microsoft Press\Excel SBS\Printing folder.folder.

OPEN thethe Corporate Revenue Corporate Revenue workbook.workbook.



   289Key Points
 3. Verify that the Selected Chart option button is selected and then click OK (or click 

Cancel if you don’t want to print the chart).

CLOSE the Corporate Revenue workbook.

CLOSE Excel 2007.

Key Points
  Excel 2007 gives you complete control over how your worksheets appear on the 

printed page. Don’t be afraid to experiment until you fi nd a look you like.

  Use Print Preview to see what your worksheet will look like on paper before you 

print, especially if you’re using an expensive color printer.

  You can preview where the page breaks will fall when you print a worksheet and 

change them if you so desire.

  Don’t forget that you can have Excel 2007 avoid printing error codes! Be sure to 

use your power wisely.

  You can repeat rows or columns in a printed worksheet.

  If you want to print a chart without printing the rest of the accompanying 

 worksheet, be sure to select the chart before you open the Print dialog box.

CLOSE the Corporate Revenue workbook.

CLOSE Excel 2007.
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 13 13 Automating Automating
  Repetitive Tasks  Repetitive Tasks
  with Macros  with Macros

In this chapter, you will learn to:

  Describe and examine macros.

  Create and modify macros.

  Run macros when a button is clicked.

  Run macros when a workbook is opened.

Many tasks you perform in Microsoft® Offi ce Excel® 2007 (for example, entering sales 

data for a particular day or adding formulas to a worksheet) are done once or (for ex-

ample, changing the format of a cell range) can be repeated quickly using available tools 

in Offi ce Excel 2007. However, you will often perform one or two tasks frequently that 

require a lot of steps to accomplish. For example, you might have a number of cells in 

a worksheet that contain important data you use quite often in presentations to your 

colleagues. Instead of going through a lengthy series of steps to highlight the cells with 

the important information, you can create a macro, or a recorded series of actions, to 

perform the steps for you. After you have created a macro, you can run, edit, or delete it 

as needed.

In Excel 2007, you run and edit macros using the items available in the View tab’s Macros 

group. You can make your macros easier to access by creating new buttons on the Quick 

Access Toolbar, to which you can assign your macros. If you run a macro to highlight 

specifi c cells in a worksheet every time you show that worksheet to a colleague, you can 

save time by adding a Quick Access Toolbar button that runs a macro to highlight the 

cells for you.
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Another handy feature of Excel 2007 macros is that you can create macros that run 

when a workbook is opened. For example, you might want to ensure that no cells in 

a  worksheet are highlighted when the worksheet opens. You can create a macro that 

removes any special formatting from your worksheet cells when its workbook opens, 

enabling you to emphasize the data you want as you present the information to your 

colleagues.

In this chapter, you’ll learn how to open, run, create, and modify macros; create Quick 

Access Toolbar buttons and shapes that enable you to run macros with a single mouse 

click; defi ne macro security settings; and run a macro when a workbook is opened.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need 

to install them from the book’s companion CD to their default location. See “Using the 

Book’s CD” on page xiii for more information.

Introducing Macros
After you have worked with your Excel 2007 documents for awhile, you will probably 

discover some series of actions you perform repeatedly. Although many of these actions 

(such as saving your changes and printing) can be accomplished quickly, some sequenc-

es involve many steps and take time to accomplish by hand. For example, you might 

want to highlight a number of cells in a worksheet to emphasize an aspect of your data. 

Instead of highlighting the cells by hand every time you present your fi ndings, you can 

create a macro, or series of automated actions, to do the highlighting for you.

Macro Security in Excel 2007
It’s possible for unscrupulous programmers to write viruses and other harmful  programs 

using the Microsoft Visual Basic for Applications (VBA) programming language, so you 

need to be sure that you don’t run macros from unknown sources. In versions of Offi ce 

Excel prior to Excel 2007, you could defi ne macro security levels to determine which 

macros, if any, your workbooks would be allowed to run, but there was no workbook 

type in which all macros were disallowed. Excel 2007 has several fi le types you can 

use to control whether the workbook will allow macros to be run. The following table 

 summarizes the macro-related fi le types.
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Extension Description

.xlsx Regular Excel 2007 workbook; macros are disabled

.xlsm Regular Excel 2007 workbook; macros are enabled

.xltx Excel 2007 template workbook; macros are disabled

.xltxm Excel 2007 template workbook; macros are enabled

When you open a macro-enabled workbook, the Excel 2007 program-level  security 

 settings might prevent the workbook from running the macro code. When that happens, 

Excel 2007 displays a security warning on the Message Bar.

Clicking the Options button displays the Microsoft Offi ce Security Options dialog box.

If you are expecting a workbook that contains macros and recognize the source of the 

workbook, you can select the Enable This Content option button and then click OK to 
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enable the workbook macros. Please take the time to verify the workbook’s source and 

whether you expected the workbook to contain macros before enabling the content.

You can change your program-level security settings to make them more or less 

 restrictive; to do so, click the Microsoft Offi ce Button, click the Excel Options button, and 

then, in the Excel Options dialog box, click the Trust Center category. On the page that 

appears, click the Trust Center Settings button to display a dialog box of the same name.

The Excel 2007 default macro security level is Disable All Macros With Notifi cation, which 

means that Excel 2007 displays a warning on the Message Bar, but you can enable the 

macros by clicking the Options button and selecting the Enable This Content option 

button. Selecting the Disable All Macros Without Notifi cation option does exactly what 

the label says. If Consolidated Messenger’s company policy is to disallow all macros in 

all Excel 2007 workbooks, you would select the Disable All Macros Without Notifi cation 

option.

Warning Because it is possible to write macros that act as viruses, potentially caus-

ing harm to your computer and spreading copies of themselves to other computers, you 

should never choose the Enable All Macros security setting, even if you have virus-checking 

 software installed on your computer.
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Examining Macros
The best way to get an idea of how macros work is to examine an existing macro. To do 

that, display the View tab. In the Macros group, click the Macros button and then click 

View Macros. 

Note In the Macro dialog box, you can display the macros available in other workbooks 

by clicking the Macros In box and selecting a workbook by name or by selecting All Open 

Workbooks to display every macro in any open workbook. If you select either of those 

choices, the macro names displayed include the name of the workbook in which the macro 

is stored. Clicking This Workbook displays the macros in the active workbook.

The Macro dialog box has a list of macros in your workbook. To view the code behind a 

macro, you click the macro’s name and then click Edit to open the Microsoft Visual Basic 

Editor.

Excel 2007 macros are recorded using VBA. The preceding graphic shows the code for 

a macro that highlights the cell range C4:C7 and changes the cells’ formatting to bold. 

After introductory information about the macro (its name and when it was created), the 

fi rst line of the macro identifi es the cell range to be selected (in this case, cells C4:C7). 

After the macros selects the cells, the next line of the macro changes the formatting of 

the selected cells to bold, which has the same result as clicking a cell and then clicking 

the Bold button in the Font group on the Home tab.
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To see how the macro works, you can open the Macro dialog box, click the name of the 

macro you want to examine, and then click Step Into. The Microsoft Visual Basic Editor 

appears, with a highlight around the instruction that will be executed next. 

To execute an instruction, press F8. The highlight moves to the next instruction, and your 

worksheet then changes to refl ect the action that resulted from executing the preceding 

instruction.

You can run a macro without stopping after each instruction by opening the Macro 

 dialog box, clicking the macro to run, and then clicking Run. You’ll usually run the macro 

this way; after all, the point of using macros is to save time.

In this exercise, you examine a macro in the Visual Basic Editor, move through the fi rst 

part of the macro one step at a time, and then run the entire macro without stopping.

USE the VolumeHighlights workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Macros folder.

BE SURE TO start Excel 2007 before beginning this exercise.

OPEN the VolumeHighlights workbook.

1. On the Message Bar, click Options.

The Microsoft Offi ce Security Options dialog box appears.

USE thethe VolumeHighlightsVolumeHighlights workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practice

fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\MacrosMy Documents\Microsoft Press\Excel SBS\Macros folder. folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

OPEN thethe VolumeHighlightsVolumeHighlights workbook. workbook.
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Introducing Macros
2. Select the Enable this content option button.

3. Click OK.

The security warning disappears, and macros are enabled.

4. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

5. Click the HighlightSouthern macro and then click Edit.

The Visual Basic Editor opens, with the code for the HighlightSouthern macro 

 displayed in the Module1 (Code) window.

6. Click the Visual Basic Editor Close button.

The Visual Basic Editor closes, and VolumeHighlights.xlsm reappears.

7. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

8. Click the HighlightSouthern macro and then click Step Into.

The macro appears in the Visual Basic Editor, with the fi rst macro instruction 

highlighted.

9. Press the F8 key.

Excel 2007 highlights the next instruction.

10. Press the F8 key.

The macro selects the Atlantic row in the table.

11. Press the F8 key twice.

The macro changes the Atlantic row’s text color to red.
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12. Click the Visual Basic Editor Close button.

A warning dialog box appears, indicating that closing the Visual Basic Editor will 

stop the debugger.

13. Click OK.

The Visual Basic Editor closes.

14. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

15. Click the HighlightSouthern macro.

16. Click Run.

The Macro dialog box disappears, and Excel 2007 runs the entire macro.
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 17. On the Quick Access Toolbar, click the Save button.

Excel 2007 saves your work.

CLOSE the VolumeHighlights workbook.

Creating and Modifying Macros
The fi rst step of creating a macro is to plan the process you want to automate. 

Computers today are quite fast, so adding an extra step that doesn’t affect the outcome 

of a process doesn’t slow you down noticeably, but leaving out a step means you will 

need to rerecord your macro. After you plan your process, you can create a macro by 

clicking the View tab and then, in the Macros group, clicking the Macros button down 

arrow. From the list that appears, click Record Macro. When you do, the Record Macro 

dialog box appears.

CLOSE the VolumeHighlights workbook.
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After you type the name of your macro in the Macro Name box, click OK. You can now 

perform the actions you want Excel 2007 to repeat later; when you’re done, click the 

View tab and then, in the Macros group, click the Macros button down arrow. From the 

list that appears, click Stop Recording to add your macro to the list of macros available in 

your workbook.

To modify an existing macro, you can simply delete the macro and rerecord it. Or if you 

just need to make a quick change, you can open it in the Visual Basic Editor and add to 

or change the macro’s instructions. To delete a macro, open the Macro dialog box, click 

the macro you want to delete, and then click Delete.

In this exercise, you record a macro that removes the bold formatting from four cells, 

modify the macro to remove the bold formatting from a fi fth cell, and then save the fi le.

USE the Yearly Sales Summary workbook in the practice fi le folder for this topic. This 

 practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Macros folder.

OPEN the Yearly Sales Summary workbook.

1. If necessary, on the Message Bar, click Options.

The Microsoft Offi ce Security Options dialog box appears.

2. Select the Enable this content option button.

3. Click OK.

The security warning disappears, and macros are enabled.

USE thethe Yearly Sales SummaryYearly Sales Summary workbook in the practice fi le folder for this topic. This workbook in the practice fi le folder for this topic. This yy
practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\MacrosMy Documents\Microsoft Press\Excel SBS\Macros folder. folder.

OPEN thethe Yearly Sales SummaryYearly Sales Summary workbook.workbook.yy
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Creating and Modifying Macros
4. On the View tab, in the Macros group, click the Macros button down arrow and 

then click Record Macro.

The Record Macro dialog box appears.

5. In the Macro name box, delete the existing name, and then type 

RemoveHighlight.

6. Click OK.

The Record Macro dialog box disappears.

7. Select the cell range C4:C7, and then, on the Home tab, in the Font group, click the 

Bold button.

8. On the View tab, in the Macros group, click the Macros button down arrow and 

then click Stop Recording.

Excel 2007 stops recording the macro.

9. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

10. In the Macro name section, click RemoveHighlight and then click Edit.

The Visual Basic Editor appears.
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11. Click at the end of the line just above End Sub, press F, and type Range(“C9”).
Select, and press F.

This macro statement selects cell C9.

12. Type Selection.Font.Bold = False and then press F.

This macro statement removes bold formatting from the selected cell (C9).

13. On the Standard toolbar of the Visual Basic Editor, click the Save button to save 

your change.

14. Click the Close button of the Microsoft Visual Basic Editor window.

The Visual Basic Editor disappears.

15. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

16. Click Highlight and then click Run.

The contents of cells C4, C5, C6, C7, and C9 appear in bold type.
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 17. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

 18. Click RemoveHighlight and then click Run.

The contents of cells C4, C5, C6, C7, and C9 appear in regular type.

 19. On the Quick Access Toolbar, click the Save button.

Excel 2007 saves your workbook.

CLOSE the Yearly Sales Summary workbook.

Running Macros When a Button Is Clicked
The new ribbon user interface enables you to discover the commands built into Excel 

2007 quickly, but it can take a few seconds to display the View tab, open the Macro 

 dialog box, select the macro you want to run, and click the Run button. When you’re in 

the middle of a presentation, taking even those few seconds can reduce your momen-

tum and force you to regain your audience’s attention. Excel 2007 offers several ways for 

you to make your macros more accessible.

CLOSE the Yearly Sales Summary workbook.y
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If you want to display the Macro dialog box quickly, you can add the View Macros 

 button to the Quick Access Toolbar. To do so, click the Customize Quick Access Toolbar 

button at the right edge of the Quick Access Toolbar and then click More Commands to 

display the Customize tab of the Excel Options dialog box.

See Also For more information on customizing the Quick Access Toolbar, see Chapter 2, 
“Setting Up a Workbook.”

When you display the Popular Commands command group, you’ll see that the last 

item in the command pane is View Macros. When you click the View Macros item, click 

the Add button, and then click OK, Excel 2007 adds the command to the Quick Access 

Toolbar and closes the Excel Options dialog box. Clicking the View Macros button on the 

Quick Access Toolbar displays the Macro dialog box without having to display the View 

tab and move the mouse to the far right edge of the ribbon, saving you a signifi cant 

amount of time.

If you prefer to run a macro without having to display the Macro dialog box, you can do 

so by adding a button representing the macro to the Quick Access Toolbar. Clicking that 

button runs the macro immediately, which is very handy when you create a macro for a 

task you perform frequently. To add a button representing a macro to the Quick Access 

Toolbar, click the Customize Quick Access Toolbar button at the right edge of the Quick 

Access Toolbar and then click More Commands to display the Customize tab of the Excel 

Options dialog box. From there, click the Choose Commands From box down arrow and 

click Macros. Click the macro you want represented on the Quick Access Toolbar, click 

Add, and then click OK.
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If you add more than one macro button to the Quick Access Toolbar or if you want to 

change the button that represents your macro on the Quick Access Toolbar, you can 

 select a new button from more than 160 options. To assign a new button to your macro, 

click the macro item in the Customize Quick Access Toolbar pane and click the Modify 

button to display your choices. Click the button you want, type a new text value to 

appear when a user’s mouse pointer hovers over the button, and then click OK twice 

(the fi rst time to close the Modify Button dialog box and the second to close the Excel 

Options dialog box).

Finally, you can have Excel 2007 run a macro when you click a shape in your workbook. 

Assigning macros to shapes enables you to create “buttons” that are graphically richer 

than those available on the Quick Access Toolbar. If you’re so inclined, you can even cre-

ate custom button layouts that represent other objects, such as a remote control. To run 

a macro when you click a shape, right-click the shape and then click Assign Macro from 

the shortcut menu that appears. In the Assign Macro dialog box, click the macro you 

want to run when you click the shape and then click OK.

Warning When you assign a macro to run when you click a shape, don’t change the name 

of the macro that appears in the Assign Macro dialog box. The name that appears refers 

to the object and what the object should do when it is clicked; changing the macro name 

breaks that connection and prevents Excel 2007 from running the macro.

In this exercise, you will add the View Macros button to the Quick Access Toolbar, add 

a macro button to the Quick Access Toolbar, assign a macro to a workbook shape, and 

then run the macros.
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USE the Performance Dashboard workbook in the practice fi le folder for this topic. This 

practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Macros folder.

OPEN the Performance Dashboard workbook.

 1. On the Quick Access Toolbar, click the Customize Quick Access Toolbar button 

and then click More Commands.

The Customize page of the Excel Options dialog box appears.

 2. If necessary, click the Choose commands from down arrow and then click Popular 
Commands.

The commands in the Popular Commands category appear.

 3. In the Commands panel, click View Macros.

 4. Click Add.

The View Macros command appears in the Customize Quick Access Toolbar 
 command panel.

 5. Click the Choose commands from box down arrow and then click Macros.

The available macros appear.

 6. In the Commands panel, click SavingsHighlight.

 7. Click Add.

The SavingsHighlight macro appears in the Customize Quick Access Toolbar 
 command panel.

USE thethe Performance DashboardPerformance Dashboard workbook in the practice fi le folder for this topic. This workbook in the practice fi le folder for this topic. This dd
practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\MacrosMy Documents\Microsoft Press\Excel SBS\Macros folder. folder.

OPEN thethe Performance DashboardPerformance Dashboard workbook.workbook.dd
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Running Macros When a Button Is Clicked
8. In the Customize Quick Access Toolbar command panel, click the 

SavingsHighlight command.

9. Click Modify.

The Modify Button dialog box appears.

10. Click the blue button with the white circle inside it (the fourth button from the left 

on the top row).

11. Click OK twice to close the Modify Button dialog box and the Excel Options 
dialog box.

The Excel Options dialog box disappears, and the View Macros and 

SavingsHighlight buttons appear on the Quick Access Toolbar.

12. Right-click the Show Effi ciency shape and then click Assign Macro.

The Assign Macro dialog box appears.

13. Click Effi ciencyHighlight and then click OK.

The Assign Macro dialog box disappears.

14. On the Quick Access Toolbar, click the SavingsHighlight button.

Excel 2007 runs the macro, which applies a conditional format to the values in the 

Savings column of the left-hand table.

15. Click the Show Effi ciency shape.

Excel 2007 runs the macro, which applies a conditional format to the values in the 

Effi ciency column of the right-hand table.
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 16. On the Quick Access Toolbar, click the Save button to save your work.

CLOSE the Performance Dashboard workbook.

Running Macros When a Workbook Is Opened
One advantage of writing Excel 2007 macros in VBA is that you can have Excel 2007 

run a macro whenever a workbook is opened. For example, if you use a worksheet for 

presentations, you can create macros that render the contents of selected cells in bold 

type, italic, or different typefaces to set the data apart from data in neighboring cells. If 

you close a workbook without removing that formatting, however, the contents of your 

workbook will have highlights when you open it. Although this is not a catastrophe, re-

turning the workbook to its original formatting might take a few seconds to accomplish.

Instead of running a macro by hand, or even from a toolbar button or a menu, you can 

have Excel 2007 run a macro whenever a workbook is opened. The trick of making that 

happen is in the name you give the macro. Whenever Excel 2007 fi nds a macro with 

the name Auto_Open, it runs the macro when the workbook to which it is attached is 

opened.

CLOSE the Performance Dashboard workbook.d
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Running Macros When a Workbook Is Opened
Note If you have your macro security set to the Disable with Notifi cation level, clicking the 

Options button that appears on the Message Bar, selecting the Enable this Content option 

button, and then clicking OK allows the Auto_Open macro to run.

In this exercise, you will create a macro to run whenever someone opens the workbook 

to which it is attached.

USE the RunOnOpen workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Macros folder.

OPEN the RunOnOpen workbook.

1. If necessary, click the Options button that appears on the Message Bar.

The Microsoft Offi ce Security Options dialog box appears.

2. Select the Enable this content option button and then click OK.

The Microsoft Offi ce Security Options dialog box disappears.

3. On the View tab, in the Macros group, click the Macros button down arrow and 

then click Record Macro.

The Record Macro dialog box appears.

4. In the Macro name box, delete the existing name and then type Auto_Open.

5. Click OK.

The Record Macro dialog box disappears.

6. Select the cell range B3:C11.

7. On the Home tab, in the Font group, click the Bold button twice.

The fi rst click of the Bold button formats all the selected cells in bold; the second 

click removes the bold formatting from all the selected cells.

USE thethe RunOnOpenRunOnOpen workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\MacrosMy Documents\Microsoft Press\Excel SBS\Macros folder.folder.

OPEN thethe RunOnOpenRunOnOpen workbook.workbook.
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8. On the View tab, in the Macros group, click the Macros button down arrow and 

click Stop Recording.

Excel 2007 stops recording your macro.

9. On the View tab, in the Macros group, click the Macros button down arrow and 

then click View Macros.

The Macro dialog box appears.

10. Click Highlight and then click Run.

The contents of cells C4, C6, and C10 appear in bold type.

11. On the Quick Access Toolbar, click the Save button to save your work.

12. Click the Close button to close RunOnOpen.xls.

13. Click the Microsoft Offi ce button and then click RunOnOpen.xlsx. 

If a warning appears, click Options, select the Enable this content option button, 

and then click OK to enable macros. RunOnOpen.xls opens, with the contents of 

cells C4, C6, and C10 changing immediately to regular type.
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 14. On the Quick Access Toolbar, click the Save button to save your work.

CLOSE the RunOnOpen workbook.

CLOSE Excel.

Key Points
Macros are handy tools you can use to perform repetitive tasks quickly, such as 

 inserting blocks of text.

You don’t have to be a programmer to use macros; you can record your actions 

and have Excel 2007 save them as a macro.

Excel 2007 uses macro-enabled workbook types, which have the fi le extensions 

.xlsx (a macro-enabled workbook) and .xlstx (a macro-enabled template workbook).

If you’re curious about what a macro looks like, you can display it in the Visual 

Basic Editor. If you know a little VBA, or if you just want to experiment, feel free to 

 modify the macro code and see what happens.

You can create Quick Access Toolbar buttons and shapes that, when clicked, run 

a macro.

CLOSE the RunOnOpen workbook.

CLOSE Excel.
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 14 14 Working with Other Working with Other 
  Microsoft Offi ce  Microsoft Offi ce
  System Programs  System Programs

In this chapter you will learn to:

  Include Microsoft Offi ce system documents in worksheets.

  Store Excel 2007 documents in other Microsoft Offi ce system  documents.

  Create hyperlinks.

  Paste Excel 2007 charts into other documents.

By itself, Microsoft® Offi ce Excel® 2007 provides a broad range of tools so that you can 

store, present, and summarize your fi nancial data. Other 2007 Microsoft Offi ce system 

programs extend your capabilities even further, enabling you to create databases, pre-

sentations, written reports, and custom Web pages through which you can organize and 

communicate your data in print and over networks.

All the Microsoft Offi ce system programs interact in many useful ways. For example, you 

can include a fi le created with another Microsoft Offi ce system program in an Excel 2007 

worksheet. If you use Microsoft Offi ce Word 2007 to write a quick note about why a 

customer’s shipping expenditures decreased signifi cantly in January, you can include the 

report in your workbook. Similarly, you can include your Excel 2007 workbooks in docu-

ments created with other Microsoft Offi ce system programs. If you want to copy only 

part of a workbook, such as a chart, to another Microsoft Offi ce system document, you 

can do that as well.

Excel 2007 integrates well with the Web. If you know of a Web-based resource that 

would be useful to someone who is viewing a document, you can create a hyperlink, or 

connection from a document to a place in the same fi le or to another fi le anywhere on a 

network or the Internet that the user’s computer can reach. 
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In this chapter, you will learn how to include a Microsoft Offi ce system document in a 

worksheet, store an Excel 2007 workbook as part of another Microsoft Offi ce system 

document, create hyperlinks, and paste an Excel 2007 chart into another document.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need 

to install them from the book’s companion CD to their default location. See “Using the 

Book’s CD” on page xiii for more information.

Including Microsoft Offi ce System Documents in 
Excel 2007 Worksheets

A benefi t of working with Excel 2007 is that because it is part of the Microsoft Offi ce 

system, it is possible to combine data from Excel 2007 and other Microsoft Offi ce  system 

programs to create informative documents and presentations. Just like  combining 

data from more than one Excel 2007 document, combining information from other 

Microsoft Offi ce system fi les with an Excel 2007 workbook entails either pasting anoth-

er Microsoft Offi ce system document into an Excel 2007 workbook or creating a link 

 between a workbook and the other document.

There are two advantages of creating a link between your Excel 2007 workbook and 

another fi le. The fi rst benefi t is that linking to the other fi le, as opposed to copying the 

entire fi le into your workbook, keeps your Excel 2007 workbook small. If the workbook is 

copied to another drive or computer, you can maintain the link by copying the linked fi le 

along with the Excel 2007 workbook, re-creating the link if the linked fi le is on the same 

network as the Excel 2007 workbook. It is also possible to use the workbook without the 

linked fi le. The second benefi t of linking to another fi le is that any changes in the fi le to 

which you link are refl ected in your Excel 2007 workbook.

Tip You usually have to close and reopen a workbook for any changes in the linked 

 document to appear in your workbook. The exception to this rule occurs when you open 

the fi le for editing from within your Excel 2007 workbook (as discussed later in this chapter).

You create a link between an Excel 2007 workbook and another Microsoft Offi ce  system 

document by clicking the Insert tab and then, in the Text group, clicking Object to 

 display the Object dialog box. In the Object dialog box, click the Create from File tab.
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Clicking the Browse button on the Create from File tab opens the Browse dialog box, 

from which you can browse to the folder with the fi le you want to link to Excel 2007. 

After you locate the fi le, double-clicking it closes the Browse dialog box and adds the 

fi le’s name and path to the File name box of the Object dialog box. To create a link to 

the fi le, select the Link to fi le check box and click OK. When you do, the fi le appears in 

your workbook.

If you want to link a fi le to your workbook but don’t want the fi le image to take up much 

space on the screen, you can also select the Display as icon check box. After you select 

the fi le and click OK, the fi le will be represented by the same icon used to represent it in 

Microsoft Windows®.

After you have linked a fi le to your Excel 2007 workbook—for example, a Microsoft 

Offi ce PowerPoint® 2007 fi le—you can edit the fi le by right-clicking its image in your 

workbook and then, from the shortcut menu that appears, pointing to the appropri-

ate Object command and clicking Edit. For an Offi ce PowerPoint fi le, you point to 

Presentation Object. The fi le will open in its native application. When you fi nish editing 

the fi le, your changes appear in your workbook.

Note The specifi c menu item you point to changes to refl ect the program used to  create 

the fi le to which you want to link. For an Offi ce Word 2007 document, for example, the 

menu item you point to is Document Object.

In this exercise, you link a PowerPoint 2007 presentation showing a yearly business sum-

mary to an Excel 2007 workbook and then edit the presentation from within Excel 2007. 

Important You must have PowerPoint 2007 installed on your computer to complete this 

exercise.
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USE the Summary Presentation workbook and the 2007 Yearly Revenue Summary 

 presentation in the practice fi le folder for this topic. This practice fi le is located in the 

My Documents\Microsoft Press\Excel SBS\Other Programs folder.

BE SURE TO start Excel 2007 before beginning this exercise.

BE SURE TO start PowerPoint 2007 before beginning this exercise.

OPEN the Summary Presentations workbook.

 1. On the Insert tab, in the Text group, click Object.

The Object dialog box appears.

 2. Click the Create from File tab.

The Create from File tab page appears.

 3. Click Browse.

The Browse dialog box appears.

 4. Browse to the My Documents\Microsoft Press\Excel SBS\Other Programs folder, click 

2007 Yearly Revenue Summary.pptx, and then click Insert.

The Browse dialog box disappears, and the full fi le path of the 2007 Yearly Revenue 
Summary presentation appears in the File name box.

 5. Select the Link to fi le check box and then click OK.

Excel 2007 creates a link from your workbook to the presentation.

 6. Right-click the presentation, and then, from the shortcut menu that appears, point 

to Presentation Object and then click Edit.

The presentation opens in a PowerPoint 2007 window.

USE thethe Summary PresentationSummary Presentation workbook and the  workbook and the 2007 Yearly Revenue Summary2007 Yearly Revenue Summary
presentation in the practice fi le folder for this topic. This practice fi le is located in the presentation in the practice fi le folder for this topic. This practice fi le is located in the 

My Documents\Microsoft Press\Excel SBS\Other ProgramsMy Documents\Microsoft Press\Excel SBS\Other Programs folder.folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

BE SURE TO start PowerPoint 2007 before beginning this exercise.start PowerPoint 2007 before beginning this exercise.

OPEN thethe Summary PresentationsSummary Presentations workbook. workbook.
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 7. Click Consolidated Messenger FY2007.

The text box containing Consolidated Messenger FY2007 is activated.

 8. Select the FY2007 text and then type Calendar Year 2007.

 9. In PowerPoint 2007, on the Quick Access Toolbar, click the Save button.

PowerPoint 2007 saves your changes, and Excel 2007 updates the linked object’s 

appearance to refl ect the new text.

 10. Click the Microsoft Offi ce Button and then click Save.

CLOSE the Summary Presentation workbook.

CLOSE the 2007 Yearly Revenue Summary presentation.

CLOSE PowerPoint 2007.

Storing Excel 2007 Documents as Parts of Other 
Microsoft Offi ce System Documents

In this chapter’s preceding section, you learned how to link to another fi le from within 

your Excel 2007 workbook. The advantages of linking to a second fi le are that the size of 

your workbook is kept small and any changes in the second document will be refl ected 

in your workbook. The disadvantage is that the second document must be copied along 

CLOSE the Summary Presentation workbook.

CLOSE the 2007 Yearly Revenue Summary presentation.y

CLOSE PowerPoint 2007.
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with the workbook—or at least be on a network-accessible computer. If Excel 2007 can’t 

fi nd or access the second fi le where the link says it is located, Excel 2007 can’t display it. 

You can still open your workbook, but you won’t see the linked fi le’s contents.

If fi le size isn’t an issue, and you want to ensure that the second document is always 

available, you can embed the fi le in your workbook. Embedding another fi le in an Excel 

2007 workbook means that the entirety of the other fi le is saved as part of your work-

book. Wherever your workbook goes, the embedded fi le goes along with it. Of course, 

the embedded version of the fi le is no longer connected to the original fi le, so changes 

in one aren’t refl ected in the other.

Important To view the embedded fi le, you need to have the program used to create it 

installed on the computer where you open the workbook.

You can embed a fi le in an Excel 2007 workbook by following the procedure described 

in the preceding section, except that the Link to fi le check box should not be selected.

It is also possible to embed your Excel 2007 workbooks in other Microsoft Offi ce system 

documents. In PowerPoint 2007, for example, you can embed an Excel 2007 fi le in a pre-

sentation by displaying the Insert tab in PowerPoint and then clicking Object to display 

the Object dialog box. When the Object dialog box appears, select the Create from fi le 

option button.

To identify the fi le you want to embed, click the Browse button and then, in the Browse 

dialog box that appears, navigate to the folder where the fi le is stored and double-click 

the fi le. The Browse dialog box disappears, and the fi le appears in the File name box. 

Click OK to embed your workbook in the presentation.

If you want to embed a workbook in a fi le created with another program, but you 

don’t want the worksheet to take up much space on the screen, select the Display as 

icon check box. After you select the fi le to embed and click OK, the fi le is represented 
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by the same icon used to represent it in Windows. Double-clicking the icon opens the 

 embedded document in its original application.

To edit the embedded Excel 2007 workbook, right-click the workbook (or the icon 

 representing it) and then, from the shortcut menu that appears, point to Worksheet 

Object and click Edit. The workbook opens for editing. After you fi nish making your 

changes, you can click anywhere outside the workbook to return to the presentation.

In this exercise, you embed an Excel 2007 workbook containing sales data in a 

PowerPoint 2007 presentation and then change the formatting of the workbook from 

within PowerPoint 2007.

Important You must have PowerPoint 2007 installed on your computer to complete this 

exercise.

USE the 2007 Yearly Revenue Summary presentation and the RevenueByServiceLevel 
workbook in the practice fi le folder for this topic. This practice fi le is located in the My 
Documents\Microsoft Press\Excel SBS\Other Programs folder.

BE SURE TO start Offi ce PowerPoint 2007 before beginning this exercise.

OPEN the 2007 Yearly Revenue Summary presentation.

 1. In the Slides panel of the presentation window, click the second slide.

The second slide appears.

 2. On the Insert tab, in the Text group, click Object.

The Insert Object dialog box appears.

 3. Select the Create from fi le option button.

The controls in the Insert Object dialog box change to show a box in which you 

can enter a fi le name.

USE thethe 2007 Yearly Revenue Summary2007 Yearly Revenue Summary presentation and thepresentation and theyy RevenueByServiceLevelRevenueByServiceLevel
workbook in the practice fi le folder for this topic. This practice fi le is located in the workbook in the practice fi le folder for this topic. This practice fi le is located in the My My 
Documents\Microsoft Press\Excel SBS\Other ProgramsDocuments\Microsoft Press\Excel SBS\Other Programs folder. folder.

BE SURE TO start Offi ce PowerPoint 2007 before beginning this exercise.start Offi ce PowerPoint 2007 before beginning this exercise.

OPEN thethe 2007 Yearly Revenue Summary2007 Yearly Revenue Summary presentation.presentation.yy
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 4. Click Browse.

The Browse dialog box appears.

 5. Browse to the My Documents\Microsoft Press\Excel SBS\Other Programs folder and 

then double-click the RevenueByServiceLevel workbook.

The Browse dialog box disappears, and the fi le’s full path appears in the File name 

box.

 6. Click OK.

The workbook appears in your presentation.

CLOSE the RevenueByServiceLevel workbook.

CLOSE the 2007 Yearly Revenue Summary presentation.

CLOSE PowerPoint 2007.

Creating Hyperlinks
One of the hallmarks of the Web is that documents published on Web pages can have 

references, or hyperlinks, to locations in the same document or to other Web docu-

ments. A hyperlink functions much like a link between two cells or between two fi les, but 

hyperlinks can reach any computer on the Web, not just those on a corporate network. 

Hyperlinks that haven’t been clicked usually appear as underlined blue text, and fol-

lowed hyperlinks appear as underlined purple text, but those settings can be changed.

To create a hyperlink, click the cell in which you want to insert the hyperlink and then, on 

the Insert tab, click Hyperlink. The Insert Hyperlink dialog box appears.

CLOSE the RevenueByServiceLevel workbook.l

CLOSE the 2007 Yearly Revenue Summary presentation.y

CLOSE PowerPoint 2007.
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Tip You can also open the Insert Hyperlink dialog box by pressing H+k. 

You can choose one of four types of targets, or destinations, for your hyperlink: an exist-

ing fi le or Web page, a place in the current document, a new document you create on 

the spot, or an e-mail address.

Note By default, the Insert Hyperlink dialog box displays the tools to connect to an 

 existing fi le or Web page.

To create a hyperlink to another fi le or Web page, you can use the Look in box 

 navigation tool to locate the fi le. If you recently opened the fi le or Web page to which 

you want to link, you can click either the Browsed Pages or the Recent Files button to 

display the Web pages or fi les in your History list.

If you want to create a hyperlink to another place in the current Excel 2007 workbook, 

you click the Place in This Document button to display a list of available targets in the 

current workbook.
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To select the worksheet to which you want to refer, you click the worksheet name in the 

Or Select A Place In This Document box. When you do, a 3-D reference with the name of 

the worksheet and cell A1 on that worksheet appears in the Text to display box.

If you want to refer to a specifi c cell on a worksheet, click the worksheet name in the Or 

Select A Place In This Document box and then change the cell reference in the Type the 

cell reference box.

You can also create hyperlinks that generate e-mail messages to an address of your 

choice. To create this type of hyperlink, which is called a mailto hyperlink, click the 

E-mail Address button.

In the dialog box that appears, you can type the recipient’s e-mail address in the E-mail 

address box and the subject line for messages sent via this hyperlink in the Subject box.

Tip If you use Windows Mail, Microsoft Offi ce Outlook®, or Microsoft Offi ce Outlook 

Express as your e-mail program, a list of recently used addresses will appear in the Recently 

used e-mail addresses box. You can insert any of those addresses in the E-mail address box 

by clicking the address.
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Creating Hyperlinks
Clicking a mailto hyperlink causes the user’s default e-mail program to open and create 

a new e-mail. The e-mail message is addressed to the address you entered in the E-mail 

address box, and the subject is set to the text you typed in the Subject box.

Regardless of the type of hyperlink you create, you can specify the text you want to 

represent the hyperlink in your worksheet. You type that text in the Text to display box. 

When you click OK, the text you type there appears in your worksheet, formatted as a 

hyperlink.

Tip If you leave the Text to display box empty, the actual link will appear in your 

 worksheet.

To edit an existing hyperlink, click the cell containing the hyperlink and then, from the 

shortcut menu that appears, click Edit Hyperlink. You can also click Open Hyperlink to 

go to the target document or create a new e-mail message, or click Remove Hyperlink to 

delete the hyperlink.

Tip If you delete a hyperlink from a cell, the text from the Text to display box remains in 

the cell, but it no longer functions as a hyperlink.

In this exercise, you create a hyperlink to another document and then a second hyperlink 

to a different location in the current workbook.

USE the Hyperlink and Level Descriptions workbooks in the practice fi le folder for this topic. 

This practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Other Programs 
folder.

OPEN the Hyperlink workbook.

1. On the Revenue by Level worksheet, click cell B9.

2. On the Insert tab, in the Links group, click Hyperlink.

The Insert Hyperlink dialog box appears.

3. If necessary, click the Existing File or Web Page button.

4. If necessary, use the controls in the Look in box to navigate to the My Documents\
Microsoft Press\Excel SBS\Other Programs folder.

The fi les in the target folder appear in the Insert Hyperlink dialog box.

5. In the fi le list, click the Level Descriptions workbook.

USE thethe HyperlinkHyperlink and and kk Level DescriptionsLevel Descriptions workbooks in the practice fi le folder for this topic.workbooks in the practice fi le folder for this topic.

This practice fi le is located in theThis practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Other ProgramsMy Documents\Microsoft Press\Excel SBS\Other Programs
folder.folder.

OPEN thethe HyperlinkHyperlink workbook.workbook.kk
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Excel 2007 highlights the workbook, and the workbook’s full path appears in the 

Text to display box.

6. In the Text to display box, edit the value so that it reads Level Descriptions.

7. Click OK.

8. Click the hyperlink in cell B9.

The Level Descriptions workbook appears.

9. In the Level Descriptions workbook, click the Microsoft Offi ce Button and then 

click Close.

The Level Descriptions workbook disappears.

10. Right-click cell B11 and then click Hyperlink.

The Insert Hyperlink dialog box appears.

11. In the Link to pane, click Place in This Document.

The document elements to which you can link appear in the dialog box.

12. In the Or select a place in this document pane, click Notes.
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 13. Click OK.

The Insert Hyperlink dialog box disappears, and Excel 2007 creates a hyperlink in 

cell B11.

 14. Right-click cell B11 and then click Edit Hyperlink.

The Edit Hyperlink dialog box appears.

 15. Edit the Text to display box’s value so it reads Revenue Notes.

 16. Click OK.

The Edit Hyperlink dialog box disappears, and the text in cell B11 changes to 

Revenue Notes.

 17. On the Quick Access Toolbar, click the Save button to save your work.

CLOSE the Hyperlink and Level Descriptions workbooks.

Pasting Charts into Other Documents
A fi nal way to include objects from one workbook in another workbook is to copy the 

object you want to share and then paste it into its new location. Copying Excel 2007 

charts to Word 2007 documents and PowerPoint 2007 presentations enables you to 

 reuse your data without inserting a worksheet into the fi le and re-creating your chart in 

that new location. 

When you want to copy the image of the chart in its current form to another document, 

you just right-click the chart, click Copy from the shortcut menu that appears, and then 

paste the image into the other document. After the other Microsoft Offi ce system pro-

gram completes the paste operation, it displays the Paste Options button. Clicking the 

Paste Options button enables you to choose whether to paste the chart as a chart that 

remains linked to the worksheet that provides its data, to paste the entire workbook, or 

to paste an image of the chart in its current state.

Note In previous versions of Microsoft Offi ce, the default option was to paste an image of 

the chart. In the 2007 release, the programs assume that you want to paste the chart and 

retain its connection to the source workbook.

In this exercise, you copy a chart containing sales information to the Clipboard and paste 

an image of the chart into a PowerPoint 2007 presentation.

CLOSE the Hyperlink and k Level Descriptions workbooks.
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Important You must have PowerPoint 2007 installed on your computer to complete this 

exercise.

USE the Revenue Chart workbook and the Revenue Summary presentation in the practice 

fi le folder for this topic. This practice fi le is located in the My Documents\Microsoft Press\
Excel SBS\Other Programs folder.

BE SURE TO start PowerPoint 2007 before beginning this exercise.

OPEN the Revenue Chart workbook and the Revenue Summary presentation.

1. In the Revenue Chart workbook, right-click the chart and then click Copy.

Excel 2007 copies the workbook to the Clipboard.

2. Display the Revenue Summary presentation.

3. Right-click a blank spot in the visible slide and click Paste.

The chart appears in the presentation, and PowerPoint 2007 displays a Paste 
Options button.

4. Click the Paste Options button and then, from the options that appear, click Paste 
as Picture.

The chart appears as a static image.

USE thethe Revenue ChartRevenue Chart workbook and the  workbook and the tt Revenue SummaryRevenue Summary presentation in the practice  presentation in the practice yy
fi le folder for this topic. This practice fi le is located in the fi le folder for this topic. This practice fi le is located in the My Documents\Microsoft Press\My Documents\Microsoft Press\
Excel SBS\Other ProgramsExcel SBS\Other Programs folder.folder.

BE SURE TO start PowerPoint 2007 before beginning this exercise.start PowerPoint 2007 before beginning this exercise.

OPEN thethe Revenue ChartRevenue Chart workbook and the  workbook and the tt Revenue SummaryRevenue Summary presentation. presentation.yy
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CLOSE the Revenue Chart workbook.

CLOSE the Revenue Summary presentation.

CLOSE PowerPoint 2007.

CLOSE Excel 2007.

Key Points
  Excel 2007 is a versatile program. You can exchange data between Excel 2007 and 

quite a few other programs in just a few steps.

  One benefi t of Excel 2007 being part of the Microsoft Offi ce system is that you can 

embed Excel 2007 worksheets in other Microsoft Offi ce system documents and 

embed other Microsoft Offi ce system documents (such as PowerPoint 2007 presen-

tations) in Excel 2007 workbooks.

  Excel 2007 works smoothly with the Web; adding hyperlinks to Web pages, other 

documents, or specifi c locations in the current workbook is possible through the 

Insert Hyperlink dialog box.

  After you create a hyperlink, you can change any part of it. 

  Excel 2007 is the easiest Microsoft Offi ce system program in which to create 

charts. After you create a chart in Excel 2007, you can paste it directly into another 

Microsoft Offi ce system document.

CLOSE the Revenue Chart workbook.

CLOSE the Revenue Summary presentationy .

CLOSE PowerPoint 2007.

CLOSE Excel 2007.
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 15  15 Collaborating withCollaborating with
  Colleagues  Colleagues

In this chapter you will learn to:

  Share data lists.

  Manage comments.

  Track and manage colleagues’ changes.

  Protect workbooks and worksheets.

  Authenticate workbooks.

  Save workbooks for the Web.

Even though a single individual might be tasked with managing a company’s fi nancial 

data and related information, many people have input when making future revenue 

projections. You and your colleagues can enhance the workbook data you share by add-

ing comments that offer insight into the information the data represents, such as why 

revenue was so strong during a particular month or whether a service level might be 

discontinued. If the workbook in which those projections and comments will be stored 

is available on a network or an intranet, you can allow more than one user to access the 

workbook at a time by turning on workbook sharing. After a workbook has been shared 

with your colleagues, you can have the workbook mark and record any changes made 

to it. After all changes have been made, the workbook’s administrator can decide which 

changes to keep and which to reject. 

If you prefer to limit the number of colleagues who can view and edit your workbooks, 

you can add password protection to a workbook, worksheet, cell range, or even an indi-

vidual cell. By adding password protection, you can prevent changes to critical elements 

of your workbooks. You can also hide formulas used to calculate values.

If you work in an environment in which you and colleagues, both inside and outside your 

organization, exchange fi les frequently, you can use a digital signature to help verify that 

your workbooks and any macros they contain are from a trusted source. 
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Finally, if you want to display information on a Web site, you can do so by saving a work-

book as a Web page. Your colleagues won’t be able to edit the information, but they will 

be able to view it, and comment by e-mail or phone.

In this chapter, you’ll learn how to share a data list, manage comments to workbook 

cells, track and manage changes made by colleagues, protect workbooks and work-

sheets, and digitally sign your workbooks.

See Also Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference entries on pages xxvii–lxiii.

Important Before you can use the practice sites provided for this chapter, you need to 

install them from the book’s companion CD to their default location. See “Using the Book’s 

CD” on page xiii for more information.

Sharing Data Lists
To enable several users to edit a workbook simultaneously, you must turn on workbook 

sharing. Enabling more than one user to edit a workbook simultaneously is perfect for an 

enterprise such as Consolidated Messenger, whose employees need to look up customer 

information, shipment numbers, and details on mistaken deliveries.

To turn on workbook sharing, on the Review tab, in the Changes group, click Share 

Workbook. In the Share Workbook dialog box that appears, turn on workbook sharing 

by selecting the Allow Changes By More Than One User At The Same Time check box. 

You can then set the sharing options for the active workbook by clicking the Advanced 

tab.
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Warning You can’t share a workbook that contains a data table. To share the workbook, 

convert the table to a regular cell range by clicking the table, clicking the Design tab, and 

then, in the Tools group, clicking Convert to Range. Click Yes in the dialog box that appears 

to confi rm the change.

On the Advanced tab of the Share Workbook dialog box, two settings are of particular 

interest. The fi rst determines whether Microsoft® Offi ce Excel® 2007 should maintain a 

history of changes made to the workbook and, if so, for how many days it should keep 

the changes. The default setting is to retain a record of all changes made in the past 30 

days, but you can enter any number of days you like. Unless it’s critical that you keep all 

changes made to a workbook, you should probably stay with the default setting of 30 

days so the list doesn’t become too large and unwieldy.

The other important setting on this tab deals with how Offi ce Excel 2007 decides which 

of two confl icting changes in a cell should be applied. For example, a service level’s price 

might change, and two of your colleagues might type in what they think the new price 

should be. Selecting the Ask Me Which Changes Win option button enables you to de-

cide which price to keep.

Another way to share a workbook is to send a copy of it to your colleagues via e-mail. 

Although the specifi c command to attach a fi le to an e-mail message is different in 

every program, the most common method of attaching a fi le is to create a new e-mail 

 message and then click the Attach button, as in Microsoft Offi ce Outlook® 2007.

In this exercise, you turn on workbook sharing and then attach the fi le to an Offi ce 

Outlook 2007 e-mail message.

Note You must have Outlook 2007 installed on your computer to follow this procedure 

exactly.

USE the Cost Projections workbook in the practice fi le folder for this topic. This practice fi le 

is located in the My Documents\Microsoft Press\Excel SBS\Sharing folder.

BE SURE TO start Excel 2007 before beginning this exercise.

BE SURE TO start Outlook 2007 before beginning this exercise.

OPEN the Cost Projections workbook.

 1. On the Review tab, in the Changes group, click Share Workbook.

The Share Workbook dialog box appears.

USE thethe Cost ProjectionsCost Projections workbook in the practice fi le folder for this topic. This practice fi le workbook in the practice fi le folder for this topic. This practice fi le 

is located in theis located in the My Documents\Microsoft Press\Excel SBS\SharingMy Documents\Microsoft Press\Excel SBS\Sharing folder. folder.

BE SURE TO start Excel 2007 before beginning this exercise.start Excel 2007 before beginning this exercise.

BE SURE TO start Outlook 2007 before beginning this exercise.start Outlook 2007 before beginning this exercise.

OPEN thethe Cost ProjectionsCost Projections workbook. workbook.
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2. Select the Allow changes by more than one user at the same time. This also 
 allows workbook merging check box.

3. Click OK.

A dialog box appears, indicating that you must save the workbook for the action to 

take effect.

4. Click OK.

Excel 2007 saves and shares the workbook.

5. Click the Microsoft Offi ce Button, point to Send, and then click E-mail.

A new e-mail message opens with the Cost Projections workbook attached.



   333Managing Comments
 6. Type an address in the To box.

 7. Click Send.

Your e-mail program sends the message. If Excel 2007 had to open your e-mail 

program to send the message, the program closes.

CLOSE the Cost Projections workbook.

Managing Comments
Excel 2007 makes it easy for you and your colleagues to insert comments in workbook 

cells, adding insights that go beyond the cell data. For example, if a regional processing 

center’s package volume is exceptionally high on a particular day, the center’s manager 

can add a comment to the cell in which shipments are recorded for that day, noting that 

two exceptionally large bulk shipments accounted for the disparity.

When you add a comment to a cell, a fl ag appears in the upper-right corner of the cell. 

When the mouse pointer hovers over a cell with a comment, the comment appears in a 

box next to the cell, along with the name of the user logged on to the computer at the 

time the comment was created.

Important Note that the name attributed to a comment might not be the same as the 

person who actually created it. Enforcing access controls, such as requiring users to enter 

account names and passwords when they access a computer, can help track the person who 

made a comment or change.

CLOSE the Cost Projections workbook.
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You can add a comment to a cell by clicking the cell, clicking the Review tab, and then 

clicking New Comment. When you do, the comment fl ag appears in the cell, and a com-

ment box appears next to the cell. You can type the comment in the box and, when 

you’re done, click another cell to close the box for editing. When you move the mouse 

pointer onto the cell that contains the comment, the comment appears next to the cell.

If you want a comment to be shown the entire time the workbook is open, click the cell 

that contains the comment, click the Review tab, and then, in the Comments group, click 

Show/Hide Comment. You can hide the comment by clicking the same button when 

the comment appears in the workbook, delete the comment by clicking the Review tab, 

and then, in the Comments group, by clicking Delete. Or you can open the comment for 

 editing by clicking Edit Comment from the same group on the Ribbon.

Important When someone other than the original user edits a comment, that person’s 

input is marked with the new user’s name and is added to the original comment. 

If you want to select every cell that contains a comment, you can do so by using the Go 

To Special dialog box. To display the Go To Special dialog box, display the Home tab, 

and then, in the Editing group, click Find & Select and click Go To Special. In the Go To 

Special dialog box, select the Comments option button and click OK. Excel 2007 then 

selects every cell that contains a comment.

In this exercise, you add comments to two cells. You then highlight the cells that contain 

comments, review a comment, and delete that comment.

USE the Projections for Comment workbook in the practice fi le folder for this topic. This 

practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Sharing folder.

OPEN the Projections for Comment workbook.

 1. Click cell E6.

 2. On the Review tab, in the Comments group, click New Comment.

A red comment fl ag appears in cell E6, and a comment box appears next to 

the cell.

USE thethe Projections for CommentProjections for Comment workbook in the practice fi le folder for this topic. This workbook in the practice fi le folder for this topic. This tt
practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\SharingMy Documents\Microsoft Press\Excel SBS\Sharing folder. folder.

OPEN thethe Projections for CommentProjections for Comment workbook.workbook.tt
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 3. In the comment box, type Seems optimistic; move some improvement to the 
next year?

 4. Click any cell outside the comment box.

The comment box disappears.

 5. Click cell G7.

 6. On the Review tab, in the Comments group, click New Comment.

A red comment fl ag appears in cell G7, and a comment box appears next to the 

cell.

 7. In the comment box, type Should see more increase as we integrate new 
processes. 

 8. Click any cell outside the comment box.

The comment box disappears.

 9. On the Home tab, in the Editing group, click Find & Select and then click Go To 
Special.

The Go To Special dialog box appears.
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 10. Select the Comments option button and then click OK.

Excel 2007 selects all cells that contain comments.

 11. Click any unselected cell.

Excel 2007 removes the previous selection.

 12. Click cell G7.

 13. On the Review tab, in the Comments group, click Delete.

Excel 2007 deletes the comment.

CLOSE the Projections for Comment workbook.

Tracking and Managing Colleagues’ Changes
Whenever you collaborate with a number of your colleagues to produce or edit a docu-

ment, you should consider tracking the changes each user makes. When you turn on 

change tracking, any changes made to the workbook are highlighted in a color assigned 

to the user who made the changes. One benefi t of tracking changes is that if you have a 

question about a change, you can quickly identify who made the change and verify that 

it is correct. In Excel 2007, you can turn on change tracking in a workbook by clicking 

the Review tab and then, in the Changes group, clicking Track Changes and then clicking 

Highlight Changes.

In the Highlight Changes dialog box that appears, select the Track Changes While Editing 

check box. Selecting this check box saves your workbook, turns on change tracking, 

and also shares your workbook, enabling more than one user to access the workbook 

simultaneously. 

You can use the controls in the Highlight Changes dialog box to choose which changes 

to track, but clearing the When, Who, and Where check boxes makes Excel 2007 track 

all changes. Now, whenever anyone makes a change to the workbook, the change is 

CLOSE the Projections for Comment workbook.t
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 attributed to the user logged in to the computer from which the change was made. Each 

user’s changes are displayed in a unique color. As with a comment, when you move the 

mouse pointer onto a change, the date and time when the change was made and the 

name of the user who made it appear as a ScreenTip.

After you and your colleagues fi nish modifying a workbook, you can decide which 

changes to accept and which changes to reject. To start the process, click the Review 

tab. In the Changes group, click Track Changes and then click Accept Or Reject Changes. 

After you clear the message box that indicates Excel 2007 will save your workbook, the 

Select Changes To Accept Or Reject dialog box appears. You can use the When down ar-

row to choose which changes to review. The default choice is Not Yet Reviewed, but you 

can also click Since Date to open a dialog box, into which you can enter the starting date 

of changes you want to review. To review all changes in your workbook, clear the When, 

Who, and Where check boxes.

When you are ready to accept or reject changes, click OK. The Accept or Reject Changes 

dialog box appears, with the fi rst change described in the body of the dialog box. 

Clicking the Accept button institutes the change; whereas clicking the Reject button 

removes the change, restores the cell to its previous value, and erases any record of the 

change. Clicking Accept All or Reject All implements all changes or restores all cells to 

their original values, but you should choose one of those options only if you are abso-

lutely certain you are doing the right thing.

If you want an itemized record of all changes you have made since the last time you 

saved the workbook, you can add a History worksheet to your workbook. To add a 

History worksheet, click Track Changes in the Changes group and then click Highlight 

Changes to open the Highlight Changes dialog box. Select the List Changes On A New 

Sheet check box. When you click OK, a new worksheet named History appears in your 

workbook. The next time you save your workbook, Excel 2007 will delete the History 

worksheet.

In this exercise, you turn on change tracking in a workbook, make changes to the work-

book, accept or reject changes, and create a History worksheet.

USE the Projection Change Tracking workbook in the practice fi le folder for this topic. This 

practice fi le is located in the My Documents\Microsoft Press\Excel SBS\Sharing folder.

OPEN the Projection Change Tracking workbook.

 1. On the Review tab, in the Changes group, click Track Changes and then click 

Highlight Changes.

The Highlight Changes dialog box appears.

USE thethe Projection Change TrackingProjection Change Tracking workbook in the practice fi le folder for this topic. Thisworkbook in the practice fi le folder for this topic. This

practice fi le is located in the practice fi le is located in the My Documents\Microsoft Press\Excel SBS\SharingMy Documents\Microsoft Press\Excel SBS\Sharing folder. folder.

OPEN thethe Projection Change TrackingProjection Change Tracking workbook. workbook.
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2. Select the Track changes while editing. This also shares your workbook 

check box.

The Highlight which changes area controls become active.

3. Click OK.

A dialog box appears, indicating that Excel 2007 will save the workbook.

4. Click OK.

The dialog box disappears. Excel 2007 saves the workbook and begins tracking 

changes.

5. In cell E6, type 15% and then press F.

A blue fl ag appears in the upper-left corner of cell E6.

6. In cell E7, type 12% and then press F.

A blue fl ag appears in the upper-left corner of cell E7.

7. On the Quick Access Toolbar, click the Save button to save your work.

8. On the Review tab, in the Changes group, click Track Changes and then click 

Highlight Changes.

The Highlight Changes dialog box appears.
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9. Select the List changes on a new sheet check box and then click OK.

Excel 2007 creates and displays a worksheet named History, which contains a list of 

all changes made since the last time a user accepted or rejected changes.

10. Click the Sheet1 sheet tab.

The Sheet1 worksheet appears.

11. On the Review tab, in the Changes group, click Track Changes and then click 

Accept/Reject Changes.

The Select Changes to Accept or Reject dialog box appears.

12. Click OK.

The Select Changes to Accept or Reject dialog box displays the fi rst change.

13. Click Accept.

Excel 2007 keeps the change and then displays the next change.

14. Click Accept.

Excel 2007 keeps the change and deletes the History worksheet. The Accept or 
Reject Changes dialog box disappears.

CLOSE the Projection Change Tracking workbook.CLOSE the Projection Change Tracking workbook.
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Protecting Workbooks and Worksheets
Excel 2007 gives you the ability to share your workbooks over the Web, over a corporate 

intranet, or by copying fi les for other users to take on business trips. An important part 

of sharing fi les, however, is ensuring that only those users you want to have access to 

the fi les can open or modify them. For example, Consolidated Messenger might have a 

series of computers available in a processing center so supervisors can look up package 

volumes and handling effi ciency information. Although those computers are vital tools 

for managing the business process, it doesn’t help the company to have unauthorized 

personnel, even those with good intentions, accessing critical workbooks.

You can limit access to your workbooks or elements within workbooks by setting 

 passwords. Setting a password for an Excel 2007 workbook means that any users who 

want to access the protected workbook must enter the workbook’s password in a dialog 

box that appears when they try to open the fi le. If users don’t know the password, they 

cannot open the workbook.

To set a password for a workbook, open the workbook to be protected, click the 

Microsoft Offi ce Button, and then click Save As. The Save As dialog box appears, with the 

name of the open workbook in the File name box. At the lower-left corner of the dialog 

box, click the Tools button and then click General Options to open the Save Options 

dialog box. In the Save Options dialog box, you can require users to enter one password 

to open the workbook and another to modify it. After you click OK, a Confi rm Password 

dialog box appears so that you can verify the passwords required to access and modify 

the workbook. After you have confi rmed the passwords, click Save in the Save As dialog 

box to fi nish adding password protection to the workbook. To later remove the pass-

words from a workbook, repeat these steps, but delete the passwords from the Save 

Options dialog box and save the fi le.

Tip The best passwords are random strings of characters, but random characters are 

hard to remember. One good method of creating hard-to-guess passwords is to combine 

 elements of two words with a number in between. For example, you might have a password 

wbk15pro, which could be read as “workbook, Chapter 15, protection.” In any event, avoid 

dictionary words in English or any other language, as they can be found easily by password-

guessing programs available on the Internet.

If you want to allow anyone to open a workbook but want to prevent unauthorized  users 

from editing a worksheet, you can protect a worksheet by displaying that worksheet, 

clicking the Review tab, and then, in the Changes group, clicking Protect Sheet to open 

the Protect Sheet dialog box.
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In the Protect Sheet dialog box, you select the Protect Worksheet And Contents Of 

Locked Cells check box to protect the sheet. You can also set a password that a user 

must type in before protection can be turned off again and choose which elements 

of the worksheet a user can change while protection is turned on. To enable a user to 

change a worksheet element without entering the password, select the check box next 

to that element’s name.

The check box at the top of the worksheet mentions locked cells. A locked cell is a cell 

that can’t be changed when worksheet protection is turned on. You can lock or un-

lock a cell by right-clicking the cell and choosing Format Cells from the shortcut menu 

that appears. In the Format Cells dialog box, you click the Protection tab to display the 

Protection tab page and select the Locked check box.

When worksheet protection is turned on, selecting the Locked check box prevents 

 unauthorized users from changing the contents or formatting of the locked cell, whereas 

selecting the Hidden check box hides the formulas in the cell. You might want to hide 

the formula in a cell if you draw sensitive data, such as customer contact information, 

from another workbook and don’t want casual users to see the name of the workbook in 

a formula.

Finally, you can password-protect a cell range. For example, you might want to let users 

enter values in most worksheet cells but also want to protect the cells with formulas that 

perform calculations based on those values. To password-protect a range of cells, select 

the cells to protect, click the Review tab, and then, in the Changes group, click Allow 

Users to Edit Ranges. The Allow Users to Edit Ranges dialog box appears.
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To create a protected range, click the New button to display the New Range dialog box. 

Type a name for the range in the Title box and then type a password in the Range pass-

word box. When you click OK, Excel 2007 asks you to confi rm the password; after you 

do, click OK in the Confi rm Password dialog box and again in the Allow Users to Edit 

Ranges dialog box to protect the range. Now, whenever users try to edit a cell in the 

protected range, they are prompted for a password. 

Tip Remember that a range of cells can mean just one cell!

In this exercise, you password-protect a workbook, a worksheet, and a range of cells and 

then hide the formula in a cell.

USE the SecureInfo workbook in the practice fi le folder for this topic. This practice fi le is 

located in the My Documents\Microsoft Press\Excel SBS\Sharing folder.

OPEN the SecureInfo workbook.

 1. Click the Microsoft Offi ce Button and then click Save As.

The Save As dialog box appears.

 2. Click the Tools button and then click General Options.

The General Options dialog box appears.

 3. Type work15pro in the Password to open box.

 4. Type pro15work in the Password to modify box.

USE thethe SecureInfoSecureInfo workbook in the practice fi le folder for this topic. This practice fi le isworkbook in the practice fi le folder for this topic. This practice fi le is

located in thelocated in the My Documents\Microsoft Press\Excel SBS\SharingMy Documents\Microsoft Press\Excel SBS\Sharing folder. folder.

OPEN thethe SecureInfoSecureInfo workbook. workbook.
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Protecting Workbooks and Worksheets
5. Click OK.

The Confi rm Password dialog box appears.

6. In the Reenter password to proceed box, type work15pro.

7. Click OK.

The Confi rm Password dialog box changes to ask you to reenter the password to 

modify the workbook.

8. In the Reenter password to modify box, type pro15work.

9. Click OK.

The Confi rm Password dialog box disappears.

10. Click Save.

Excel 2007 saves the workbook.

11. If necessary, click the Performance sheet tab.

The Performance worksheet appears.

12. Right-click cell B8 and then click Format Cells.

The Format Cells dialog box appears.

13. Click the Protection tab.

The Protection tab appears.

14. Select the Hidden check box and then click OK.

Excel 2007 formats cell B8 so that it won’t display its formula after you protect the 

worksheet.
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15. On the Review tab, in the Changes group, click Protect Sheet.

The Protect Sheet dialog box appears.

16. In the Password to unprotect sheet box, type prot300pswd.

17. Clear the Select locked cells and Select unlocked cells check boxes; then click OK.

The Confi rm Password dialog box appears.

18. In the Reenter password to proceed box, type prot300pswd and then click OK.

The Confi rm Password dialog box disappears.

19. Click the Weights sheet tab.

The Weights worksheet appears.

20. Select the cell range B2:C7.

21. On the Review tab, in the Changes group, click Allow Users to Edit Ranges.

The Allow Users to Edit Ranges dialog box appears.

22. Click New.

The New Range dialog box appears, with the range B2:C7 called out in the Refers 
to cells box.

23. In the Title box, type AllWeights.

24. In the Range password box, type work15pro and then click OK.

25. In the Confi rm Password dialog box, reenter the password work15pro.

The range appears in the Allow Users to Edit Ranges box.

26. Click Protect Sheet.

The Protect Sheet dialog box appears.

27. In the Password to unprotect sheet box, type work15pro and then click OK.

The Protect Sheet dialog box disappears.

28. In the Confi rm Password dialog box, reenter the password work15pro.

29. Click OK.

30. On the Quick Access Toolbar, click the Save button to save your changes.
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CLOSE the SecureInfo workbook.

Authenticating Workbooks
The unfortunate reality of exchanging fi les over networks, especially over the Internet, 

is that you need to be sure you know the origin of the fi les you’re working with. One 

way an organization can guard against fi les with viruses or substitute data is to authen-

ticate every workbook using a digital signature. A digital signature is a value created by 

combining a user’s unique secret digital signature fi le mathematically with the contents 

of the workbook, which programs such as Excel 2007 can recognize and use to verify 

the identity of the user who signed the fi le. A good analog for a digital signature is a 

wax seal, which was used for thousands of years to verify the integrity and origin of a 

document.

Note The technical details of and procedure for managing digital certifi cates are beyond 

the scope of this book, but your network administrator should be able to create a digital 

certifi cate for you. You can also directly purchase a digital signature from a third party, 

which can usually be renewed annually for a small fee. For the purposes of this book, you’ll 

use the selfcert.exe Microsoft Offi ce system accessory program to generate a certifi cate 

with which to perform the exercise at the end of the chapter. This type of certifi cate is use-

ful for certifying a document on your own computer, but it is not a valid certifi cate to verify 

yourself to others across your network or on the Internet.

To create a digital certifi cate you can use as a demonstration, open the Start menu, click 

All Programs, click Microsoft Offi ce, click Microsoft Offi ce Tools, and then click Digital 

Certifi cate for VBA Projects. In the Create Digital Certifi cate dialog box, type a name 

for your certifi cate and click OK to have the program create your trial certifi cate. Then, 

in Excel 2007, click the Microsoft Offi ce Button, click Prepare, and click Add a Digital 

Signature. In the Sign dialog box, type your purpose for signing the document and then 

click Sign to sign your workbook.

Note After you click Add a Digital Signature, Excel 2007 displays a dialog box, indicating 

that you can buy digital signatures from third-party providers. To get information about 

those services, click the Signature Services from the Offi ce Marketplace button. To bypass 

the message, click OK; to prevent the dialog box from appearing again, select the Don’t 

Show This Message Again check box and then click OK.

If you have several certifi cates from which to choose, and the desired certifi cate doesn’t 

appear in the Sign dialog box, you can click Change to display the Select Certifi cate 

CLOSE the SecureInfo workbook.
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 dialog box. In the Select Certifi cate dialog box, click the certifi cate with which you want 

to sign the workbook and then click OK. The Select Certifi cate dialog box disappears, 

and the certifi cate with which you signed the workbook appears in the Sign dialog box. 

As before, click Sign to sign your document using the digital certifi cate.

In this exercise, you create a digital certifi cate and digitally sign a workbook using the 

certifi cate.

USE the Projections Signed workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Sharing folder.

OPEN the Projections Signed workbook.

 1. Click the Start button, click All Programs, click Microsoft Offi ce, click Microsoft 
Offi ce Tools, and then click Digital Certifi cate for VBA Projects.

The Create Digital Certifi cate dialog box appears.

 2. In the Your certifi cate’s name box, type Excel2007SBS and then click OK.

A message box indicates that the program created your certifi cate successfully.

 3. Click OK.

The message box disappears.

 4. Click the Microsoft Offi ce Button, click Prepare, and then click Add a Digital 
Signature.

A dialog box appears, offering the opportunity to view signature services on Offi ce 

Marketplace.

 5. Click OK.

The dialog box disappears, and the Sign dialog box appears.

 6. In the Purpose for signing this document box, type Testing.

USE the the Projections SignedProjections Signed workbook in the practice fi le folder for this topic. This practice workbook in the practice fi le folder for this topic. This practicedd
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\SharingMy Documents\Microsoft Press\Excel SBS\Sharing folder. folder.

OPEN thethe Projections SignedProjections Signed workbook.workbook.dd
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 7. Verify that the Excel2007SBS certifi cate appears in the Signing as area of the dialog 

box and then click Sign.

The Signature Confi rmation dialog box appears.

 8. Click OK.

The Signatures task pane appears.

CLOSE the Projections Signed workbook.

Saving Workbooks for the Web
Excel 2007 enables you to save Excel 2007 workbooks as Web documents, so you and 

your colleagues can view workbooks over the Internet or a corporate intranet. For a doc-

ument to be viewed on the Web, the document must be saved as a Hypertext Markup 

Language (HTML) fi le. HTML fi les, which end with either the .htm or the .html extension, 

include tags that tell a Web browser such as Microsoft Internet Explorer® how to display 

the contents of the fi le.

For example, you might want to set the data labels in a workbook apart from the rest of 

the data by having the labels displayed with bold text. The coding in an HTML fi le that 

indicates text to be displayed as bold text is <B>...</B>, where the ellipsis points be-

tween the tags are replaced by the text to be displayed. So the following HTML  fragment 

would be displayed as Excel:

<B>Excel</B>

You can create HTML fi les in Excel 2007 by clicking the Microsoft Offi ce Button and click-

ing Save As to display the Save As dialog box. To save a workbook as an HTML fi le, select 

the Entire Workbook option button, type a name for the fi le in the File name box, click 

the Save as Type down arrow, and click Web Page (*.htm; *.html). With the fi le type set 

to Web Page, you can then click Save to have Excel 2007 create an HTML document for 

each sheet in the workbook.

Note If your workbook contains data only on the sheet displayed when you save the 

 workbook as a Web page, only that worksheet is saved as a Web page.

After you save an Excel 2007 workbook as a series of HTML documents, you can open it 

in your Web browser. To open the Excel 2007 fi le, start Internet Explorer, open the File 

menu, and then click Open to display the Open dialog box. In the Open dialog box, click 

CLOSE the Projections Signed workbook.d
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the Browse button to open the Microsoft Internet Explorer dialog box. You can use the 

controls in that dialog box to identify the fi le you want to open.

When you double-click the fi le to open, the Microsoft Internet Explorer dialog box 

disappears and the fi le’s name and path appear in the Open box. To display the Excel 

2007 workbook, click OK, and the workbook appears in Internet Explorer. You can move 

among the workbook’s worksheets by clicking the sheet tabs at the lower-left corner of 

the page.

Saving a workbook to an organization’s intranet enables you to share data with your 

 colleagues. For example, Consolidated Messenger’s chief operating offi cer, Jenny Lysaker, 

could save a daily report on package misdeliveries to her team’s intranet so that every-

one could examine what happened, where the problem occurred, and how to fi x the 

problem. It’s also possible to save a workbook as a Web fi le that retains a link to the 

original workbook. Whenever someone updates the workbook, Excel 2007 updates the 

Web fi les to refl ect the new content.

To publish a workbook to the Web, click the Microsoft Offi ce Button, click Save As, 

click the Save as Type down arrow, and click Web Page (*.htm; *.html). When you do, 

Excel 2007 displays the Publish button; clicking the Publish button displays the Publish as 

Web Page dialog box.

The controls in the Publish as Web Page dialog box enable you to select which elements 

of your workbook you want to publish to the Web. Clicking the Choose down arrow 

displays a list of publishable items, including the option to publish the entire workbook, 

items on specifi c sheets, a PivotTable® dynamic view, or a range of cells. To have Excel 

2007 update the Web page whenever someone updates the source workbook, select the 

AutoRepublish Every Time This Workbook Is Saved check box. You can also specify which 

text appears on the Web page’s title bar. To do so, click the Change button, type the 

page title in the Set Title dialog box, and click OK. When you save a workbook that has 

AutoRepublish turned on, Excel 2007 displays a dialog box indicating that the changes 

will update the associated Web fi le.
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Important When you save a PivotTable to the Web, the PivotTable doesn’t retain its 

 interactivity. Instead, Excel 2007 publishes a static image of the PivotTable’s current 

 confi guration.

In this exercise, you save a workbook as a Web page and then publish a worksheet’s 

PivotTable to the Web.

USE the Shipment Summary workbook in the practice fi le folder for this topic. This practice 

fi le is located in the My Documents\Microsoft Press\Excel SBS\Web folder.

OPEN the Shipment Summary workbook.

 1. Click the Microsoft Offi ce Button and then click Save As.

The Save As dialog box appears.

 2. In the File name box, type Shipment Summary Web.

 3. Click the Save as type down arrow and then click Web Page.

The Save As dialog box changes to refl ect the Web Page fi le type.

 4. Click Save.

A warning dialog box appears, indicating that the workbook might contain ele-

ments that can’t be saved in a Web page.

 5. Click Yes to save the workbook as a Web fi le.

The dialog box disappears, and Excel 2007 saves the workbook as a Web page.

 6. Click the Microsoft Offi ce Button and then click Close.

The Shipment Summary Web fi le disappears.

 7. Click the Microsoft Offi ce Button, and then, in the list of recently viewed fi les, click 

Shipment Summary.

The Shipment Summary workbook appears.

USE thethe Shipment SummaryShipment Summary workbook in the practice fi le folder for this topic. This practiceworkbook in the practice fi le folder for this topic. This practiceyy
fi le is located in the fi le is located in the My Documents\Microsoft Press\Excel SBS\WebMy Documents\Microsoft Press\Excel SBS\Web folder.folder.

OPEN thethe Shipment SummaryShipment Summary workbook.workbook.yy
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8. Click the Microsoft Offi ce Button and then click Save As.

The Save As dialog box appears.

9. In the File name box, type Shipment Summary Publish.

10. Click the Save as type down arrow and then click Web Page.

The Save As dialog box changes to refl ect the Web Page fi le type.

11. Click Publish.

The Publish as Web Page dialog box appears.

12. Click the Choose box’s down arrow and then click Items on Sheet 2.

The available items on Sheet2 appear.

13. In the Item to Publish list, click PivotTable.

14. Select the AutoRepublish every time this workbook is saved check box.

15. Click Publish.

Excel 2007 publishes the PivotTable to a Web page. Excel 2007 will update 

the  contents of the Web page whenever a user saves the Shipment Summary 

workbook.

CLOSE the Shipment Summary workbook.

CLOSE Excel 2007.

CLOSE the Shipment Summary workbook.y

CLOSE Excel 2007.
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Key Points
  Sharing a workbook enables more than one user to view and edit the data at one 

time, which is useful in group projects in which each member has a distinct area of 

responsibility.

  Sending fi les by e-mail is a very effi cient means of collaborating with colleagues. 

  Adding comments to cells is a quick way to let your colleagues know what you’re 

thinking without taking up valuable space in a cell.

  Use the Go To Special dialog box to fi nd cells with special contents, such as 

 comments, constants, or formulas.

  Tracking changes is vital when you share responsibility for a workbook with several 

other people.

  When your workbook’s data is too important to leave lying around in the open, use 

passwords to protect all or part of the fi le!

  Authenticating workbooks with digital signatures helps to identify the source of 

your fi les, so you won’t have to guess about the origins of that next attachment in 

your e-mail inbox.

  Saving a workbook as a Web-accessible HTML document is as easy as saving it as a 

regular Excel 2007 fi le, and opening a workbook saved for the Web is just as easy 

as opening any other Web page.

  Use the AutoRepublish facility to update Excel 2007 fi les on the Web. Whenever 

anyone changes the original workbook, Excel 2007 writes the edits to the HTML 

version of the fi le.
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3-D reference A pattern for referring to the 

workbook, worksheet, and cell from which a 

value should be read

active cell The cell that is currently selected and 

open for editing

Add-In A supplemental program that can be 

used to extend Excel’s functions

alignment The manner in which a cell’s  contents 

are arranged within that cell (for example, 

centered)

arguments  The specifi c data a function requires 

to calculate a value 

aspect ratio The relationship between a 

 graphic’s height and width

auditing The process of examining a worksheet 

for errors

AutoComplete The ability to complete data 

 entry for a cell based on similar values in other 

cells in the same column

AutoFill The ability to extend a series of values 

based on the contents of a single cell

AutoFilter A Microsoft Excel tool you can use to 

create fi lters

AutoRepublish An Excel technology that 

 maintains a link between a Web document and 

the worksheet on which the Web document is 

based and updates the Web document when-

ever the original worksheet is saved

browser A program that lets users view Web 

documents

cell The box at the intersection of a row and a 

column

cell range A group of cells

cell reference The letter and number 

 combination, such as C16, that identifi es the 

row and column intersection of a cell

charts Visual summaries of worksheet data, also 

called graphs

columns Cells that are on the same vertical line 

in a worksheet

conditional formats Formats that are applied 

only when cell contents meet certain criteria

conditional formula A formula that calculates a 

value using one of two different expressions, 

depending on whether a third expression is 

true or false

data consolidation Summarizing data from a set 

of similar cell ranges

data list One or more columns of data depicting 

multiple instances of a single thing (such as an 

order)

data table A new Microsoft Offi ce Excel 2007 

object that enables you to store and refer to 

data based on the name of the table and the 

names of its columns and rows

dependents The cells with formulas that use the 

value from a particular cell

driver A program that controls access to a fi le or 

device

dynamic-link library A fi le with  programming 

code that can be called by a worksheet 

function

embed To save a fi le as part of another fi le, as 

opposed to linking one fi le to another

error code A brief message that appears in a 

worksheet cell, describing a problem with a 

formula or a function

Glossary



354  Glossary
Extensible Markup Language (XML) A 

 content-marking system that lets you store 

data about the contents of a document in that 

document

fi eld A column in a data list

fi ll handle The square at the lower right corner 

of a cell you drag to indicate other cells that 

should hold values in the series defi ned by the 

active cell

Fill Series The ability to extend a series of values 

based on the contents of two cells, where the 

fi rst cell has the starting value for the series 

and the second cell shows the increment

fi lter A rule that Excel uses to determine which 

worksheet rows to display

formats Predefi ned sets of characteristics that 

can be applied to cell contents

formula An expression used to calculate a value

Formula AutoComplete The ability to enter a 

formula quickly by selecting functions, named 

ranges, and table references that appear when 

you begin to type the formula into a cell

freeze To assign cells that will remain at the top 

of a worksheet regardless of how far down the 

worksheet a user scrolls

function A predefi ned formula

Goal Seek An analysis tool that fi nds the value 

for a selected cell that would produce a given 

result from a calculation

graphs Visual summaries of worksheet data, also 

called charts

hyperlink A reference to a fi le on the Web

Hypertext Markup Language (HTML) A 

document-formatting system that tells a Web 

browser such as Internet Explorer how to 

 display the contents of a fi le

landscape mode A display and printing mode 

whereby columns run parallel to the short 

edge of a sheet of paper

link A formula that has a cell show the value 

from another cell

locked cells Cells that cannot be modifi ed if their 

worksheet is protected

macro A series of recorded automated actions 

that can be replayed

mailto A special type of hyperlink that lets a user 

create an e-mail message to a particular e-mail 

address

Merge and Center An operation, initiated by 

clicking the Merge and Center toolbar button, 

that combines a contiguous group of cells into 

a single cell. Selecting a merged cell and click-

ing the Merge and Center toolbar button splits 

the merged cells into the original group of 

separate cells.

metadata Data that describes the contents of a 

fi le

named range A group of related cells defi ned by 

a single name

Open DataBase Connectivity (ODBC) A proto-

col that facilitates data transfer between data-

bases and related programs

Paste Options A button, which appears after 

you paste an item from the Clipboard into your 

workbook, that lets you control how the item 

appears in the workbook

Pick from List The ability to enter a value into 

a cell by choosing the value from the set of 

values already entered into cells in the same 

column

pivot To reorganize the contents of a PivotTable

PivotChart A chart that is linked to a PivotTable 

and that can be reorganized dynamically to 

emphasize different aspects of the underlying 

data

PivotTable A dynamic worksheet that can be 

 reorganized by a user

portrait mode A display and printing mode 

whereby columns run parallel to the long edge 

of a sheet of paper

precedents The cells that are used in a formula
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primary key A fi eld or group of fi elds with  values 

that distinguish a row in a data list from all 

other rows in the list

property A fi le detail, such as an author name or 

project code, that helps identify the fi le

query A statement that locates records in a 

database

range A group of related cells

refresh To update the contents of one document 

when the contents of another document are 

changed

relative reference A cell reference in a formula, 

such as =B3, that refers to a cell that is a specif-

ic distance away from the cell that contains the 

formula. For example, if the formula =B3 were 

in cell C3, copying the formula to cell C4 would 

cause the formula to change to =B4.

report A special document with links to one or 

more worksheets from the same workbook

rows Cells that are on the same horizontal line in 

a worksheet

scenarios Alternative data sets that let you 

view the impact of specifi c changes on your 

worksheet

schema A document that defi nes the structure of 

a set of XML fi les

sharing Making a workbook available for 

more than one user to open and modify 

simultaneously

sheet tab The indicator for selecting a work-

sheet, located in the lower left corner of the 

workbook window

smart tags A Microsoft Offi ce technology that 

recognizes values in a spreadsheet and fi nds 

related information on the Web

sort To reorder the contents of a worksheet 

based on a criterion

split bar A line that defi nes which cells have 

been frozen at the top of a worksheet

subtotals Partial totals for related data in a 

worksheet

tables Data lists in a database

tags Marks used to indicate display properties or 

to communicate data about the contents of a 

document

template A workbook used as a pattern for 

 creating other workbooks

theme A predefi ned format that can be applied 

to a worksheet

trend line A projection of future data (such as 

sales) based on past performance

validation rule A test that data must pass to 

be entered into a cell without generating a 

 warning message

what-if analysis Analysis of the contents of 

a worksheet to determine the impact that 

 specifi c changes have on your calculations

workbook The basic Excel document, consisting 

of one or more worksheets

worksheet A page in an Excel workbook

workspace An Excel fi le type (.xlw) that allows 

you to open several fi les at once
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Symbols
##### error code, 76
#DIV/0! error code, 76
#NAME? error code, 76
#REF! error code, 76
#VALUE! error code, 76
.xlsm fi les, 293
.xlsx fi les, 293
.xltm fi les, 293
.xltxm fi les, 293
3-D references, 167

A
absolute references, 68
Accept or Reject Changes dialog box, 337
active cell, 41
Add-Ins

Analysis ToolPak, 197
installing, 191
Solver, 191

adding worksheets, 18
Add Scenario dialog box, 181
Allow Users to Edit Ranges dialog box, 341
alternative data sets, 179–199

defi ning, xlviii, 180
multiple, 183

alternative scenarios, 180
Analysis ToolPak, 197
analyzing data

Descriptive Statistics, xlix, 197
Goal Seek, xlix, 188

arguments, 65
arranging workbooks, 27
authenticating workbooks, 345
AutoCalculate, xliii, 128
AutoComplete, xxxii, 37

enabling, 38
AutoCorrect Options smart tag, 53

Index
Note Items with roman numerals refer to the Quick Reference pages at the front of the book.

AutoFill, xxxii, 36
Auto Fill Options button, 38
fi ll handle, 36
FillSeries, 36
repeating values, 37

AutoFilter, 122
AutoHeaders, lvi, 269
automating tasks. See macros
AutoRepublish, 351
AVERAGE function, 65
AVERAGEIF function, 71
AVERAGEIFS function, 72
axes

adding series, liii, 240
removing series, lii, 240

Axis Labels dialog box, 240

B
banded rows, 225
borders, xxxviii, 87

C
calculations. See formulas
Cascade option, 27
cell delimiters, 231
cell ranges. See ranges
cells

active cell, 41
adding borders, xxxviii, 87
adding comments, 333
adding text, xl, 103
applying styles, xxxviii, 92
borders, 87
cell ranges, 41
cell styles, 92
comments, lxi, 333
conditional formats, xli, 107
copying and pasting, xxxii, 41
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cells, (continued)
copying formatting, xxxviii, 94
defi ning data allowed in, 132
deleting, xxx, 22
editing contents, xxxiii, 44
font color, 87
fonts, 87
formatting, xxxviii, 86
formatting as currency, xl, 103
formatting as phone numbers, xl, 102
formatting based on their values, 107
hiding formulas, 341
inserting, xxx, 22
linking, xlviii, 166
locking, 341
monitoring selected, 78
moving, xxx, 23
number of text characters, 3
overwriting destination, 23
shading, 88
tracing dependents, 76
tracing precedents, 76
watching values, xxxviii, 78

Cell Styles gallery, 92
change tracking, 336
chart elements

3-D formats, 245
alignment, 245
fi lls, 245
formatting, liv, 245
lines, 245
line styles, 245
listing, 245
resizing, 245
shadows, 245

charts
applying chart templates, 246
axes, 239
Chart Styles, liii, 244
Chart Styles gallery, 244
creating, lii, 238–244
creating based on templates, 246
creating chart templates, liv, 246
creating on new worksheet, 241
formatting elements, 245
gridlines, liii, 245
labels, 240
layouts, liii, 244
listing elements, 245
moving in a worksheet, 241
moving to a different worksheet, liii, 241

printing, lviii, 288
resizing, 241
selecting data points, liii, 245
selecting elements for formatting, liii, 245
subtypes, 238
trendline options, 251
trendlines, liv, 250
x-axis, 239
y-axis, 239

Chart Styles gallery, 244
Choose a SmartArt Graphic dialog box, 259
circling invalid data, 133
color scales, xlii, 109
Colors dialog box, 97
columns

copying, xxxii, 41
deleting, xxix, 22
formatting inserted, 22
headers, 41
hiding, xxix, 22
inserting, xxix, 21
moving, 41
resizing multiple, 21
selecting, 41
unhiding, xxix, 22
width, xxix, 21

combining data. See consolidating data
comments, 333–336

adding, lxi, 334
deleting, lxii
editing, lxi, 334
selecting cells containing, 334
showing or hiding, 334

conditional data formats, new types, 8
conditional formatting

cells, xli, 107
creating conditional formats, 107
creating rules, 108
deleting rules, xli, 108, 334
displaying rules, 108
editing rules, 108
new types, 109
PivotTables, 224
rules, xli, 109
saving rules, 108

Conditional Formatting Rule Manager, 110
conditional formulas, xxxvii, 71, 71–74, 73
Consolidate dialog box, 173
consolidating data, 172–175

defi ning ranges, 173
controls, 2

cells, (continued)
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copying
cells, xxxii, 41
columns, xxxii, 41
formulas, 68
rows, xxxii, 41
worksheets, 18

corporate intranets, 347
COUNT function, 65
COUNTIFS function, 72
Create Names from Selection dialog box, 61
Create PivotTable dialog box, 204
Create PivotTable with PivotChart dialog box, 

255
creating macros, 299
creating PivotCharts, 252
Currency format, xl, 103
custom dictionaries, 48
custom lists for sorting

creating, xlvi, 142
using, xlvi, 142

custom number formats, 103
cycle diagrams, 259

D
data

analyzing, 196
automatic entry, 36
consolidating, 172
entering, 36
entering automatically, xxxii, 36
entering from list, xxxii, 37
entering using AutoComplete, xxxii, 37
exporting, 231
fi nding, xxxii, 44
grouping, xlvi, 147
importing, lii, 231
replacing, 44

data analysis, 196
data bars, xli, 109
data consolidation, 172
data labels, 86
data lists. See also data tables

converting to tables, 53
looking up information, 153–157
printing parts, 283
sorting, xlv, 141

data points, liii, 24
data sets, consolidating, 172

data tables, 35–57. See also tables
adding rows, xxxiv, 53
creating, xxxiv, 53
entering data, 36–40
linking, 168
renaming, xxxv, 54
resizing, xxxiv, 53
Total rows, xxxiv, 53

data validation, xliv, 132
turning off, xlv, 134

Data Validation dialog box, 132
Date format, 103
Delete dialog box, 23
deleting

rows or columns, 22
watches, xxxviii, 79
worksheets, 19

delimiters, 231
dependents, 76
descriptive statistics, xlix, 196–199
Descriptive Statistics dialog box, 197
diagrams. See also SmartArt

adding shapes, lv, 261
adding text, lv, 261

dialog boxes, opening, 2
Dialog Box Launchers, 2
digital certifi cates, 345

adding, 345
preparing, 345
selecting, 345

digital signatures, lxii, 345
displaying top or bottom values in a column, 

xliii, 124
Document Properties panel, 15
Down, Then Over printing option, 277
dynamic charts. See PivotCharts
dynamic lists, l
dynamic worksheets. See PivotTables

E
Edit Links dialog box, 168
Edit Name dialog box, 62
embedding Microsoft Offi ce system documents, 

lx, 317
entering data, 36

AutoFill, 36
FillSeries, 36
Pick from Drop-down List, 36

error checking, 75–81

error checking
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Error Checking dialog box, 77
error codes, 75

#####, 76
#DIV/0!, 76
#NAME?, 76
#REF!, 76
#VALUE!, 76

Evaluate Formula dialog box, 78
Excel Options dialog box, 28
extensible fi le formats, 4

F
fi elds, 206
fi le properties, 15

defi ning custom, xxvii, 16
deleting, 16
setting, xxvii, 15

fi les
formats, standards based, 4
grouping, 175
Microsoft Offi ce Compatibility Pack, 4
opening in previous versions of Excel, 4
open standards, 4
properties, 15
saving, 15
saving in Excel 2003 format, 15
searching, 15
sizes, 4
templates, 160
zip compression, 4

fi ll handles, xxxii, 36
FillSeries, 36
fi ltering PivotTables, 211
fi ltering worksheets, xlii, 122
fi lters, 122–137

applying, xlii, 122
criteria, 123
custom, xliii, 124
removing, xlii, 124
Top 10, 124

Find and Replace dialog box, 44
fi nding

data, 44
entire cell contents, 45
formatting, 45
match case, 45
options, 45
within list, 45

fi nding unique values in a list, 129

fi tting worksheets to printed pages, 283
Fixed Width, 232
font color, 87
fonts, standard, 88
footers, 268

adding images, lvi, 270
formatting images, lvi, 270

Format as Table dialog box, 53
Format as Table gallery, 98
Format Cells dialog box, 102
Format Painter button, 93
Format Shape dialog box, 262
formatting

chart elements, liv, 245
conditionally, 107
inserted rows or columns, 22
numbers, 102–107

formatting cells, xxxviii, 86–91
borders, 87
color, 87
deleting formatting, 87
fonts, 87
Format Painter, 93
shading, 88
styles, 92

Formatting Only option, 42
Formatting Options smart tag, 224
formatting rows or columns, 88
Formula AutoComplete, 6, 66
formula bar, 64
formulas, 59–83

absolute references, 68
auditing, xxxvii, 75
calculating optimal solutions, 190
conditional, xxxvii, 71, 73
copying and pasting, 68
creating, xxxvi, 64
creating static, xxxvi, 64
creating using AutoComplete, xxxvi, 67
desired result calculations, 188
displaying precedents, xxxvii, 76
error codes, 75
evaluating, 78
Formula AutoComplete, 66
formula bar, 64
functions, 64
hiding, 341
identifying errors, 75
Insert Function dialog box, xxxvi, 64
locating errors, xxxviii, 78
maximum length, 3

Error Checking dialog box
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new functions, 7
number of arguments, 3
number of nested levels, 3
range names, 66
references, 68
referring to table columns or rows, xxxvi, 66
relative references, 68
removing tracer arrows, xxxvii
SUBTOTAL, xliv, 128
tracing dependents, xxxvii, 76
tracing precedents, 76
using named ranges, xxxvi, 66
writing, 64

functions, 64
arguments, 65
AVERAGE, 65
AVERAGEIF, 71
AVERAGEIFS, 72
COUNT, 65
COUNTIFS, 72
GETPIVOTDATA, 220
HLOOKUP, 155
IF, 71
IFERROR, 71
MAX, 65
MIN, 65
new, 7
NOW(), 65
PMT(), 65
RAND(), 127
RANDBETWEEN, 128
SUBTOTAL, 128
SUM, 65, 67
SUMIFS, 72
VLOOKUP, 72, 153

G
GETPIVOTDATA function, 220
goal seeking, xlix, 188–190
Go To Special dialog box, 334
graphics. See SmartArt
grouping worksheet data, xlvi, 148

removing levels, xlvii, 150
groups, 2

H
headers, 268

adding graphics, lvi, 270
Auto Headers, 269
formatting images, lvi, 270

hiding
detail, 148
rows or columns, 22
worksheets, 19

hierarchy diagrams, 259
Highlight Changes dialog box, 336
history, 331
History worksheets, lxii, 337
HLOOKUP function, 155
Home tab, 2
HTML. See Hypertext Markup Language (HTML) 

fi les
hyperlinks

creating, lx, 320
deleting, lxi, 323
editing, lxi, 323

Hypertext Markup Language (HTML) fi les, 347
saving workbooks as, 347

I
icon sets, xlii, 109
IFERROR function, 71
IF function, 71
images, 114–117

adding borders, 115
adding to headers or footers, lvi, 270
adding to worksheets, 115
contrast and brightness, 115
formatting, xlii, 113
repositioning, 115
resizing, 115
rotating, 115
tiling on worksheet background, 115

importing
delimited data, 232
fi xed width data, 232
text fi le data, 231

Import Text File dialog box, 231
Insert dialog box, 22
Insert Function dialog box, 6, 64
Insert Picture dialog box, 114

Insert Picture dialog box
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Intelliprint, 285
Internet, 347

K
Keep Source Column Widths option, 42
Keep Source Formatting option, 42

L
labels. See data labels
landscape mode, 274
levels of detail, 149
linking

3-D references, 167
cells, worksheets, workbooks, xlviii, 166–171
data tables, 168
editing links, 168
Microsoft Offi ce system documents, lx, 314

list diagrams, 259
locking cells, 341
logos, 114
looking up data, xlvii, 153–157

M
Macro dialog box, 295, 296
macros, 291–311

assigning to buttons, 304
assigning to shapes, lx, 305
Auto_Open, 308
creating, 299
deleting, 300
disabling, 294
editing, lviii
enabling, lviii, 294
examining, 295
executing instructions, 296
fi le types, 293
naming, 300
recording, lviii, 299
running, lviii, 296
running when workbooks are opened, 308
security levels, 294
stepping through, lviii, 296
viewing, lviii, 296

magnifying a worksheet. See zooming

margins, lvi
custom, 273
preset, 273

Match Destination Formatting option, 42
matrix diagrams, 259
MAX function, 65
Microsoft Encarta encyclopedia, 48
Microsoft Internet Explorer, 347
Microsoft Offi ce Button, 14
Microsoft Offi ce Compatibility Pack, 4
Microsoft Offi ce Open XML fi le formats, 4

advantages, 4
Microsoft Offi ce Security Options dialog box, 

293
Microsoft Offi ce system documents

linking to, lx, 314
Microsoft Visual Basic Editor, 295, 296
Microsoft Visual Basic for Applications, 292
MIN function, 65
minitoolbars, 88
modifying macros, 299
Move Chart dialog box, 241
Move Or Copy dialog box, 18
moving worksheets, 18
multiple workbooks, 27
My table has headers check box, 53

N
Name box, 61
named ranges. See ranges
Name Manager, xxxv, 61
naming macros, 300
naming ranges, 60–63
negative numbers, 103
new features, 1–11
new functions

AVERAGEIF, 8
AVERAGEIFS, 8
COUNTIFS, 8
IFERROR, 8
SUMIFS, 8

New Name dialog box, 61
New Range dialog box, 342
New Table Quick Style dialog box, 98
New Workbook dialog box, 161
NOW() function, 65
number formatting

custom, 103
phone numbers, 102

Intelliprint
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O
Offi ce Excel 2007

earlier versions, 1, 2
expanded capabilities, 3
new features, 1–11

opening
second copy of a workbook, 27
workbooks, 27

open standards, 4
Open XML. See Microsoft Offi ce Open XML fi le 

formats
optimal solutions, 190
organization charts, 262
Over, Then Down printing option, 277

P
Page Break Preview mode, 276
page breaks

adding manual, lvi, 276
moving, 277
previewing, 276
removing, lvi, 276

Page Layout view, lv, 10, 268
Page Setup dialog box, 275
passwords

deleting, 340
modify workbook passwords, 340
open workbook passwords, 340
ranges, 341
requiring, lxii, 340
workbooks, 340

Paste Options button, 41
showing, 42

phone number formatting, xl, 102
photos. See images
Pick from Drop-down List, 36
pictures, 114. See images
PivotCharts, 252–258

chart types, liv, 254
creating, liv, 252
fi ltering, 253
refreshing, 253

PivotTable Field List task pane, l, 205, 255
PivotTables, l, 201–235

assigning fi elds, 206
column limit, 3
conditional formatting, l, 224

creating, l, 204
deferring layout updates, 208
editing, 218–223
external data sources, 230
fi ltering, l, 211, 211–217
formatting, 223–230
GETPIVOTDATA function, 220
grand totals, 218
hiding levels of detail, l, 214
linking to workbooks, 219
number formats, li, 223
pivoting, l, 208
PivotTable names, 218
PivotTable Styles, li, 225
QuickStyles, 225
refreshing connections to data source, 208
renaming, l, 218
styles, 225
subtotals and grandtotals, li, 218
summary functions, li, 219
summary rows and columns, 218
updating, 208

PMT() function, 65
portrait mode, 274
precedents, 76
primary key columns, 153
print area, 284
Print dialog box, 282, 288
printing, 267–289

Auto Headers, 269
centering on page, lvii, 284
charts, lviii, 288
collating pages, 281
column headings, 285
custom headers, 270
data lists, 281
Down, Then Over, 277
fi tting worksheets to pages, 283
headers and footers, lv, 268
Intelliprint, 285
landscape mode, 274
margins, lvi, 273
multiple copies, 281
order, lvi, 277
Over, Then Down, 277
page breaks, lvii, 275
page orientation, lvi, 274
parts of data lists, 283
portrait mode, 274
previewing, lvi, 275
print areas, 284
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printing (continued)
Print Preview, 268
print titles, 285
Print What option, 282
Quick Print, 281
removing page breaks, lvi, 276
scaling to fi t, 275, 284
selecting worksheets, 281
specifi c number of pages, lvi, 275
without blank pages, 285
worksheet errors, 281
worksheet parts, lvi, 283

Print Preview, 268, 275
process diagrams, 259
Properties dialog box, 15
Property Views and Options, 15
protecting a worksheet, 340
Protect Sheet dialog box, 340
Publish as Web Page dialog box, 348
publishing workbooks to the Web, 348
pyramid diagrams, 259

Q
Quick Access Toolbar, lviii, 28–32

adding buttons, xxxi, 28
adding macro buttons, 304
moving buttons, xxxi, 28
removing buttons, xxxi, 28

Quick Print, 281

R
RAND() function, xliii, 127
RANDBETWEEN function, xliii, 128
random values, xliii, 128
ranges, 41, 60

copying, 41
cutting, 41
deleting, 41
deleting names, 62
editing named, xxxv, 62
editing names, 62
formatting, 41
Name Manager, xxxv, 61
naming, xxxv, 61
naming from a selection, xxxv, 61
passwords, lxii, 341

recording macros, 299
recording workbook changes, lxii, 331
Record Macro dialog box, 299

references
3-D, 167
absolute, 68
relative, 68

relationship diagrams, 259
relative references, 68
reorganizing data dynamically. See PivotTables
replacing data, xxxiii, 44
Research task pane, 48
resolving confl icting changes, 331
Review tab, 334
Ribbon

controls, 2
Dialog Box Launchers, 2
ellipsis, 2
groups, 2
tabs, 2

rows
copying, xxxii, 41
deleting, xxix, 22
formatting inserted, 22
height, xxix, 21
hiding, xxix, 22
inserting, xxix, 21
resizing multiple, 21
unhiding, xxix, 22

rules, conditional formatting, 8

S
Save As dialog box, 15
saving in Excel 2003 fi le format, 15
Scenario Manager, 180, 183
scenarios

multiple, xlix, 183
undo, 184

Scenario Summary dialog box, 184
schema, 4
ScreenTips, 337
searching for workbooks, 15
seeking a goal, 188
Select Certifi cate dialog box, 346
Select Changes To Accept Or Reject dialog box, 

337
Select Source Data dialog box, 239
series, lii-liii, 240

autofi lling, 36
extending, xxxii, 37

shading, 88
Share Workbook dialog box, 331
sharing workbooks, lxi, 330–333
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by e-mail, 331
change history, 331
inserting comments, 333
methods, 331
recording changes, 331
resolving confl icting changes, 331

SmartArt, lv, 258–265
adding shapes, lv, 260
adding text, lv, 260
cycle diagrams, 259
editing elements, 262
formatting shapes, lv, 262
hierarchy diagrams, 259
list diagrams, 259
matrix diagrams, 259
process diagrams, 259
pyramid diagrams, 259
relationship diagrams, 259

Solver Add-In, 191–196
Solver Parameters dialog box, 192
sorting

adding sorting levels, xlv, 142
custom sort lists, xlvi, 142
data, 140–147
deleting sorting levels, xlv, 142
levels, 142
multiple column, xlv, 141
order, 142

spelling checker, xxxiii, 48
Spreadsheet Solutions, 162
Style dialog box, 92
styles

applying to cells, xxxviii, 92
choosing, 92
creating, xxxviii, 92
defi ning, 92–96
deleting, xxxviii, 93

Subtotal dialog box, 147
SUBTOTAL function, xliv, 128
subtotals, 128, 147–152

grouping, 148
hiding and showing detail, 148
PivotTables, 218

SUM function, 65
SUMIFS function, 72
summarizing data quickly, xliii
summary functions, xxxv, 54

T
tab bar, 18, 19
tables, 52–55

adding data, 53
adding rows or columns, 53
AutoExpansion, 53
converting to normal ranges, 54
creating, 53
creating from data lists, 53
renaming, 54
resize handles, 53
table styles, 98
total rows, 53

table styles, 96–102
creating, xl, 98
saving, 98

tabs, 2
templates

adding template-based worksheets, xlviii, 162
changing, 160
creating from existing workbooks, 160
workbook, xlvii, 160
worksheet, xlviii, 162

text
data labels, 88
formatting, 88
importing data from, 231
styles, 92

Text Import Wizard, 231
themes, 96–102

applying, xxxviii, 97
creating from a workbook’s format, xxxix, 162
customizing, 98
editing, xxxix, 98
saving, 98

Thesaurus, xxxiv, 48
toolbars, 1
Top 10 fi lters, 124
Total rows

adding, xxxiv, 53
summary function, xxxv, 54

tracer arrows, xxxvii, 77
tracing dependents, 76
tracing precedents, 76
tracking changes, lxii, 336–339

accepting all changes, 337
accepting or rejecting changes, lxii, 337
benefi ts, 336

Z02I62304X.indd   365 11/28/2006   12:52:37 PM



366  

tracking changes (continued)
History worksheets, 337
rejecting all changes, 337
reviewing changes, 337

translating text, xxxiv, 49
trends, 250–252

charting trendlines, 250
distribution types, 251
exponential, 251
linear, 251
logarithmic, 251
polynomial, 251
trendline options, 251

Trust Center, 294

U
Undo button, 48
undo scenario, 184
unhiding rows or columns, 22
unhiding worksheets, 19
unique values, fi nding, xliv, 127
Use Destination Theme option, 42
user interface, 1

V
validating data, 132–137
validation rules, xliv, 132
Values and Number Formatting option, 42
Values and Source Formatting option, 42
Values Only option, 42
VBA. See Microsoft Visual Basic for Applications
VLOOKUP function, xlvii, 72, 153

W
watching values, xxxviii, 78
Watch Windows, 78
Web

publishing workbooks, lxii, 347
saving workbooks as Web fi les, lxiii, 347

Web browsers, 347
opening worksheets, 347

Web pages, saving workbooks as, 347
what-if analyses, 180, 188
Windows search, 15
workbook properties, 273
workbooks

adding images, 114

alternative scenarios, 180
arranging open, xxxi, 27
authenticating, 345
consolidating. See consolidating data
creating, xxvii, 14–17
default, 14
design themes, 5
displaying two copies, 27
enabling simultaneous editing, 330
grouping, 175
history of changes, 331
linking, 166
modifying, 18, 18–21
moving data within, 40–43
multiple alternative scenarios, 183
naming, 15
opening, xxvii, 14
opening multiple, xlviii, 27
passwords, lxii, 340
properties, 15
publishing to Web, lxii, 347
recording changes, 331
saving, xxvii, 14
saving as Web pages, 347
saving frequency, 15
sharing, lxi, 330
signing with digital signatures, lxii, 345
standard font, 88
switching among, xxxi, 27
templates, xlvii, 160
themes, 5, 96
tracking changes, lxii, 336

worksheets
adding, 18
adding images, 114
adding logos, 114
adding pictures, xlii, 113
column width, 21
consolidating. See consolidating data
copying between workbooks, xxviii, 18
creating, xxviii, 18
deleting, xxix, 19
displaying, xxviii, 18
fi ltering, xlii, 122
fi nding data, xxxii, 44
headers and footers, lv, 268
hiding, xxix, 19
linking, 166
margins, lvi, 273
maximum number of columns, 3
maximum number of rows, 3
modifying, 21, 21–25

tracking changes (continued)
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   367Zoom to Selection

moving, 18
outlining, 148
Page Layout View, lv
passwords, lxiii, 340
printing, lvii, 281
printing parts, lvii, 283
renaming, xxviii, 18
reordering, xxviii, 19
row height, 21
size limits, 2
tab bar, 18
unhiding, xxix, 19
zooming, 26

worksheet tabs
color, 19
deleting, 19
hiding, 19
reordering, 19

workspaces, 159
defi ning, 175
opening, 175

X
XML fi le format, 4

Z
Zoom dialog box, 26
zooming, xxx, 26

in, xxx, 26
out, xxx, 26
specifi c zoom level, xxxi, 26

Zoom to Selection, 26
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