
Excel: VLookup Function 
 

In Excel, the VLookup function searches for value in the left-most column of 
table_array and returns the value in the same row based on the index_number. 
The syntax for the VLookup function is: 

VLookup( value, table_array, index_number, 
not_exact_match ) 

value is the value to search for in the first column of the table_array. 
table_array is two or more columns of data that is sorted in ascending order. 
index_number is the column number in table_array from which the matching 
value must be returned. The first column is 1. 
not_exact_match determines if you are looking for an exact match based on 
value. Enter FALSE to find an exact match. Enter TRUE to find an approximate 
match, which means that if an exact match if not found, then the VLookup 
function will look for the next largest value that is less than value. 
 

Note: 
If index_number is less than 1, the VLookup function will return #VALUE!. 
If index_number is greater than the number of columns in table_array, the 
VLookup function will return #REF!. 
If you enter FALSE for the not_exact_match parameter and no exact match is 
found, then the VLookup function will return #N/A. 
 

For example: 
Let's take a look at an example: 



 
Based on the Excel spreadsheet above: 

=VLookup(10251, A1:B21, 2, 
FALSE) would return "Tofu" 

=VLookup(10251, A1:C21, 3, 
FALSE) would return $18.60 

=VLookup(10248, A1:B21, 2, 
FALSE) would return #N/A 

=VLookup(10248, A1:B21, 2, 
TRUE) 

would return "Queso 
Cabrales"

 

Frequently Asked Questions 

 
Question:  In Excel, I'm using the VLookup function to return a value. I want to 
sum the results of the VLookup, but I can't because the VLookup returns a #N/A 
error if no match is found. How can I sum the results when there are instances of 
#N/A in it? 
Answer: To perform mathematical operations on your VLookup results, you need 
to replace the #N/A error with a 0 value (or something similar). This can be done 



with a formula that utilizes a combination of the VLookup function, IF function, 
and ISNA function. 

Based on the spreadsheet above: 

=IF(ISNA(VLOOKUP(E2,$A$2:$C$5,3,FALSE)),0,VLOOKUP(E2,$A$2:$C$5,3,FALSE))
would
return 
0 

First, you need to enter a FALSE in the last parameter of the VLookup function. 
This will ensure that the VLookup will test for an exact match. 
If the VLookup function does not find an exact match, it will return the #N/A error. 
By using the IF and ISNA functions, you can return the Unit Price value if an 
exact match is found. Otherwise, a 0 value is returned. This allows you to 
perform mathematical operations on your VLookup results. 

 
Question:  I have a list of #s in column A (lets say 1-20). There is a master list in 
another column that may not include some of the column A #s. I want a formula 
in column B to say (if A1 exists in the master list, then "Yes", "No". Is this 
possible? 



Answer: This can be done with a formula that utilizes a combination of the 
VLookup function, IF function, and ISNA function. 

 
Based on the spreadsheet above: 

=IF(ISNA(VLOOKUP(A2,$D$2:$D$185,1,FALSE)),"No","Yes") 
would 
return 
"No" 

=IF(ISNA(VLOOKUP(A5,$D$2:$D$185,1,FALSE)),"No","Yes") 
would 
return 
"Yes" 

First, you need to enter a FALSE in the last parameter of the VLookup function. 
This will ensure that the VLookup will test for an exact match. 
If the VLookup function does not find an exact match, it will return the #N/A error. 
By using the IF and ISNA functions, you can return a "Yes" value if an exact 
match is found. Otherwise, a "No" value is returned. 

 
Question:  Is there a simple way in Excel to VLookup the second match in a 
column? So, for instance, If I had apple, pear, apple listed in the column (each 
word in a separate cell), would there be a way to look up the values to the right of 
the second "apple"? 



Answer: This can be done with a formula that utilizes a combination of the Index 
function, Small function, Row function (all in an array formula). 

If you wanted to return the quantity value for the second occurrence of apple, you 
would use the following array formula: 

=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),2),2) 

When creating your array formula, you need to use Ctrl+Shift+Enter instead of 
Enter. This creates {} brackets around your formula as follows: 

{=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),2),2)} 

 

If you wanted to return the quantity value for the third occurrence of apple, you 
would use the following array formula: 

=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),3),2) 



When creating your array formula, you need to use Ctrl+Shift+Enter instead of 
Enter. This creates {} brackets around your formula as follows: 

{=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),3),2)} 

 

If you wanted to return the bin # for the second occurrence of apple, you would 
use the following array formula: 

=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),2),3) 

When creating your array formula, you need to use Ctrl+Shift+Enter instead of 
Enter. This creates {} brackets around your formula as follows: 

{=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),2),3)} 

 

If you wanted to return the bin # for the third occurrence of apple, you would use 
the following array formula: 

=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),3),3) 

When creating your array formula, you need to use Ctrl+Shift+Enter instead of 
Enter. This creates {} brackets around your formula as follows: 

{=INDEX(A2:C6,SMALL(IF(A2:C6="apple",ROW(A2:C6)-
ROW(A2)+1,ROW(C6)+1),3),3)} 

 



Excel: If Function 
 

In Excel, the If function returns one value if a specified condition evaluates to 
TRUE, or another value if it evaluates to FALSE. 
The syntax for the If function is: 

If( condition, value_if_true, value_if_false ) 

condition is the value that you want to test. 
value_if_true is the value that is returned if condition evaluates to TRUE. 
value_if_false is the value that is return if condition evaluates to FALSE. 
 

For example: 
Let's take a look at an example: 

 
Based on the Excel spreadsheet above: 

=If(A1>10, "Larger", "Smaller") would return "Larger".

=If(A1=20, "Equal", "Not would return "Not Equal".



Equal") 
=If(A2="Tech on the Net", 12, 
0) would return 12. 

 

Learn how to nest multiple If Functions. (up to 7) 
Learn how to nest multiple If Functions. (more than 7) 
 

Frequently Asked Questions 

 
Question:  In Excel, I'd like to use the If function to create the following logic: 

if C11>=620, and C10="F"or"S", and C4<=$1,000,000, and 
C4<=$500,000, and C7<=85%, and C8<=90%, and C12<=50, and 
C14<=2, and C15="OO", and C16="N", and C19<=48, and 
C21="Y", then reference cell A148 on Sheet2. Otherwise, return an 
empty string. 

Answer:  The following formula would accomplish what you are trying to do: 

=IF(AND(C11>=620, OR(C10="F",C10="S"), C4<=1000000, 
C4<=500000, C7<=0.85, C8<=0.9, C12<=50, C14<=2, C15="OO", 
C16="N", C19<=48, C21="Y"), Sheet2!A148, "") 

 

Excel: Nested IF Functions 
 

It is possible to nest multiple IF functions within one Excel formula. You can nest 
up to 7 IF functions to create a complex IF THEN ELSE statement. 
The syntax for the nesting the IF function is: 



IF( condition1, value_if_true1, IF(condition2, 
value_if_true2, value_if_false2 ) 

This would be equivalent to the following IF THEN ELSE statement: 

IF condition1 THEN 
    value_if_true1 
ELSEIF condition2 THEN 
    value_if_true2 
ELSE 
    value_if_false2 
END IF 

This syntax example demonstrates how to nest two IF functions. You can nest up 
to 7 IF functions. 
condition is the value that you want to test. 
value_if_true is the value that is returned if condition evaluates to TRUE. 
value_if_false is the value that is return if condition evaluates to FALSE. 
 

For example: 
Let's take a look at an example: 

 



Based on the Excel spreadsheet above: 

=IF(A1="10X12",120,IF(A1="8x8",64,IF(A1="6x6",36)))
would 
return 
120

=IF(A2="10X12",120,IF(A2="8x8",64,IF(A2="6x6",36)))
would 
return 64 

=IF(A3="10X12",120,IF(A3="8x8",64,IF(A3="6x6",36)))
would 
return 36 

 

Frequently Asked Questions 

 
Question:  In Excel, I need to write a formula that works this way: 

If (cell A1) is less than 20, then times it by 1, 
If it is greater than or equal to 20 but less than 50, then times it by 2 
If its is greater than or equal to 50 and less than 100, then times it 
by 3 
And if it is great or equal to than 100, then times it by 4 

Answer:  You can write a nested IF statement to handle this. For example: 

=IF(A1<20, A1*1, IF(A1<50, A1*2, IF(A1<100, A1*3, A1*4))) 

 

Excel: Create custom function to exceed 
7 nested If functions 

 
Question:  I have a formula in Excel that I am using to test for 7 conditions, and 
each condition if true will return a different value. However, I now need to test a 
total of 12 possible values. The limitation of the nested IFs is that you can only 



nest up to 7. Is there an alternative to this formula to test so that I can test for 12 
values instead of 7? 
=IF(A1="10X12",140,IF(A1="8x8",64,IF(A1="6x6",36,IF(A1="8x10",80,IF(A1="14
x16",224,IF(A1="9x9",81,IF(A1="4x3",12))))))) 
 

Answer:  There is no built-in alternative formula in Excel, but you could write your 
own function in VBA and then call this new function instead. 
Let's take a look at an example. 
Download Excel spreadsheet (as demonstrated below) 

 
In our spreadsheet, we've created a custom VBA function called CalcValue. This 
function accepts as a parameter a cell and returns a value based on a complex 
IF THEN ELSE statement. You can use this method to nest up to or more than 7 
IF conditions. 
You can press Alt-F11 to view the VBA code. 
 

Macro Code: 

The macro code looks like this: 



Function CalcValue(pVal As String) As Long 

    If pVal = "10x12" Then 
        CalcValue = 140 

    ElseIf pVal = "8x8" Then 
        CalcValue = 64 

    ElseIf pVal = "6x6" Then 
        CalcValue = 36 

    ElseIf pVal = "8x10" Then 
        CalcValue = 80 

    ElseIf pVal = "14x16" Then 
        CalcValue = 224 

    ElseIf pVal = "9x9" Then 
        CalcValue = 81 

    ElseIf pVal = "4x3" Then 
        CalcValue = 12 

    Else 
        CalcValue = 0 
    End If 

End Function 

 
 



Excel: Hide formulas from appearing in 
the edit bar 

 
We'll demonstrate how to hide formulas from appearing in the edit bar in Excel 
2007 as well as earlier versions such as Excel 2003/XP/2000/97. 
 

Hide formulas from appearing in the edit bar in Excel 
2007 

Question:  I have formulas in an Excel worksheet that I don't want to be visible 
when that cell is selected. 
Is there a way I can click on the cell and not see the formula up top? 
Answer:  As you can see, currently the formulas are visible. 

 
 



To hide the formulas, first you'll need to un-protect all of the cells on your sheet. 
To do this, select all of the rows and columns in your sheet. Right-click on then 
select "Format Cells" from the popup menu. 

 
 

When the Format Cells window appears, select the Protection tab. Uncheck the 
"Locked" checkbox. Click on the OK button. 



 
 

Next, select the cell(s) that you wish to hide the formulas for. Right-click and then 
select "Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Protection tab. Check the 
"Hidden" checkbox. Click the OK button. 



 
 

For the formulas to be hidden, you must also protect the worksheet. To do this, 
select the Review tab from the toolbar at the top of the screen. Then click on 
Protect Sheet button. 



 
 

A "Protect Sheet" window will appear. You may enter a password to protect the 
sheet if you wish. The password is optional. Click on the OK button. 

 
 

Now when you view your spreadsheet, the formula will no longer appear at the 
top when the cell is selected. 



 
 

Hide formulas from appearing in the edit bar in Excel 
2003/XP/2000/97 

Question:  I have formulas in an Excel worksheet that I don't want to be visible 
when that cell is selected. 
Is there a way I can click on the cell and not see the formula up top? 
Answer:  First, you'll need to un-protect all of the cells on your sheet. To do this, 
select all of the rows and columns in your sheet. Right-click on then select 
"Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Protection tab. Uncheck the 
"Locked" checkbox. Click on the OK button. 

 
 



Next, select the cell(s) that you wish to hide the formulas for. Right-click and then 
select "Format Cells" from the popup menu. 

 
 

When the Format Cells window appears, select the Protection tab. Check the 
"Hidden" checkbox. Click the OK button. 



 
 

For the formulas to be hidden, you must also protect the worksheet. To do this, 
select Protection and then "Protect Sheet" under the Tools menu. 

 
 



A "Protect Sheet" window will appear. Check the "Contents" checkbox. You may 
enter a password to protect the sheet if you wish. The password is optional. Click 
on the OK button. 

 
 

Now when you view your spreadsheet, the formula will no longer appear at the 
top when the cell is selected. 

 



Excel: Copy and paste only nonblank 
cells (condensing paste range) 

 
We'll demonstrate how to copy and paste only nonblank cells in Excel 2007 as 
well as earlier versions such as Excel 2003/XP/2000/97. 
 

Copy and paste only nonblank cells (condensing 
paste range) in Excel 2007 

Question:  In Excel, how do I copy the entries of a series of cells and paste only 
non-blank cells? Paste special then skip blank option doesn't seem to work. 
Answer:  Unfortunately, there isn't a simple solution to this question. The 
following example demonstrates how to copy and paste only nonblank cells. 
First, highlight all of the cells (including both blank and nonblank cells) that you 
wish to paste. In this example, we've highlighted cells A1 to A8. 
Next, select the Data tab in the toolbar at the top of the screen and click on the 
Filter button (see orange highlighted button in picture below). 



 
 

A drop-down should appear in the first cell of your range. Click on this drop-
down. 



 
 

De-select the (Blanks) option and then click on the OK button. 

 
 



Your spreadsheet should now only display nonblank cells. 
Next, copy the data using Ctrl-C. 

 
 

Then paste the data using Ctrl-V. In this example, we've chosen to paste the 
nonblank cells into Sheet2. 



 
 

Copy and paste only nonblank cells (condensing 
paste range) in Excel 2003/XP/2000/97 

Question:  In Excel, how do I copy the entries of a series of cells and paste only 
non-blank cells? Paste special then skip blank option doesn't seem to work. 
Answer:  Unfortunately, there isn't a simple solution to this question. The 
following example demonstrates how to copy and paste only nonblank cells. 
First, highlight all of the cells (including both blank and nonblank cells) that you 
wish to paste. In this example, we've highlighted cells C1 to C8. 



 
 

Under the Data menu, select Filter > AutoFilter. 

 
 

A drop-down should appear in the first cell of your range. Select NonBlanks from 
the drop-down. 



 
 

Your spreadsheet should now only display nonblank cells. 
Next, copy the data using Ctrl-C. 

 
 

Then paste the data using Ctrl-V. In this example, we've chosen to paste the 
nonblank cells into Sheet2. 



 
 
 

Excel: Display comment indicator next 
to cells with comments 

 
We'll demonstrate how to display a comment indicator next to cells with 
comments in Excel 2007 as well as earlier versions such as Excel 
2003/XP/2000/97. 
 

Display comment indicator next to cells with 
comments in Excel 2007 

Question:  When a comment has been inserted in a cell, the little red triangle is 
not being displayed to indicate a comment in a cell. What can I do to remedy this 
in Excel? 



Answer:  As you can see, the little red triangle is not being displayed in cell A1 
even though there is a comment in that cell. 

 
 

Click on the Microsoft Office button and then click on the Excel Options 
button. 



 
 

When the Excel Options window appears, click on the Advanced option on the 
left. Then scroll down to the Display section in the right side of the window and 
select the option called "Indicators only, and comments on hover". 



 
 

Now when you return to the Excel spreadsheet, you should see the comment 
indicator. The comment indicator is the red triangle positioned in the top right 
corner of the cells that contain comments. 



 
 

Display comment indicator next to cells with 
comments in Excel 2003/XP/2000/97 

Question:  When a comment has been inserted in a cell, the little red triangle is 
not being displayed to indicate a comment in a cell. What can I do to remedy this 
in Excel? 
Answer:  Under the Tools menu, select Options. 



 
 

When the Options window appears, select the View tab.  Select the option called 
"Comment indicator only". 

 
 



Now when you return to the Excel spreadsheet, you should see the comment 
indicator. The comment indicator is the red triangle positioned in the top right 
corner of the cells that contain comments. 

 
 
 

Excel: Protect a cell 
 

We'll demonstrate how to protect a cell in Excel 2007 as well as earlier versions 
such as Excel 2003/XP/2000/97. 
 

Protect a cell in Excel 2007 

Question:  How do I protect a cell from being edited by others? 
Answer:  First, you'll need to un-protect all of the cells on your sheet. To do this, 
select all of the rows and columns in your sheet. Right-click on then select 
"Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Protection tab. Uncheck the 
"Locked" checkbox. Click on the OK button. 



 
 

Next, select the cell(s) that you wish to protect. Right-click and then select 
"Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Protection tab. Check the 
"Locked" checkbox. Click the OK button. 



 
 

For the locking of the cells to take effect, you must also protect the worksheet. To 
do this, select the Review tab from the toolbar at the top of the screen. Then click 
on Protect Sheet button. 



 
 

A "Protect Sheet" window will appear. You may enter a password to protect the 
sheet if you wish. The password is optional. Click on the OK button. 

 
 

Protect a cell in Excel 2003/XP/2000/97 



Question:  How do I protect a cell from being edited by others? 
Answer:  First, you'll need to un-protect all of the cells on your sheet. To do this, 
select all of the rows and columns in your sheet. Right-click on then select 
"Format Cells" from the popup menu. 

 
 

When the Format Cells window appears, select the Protection tab. Uncheck the 
"Locked" checkbox. Click on the OK button. 



 
 

Next, select the cell(s) that you wish to protect. Right-click and then select 
"Format Cells" from the popup menu. 

 



 

When the Format Cells window appears, select the Protection tab. Check the 
"Locked" checkbox. Click the OK button. 

 
 

For the locking of the cells to take effect, you must also protect the worksheet. To 
do this, select Protection and then "Protect Sheet" under the Tools menu. 



 
 

A "Protect Sheet" window will appear. You may enter a password to protect the 
sheet if you wish. The password is optional. Click on the OK button. 

 
 
 

Excel: Rotate text in a cell 
 



We'll demonstrate how to rotate text in a cell in Excel 2007 as well as earlier 
versions such as Excel 2003/XP/2000/97. 
 

Rotate text in a cell in Excel 2007 

Question:  How do I rotate text in a cell? 
Answer:  Select the cell(s) that you wish to rotate the text for. Right-click and then 
select "Format Cells" from the popup menu. 

 
 



When the Format Cells window appears, select the Alignment tab. Then set the 
number of degrees that you wish to rotate the text. This value ranges from 90 
degrees to -90 degrees. 

 
 

Now when you return to your spreadsheet, the text should be rotated. 



 
 

Rotate text in a cell in Excel 2003/XP/2000/97 

Question:  How do I rotate text in a cell? 
Answer:  Select the cell(s) that you wish to rotate the text for. Right-click and then 
select "Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Alignment tab. Then set the 
number of degrees that you wish to rotate the text. This value ranges from 90 
degrees to -90 degrees. 



 
 

Now when you return to your spreadsheet, the text should be rotated. 

 
 
 



Excel: Create a superscript value in a 
cell 

 
We'll demonstrate how to create a superscript value in a cell in Excel 2007 as 
well as earlier versions such as Excel 2003/XP/2000/97. 
 

Create a superscript value in a cell in Excel 2007 

Question:  How do I create a superscript value in a cell? 
Answer:  Select the text that you wish to convert to superscript. This can either 
be the entire cell or only a character in the cell. 

 
 

While your mouse is over the selected text, right-click and then select "Format 
Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Font tab. Check the 
Superscript checkbox. 



 
 

Now when you return to your spreadsheet, you should see the selected text as a 
superscript value. 



 
 

Create a superscript value in a cell in Excel 
2003/XP/2000/97 

Question:  How do I create a superscript value in a cell? 
Answer:  Select the text that you wish to convert to superscript. This can either 
be the entire cell or only a character in the cell. 



 
 

While your mouse is over the selected text, right-click and then select "Format 
Cells" from the popup menu. 

 



 

When the Format Cells window appears, select the Font tab. Check the 
Superscript checkbox. 

 
 

Now when you return to your spreadsheet, you should see the selected text as a 
superscript value. 



 
 

Excel: Create a subscript value in a cell 
 

We'll demonstrate how to create a subscript value in a cell in Excel 2007 as well 
as earlier versions such as Excel 2003/XP/2000/97. 
 

Create a subscript value in a cell in Excel 2007 

Question:  How do I create a subscript value in a cell? 
Answer:  Select the text that you wish to convert to subscript. This can either be 
the entire cell or only a character in the cell. 



 
 

While your mouse is over the selected text, right-click and then select "Format 
Cells" from the popup menu. 

 
 



When the Format Cells window appears, select the Font tab. Check the 
Subscript checkbox. 

 
 

Now when you return to the spreadsheet, you should see the subscript value. 



 
 

Create a subscript value in a cell in Excel 
2003/XP/2000/97 

Question:  How do I create a subscript value in a cell? 
Answer:  Select the text that you wish to convert to subscript. This can either be 
the entire cell or only a character in the cell. 



 
 

While your mouse is over the selected text, right-click and then select "Format 
Cells" from the popup menu. 

 



 

When the Format Cells window appears, select the Font tab. Check the 
Subscript checkbox. 

 
 

Now when you return to the spreadsheet, you should see the subscript value. 



 
 
 
 

Excel: Change the font color based on 
the value in the cell 

 
Question:  I'm putting the sum of 3 cells in a 4th cell. If the sum is greater than 
10, I would like the sum to be the color red. If the sum is less than 10, I would like 
the sum to be the color blue. If the sum equals 10, I want the font color to be 
black. Is this possible? 
 

Answer:  If you wish to change the color of the font based on the value in a cell, 
you will need to apply conditional formatting. 
To do this, select the cell that you wish to apply the formatting to. In this example, 
we've selected cell B8. 



 
 

Under the Format menu, select Conditional Formatting. 

 
 

When the Conditional Formatting window appears, enter the first condition. In our 
example, we've selected when the cell value is greater than 10. 
Next, we need to select what formatting to apply when this condition is met. To 
do this, click on the Format button. 



 
 

When the Format Cells window appears, select the formatting conditions that you 
wish to apply. We've changed the Color to Red. Then click on the OK button. 

 
 

If you wish to apply more than one condition, you will need to click on the Add 
button. 

 



 

We've added three different conditions. When you're done, click on the OK 
button. 

 
 

Now when you return to the spreadsheet, the conditional formatting will be 
applied. As you can see, the value in cell B8 appears in red. 

 
 



 

Excel: Automatically alternate row colors 
(dynamically) 

 
Question:  How can I set up alternating row colors in Excel? I don't want to have 
to change the row colors every time I insert, delete, or move a row. 
 

Answer:  Special thanks to Bertram for sending in this handy formatting trick. 
If you wish to set up alternating row colors in Excel, first highlight the rows that 
you wish to apply the formatting to. In this example, we've selected all rows in the 
spreadsheet. 

 
 

Under the Format menu, select Conditional Formatting. 



 
 

When the Conditional Formatting window appears, select "Formula Is" in the 
drop down. Then enter the following formula: 

=mod(row(),2)=1 

Next, we need to select the color we want to see in the alternating rows. To do 
this, click on the Format button. 

 
 

When the Format Cells window appears, select the Patterns tab. Then select the 
color that you'd like to see. In this example, we've selected a light grey. Then 
click on the OK button. 



 
 

When you return to the Conditional Formatting window, you should see the 
following. Next, click on the OK button. 

 
 

Now when you return to the spreadsheet, the conditional formatting will be 
applied. 
As you can see, you now have alternating colors in the rows. You can insert, 
delete, and move rows, and you don't have to worry about reapplying formatting. 



 
 
 

Excel: Automatically highlight highest 
and lowest values in a range of cells 

 
Question:  In Excel, is there a way to shade one cell green if it is the highest 
value in a range of cells, and to shade another cell red if it is the lowest number 
in a range of cells? 
 

Answer:  Yes, you can use conditional formatting to highlight the highest and 
lowest values in a range of cells. 
First highlight the range of cells. In this example, we've selected cells A1 through 
A5. 
Under the Format menu, select Conditional Formatting. 



 
 

When the Conditional Formatting window appears, select "equal to" in the 
second drop down. Then enter the following formula: 

=Max($A$1:$A$5) 

Then click on the Format button. 

 
 

When the Format Cells window appears, select the Patterns tab. Then select the 
color that you'd like to see for the highest value in the range. In this example, 
we've selected light green. Then click on the OK button. 



 
 

When you return to the Conditional Formatting window, you should see the 
following. Next, click on the Add button. 

 
 

For Condition2, select "equal to" in the second drop down. Then enter the 
following formula: 

=Min($A$1:$A$5) 



Then click on the Format button. 
 

When the Format Cells window appears, select the Patterns tab. Then select the 
color that you'd like to see for the lowest value in the range. In this example, 
we've selected red. Then click on the OK button. 

 
 

Your Conditional Formatting window should now look like this: 

 
Click on the OK button. 



Now when you return to the spreadsheet, the conditional formatting will be 
applied. 
As you can see, the -3 value appears in a red cell while the 200 value appears in 
a light green cell. 

 
 
 

Excel: Center text across multiple cells 
 

We'll demonstrate how to center text across multiple cells in Excel 2007 as well 
as earlier versions such as Excel 2003/XP/2000/97. 
 

Center text across multiple cells in Excel 2007 

Question:  I want to center text across multiple cells but I don't want to have to 
merge the cells. How can I do this? 
Answer:  Select the cells that you wish to center the text across. 



 
Right-click and then select "Format Cells" from the popup menu. 
 



 
 

When the Format Cells window appears, select the Alignment tab. Click on 
"Center Across Selection" in the drop-down box called Horizontal. 



 
 

Now when you return to your spreadsheet, you should see the text centered 
across the cells that you selected. 



 
 

Center text across multiple cells in Excel 
2003/XP/2000/97 

Question:  I want to center text across multiple cells but I don't want to have to 
merge the cells. How can I do this? 
Answer:  Select the cells that you wish to center the text across. 



 
Right-click and then select "Format Cells" from the popup menu. 
 

 



 

When the Format Cells window appears, select the Alignment tab. Click on 
"Center Across Selection" in the drop-down box called Horizontal. 

 
 

Now when you return to your spreadsheet, you should see the text centered 
across the cells that you selected. 



 
 
 

Excel: Align text to the top of the cell 
 

We'll demonstrate how to align text to the top of the cell in Excel 2007 as well as 
earlier versions such as Excel 2003/XP/2000/97. 
 

Align text to the top of the cell in Excel 2007 

Question:  When I increase the size of a row, the text seems to align itself to the 
bottom of the cell and there is a blank space at the top of the cell. How can I get 
the text to align itself to the top of the cell? 
Answer:  Select the cells that you wish to align. 



 
 

Right-click and then select "Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Alignment tab. Then select 
"Top" in the drop-down box called Vertical. 



 
 

Now when you return to your spreadsheet, the cells that you've selected should 
be aligned to the top, as follows: 



 
 

Align text to the top of the cell in Excel 
2003/XP/2000/97 

Question:  When I increase the size of a row, the text seems to align itself to the 
bottom of the cell and there is a blank space at the top of the cell. How can I get 
the text to align itself to the top of the cell? 
Answer:  Select the cells that you wish to align. 



 
 

Right-click and then select "Format Cells" from the popup menu. 



 
 

When the Format Cells window appears, select the Alignment tab. Then select 
"Top" in the drop-down box called Vertical. 

 



 

Now when you return to your spreadsheet, the cells that you've selected should 
be aligned to the top, as follows: 

 
 
 

Excel: Set up a cell to only allow a 
certain number of characters 

 
We'll demonstrate how to align text to the top of the cell in Excel 2007 as well as 
earlier versions such as Excel 2003/XP/2000/97. 
 



Set up a cell to only allow a certain number of 
characters in Excel 2007 

Question:  In Excel, I want to set up a cell to only allow 15 characters. How can I 
do this? 
Answer:  Select the cells that you wish to restrict to a certain number of 
characters. In this example, we've selected cells A2 to A6. 
Select the Data tab in the toolbar at the top of the screen. Then click on the Data 
Validation drop-down and select Data Validation. 

 
 

When the Data Validation window appears, set up your criteria. In this example, 
we've setup the cells to allow a text length of less than or equal to 15. 
Next, click on the Error Alert tab. 



 
 

Enter an Error message to appear when data entered does not conform to the 
validation rules. 

 
 

Now if a value is entered in one of those cells that is longer than 15 characters, 
the following error message will appear: 



 
 

Set up a cell to only allow a certain number of 
characters in Excel 2003/XP/2000/97 

Question:  In Excel, I want to set up a cell to only allow 15 characters. How can I 
do this? 
Answer:  Select the cells that you wish to restrict to a certain number of 
characters. In this example, we've selected cells A2 to A6. 
Under the Data menu, select Validation. 

 
 

When the Data Validation window appears, set up your criteria. In this example, 
we've setup the cells to allow a text length of less than or equal to 15. 
Next, click on the Error Alert tab. 



 
 

Enter an Error message to appear when data entered does not conform to the 
validation rules. 

 
 

Now if a value is entered in one of those cells that is longer than 15 characters, 
the following error message will appear: 



 
 
 

Excel: Set up a cell to only allow 
numbers 

 
We'll demonstrate how to set up a cell to only allow numbers in Excel 2007 as 
well as earlier versions such as Excel 2003/XP/2000/97. 
 

Set up a cell to only allow numbers in Excel 2007 

Question:  In Excel, I want to set up a cell to only allow numbers. How can I do 
this? 
Answer:  Select the cells that you wish to restrict to a certain number of 
characters. In this example, we've selected cells A2 to A6. 
Select the Data tab in the toolbar at the top of the screen. Then click on the Data 
Validation drop-down and select Data Validation. 



 
 

When the Data Validation window appears, set up your criteria. In this example, 
we've setup the cells to allow a positive number. 
Next, click on the Error Alert tab. 

 
 

Enter an Error message to appear when data entered does not conform to the 
validation rules. 



 
 

Now if a value is entered in one of those cells is not a positive number, the 
following error message will appear: 

 
 

Set up a cell to only allow numbers in Excel 
2003/XP/2000/97 

Question:  In Excel, I want to set up a cell to only allow numbers. How can I do 
this? 
Answer:  Select the cells that you wish to restrict to a certain number of 
characters. In this example, we've selected cells A2 to A6. 
Under the Data menu, select Validation. 



 
 

When the Data Validation window appears, set up your criteria. In this example, 
we've setup the cells to allow a positive number. 
Next, click on the Error Alert tab. 

 
 

Enter an Error message to appear when data entered does not conform to the 
validation rules. 



 
 

Now if a value is entered in one of those cells is not a positive number, the 
following error message will appear: 

 
 
 
 

Excel: SumIf Function 
 

In Excel, the SumIf function adds all numbers in a range of cells, based on a 
given criteria. 
The syntax for the SumIf function is: 

SumIf( range, criteria, sum_range ) 

range is the range of cells that you want to apply the criteria against. 



criteria is used to determine which cells to add. 
sum_range are the cells to sum. 
 

For example: 
Let's take a look at an example: 

 
Based on the Excel spreadsheet above: 

=SumIf(A2:A6, D2, C2:C6) would return 218.6

=SumIf(A:A, D2, C:C) would return 218.6

=SumIf(A2:A6, 2003, C2:C6) would return 7.2

=SumIf(A2:A6, ">=2001", 
C2:C6) would return 12.6 

 

Using Named Ranges 

You can also use a named range in the SumIf function. For example, we've 
created a named range called family that refers to column A in Sheet 1. 



 
 

Then we've entered the following data in Excel: 

 
Based on the Excel spreadsheet above: 

=SumIf(family, C2, B:B) would return 218.6

=SumIf(family, ">=2001", 
B:B) would return 12.6 

 

To view named ranges: Under the Insert menu, select Name > Define. 



 
 

Excel: Lookup Function 
 

In Excel, the Lookup function returns a value from a range (one row or one 
column) or from an array. There are 2 different syntaxes for the Lookup function: 

Syntax #1 

In Syntax #1, the Lookup function searches for value in the lookup_range and 
returns the value in the result_range that is in the same position. 
The syntax for the Lookup function is: 

Lookup( value, lookup_range, result_range ) 

value is the value to search for in the lookup_range. 
lookup_range is a single row or single column of data that is sorted in ascending 
order. The Lookup function searches for value in this range. 



result_range is a single row or single column of data that is the same size as the 
lookup_range. The Lookup function searches for the value in the lookup_range 
and returns the value from the same position in the result_range. 
 

Note: 
If the Lookup function can not find an exact match, it chooses the largest value in 
the lookup_range that is less than or equal to the value. 
If the value is smaller than all of the values in the lookup_range, then the Lookup 
function will return #N/A. 
If the values in the Lookup_range are not sorted in ascending order, the Lookup 
function will return the incorrect value. 
 

For example: 
Let's take a look at an example: 

 
Based on the Excel spreadsheet above: 

=Lookup(10251, A1:A21, 
B1:B21) would return "Tofu" 

=Lookup(10246, A1:A21, would return #N/A



B1:B21) 
=Lookup(10248, B1:B21, 
A1:A21) would return "Queso Cabrales"

 

Syntax #2 

In Syntax #2, the Lookup function searches for the value in the first row or 
column of the array and returns the corresponding value in the last row or column 
of the array. 
The syntax for the Lookup function is: 

Lookup( value, array ) 

value is the value to search for in the array. The values must be in ascending 
order. 
array is an array of values that contains both the values to search for and return. 
 

Note: 
If the Lookup can not find an exact match, it chooses the largest value in the 
array that is less than or equal to the value. 
If the value is smaller than all of the values in the array, then the Lookup function 
will return #N/A. 
If the values in the array are not sorted in ascending order, the Lookup function 
will return the incorrect value. 
 

For example: 
Let's take a look at an example: 

=Lookup("T", {"s","t","u","v";10,11,12,13}) would return 11 
=Lookup("Tech on the Net", 
{"s","t","u","v";10,11,12,13})

would return 11 

=Lookup("t", {"s","t","u","v";"a","b","c","d"}) would return "b" 
=Lookup("r", {"s","t","u","v";"a","b","c","d"}) would return #N/A 
=Lookup(2, {1,2,3,4;511,512,513,514}) would return 512 



 
 

Excel: CountIf Function 
 

In Excel, the CountIf function counts the number of cells in a range, that meets a 
given criteria. 
The syntax for the CountIf function is: 

CountIf( range, criteria ) 

range is the range of cells that you want to count based on the criteria. 
criteria is used to determine which cells to count. 
 

For example: 
Let's take a look at an example: 

 
Based on the Excel spreadsheet above: 

=CountIf(A2:A7, D2) would return 1

=CountIf(A:A, D2) would return 1

=CountIf(A2:A7, 
">=2001") would return 4 



 

Using Named Ranges 

You can also use a named range in the CountIf function. For example, we've 
created a named range called family that refers to column A in Sheet 1. 

 
 

Then we've entered the following data in Excel: 

 
Based on the Excel spreadsheet above: 

=CountIf(family, D2) would return 1

=CountIf(family, 
">=2001") would return 4 



 

To view named ranges: Under the Insert menu, select Name > Define. 

 
 

Frequently Asked Questions 

 
Question:  I'm trying to use COUNTIF on a selection of cells (not necessarily one 
solid range), and the syntax of the function does not allow that. Is there another 
way to do this? 
Here's an example of what I'd like to be able to do: 

=COUNTIF(A2,A5,F6,G9,">0") 

Answer:  Unfortunately, the COUNTIF function does not support multiple ranges. 
However, you could try summing multiple COUNTIFs. 
For example: 

=SUM(COUNTIF(A2,">0"),COUNTIF(A5,">0"),COUNTIF(F6,">0"),
COUNTIF(G9,">0")) 

OR 



=COUNTIF(A2,">0")+COUNTIF(A5,">0")+COUNTIF(F6,">0")+COU
NTIF(G9,">0") 

 

Question:  I am using the COUNTIF function and I would like to make the criteria 
equal to a cell. 
For example: 

=COUNTIF(C4:C19,">=2/26/04") 

I want to replace 2/26/04 with cell A1. How do I do this? 
Answer:  To use a cell reference in the criteria, you could do the following: 

=COUNTIF(C4:C19,">="&A1) 

 
 

Excel: Creating a combo box in Excel 
 

Question:  I'm trying to create pull down boxes in Excel with selections to 
highlight and fill in the cell. How do I do that? 
 

Answer:  To create a combo box in Excel, the first thing that you need to do is 
display the Forms toolbar. To do this, under the View menu, select Toolbars > 
Forms. 



 
 

The Forms toolbar should now appear. Select the combo box icon. Then left-click 
on the spreadsheet where you'd like the combo box object to appear and drag 
the mouse pointer to the right until the combo box is the desired size. 



 
 

Next, you will need to enter somewhere on your spreadsheet, the values that 
you'd like to appear as selections in the combo box. We've entered our values in 
cells A2 through A4. 
Next, right-click on the combo box and select Format Control from the popup 
menu. 



 
 

When the Format Object window appears, select the Control tab. Then select the 
input range for the combo box. This is the cells that contain the values that you 
wish to see in the combo box. 
Then select the Cell link. This the cell that is linked to the combo box. This cell 
will display the combo box selection. 
Click on the OK button. 



 
 

Now when you return to the spreadsheet, your combo box should display a 
selection of values. In our example, it displays Active, Inactive, and Unknown. 



 
 

When you select a value, the linked cell should display the index of the selection. 
In this case, we selected "Inactive", so cell C5 displays a 2. The value of 2 
represents the 2nd value in the combo box. 



 
 

If you need to translate C5 back to the combo box selection, you can use the 
following formula:  (but do not place this formula in cell C5, place it in a cell that 
you are currently not using) 

=INDEX(A2:A4, C5) 

The INDEX formula would return the value "Inactive". 
 
 

Excel: Concatenate Function 
 

In Excel, the Concatenate function allows you to join 2 or more strings together. 
The syntax for the Concatenate function is: 

Concatenate( text1, text2, ... text_n ) 



There can be up to 30 strings that are joined together. 
 

For example: 
Let's take a look at an example: 

 
Based on the Excel spreadsheet above: 

=Concatenate(A1, A2) would return "Alphabet"

=Concatenate("Tech on the ", "Net") would return "Tech on the Net" 
=Concatenate(A1, "bet soup") would return "Alphabet soup" 

 
 

Excel: Match Function 
 

In Excel, the Match function searches for a value in an array and returns the 
relative position of that item. 
The syntax for the Match function is: 

Match( value, array, match_type ) 

value is the value to search for in the array. 



array is a range of cells that contains the value that you are searching for. 
match_type is optional. It the type of match that the function will perform. The 
possible values are: 

match_type Explanation

1 
(default) 

The Match function will find the largest value 
that is less than or equal to value. You should 
be sure to sort your array in ascending order.  

If the match_type parameter is omitted, the 
Match function assumes a match_type of 
1. 

0 
The Match function will find the first value 
that is equal to value. The array can be sorted 
in any order. 

-1 
The Match function will find the smallest 
value that is greater than or equal to value. You 
should be sure to sort your array in descending 
order. 

 

Note: 
The Match function does not distinguish between upper and lowercase when 
searching for a match. 
If the Match function does not find a match, it will return a #N/A error. 
If the match_type parameter is 0 and a text value, then you can use wildcards in 
the value parameter. 

Wild 
card Explanation 

* matches any sequence of 
characters 

? matches any single character

 

For example: 
Let's take a look at an example: 



 
Based on the Excel spreadsheet above: 

=Match(10572, A2:A5, 
1) would return 3 

=Match(10572, A2:A5) would return 3

=Match(10573, A2:A5, 
1) would return 4 

=Match(10572, A2:A5, 
0) would return #N/A 

=Match(10573, A2:A5, 
0) would return 4 

=Match(3.49, C2:C5, -1) would return 3

=Match(3.50, C2:C5, -1) would return 3
 

Let's take a look at how we can use wild cards in the Match function. 



 
Based on the Excel spreadsheet above: 

=Match("I?M", A2:A5, 
0) would return 1 

=Match("M*t", A2:A5, 
0) would return 2 

=Match("M?t", A2:A5, 
0) would return #N/A 

 
 

Excel: HLookup Function 
 

In Excel, the HLookup function searches for value in the top row of table_array 
and returns the value in the same column based on the index_number. 
The syntax for the HLookup function is: 

HLookup( value, table_array, index_number, 
not_exact_match ) 

value is the value to search for in the first row of the table_array. 
table_array is two or more rows of data that is sorted in ascending order. 



index_number is the row number in table_array from which the matching value 
must be returned. The first row is 1. 
not_exact_match determines if you are looking for an exact match based on 
value. Enter FALSE to find an exact match. Enter TRUE to find an approximate 
match, which means that if an exact match if not found, then the HLookup 
function will look for the next largest value that is less than value. 
 

Note: 
If index_number is less than 1, the HLookup function will return #VALUE!. 
If index_number is greater than the number of columns in table_array, the 
HLookup function will return #REF!. 
If you enter FALSE for the not_exact_match parameter and no exact match is 
found, then the HLookup function will return #N/A. 
 

For example: 
Let's take a look at an example: 

 
Based on the Excel spreadsheet above: 

=HLookup(10251, A1:K3, 2, 
FALSE) would return $16.80 

=HLookup(10251, A1:K3, 3, 
FALSE) would return 6 

=HLookup(10248, A1:K3, 2, would return #N/A



FALSE) 
=HLookup(10248, A1:K3, 2, 
TRUE) would return $14.00 

 
 

Excel: Create a hyperlink to another cell 
 

Question:  I want to create a hyperlink in Excel. How do I specify a particular 
location that a hyperlink should point to? 
 

Answer:  To create a hyperlink to another cell in your spreadsheet, right click on 
the cell where the hyperlink should go. Select Hyperlink from the popup menu. 

 
 

When the Insert Hyperlink window appears, click on the "Place In This 
Document" on the left. Enter the text to display. In this example, we've entered 
"Hyperlink to cell A5". This is the value that will be displayed in Excel. 
Next enter the cell reference that the hyperlink points to. We've chosen to link to 
cell A5. Click the OK button. 



 
 

Now when you return to the spreadsheet, you should see the hyperlink. 

 
 

If you click on the hyperlink, your active cell should become cell A5. 



 
 
 

Excel: Extract hyperlink address(web 
addresses ONLY) 

 
Question:  I've downloaded a table from the web with hyperlink references into 
Excel. What I need to do is examine the hypertext link and extract a small part of 
that link. All I seem to get is the details of the link in a pop up box (yellow) and 
any attempt to filter out detail only results in the display of the destination ? 
Is there a way I can examine a hyperlink details without invoking the hyperlink? 



 
 

Answer:  Below is a function that you can include in your spreadsheet to extract 
the hyperlink address from a cell in Excel. 

Function HyperLinkText(pRange As Range) As String 

Dim ST1 As String 
Dim ST2 As String 

If pRange.Hyperlinks.Count = 0 Then 
   Exit Function 
End If 

ST1 = pRange.Hyperlinks(1).Address 
ST2 = pRange.Hyperlinks(1).SubAddress 

If ST2 <> "" Then 
   ST1 = "[" & ST1 & "]" & ST2 
End If 

HyperLinkText = ST1 



End Function 

Then you can reference this new function in your spreadsheet. 
For example in cell B1, you could enter the following: 

=HyperLinkText(A1) 

 
 

Excel: Extract hyperlink address (files 
and web addresses) 

 
Question:  I have an Excel spreadsheet that contains hyperlink addresses to 
files. I tried extracting the hyperlink address for these files, however I'm not 
getting the complete Address. The complete Address should be: 

C:\My Documents\Past Projects\Centennial\Program Status 
Report.xls 

But I only get: 

\..\..\Past Projects\Centennial\Program Status Report.xls 

Is there a way to always get the complete hyperlink address? 



 
 

Answer:  Below are two functions that you can include in your spreadsheet to 
extract the complete hyperlink address for either a file or a web address. 

Function HyperLinkText(pRange As Range) As String 

Dim ST1      As String 
Dim ST2      As String 
Dim LPath    As String 
Dim ST1Local As String 
     
If pRange.Hyperlinks.Count = 0 Then 
       Exit Function 
End If 
     
LPath = ThisWorkbook.FullName 
     
ST1 = pRange.Hyperlinks(1).Address 
ST2 = pRange.Hyperlinks(1).SubAddress 
     
If Mid(ST1, 1, 15) = "..\..\..\..\..\" Then 



        ST1Local = ReturnPath(LPath, 5) & Mid(ST1, 
15) 
ElseIf Mid(ST1, 1, 12) = "..\..\..\..\" Then 
        ST1Local = ReturnPath(LPath, 4) & Mid(ST1, 
12) 
ElseIf Mid(ST1, 1, 9) = "..\..\..\" Then 
        ST1Local = ReturnPath(LPath, 3) & Mid(ST1, 9) 
ElseIf Mid(ST1, 1, 6) = "..\..\" Then 
        ST1Local = ReturnPath(LPath, 2) & Mid(ST1, 6) 
ElseIf Mid(ST1, 1, 3) = "..\" Then 
        ST1Local = ReturnPath(LPath, 1) & Mid(ST1, 3) 
Else 
        ST1Local = ST1 
End If 
     
If ST2 <> "" Then 
       ST1Local = "[" & ST1Local & "]" & ST2 
End If 
     
HyperLinkText = ST1Local 

End Function 

 

Function ReturnPath(pAppPath As String, pCount As Integer) As 
String 

Dim LPos    As Integer 
Dim LTotal  As Integer 
Dim LLength As Integer 



LTotal = 0 
LLength = Len(pAppPath) 

Do Until LTotal = pCount + 1 
        If Mid(pAppPath, LLength, 1) = "\" Then 
            LTotal = LTotal + 1 
        End If 
        LLength = LLength - 1 
Loop 

ReturnPath = Mid(pAppPath, 1, LLength) 

End Function 

 

Then you can reference these new functions in your spreadsheet. 
For example in cell B1, you could enter the following: 

=HyperLinkText(A1) 

 

Excel: Delete all hyperlinks on a sheet 
 

Question:  I've had a hyperlink problem in my Excel files for ages: false 
hyperlinks had crept in (even in empty cells) and were multiplying regularly 
whenever I inserted new lines. How can I delete all hyperlinks in a sheet at once 
and not have to delete them cell by cell? 
 

Answer:  You will need to create a macro to delete the hyperlink addresses in 
your Excel sheet. 



Open your Excel spreadsheet that you wish to remove the hyperlinks from. Press 
<ALT>-F11 to go to the Visual Basic editor. Create a new module. You can do 
this by selecting Module under the Insert menu. 
Paste the following code into your new module: 

Sub RemoveHyperlinks() 

'Remove all hyperlinks from the active sheet 
ActiveSheet.Hyperlinks.Delete 

End Sub 

Close the Visual Basic editor window by selecting "Close and Return to Microsoft 
Excel" under the File menu. 
Now, go to the sheet that contains the hyperlinks that you wish to delete. Here is 
an example of a sheet with multiple hyperlink addresses: 

 
 

Under the Tools menu, select Macro > Macros. Highlight the macro called 
"RemoveHyperlinks" and click on the Run button. 



 
Now your hyperlinks should be deleted as you can see by the example below: 

 
 

If you need to remove hyperlinks from other sheets, just repeat the steps above. 
 
 

Excel: View hyperlink result at top of 
viewing area 

 
Question:  I have an Excel worksheet that has the first 6 rows frozen. In the first 6 
rows, I have hyperlinks to different cells in column B. When I click the hyperlinks, 
Excel tends to show the cell at the bottom of the viewing page. 
I want the cell that the hyperlink refers to be displayed in the next row after the 
frozen rows. Can this be done? 
 

Answer:  Let's take a look at an example. 



Below, we have an Excel spreadsheet with the first 6 rows hidden. In cell B5, 
we've created a hyperlink to cell B30. When we click on the hyperlink in cell B5, 
the spreadsheet looks as follows: 

 
The hyperlink is at the bottom of the viewing area in the spreadsheet. We want to 
see row 30 directly under row 6. 
To fix this, select Options under the Tools menu. When the Options window 
appears, click on the Transition tab. Then select the option called "Transition 
navigation keys". Click on the OK button. 



 
 

Now when you click on the hyperlink in cell B5, your spreadsheet should look as 
follows: 



 
 
 

Excel: Update cell based on hyperlink 
selected 

 
Question:  I have created a hyperlink from one worksheet to another within the 
same file. But when the linked worksheet is pulled up, I want to populate the 
designated field with some text. The text will change depending on the hyperlink 
selected, but all the links will connect to the same worksheet and the same field. 
The field I am wanting to populate controls numerous lookup functions. 
HELP!!  Can this be done? 
 



Answer:  Yes, this can be done by utilizing macros on two Excel workbook 
"events". 
Let's take a look at an example. 
Download Excel spreadsheet (as demonstrated below) 
In our spreadsheet, there are two sheets called Hyperlinks and Destination. The 
Hyperlinks sheet contains three hyperlinks in cell A3, A6, and A9. All three 
hyperlinks point to cell B2 in the Destination sheet 

.  
 

When a hyperlink is clicked, the Destination sheet is activated and cell B2 will 
display text showing which hyperlink was selected. In our example below, we've 
selected "Hyperlink #1" in cell A3. 



 
 

You can view the macros by pressing Alt-F11 and double-clicking on the 
ThisWorkbook object in the left window. 
There are three components to this solution: 

1. There is a global variable called GSourceCell which contains the cell reference 
when the hyperlink was selected. 

2. There is a workbook event called "SheetSelectionChanged". When this event 
fires, the GSourceCell variable will be populated 

3. There is a workbook event called "SheetFollowHyperlink". When this event fires, 
cell B2 in the Destination sheet will be populated with text. 

 

Macro Code: 

The macro code looks like this:  



Private Sub Workbook_SheetFollowHyperlink(ByVal Sh As Object, 
ByVal Target As Hyperlink) 

    'Update cell B2 in Destination sheet based on the origin of 
hyperlink 
    If Sh.Name = "Hyperlinks" Then 
        If GSourceCell = "A3" Then 
            Sheets("Destination").Range("B2").Value = "Hyperlinked 
from cell A3" 
        ElseIf GSourceCell = "A6" Then 
            Sheets("Destination").Range("B2").Value = "Hyperlinked 
from cell A6" 
        ElseIf GSourceCell = "A9" Then 
            Sheets("Destination").Range("B2").Value = "Hyperlinked 
from cell A9" 
        Else 
            Sheets("Destination").Range("B2").Value = "" 
        End If 
    End If 

End Sub 

 

Private Sub Workbook_SheetSelectionChange(ByVal Sh As 
Object, ByVal Target As Range) 

    If Sh.Name = "Hyperlinks" Then 
        'Capture last active cell on Hyperlinks worksheet and store in 
global variable 
        GSourceCell = Target.Address(False, False) 
    End If 



End Sub 

 

Excel: Filter final series of numbers in 
hyperlink address 

 
Question:  I've downloaded a table from the web with hyperlink references into 
Excel. I need to filter out the final series of numbers for each hyperlink address 
and put them as a number in a column. How can I do this? 

 
 

Answer:  Below is a function that you can include in your spreadsheet to filter the 
final series of numbers in a hyperlink address in Excel. 

Function FinalNumberSeries(pCell) As Long 



Dim LChar As String 
Dim LLength As Integer 
Dim LStart As Integer 
Dim LExit As Boolean 
 
LLength = Len(pCell) 
LStart = LLength 
LExit = False 
 
'Search backwards through the string until a non-
numeric 
'character is found 
Do Until LExit = True 
   LChar = Mid(pCell, LStart, 1) 
 
   If IsNumeric(LChar) = False Then 
      LExit = True 
   ElseIf LStart = 1 Then 
      LExit = True 
End If 
 
LStart = LStart - 1 
Loop 
 
FinalNumberSeries = Mid(pCell, LStart + 2) 

End Function 

Then you can reference this new function in your spreadsheet. 
For example in cell B1, you could enter the following: 



=FinalNumberSeries(A1) 

 
 
 

Excel: Create a pivot table 
 

Question:  How do I create a pivot table in Excel? 
 

Answer:  We'll start by creating a very simple pivot table. The example that 
follows has been done in Excel 2000, so the screen may look different if you are 
using a different version of Excel. Either way, it will give you a basic 
understanding of pivot tables. 
First, our data that we want to use to populate the pivot table resides on Sheet1. 



 
 

Under the Data menu, select "PivotTable and PivotChart Report". 



 
 

A PivotTable wizard should appear. Make sure that the "Microsoft Excel list or 
database" and "PivotTable" options are chosen. Click on the Next button. 



 
 

Select the range of data for the pivot table and click on the Next button. In this 
example, we've chosen data from Sheet1. 



 
 

Select the position to create the new pivot table. It will automatically default to the 
cell that was highlighted when you started this process. In this example, we want 
to create our pivot table on Sheet2 in cell A1. 
Click on the Layout button. 

 



 

Now drag the fields that you want to appear in the Page, Row, Column, and Data 
sections of the pivot table. In this example, we've dragged the Order ID field to 
the Row section and the Quantity to the Data section. 
Click on the OK button to continue. 

 
 

Now click on the Finish button. 

 
 

Your pivot table should now appear on Sheet2. What this pivot table displays is 
the total quantity for each order ID. 



 
 
 

Excel: Refresh a pivot table 
 

Question:  How do I refresh a pivot table? 
 

Answer:  To refresh a pivot table in Excel, select a cell in the pivot table. Right-
click and then select "Refresh Data" from the popup menu. 



 
 
 

Excel: Automatically refresh pivot table 
when file is opened 

 
Question:  How do I get a pivot table to automatically refresh when the Excel 
spreadsheet is opened? 
 

Answer:  Select a cell in the pivot table. Right-click and then select "Table 
Options" from the popup menu. 



 
 

When the PivotTable Options window appears, check the checkbox called 
"Refresh on open". Click on the OK button. 



 
 
 

Excel: Refresh multiple pivot tables with 
a button 

 
Question:  Is it possible to create a button in Excel that will refresh/update 
multiple pivot tables? 
 

Answer:  Yes, you can refresh multiple pivot tables with a button. To do this: 
Under the View menu, select Toolbars > Forms. 



 
 

Create a button in your spreadsheet using the Forms toolbar. To do this, click on 
the button icon (currently highlighted in picture below) and click on your 
spreadsheet where you would like the button to appear. 



 
 

After creating the button, the Assign Macro window should appear. Click on the 
"New" button. 

 
 

Then paste in similar code as below in the Button_Click event: 



Sheets("Sheet1").Select 
ActiveSheet.PivotTables("PivotTable1").RefreshTable 
Sheets("Sheet2").Select 
ActiveSheet.PivotTables("PivotTable2").RefreshTable 

 

 
You will need to replace the Sheet1 and Sheet2 with the names of your sheets 
and PivotTable1 and PivotTable2 with the names of your pivot tables. 
 

To find out the name of a pivot table, right-click on the pivot table and select 
Table Options. 



 
 
 

Excel: Automatically refresh pivot table 
when data in a sheet changes 

 
Question:  I'm looking for a macro that would automatically refresh a pivot table 
whenever data is changed in an Excel worksheet. Is this possible? 
 



Answer:  There are several "events" available within an Excel spreadsheet where 
you can place VBA code. In your case, we want to refresh the pivot table when 
the "Worksheet_Calculate" event fires. 
Let's take a look at an example. 
Download Excel spreadsheet (as demonstrated below) 

 
In our spreadsheet, there are two sheets - one is called Data which contains the 
source data for the pivot table. Another sheet is called Pivot which contains the 
pivot table. 
On the sheet called Data, we've placed code on the "Worksheet_Calculate" 
event, so that whenever the data changes on the "Data" sheet, the pivot table will 
be refreshed. 
You can press Alt-F11 to view the VBA code. 



Note: This only will work, if you have the spreadsheet set to calculate 
"automatically". This is the default for most Excel spreadsheets, but some people 
turn this feature off.  

Macro Code: 

The macro code looks like this:  

Private Sub Worksheet_Calculate() 

    'If data on this worksheet changes, refresh the pivot table 
    Sheets("Pivot").PivotTables("PivotTable1").RefreshTable 

End Sub 

 
 

Excel: Remove grand totals for columns 
 

Question:  On a pivot table, how do I remove grand totals for columns? 
 

Answer:  Below is a pivot table with a grand total for the column called OrderID. 



 
 

To remove this column grand total, select a cell in the pivot table. Right-click and 
then select "Table Options" from the popup menu. 



 
 

When the PivotTable Options window appears, uncheck the checkbox called 
"Grand totals for columns". Click the OK button. 



 
 

Now when you return to the spreadsheet, the grand total for the OrderID column 
will no longer be visible. 



 
 
 

Excel: Remove grand totals for rows 
 

Question:  On a pivot table, how do I remove the grand totals for rows? 
 

Answer:  Below is a pivot table with a grand total for the row called Product. 



 
 

To remove this row grand total, select a cell in the pivot table. Right-click and 
then select "Table Options" from the popup menu. 



 
 

When the PivotTable Options window appears, uncheck the checkbox called 
"Grand totals for rows". Click the OK button. 



 
 

Now when you return to the spreadsheet, the grand total for the Product row will 
no longer be visible. 



 
 
 

Excel: Change pivot table name 
 

Question:  How do I change the name associated with a pivot table? 
 

Answer:  Select a cell in the pivot table. Right-click and then select "Table 
Options" from the popup menu. 



 
 

When the PivotTable Options window appears, enter the new name for the pivot 
table in the Name field. Click the OK button. In this example, we've renamed our 
pivot table to ExamplePT. 



 
 
 

Excel: Do not save data with table 
layout 

 
Question:  After I created a pivot table, the size of the Excel spreadsheet became 
quite large. This was due to the fact that the data behind the pivot table was 
saved with the table layout. How do I prevent Excel from saving the data with the 
table layout? 
 

Answer:  Select a cell in the pivot table. Right-click and then select "Table 
Options" from the popup menu. 



 
 

When the PivotTable Options window appears, uncheck the checkbox called 
"Save data with table layout". Click on the OK button. 



 
 
 

Excel: Display pivot table wizard 
 

Question:  Once I've created a pivot table, how do I get back to the Pivot Table 
Wizard? 
 

Answer:  To return to the Pivot Table Wizard, select any cell in the pivot table. 



 
 

Right-click and then select "Wizard" from the popup menu. 



 
 

You should now see the Pivot Table Wizard. 

 
 
 



Excel: Remove subtotals on pivot table 
rows 

 
Question:  How do I remove subtotals on a pivot table row? 
 

Answer:  Select the row heading that you wish to remove subtotals on. Right-
click and then select "Field Settings" from the popup menu. In this example, 
we've chosen the row heading called Order ID. 

 
 



When the PivotTable Field window appears, select the "None" subtotals option. 
Click on the OK button. 

 
 

Now when you return to the spreadsheet, the subtotals for each OrderID are no 
longer visible. 



 
 
 

Excel: Remove subtotals on pivot table 
columns 

 
Question:  How do I remove subtotals on a pivot table column? 
 

Answer:  Select the column heading that you wish to remove subtotals on. In this 
example, we've chosen the column heading called Discount. 



 
 

Right-click and then select "Field Settings" from the popup menu. 



 
 

Under subtotals, select the "None" option. Click on the OK button. 

 
 



Now when you return to the spreadsheet, the subtotals for each Discount are no 
longer visible. 

 
 
 

Excel: Show Top 10 results 
 

Question:  How do I show only the top 10 results in a pivot table? 
 

Answer:  Select a row heading in the pivot table. In this example, we've chosen 
the row heading called Order ID. 



 
 

Right-click and then select "Field Settings" from the popup menu. 



 
 

When the PivotTable Field window appears, click on the Advanced button. 

 
 

Under the AutoShow options, select Automatic. Select Top and the number of 
items that you wish to view. Now click on the OK button. 



In this example, we've chosen the Top 10 values based on the "Sum of Quantity" 
field. 

 
 

This will return you to the PivotTable Field window. Click on the OK button. 

 
 

Now when you view your spreadsheet, you should only see the top 10 values 
based on quantity. 



 
 
 

Excel: Show Bottom 10 results 
 

Question:  How do I show only the bottom 10 results in a pivot table? 
 

Answer:  Select the row heading in the pivot table. In this example, we are 
selecting the Order ID heading. 



 
 

Right-click and then select "Field Settings" from the popup menu. 



 
 

When the PivotTable Field window appears, click on the Advanced button. 

 
 

Under the AutoShow options, select Automatic. Select Bottom and the number of 
items that you wish to view. Now click on the OK button. 



In this example, we've chosen the Bottom 10 values based on the "Sum of 
Quantity" field. 

 
 

This will return you to the PivotTable Field window. Click on the OK button. 

 
 

Now when you view your spreadsheet, you should only see the bottom 10 values 
based on quantity. 



 
 
 

Excel: Change how errors are displayed 
 

Question:  I don't want to see errors in the pivot table. How do I replace all errors 
with another value? 
 

Answer:  Let's first take a look at an example of an error in a pivot table. This is a 
picture of our underlying data for the pivot table. You can see in row 16 that the 
quantity entry has an error in it. This could be the result of a vlookup function, for 
example. 



 
 

Now when you take a look at the pivot table that uses this data, you can see the 
error in the pivot table. 



 
 

You can replace this error with a more appropriate value. To do this, select a cell 
in the pivot table. Right-click and then select "Table Options" from the popup 
menu. 



 
 

When the PivotTable window appears, check the checkbox called "For error 
values, show". Then enter the value that you wish to see in the pivot table 
instead of the error. Click on the OK button. In this example, we've decided to 
replace the error with a 0. 



 
 

Now when we return to the pivot table, this is what we'll see. 



 
 
 

Excel: Change how empty cells are 
displayed 

 
Question:  I don't want to see empty cells in a pivot table. How do I replace all 
empty cells with another value? 
 

Answer:  First, let's explain what an empty cell is. In the example below, we have 
order # 10253 that does not have any quantity (row 10 in spreadsheet). 
Therefore, the quantity is showing as a blank cell. 



 
 

We'd like to replace all empty cells with the value "n/a". To do this, select any cell 
in the pivot table. Right-click and then select "Table Options" from the popup 
menu. 



 
 

When the PivotTable window appears, check the checkbox called "For empty 
cells, show". Then enter the value that you wish to see in the pivot table instead 
of the empty cell. Click on the OK button. In this example, we want all blank cells 
to show as "n/a". 



 
 

Now when we return to the pivot table, we see "n/a" as the quantity value for 
order #10253. 



 
 
 
 

Excel: Display the fields in the Data 
Section in multiple columns 

 
Question:  I've created a pivot table in Excel with two fields in the Data Section of 
the pivot table. These fields are the sum of the Quantity as well as the sum of the 
Total cost of an order. The pivot table seems to be populating the Data Section in 
a single column and I want to see the results in two columns. 
How can I set up my pivot table so that the Quantity and Total cost (in the data 
section) values show up in two columns instead of being listed in one? 
 



Answer:  By default, Excel will probably format your data section of your pivot 
table to populate all values in one column, as seen below: 

 
In this example, you can see that the "Sum of Quantity" as well as "Sum of Total 
Cost" fields are being displayed in one column. To change the pivot table so that 
each field is in its own column, first highlight the label called "Data". 
 



 
Next, while your mouse cursor is over the Data label, click and hold down the 
Left Mouse Button. Slowly drag your mouse cursor to the right until you see the 
mouse cursor change to a picture similar to the above. This is usually when your 
cursor is over the label called Total. 
Now, let go of the Left Mouse Button. 
 



 
Now your pivot table should display the "Sum of Quantity" and "Sum of Total 
Cost" fields in their own columns. 
 

Excel: Display the fields in the Data 
Section in a single column 

 
Question:  I've created a pivot table in Excel with two fields in the Data Section of 
the pivot table. These fields are the sum of the Quantity as well as the sum of the 
Total cost of an order. The pivot table seems to be populating the data section in 
multiple columns and I want to see the results in a single column. 
How can I set up my pivot table so that the Quantity and Total cost (in the data 
section) values show up in a single column instead of being listed in two? 
 



Answer:  Excel may format your data section of your pivot table to populate your 
values in multiple columns, as seen below: 

 
In this example, you can see that the "Sum of Quantity" as well as "Sum of Total 
Cost" fields are being displayed in multiple columns. To change the pivot table so 
that the fields are populated in a single column, first highlight the label called 
"Data". 
 



 
Next, while your mouse cursor is over the Data label, click and hold down the 
Left Mouse Button. Slowly drag your mouse cursor to the left until you see the 
mouse cursor change to a picture similar to the above. This is usually when your 
cursor is next to your Row Section (ie: Order ID field). 
Now, let go of the Left Mouse Button. 
 



 
Now your pivot table should display the "Sum of Quantity" and "Sum of Total 
Cost" fields in a single column, populating down. 
 

Excel: Hide a value 
 

Question:  How do I hide a value in a pivot table? 
 

Answer:  Select the value that you wish to hide. In this example, we are going to 
order Order #10249. 



 
 

Right-click and the select "Hide" from the popup menu. 



 
 

The Order #10249 is now hidden. 



 
 
 

Excel: Display a hidden value 
 

Question:  How do I display a hidden value in a pivot table in Excel? 
 

Answer:  To explain how to display a hidden value in an Excel pivot table, we'll 
take a look at an example. In this case, the entry for Order ID 10249 is hidden. 



 
Click on the arrow to the right of the field that has the hidden value. In this 
example, the field that has the hidden value is called Order ID, so we'll click on 
the arrow to the right of the Order ID field. 
 



 
Check the box to the left of the value that you want to display. Click on the OK 
button. In this example, we've checked the box for Order ID 10249. 
Just to summarize, all checked values are visible in the pivot table and all 
unchecked values are hidden in the pivot table. 
 



 
Now when we return to the pivot table, we can see the details for Order ID 
10249. 
 
 

Excel: Hide empty cells in a pivot table 
 

Question:  How do I hide empty cells in an Excel pivot table? 
 

Answer:  To hide empty cells in a pivot table, select the empty cell in the pivot 
table. 



 
 

Right-click and select Hide from the popup menu. 



 
 

Now whenever the OrderID is blank, the data will be hidden in the pivot table. 



 
 
 

Excel: Hide zero value lines within a 
pivot table 

 
Question:  I wonder if you can help, is there a way in which you are able to hide 
zero valued lines within a pivot table ?  i.e. I have a table with two columns 
branch name and stock value and I would like to hide the branches with no value 
against them - is this possible ? 
Your help on this would be much appreciated. 
 



Answer:  Let's take a look at an example. Below is an Excel spreadsheet that 
contains values that are zeros. We want to hide these lines from being displayed 
in the pivot table. 

 
 

Right-click in the Pivot table and select Wizard from the popup menu. 



 
 

When the PivotTable Wizard appears, click on the Layout button. 

 
 



Drag the STOCK VALUE field to the PAGE section. Click on the OK button. 

 
 

Click on the Finish button to return to the spreadsheet. 

 
 

Double-click on the Stock Value field in the Page section. 



 
 

Highlight the 0 in the Hide Items window. Click on the OK button. 



 
 

Now when you return to the spreadsheet, the blank/zero lines should be hidden. 



 
 
 

Excel: Sort pivot table results 
 

Question:  How do I sort the pivot table results? 
 

Answer:  Select the row heading that you wish to sort on. Right-click and then 
select "Field Settings" from the popup menu. In this example, we've selected the 
row heading called Order ID. 



 
 

When the PivotTable Field window appears, click on the Advanced button. 

 
 

Under the AutoSort options, select either Ascending or Descending depending 
on the sort order that you wish to select. Click on the OK button. In this case, 
we've chosen to sort the Order ID field in ascending order. 



 
 

This will return you to the PivotTable Field window. Click on the OK button. 

 
 
 

Excel: GetPivotData Example #1 
 

The GetPivotData function returns data from a pivot table. It can retrieve 
summary data from a pivot table as long as the summary data is visible. 
The syntax for the GetPivotData function is: 

GetPivotData( pivot_table, name ) 



pivot_table is generally a named range that has been set up to point to the pivot 
table. 
name is the name of the summary value that you wish to retrieve. 
 

For Example: 
Let's take a look at an example. 
Below we have an Excel spreadsheet that has a pivot table on Sheet2. We've set 
up a named range called PivotTable that references this pivot table 
(Sheet2!$A:$E). 

 
 

=GetPivotData(PivotTable,"10249 Qty") would return 49 
=GetPivotData(PivotTable,"10249 Price/unit") would return 61 
=GetPivotData(PivotTable,"10249 Total_Cost") would return 1863.4 
=GetPivotData(PivotTable,"10249 Tofu would return 167.4 



Total_Cost")
 
 

Excel: GetPivotData Example #2 
 

The GetPivotData function returns data from a pivot table. It can retrieve 
summary data from a pivot table as long as the summary data is visible. 
The syntax for the GetPivotData function is: 

GetPivotData( pivot_table, name ) 

pivot_table is generally a named range that has been set up to point to the pivot 
table. 
name is the name of the summary value that you wish to retrieve. 
 

For Example: 
Let's take a look at an example. 
Below we have an Excel spreadsheet that has a pivot table on the sheet called 
"Pivot Table". We've set up a named range called team_count that references 
this pivot table ('Pivot Table'!$A:$C). 



 
 

=GetPivotData (team_count,"'Team 1' 'Count of 
B'") would return 1 

=GetPivotData (team_count,"'Team 2' 'Count of 
B'") would return 3 

=GetPivotData (team_count,"'Team 2' 'Count of 
C'") would return 12 

 
 

Excel: Create a column/line chart with 8 columns 
line 

Question:  I have a question with Excel charts. 
 

How can I make a column/line chart. I have 8 rows that I would like graphed in columns and 1 row 
on the same graph but in the form of a line. I have tried using the chart wizard, custom chart type c
Column". This format, however, only allows 5 rows of data to appear in the form of columns. Then t
data will default in to the form of lines. Is there a way to prevent this from happening? 
 



Answer:  The chart wizard in Excel is a good way to create the starting point for your chart. Howeve
sometimes need to perform some formatting after your chart is created. 
In this example, we want OSD1 through OSD 8 to appear as columns and POA to appear as a line

 

To do this, highlight the full chart and right-click. Select Chart Type from the popup menu. 



 

When the Chart Type window appears, select Column as the Chart type and click on the OK button



 
 

Now, in the chart, select the POA data series. A selection box should appear on all POA column ob
and select Chart Type from the popup menu. 



 

When the Chart Type window appears, select Line and click on the OK button. 



 
 

Now when you view the chart, OSD 1 through OSD 8 should appear as columns and POA should a
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Array Formulas are formulas that work with arrays, instead of individual numbers, 
as arguments to the functions that make up the formula.   

Introduction To Array Formulas  

When an array formula is displayed, it is surrounded by braces {}.  You do not 
enter the braces.  Instead, when you enter an array formula, you press 
Ctrl+Shift+Enter, rather than just Enter.  Excel will automatically add the 



braces.   You must press Ctrl+Shift+Enter when you first enter an array 
formula, and also each time you edit the formula later.   If you enter or array 
formula without pressing Ctrl+Shift+Enter, it will return an incorrect result or 
a #VALUE! error. 

For example, consider the formula 
 
=IF(A1=B1,1,0) 

This will return either 1, if A1=B1, or 0 if they are not equal.  But suppose you 
want to get a count of  
the number of cells in a range, A1:A10, which are equal to the corresponding 
cells in B1:B10.  By using an array formula, you can do this with a single formula 
by passing arrays to the =IF function, and summing up the results:  

=SUM(IF(A1:A10=B1:B10,1,0)) 

By entering this as an array formula, you are instructing the =IF function to 
"loop" through the range A1:A10, compare each element to the corresponding 
element in B1:B10, and return an array of 1's and 0's, each element of which 
indicates the result of each comparison.  The =SUM function adds up this array, 
and returns a single number indicating the number of cells in A1:A10 which are 
equal to their counterparts in B1:B10. 

When you use more than one range in an array formula, all of the ranges must 
contain the same number of elements.  Otherwise, an error is returned.   

Array formulas are ideal for counting cells in a range with multiple criteria.   For 
example, suppose in A2:A10 we have a product-name, in  B2:B10 we have a 
salesman-name, and in C2:C10 we  have number of units sold:  

To compute the number of Phones sold by Smith, we would use the following 
array formula:  

=SUM((A2:A10="Phone")*(B2:B10="Smith") 
*C2:C10) 

This formula works by looping, looking at the elements in the three ranges 
A2:A10, B2:B10, and C2:C10.  These three ranges do not have to be in 
adjacent columns, or even in the same rows, but  
they must contain the same number of rows.   

   



  

 
The ranges are looped though "simultaneously."   Element 
Ai is evaluated in the same iteration as elements Bi and 
Ci. 

If element Ai is Phone, a 1 (True) is returned.  Otherwise, 0 (False) is 
returned.  If element Bi is Smith, a 1 is returned, otherwise 0 is returned.  Then 
Ci is returned.  These three values are multiplied together.  The product will be 
either 0 (if either or both of the Ai or Bi comparisons were false) or Ci.   
Summing these results together gives of the sum of entries Ci where Ai is 
"Phone" and Bi is "Smith".  
Logical Operations With Array Formulas 
In addition to the AND operation described above, you can also use array 
formulas to perform an OR, and XOR, or even a NAND (Not AND) operation.  
 
Addition simulates the OR operation.  If either one or both conditions are true, 
addition will return a non-zero result.  Using the example above, we can count 
the number of sales, in which either a Fax was sold, or Jones was the salesman 
(or both).    

=SUM(IF((A2:A10="Fax")+(B2:B10="Jones"),1,0)) 

=SUM(IF(MOD((A2:A10="Fax")+(B2:B10="Jones"),2),1,0)) 

The MOD operator in the above formula returns 0 when either both conditions 
(Fax, Jones) are True or when both are False.  It returns 1 only when either 
exactly one of the conditions is True. 

NAND is an Negative And operation, which returns true when neither or one of 
the elements is True. It returns False when BOTH elements are True. 
 
=SUM(IF((A2:A10="Fax")+(B2:B10="Jones")<>2,1,0)) 
 
This counts all sales, except those in which Jones sold a Fax.  

You can combine these formulas to create rather complex logical tests.  Just be 
careful to make sure that you parentheses are in the right places.  

Formulas That Return Arrays  

The other "flavor" of array formulas are functions that return arrays as their 
result.  To work with these types of functions, you must enter the same formula 
into an array of cells.  As is often the case, an example best explains this.    



Suppose we have a matrix in A1:C3.  We can use the 
=MINVERSE function to return the inverse of this matrix.   Since 
the inverse of a matrix is itself a matrix, we've got to enter the 
=MINVERSE function as an array formula.   

  

         Select a range of cells, A5:C7, in our example, with the same number of 
rows and columns as the original matrix, enter =MINVERSE(A1:C3), and press 
Ctrl+Shift+Enter.  This enters the =MINVERSE function as an array formula 
into all of the selected cells, and the inverse matrix will be returned into this 
array.  You'll notice that when you enter a formula into an array of cells, you 
cannot alter a single cell in the array.  You must edit or delete the entire array.  

  

 
 


